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Preface

This Preface contains the following sections:
“About This Manual” on page liii describes this manual and its intended audience.

o “Conventionsin This Manua” on page lv describes the text formatting, syntax
notation, and flags used in this manual.

« “Available Documentation” on page Iviii describes the printed and online
documentation that accompanies Stylus Studio® 2010°.

« “Technical Support” on page Iviii provides information on contacting Technical
Support.

About This Manual

This manual describes how to use Stylus Studio 2010 to develop XML applications. Itis
assumed that you are familiar with XML and the concepts of it and its related
technologies.

This manual has the following chapters:

« Chapter 1, Getting Started with Stylus Studio®, provides step-by-stepinstructionsfor
editing an XML document, applying a stylesheet, creating a dynamic Web page,
debugging stylesheets and Java files, and mapping an XML document with one
schemato an XML document with another schema.

o Chapter 2, Editing and Querying XML, describes how to update an XML document
in the text, tree, schema, and grid views of the XML editor. It also provides
information about how to query documents and handle query results.
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Chapter 3, Converting Non-XML Filesto XML, describes how to use DataDirect
XML Converters™ and Stylus Studio custom XML converters to convert files (EDI,
CSV, binary, and others) to XML.

Chapter 4, Converting EDI to XML, describes how to usethe EDI to XML moduleto
convert EDI documentsto XML, and how to create and use Standard Exchange
Format (SEF) files to describe custom EDI structures.

Chapter 5, Working with XSLT, includesatutorial for using XSLT and understanding
how X SLT works. It providesinformation and instructions for using the XSLT editor
to create, modify, and apply stylesheets. It also contains reference information for the
various X SLT instructions you can specify in a stylesheet.

Chapter 6, Creating XSLT Using the XSLT Mapper, describes how to use the Stylus
Studio XML mapper. The XML mapper generates a stylesheet for transforming an
XML document that uses one schemato an XML document that uses another schema.

Chapter 7, Debugging Stylesheets, describes how to use the Stylus Studio debugging
features.

Chapter 8, Defining XML Schemas, provides information and instructions for
creating and editing DTDs and XML Schema documents.

Chapter 9, Defining Document Type Definitions,provides information about how to
use the Stylus Studio Document Type Definition (DTD) editor to definea DTD.

Chapter 10, Writing X Path Expressions, includes complete information about how to
define a query, which must be an XPath expression. In addition to explicitly running
aquery on an XML document, you specify queriesasthevaluesof sel ect and mat ch
attributes in styleshests.

Chapter 11, Working with XQuery in Stylus Studio, describes how to work with
XQuery in Stylus Studio, including how to use the XQuery debugger.

Chapter 12, Composing Web Service Calls, describes how to design, compose, and
test aWeb service call without writing any code, and how to use the Web servicecalls
you create elsewhere in Stylus Studio.

Chapter 13, Working with WSDL Documents, describes how to compose and review
Web Services Description Language (WSDL) documentsin Stylus Studio.

Chapter 14, Building XML Pipelines, describes how to use Stylus Studio to create an
XML pipeline application that chains together two or more XML transformations,
and how to generate Java code you can use to deploy that application.

Chapter 15, Publishing XML Data, describes how to use Stylus Studio to use XML
Publisher to generate X Query or XSLT that createsHTML+CSS or X SL-FO reports
using XML and non-XML data sources.

liv
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Chapter 16, Integrating with Third-Party File Systems, describes how Stylus Studio
isintegrated with third-party file systems like RainingData® TigerLogic® XML Data
Management Server (TigerLogic XDMS).

Chapter 17, Extending Stylus Studio, provides a description of advanced Stylus
Studio features, including information about using the Stylus Studio custom
document wizard.

Chapter 18, The Stylus Studio Java API, was deprecated in Stylus Studio 2007 XML
Enterprise Suite Release 2. The functionality provided by the Stylus Studio Java API
has been replaced by DataDirect XML Converters™ standalone components for
Java™ and .NET. See the DataDirect XML Converters documentation for more
information:
http://www.datadirect.com/techres/xmlconvertersproddoc/index.ssp.

Conventions in This Manual

This section describes the typographical and formatting conventions used in this manual
for text, notes, warnings, and important messages.

Typographical Conventions

This manual uses the following typographical conventions:

Bold typeface in this font indicates keyboard key names (such as Tab or Enter) and
the names of windows, menu commands, buttons, and other user-interface elements.
For example, “ From the File menu, select Open.”

Italic text emphasizes new terms when they are introduced.
Code samples appear in text like this:
- Xdebug - Xnoagent - Xrunj dwp:transport=dt_socket,
server =y, suspend=n, addr ess=8000 - Dj ava. conpi | er =NON\E
Monospace typeface indicates text that might appear on a computer screen such as
» Code that the user must enter
= System output (such as responses, error messages, and so on)
» Filenames and pathnames
= Software component names, such as class and method names

Essentially, monospace typeface indicates anything that the computer is*“saying,” or
that must be entered into the computer in alanguage that the computer “understands.”
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Bold monospace typeface emphasizestext that would otherwise appear in monospace
typeface.

Monospace typeface in italics Of Bold monospace typeface in italics (depending
on context) indicates variables or placeholders for values you supply or that might
vary from one case to another.

0 Procedures are introduced this way:

Syntax Notation

This manual uses the following syntax notation conventions:
o Brackets ([ 1) in syntax statements indicate parameters that are optional.

« Braces({ 1) indicate that one (and only one) of the enclosed itemsis required. A
vertical bar (|) separates the alternative selections.

« Ellipses(...) indicate that you can choose one or more of the preceding items.

Information Alerts

Thismanual highlights special kinds of information by shading the information area, and
indicating the type of alert in the left margin.

Tip A Tip flag identifies information that can help you use Stylus Studio more effectively —
short-cuts, alternatives, and information about system behavior are all examples of tips.

Note A Note flag indicatesinformation that complementsthe main text flow. Such information
is especially needed to understand the concept or procedure being discussed.

Important AnImportant flag indicatesinformation that must be acted upon within the given context
in order for the procedure or task (or other) to be successfully completed.

Warning A Warning flag indicates information that can cause loss of data or other damage if
ignored.

Ivi Stylus Studio® 2010 User Guide



Conventions in This Manual

Edition Alerts

Not all features are supported in all editions of Stylus Studio. Documentation that
describes features peculiar to agiven edition isidentified with an aert like the following:

XML Pipelines are available only in Stylus Studio XML Enterprise Suite.

See “ Stylus Studio Editions” on page 3 for more information about the features that are
availablein a given edition.

Video Alerts

Stylus Studio provides dozens of video demonstrations of editing tools and features for
XSLT, XQuery, XML Schema, relational-toXML conversion, and others. Sectionsin the
documentation that describe a Stylus Studio feature for which avideo demonstration
exists include an alert like the following:

Watch it! You can view a video demonstration of this feature by clicking the
television icon or by clicking this link: watch a video on Custom XML
Conversions.

Clicking either the television icon or the hyperlink launches the video.

Video Descriptions

You can find descriptions of all Stylus Studio video demonstrations here:
http://www.StylusStudio.com/xml_videos.html
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Available Documentation

Table 1 lists the documentation supplied with Stylus Studio® 2010. In addition to the
documentation listed in this table, Stylus Studio® 2010 comes with samplefiles. All
documentation is included with the Stylus Studio® 2010 media and downloads.

Table 1. The Stylus Studio® 2010 Documentation Set

Document

Description

Sylus Sudio® 2010 User Guide Describes how to use Stylus Studio to develop XML applications

using XML, SQL/XML, XQuery, Web Services, and XSLT.

ReadMe

Describes featuresin the current release of Stylus Studio® 2010
plus late-breaking information and known issues. The release
notes arelocated in the \doc directory where you installed Stylus
Studio.

Online help

Stylus Studio’s online help system can be accessed from the
application by pressing F1 or by selecting Help >
Documentation from the menu bar. You can also view the help
independently of the application, by opening ide. chminthe\doc
directory where you installed Stylus Studio.

Technical Support

Submit questions and report problems using the Stylus Studio Developer Network
(SSDN). SSDN has numerous active forums, including specialized forums for

XQuery

XSLT

Code samples and utilities
General technical questions
Feature requests

SSDN isfully searchable, and contains current as well as historical information about
Stylus Studio and XML technologies. If you cannot find the answer to the question you
have, submit it to the forum and a Stylus Studio technician will respond to you.

When submitting a question or reporting an issue, it often helps to state the version of
Stylus Studio you are running (click Help > About Stylus Studio on the menu bar) aswell

[viii
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Technical Support

as any other information about your environment you think might be relevant (such asthe
JVM version you are using, for example).
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Chapter1 = Getting Started with Stylus Studio®

Stylus Studio® isan integrated development environment (IDE) for XML and related
technologies. Stylus Studio allows you to design, develop, and test XML applications
using itsintuitive graphical interface, textual editors, and debuggers for XML, XML
Schema, DTD, XQuery, XSLT, Web services, and Java.

Stylus Studio - [order. pipeline ™] =1
x

E_w File Edit ¥ew Project Debug ZMLPipeline SourceControl Tools Wwindow Help

EE R B Xk ($ M8 e

LR el
P ti R P
;:r:;las i X A D,de,_pip___'| XML Pipeline Editor
Mame Eutract full order in... I - 1
_waquery file file: /4 /c: /Program ... L ag [Soenarial Vi [:] YR U &l UeEIIheE (EnE

DB Connections A | Tookax

L] L] 2
(ConvertToXML ([ ConvertToRmL
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i T
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[e]
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X

ipeline Pipeline Input Pipeline Output

£ 3
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Figure 1. Stylus Studio’s XML Pipeline Editor
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Stylus Studio includes modules for:

XML

XQuery

XSLT

XML Pipelines

XML reporting
Relational data sources
DTD

XML Schema

Web services

Java

Converting non-X ML filesto XML, and vice versa

Each module has one or more editors to help you author, edit, and debug XML
applications.

This chapter provides atour of the basic operations Stylus Studio provides with each of
itsmodules. It also includesinformation about opening filesin any module, using projects
to organize files, and setting options that affect all modules.

This chapter is organized as follows:

“Stylus Studio Editions” on page 3

“Integrated Components’ on page 4

“Starting Stylus Studio” on page 8

“Updating an XML Document — Getting Started” on page 10
“Working with Stylesheets — Getting Started” on page 33
“Using the XSLT Mapper — Getting Started” on page 44
“Debugging Stylesheets — Getting Started” on page 52
“Defining aDTD — Getting Started” on page 61

“Defining an XML Schema Using the Diagram Tab — Getting Started” on page 66
“Opening Filesin Stylus Studio” on page 92

“Working with Projects’ on page 100

“Customizing Tool Bars’ on page 118

“Specifying Stylus Studio Options” on page 120

“Defining Keyboard Shortcuts’ on page 125
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“Using Stylus Studio from the Command Line” on page 128
“Managing Stylus Studio Performance” on page 130
“Configuring Java Components’ on page 133

Stylus Studio Editions

Stylus Studio is offered in several editions to provide atool that is appropriate for every
level of user, from integration architects and application developers providing enterprise-
class solutions, to students and non-professional users just starting out with XML and
related technologies.

Stylus Studio XML Enterprise Suite

Stylus Studio XML Enterprise Suite is Stylus Studio’s most comprehensive XML |IDE,
offering acomplete and robust set of tools for writing, testing, debugging, and deploying
XML applications. In addition to editors for XML, XML Schema, XQuery, and XSLT,
Stylus Studio XML Enterprise Suite provides the following features exclusive to this
edition of Stylus Studio:

Javaand C# for .NET code generation for deployment of XQuery and XSLT
transformations

The ahility to expose XML Schemato Java bindings

XQuery and XSLT Profilersto help you gather performance metrics and troubl eshoot
performance bottlenecks

Custom XML Conversions, amodulethat allowsyou to easily convert non-XML files
like EDI and CSV to XML

Web Service Call Composer to help you build and test calls to hundreds of industry-
standard Web services

Integration with Raining Data Tiger Logic XDMS
Support for OASIS catal ogs, including dozens of catal ogs bundled with Stylus Studio

Stylus Studio XML Professional Suite

Stylus Studio XML Professiona Suite provides a complete set of tools for the XML
application developer, including XML Differencing for comparing multiple XML
documents and folders.

XML Differencing is also included in Stylus Studio XML Enterprise Suite.
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Stylus Studio Home Edition

Stylus Studio Home Edition isavalue-priced XML IDE that provides an excellent way to
learn about and work with XML and its rel ated technol ogies. Stylus Studio Home Edition
offers many of the features of Stylus Studio XML Professional Suite, allowing you to do
real work with XML, XML Schema, XSLT, DTD, and other important XML
technologies.

Edition Alerts

&

The Stylus Sudio® 2010 User Guide describes features found in all Stylus Studio
editions. Alerts, like the one shown here, are used to identify documentation describing
features found only in particular Stylus Studio editions.

,:""3 The XML Editor Grid tab is available only in Stylus Studio XML Enterprise Suite

and Stylus Studio XML Professional Suite.

More Information

For a compl ete description of Stylus Studio XML Enterprise Suite, Stylus Studio XML
Professional Suite, and Stylus Studio Home Edition, see the Stylus Studio Web site:
http://www.StylusStudio.com/xml_feature_comparison.html

Integrated Components

Stylus Studio XML Enterprise Suiteis fully integrated with these DataDirect products:
« DataDirect XML Converters™ for Java

o DataDirect XML Converters™ for .NET

o DataDirect XQuery®

The XML Converters™ are high-performance Java™ and .NET componentsthat provide
bi-directional, programmatic access to virtually any non-XML file including EDI, flat
files, and other legacy formats. DataDirect XML Converters allow developersto
seamlessly stream any non-XML dataas XML to industry-leading XML processing
components or to any application. They support StAX, SAX, XmlReader, XmIWriter,
DOM and I/O streaming interfaces, and can be embedded directly for transformation
purposes, or as part of achain of programsincluding XSLT and XQuery, or even inside
XML pipelines. DataDirect XML Converters maximize developer productivity and
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Integrated Components

provide afast, scalable solution for converting between EDI and other legacy formats and
XML.

DataDirect XQuery® isan X Query processor that enables developersto accessand query
XML, relational data, SOAP messages, EDI, legacy, or a combination of data sources,
and, in addition, provides full update support for relational data. DataDirect X Query
supportsthe X Query for Java™ (X QJ) API, and iseasily embedded into any Javaprogram
—it does not require any other product or application server, and has no server of its own.

Evaluation copies of these DataDirect products are installed in the \Components directory
where you installed Stylus Studio. These copies provide full development libraries,
sample code, and user documentation.

How Stylus Studio Uses Integrated Components

Stylus Studio uses the DataDirect X Query® and XML Converters™ engines to process
XQuery and XML conversions. These processing engines run under the covers
throughout Stylus Studio —in the XQuery module, EDI to XML Conversions module,
XML Pipelines module, and the Custom XML Conversions module, to name afew.

You can also use the APIs for these components to build and test applications that run
outside Stylus Studio. You might, for exampl e, want to build an X Query application using
Java or C# code for .NET generated by Stylus Studio for the X Query you develop using
the Stylus Studio X Query module.

Managing Component Licenses

Each DataDirect component is installed with an evaluation license that allows you to
develop and test X Query and XML conversion applications. Applicationsthat you deploy
outside Stylus Studio might require alicense for DataDirect XML Converters™,
DataDirector XQuery®, or both, regardless of whether the application is built using a
DataDirect API or simply takes advantage of the XQuery or XML Converters processing
engines.

The Stylus Studio License Manager

The Stylus Studio License Manager allows you to perform the following tasks for
DataDirect XQuery® and XML Converters™ components. You can

« Extend the evaluation period

o Addand remove license keys
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The License Manager is on the Components page of the Options dialog box (click Tools
> Options on the Stylus Studio menu). As seen in the following illustration, licenses for
each component are managed separately:

Options §|
© Gen:«:;lication Settings =
Editor General m Files\Styluz Studio 2009 3ML Enterprise Suite\Componentz\D atalirect X Query E]
Editar Sensei
Editor Format Lizenze b anager
B ack-mapping

. Ewaluation; all databases; unlimited CPUs; expires Thu Sep 25 09:23:56 EDT 2008
Spell Checking

Components
ML Converters For Java

Add ] [ Remove ] [Extand Evaluation

Custorn ¥ alidation Engines
55 Module Settings

£ EDI toxML

ED| Viewer Settings
3 Java

Diebugger
£ Web Service Call Composer

Figure 2. Stylus Studio License Manager

The component name Folder field displays the location of the DataDirect component
installation whose license you wish to manage. You can use the License Manager to

manage license keys for
« Thecopies of the DataDirect components that are installed with Stylus Studio. This
is the default.

« Standalone ingtallations of the DataDirect components. If you acquired a separate
copy of a DataDirect component, you can specify its URI in the component name
Folder field.

How to Extend an Evaluation

O To extend an evaluation:

1. Select the component whose evaluation you wish to extend from the Components
tree in the Options diaog box.

2. If necessary, changethe URI in the component name Folder field to point to the folder
where the component whose license you wish to manage is installed.
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Click the Extend Evaluation button.
An entry field appearsin the License Manager list box.

Replace the instructional text with the IPE key.

Press Enter or click the OK button.
Thelicenseis added to your XML Converters™ installation.

Click OK to close the Options dialog box.

How to Add a License

00 To add alicense:

1.

Select the component for which you wish to add alicense from the Components tree
in the Options dialog box.

If necessary, changethe URI in the component name Folder field to point to thefolder
where the component whose license you wish to add isinstalled.

Click the Add button.
An entry field appearsin the License Manager list box.

Replace the instructional text with the IPE key.

Press Enter or click the OK button.
Thelicense for your XML Converters™ installation is added to the license manager.

Click OK to close the Options dialog box.

How to Remove a License

00 To remove alicense:

1.

Select the component whose license you wish to remove from the Components tree
in the Options dialog box.

If necessary, changethe URI in the component name Folder field to point to thefolder
where the component whose license you wish to remove is installed.

Select the license you want to remove from the License Manager list box.

Click the Remove button.
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5. Press Enter or click the OK button.
Thelicense is removed from the license manager.

6. Click OK to close the Options dialog box.

Starting Stylus Studio

Throughout this chapter, you perform exercises that require you to first start Stylus
Studio. For example, if you installed Stylus Studio XML Enterprise Suite, you would
0 Select Start > Programs > Stylus Studio XML Enterprise Suite > Stylus Studio.

The path shown here assumes that you accepted the defaults when you installed Stylus
Studio. If you did not, you must alter your selection path accordingly.

You can also start Stylus Studio by double-clicking the desktop icon, which is added to
your desktop by default when you install Stylus Studio:

Figure 3. Example of a Stylus Studio Desktop Icon
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On startup, Stylus Studio displaysthe Tip of the Day diaog box.

o dia - [order. pipe =]
{ew File Edit Wiew Project Debug x¥MLPipeline SourceControl Tools Window Help x
) ¢
& Tip of the Day
Project ] T
= 53_-' examples @ - :
i Did you know...
Qg “  voEs
orde The new XML Fipeline Editor, available in Stylus Studio - Toolbox
= creat] | 2007 XML Enterprise Suite, helps you create an XML e
= pipeling - a chain of XML transformations and flow &
s OES | ontral operations. You can use data from numerous P
ar C1E3 | cnirees (ML, relational, Web services, CSY, EDI, and Choose
3 Al others), and generate Java code to execute the XML b
(3 stocks pipeline as an application. Click File = New = XL
3 servet Pipeline to get started E
=23 query
o books. ConvwertFromiML
i b?UkS‘U' [¥] Show Tips at Startup
o Mizedcat —
=23 WideoCenter L -I::>D‘[E
= mavies html LE =
o videos. kml | | ComvertTosmL
s Wideoswed 2 < | > v
For Help, press F1 ML

Figure 4. Stylus Studio on Startup (XML Enterprise Suite Shown)

Getting Updates

By default, Stylus Studio checks the Stylus Studio Web site for newer versions each time
you start the application. You can review and modify this and other application settings
by selecting Tools > Options from the menu bar and selecting the Application Settings
page.

If you want, you can perform this check manually by selecting Help > Check for latest
version from the Stylus Studio menu.

Getting Help

Asyou use Stylus Studio, you can press F1 at any time to obtain context-sensitive help.
If you want, you can open the online help manually (and independent of the Stylus Studio
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application) by selecting Start > Programs > Stylus Studio XML Edition Name> Stylus
Studio Documentation.

Note The online documentation is not installed with Stylus Studio. Thefirst time you access
the online documentation, you are prompted to download it from the Stylus Studio web
site. By default, the online documentation is installed in the \doc directory where you
installed Stylus Studio.

Updating an XML Document — Getting Started

Each of the following topics contains instructions for editing a sample XML document.
You should perform the stepsin each topic before you move on to the next topic. After the
first topic, some steps depend on actions you performed in a previoustopic. This
introduction to updating XML documentsin Stylus Studio is organized as follows:

o “Opening a Sample XML Document” on page 10

o “Updating the Text of a Sample Document” on page 12

« “Updating the Schema of a Sample Document” on page 20

« “Updating the Tree Representation of a Sample Document” on page 26
o “Updating a Sample Document Using the Grid Tab” on page 30

Opening a Sample XML Document

[0 To open the your-quotes.xml sample XML document in Stylus Studio:

1. IntheFile Explorer window, navigate to the examples\quotes directory inyour Stylus
Studio installation directory.

Tip The\examples directory isasibling of \bin.

2. Double-click your-quotes.xml.
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Stylus Studio displays the your-quotes.xm1 document in the XML editor. Theinitial
view of the document is the Text view, asyou can see by the tab at the bottom of the

window.
Stylus Studio - [your-quotes.xml]
E_xm File Edit W¥iew Project Debug #ML SourceControl Tools ‘wWindow Help x
g n= . =
g‘;,’iﬁ 1 - L8 % = 0
: = [
24| o |
L yuul-quot...|
GoemWr £ A W
E< = A~
= < =
< =EML Innovations< =
< =EMLT< =
< *Nasdag NM3< >
< =7 16 >
< =27 1/4< =
= >=1.58< >
< =108, 10 5/8< =
< =27 9/16, 26 1/2< =
< =105, 100< =
< =27 11/16é< =
< =27 3/8< >
< B
= = =
T < *%8L Solutions< = v
\Text ATree }\‘Grid }\‘Sc:hemal#r
For Help, press F1 Ln1Col 1 Char 60 (0x003C) MM

Figure 5. Editors Use Color-Keyed Text

Tip Stylus Studio usesdifferent colorsto distinguish markup, tag names, and datain all of its
text editors. Orange, for example, identifies elements that are not associated with a
schema. You can change the colorsfor editorsindividually. Select Tools > Options from
the menu bar, then select Editor Format. You select the editor whose settings you want to
modify using the Editor drop-down list.

Alternatives
The File Explorer window is the primary way to open and access filesin Stylus Studio,
but you can also open files using:

« TheOpen dialog box, which is displayed when you select File > Open from the menu
bar or click the Open @ button on the tool bar, for example.

« TheProject window, which is displayed on the left of the Stylus Studio desktop. The
Project window shows only those files associated with Stylus Studio projects.
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For more information

See “Opening Filesin Stylus Studio” on page 92 to learn more about the File Explorer
window.

See “Working with Projects’ on page 100 to learn more about projectsin Stylus Studio.

Updating the Text of a Sample Document

When you update an XML document in the Text view of the XML editor, you can usethe
usual editing tools, aswell as tools tailored for handling XML.

Each of the following topics containsinstructions for editing a sample XML document.
You should perform the stepsin each topic before you move on to the next topic. After the
first topic, some steps depend on actions you performed in a previous topic.

For more information on editing tools and features, see Using the Text Editor on
page 143.

This section provides instructions for

. “Displaying Line Numbers’ on page 12

« “Adding Elementsin the Text View of a Sample Document” on page 13

« “Copying and Pasting in the Text View of a Sample Document” on page 14
« “Undoing Operationsin the Text View of a Sample Document” on page 14

o “Inserting Indents in the Text View of a Sample Document” on page 16

o “Querying inthe Text View of a Sample Document” on page 17

« “Deleting and Saving Queries’ on page 19

Displaying Line Numbers

Stylus Studio letsyou optionally display line numbersin most of itseditors. Line numbers
provide simple, unobtrusive points of reference that can make working large or complex
documents easier. Line numbers are off by default; turn them on now.

0 To display line numbers:

1. Select Tools > Options from the Stylus Studio menu.
Stylus Studio displays the Options dialog box.

12
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2. Click Application Settings > Editor General.

Options E|
I General - —
pplication Settings Editor: | #ML Editor b Mewline format | Preserve Original -
M E ditor General [] Show line numbers . ‘wiord delfimiters: | <3""=.2 A0
Editor Farmat Tiatle sl eokiAy
B ack-mapping : ]
Spell Checking Indenter Settings Tah Settings
File Types ] Preserve hailing/leading whitespace () Keep Tabs
JavaVitual Machine Prezerve newlines between elements () Insert Spaces
Custom Tools
Custom File Systems Wiap attributes if they exceed column | 256 Tab Size: |4
Customn Document Wizards
Custom ¥ alidation Engines
I3 Module Settings Sense:
[E9 DBtaXML Sensge: enabled Auto-close open tag when tping </
& Defait Datebase Connact . [#] swtamatically insert attribute value  [] Add chozing bag when creating new tag
arva
Debugger Dropdown delay: Short : Long
7 ‘Web Service Call Composer
P'D_"-” Settings [ Do not add *Created with Stz Studio” comment at the end of a document
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Engine
Presentation 3

Figure 6. Sense:X and Other Editor Features are in the Options Dialog Box

3. Select XML Editor from the Editor drop-down list.
4. Click Show line numbers.

5. Click OK.

Adding Elements in the Text View of a Sample Document

0 To add elements in the Text view of your-quotes.xml:
1. Inthe XML editor window, click in thefirst line just after <ticker>.

2. Press Enter and type <quote><company>data</.

Sense:X™ Auto-Completion

As soon as you type the closing forward slash, Stylus Studio displays company> because
itisthe only element that is appropriate to close. Automatic closing of open tagsis part
of Stylus Studio’s Sense: X intelligent editing. You can change this and other Sense: X
optionson the Editor General page of the Options dialog box —for example, you can have
Stylus Studio display alist of appropriate elements, even if that list includes one only
item.
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Stylus Studio’s Sense: X provides even greater functionality if the document you are
editing has either aDTD or XML Schema associated with it. See “ Sense:X Speeds
Editing” on page 145 for more information.

Copying and Pasting in the Text View of a Sample Document

Thistopic is part of a sequence. If your-quotes.xm1 iSnot open, see “Opening a Sample
XML Document” on page 10. The sequence starts with “Adding Elementsin the Text
View of a Sample Document” on page 13.

[0 To copy and paste elements in the Text view of your-quotes.xml:

1.
2.

Use the mouse to select the text for one quote e ement and its contents.

In the menu bar, select Edit > Copy.
Alternatives. Press Ctrl+C or click Copy.

Scroll down in the XML editor and click just before </tickers.

In the menu bar, select Edit > Paste.

Stylus Studio copies the quote element here, but the indentations are not quite right.
Instructions for fixing this are in the topic Inserting Indents in the Text View of a
Sample Document on page 16.

Alternatives: Press Ctrl+V or click Paste. B .

Undoing Operations in the Text View of a Sample Document

Thistopic is part of asequence. If your-quotes.xm1 iSnot open, see “Opening a Sample
XML Document” on page 10. The sequence starts with “Adding Elementsin the Text
View of a Sample Document” on page 13.

0 To undo operations performed on the your-quotes.xml document:

1.

In the menu bar, select Edit > Undo to remove the text you just pasted.
Alternative: Press Ctrl+Z.

In the menu bar, select Edit > Redo to replace the text you just removed.
Alternative: Press Ctrl+Y.

In the XML editor window, click Indent XML Tags s & , which isthe left most button.

14
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Stylus Studio displays a message that alerts you that there is an open tag for a quote
element but no close tag. The messages indicates the line and column in which the
error was found.

4. Intheaert box, click OK. Because the document is not well-formed XML, Stylus
Studio does not insert indents in the document. The next topic, Inserting Indentsin
the Text View of a Sample Document on page 16, shows how to fix the document so
that it is well-formed.
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In the menu bar, click Edit.

The Undo and Redo operations are no longer active. After you click the Indent XML
Tags button, you cannot automatically undo or redo recent changes. It does not matter
whether or not Stylus Studio actually inserts the indents. After you make another
change, the Undo operation becomes active again.

Inserting Indents in the Text View of a Sample Document

O

Tip

Thistopic is part of a sequence. If your-quotes.xm1 iSnot open, see “Opening a Sample
XML Document” on page 10. The sequence starts with “Adding Elementsin the Text
View of a Sample Document” on page 13.

To insert indents in your-quotes.xml:

1.

In the XML editor tool bar, click Indent XML Tags & & again.

Stylus Studio displays the message that indicates that a close tag is missing. It
specifies the element name, and the line and column numbers that identify where the
error was found.

In the alert box, click OK.
Stylus Studio moves the cursor so that it appearsimmediately after the quote tag that
has no closing tag.

The current cursor location within the document is displayed as line/column
coordinatesin the Stylus Studio status bar at the bottom of the Stylus Studio window.

11 < =105,100< =

12 < =27 11/16< =
12 « =27 378« s
14 [ =

3

€ Lnid4cals[l >

Figure 7. Document Position Displayed in Status Bar

£
\Texl l(ﬂTnae lh[ilil:l .h Schema l/

Inline2, click after the </company> tag and type </. By default, Stylus Studio displays
quote> because it isthe only element that is appropriate to close.

In the XML Editor tool bar, click Indent XML Tags & & .
Thistime, Stylus Studio correctly indents the XML text.

Indent XML Tags changes your XML document by inserting white space. If thisis
undesirable, and you want to check for well-formedness, click the Tree tab at the bottom

16
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of the XML Editor window. If the document is well-formed, Stylus Studio displaysthe
tree representation. If the document isnot well formed, Stylus Studio displays a message
that indicates the reason the document is not well formed and the location of the error or
omission.

Querying in the Text View of a Sample Document

You use the XPath Query Editor to query XML documents using X Path. Stylus Studio
supports both XPath 2.0 and 1.0. The default is X Path 2.0.

The XPath Query Editor is a dockable window that appears to the right of the XML
document window. If you do not seeiit, click the Show XPath Query Editor button ([I4]).

Ex»ﬂ File Edit Wew Project Debug XML SourceControl Tools ‘Window Help

iv.iml B & &y [ ; # o

#Path Query Editor

D

Mamespace LRI Prefix from D ocument Fedefined Prel

§ ML youl-quol...|
R B A
= < =

#XML Innovafflons-
FEMLI<
>Nasdag NME<
==7/16<
=27 1/4< >
==1.58<
=108, 10 3
=Z7 9716,

=105, 100=
=27 11/16<
=27 3/8= >

L & 1

AA A A A A A A A A A

14 < =

15 M < =

X80 Solutions<
=EELE =
>Nasdag NME<

==9/16+< = v
b

A A A

<
\Text A Tree } Grid J, Schema /

Ln 1 Col 1 Char 60 {0x003C) MUM

Figure 8. XPath Query Editor

Thistopic is part of a sequence. If your-quotes.xm1 iSnot open, see “Opening a Sample
XML Document” on page 10. The sequence starts with “Adding Elements in the Text
View of a Sample Document” on page 13.

[0 To query your-quotes.xml:

1. Click the Query 1 tab in the XPath Query Editor.
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2. Type /ticker/quote and click the Execute Query button ([ ).

Stylus Studio runsthe /ticker/quote query on your-quotes.xml, and displays the
results at the bottom of the XPath Query Editor window.

3. Inthe Query Output window, expand the second quote element to view its contents.
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4. Click the symbol element.

In the Text view, Stylus Studio uses its back-mapping feature to move the cursor to
the source element for the symbol result element you clicked.

BT & Yx[O $ S Qi #h 4

H#Path Guery Editor L o=

PO 23 [a)

o
i A E s (f f. & Marmespace LRI Prefix fram Document Redefined Prefix

< = ~
TR
»¥ML Innovations-
FEMLI= =
*Nasdaqg NM3<
==T7/16< =
=27 1/4< =
==-1.58< 1 /ticker/quote
=108, 10 5/8<
27 9/16, 26 :
=105, 100= >
=27 11/16<
=27 3/8< =

e pour-quot. .. |

Queryl

Mo~ omom bW ok =

A A A A A A A A A A

Tag Walue
"% company X3L Solutions

19

\ Test i Tree }, Grid J, Schema / = . D
Ln 17 Col 30 Char 0 {0x0000) MUM

Figure 9. Backmapping from XPath Query Result to XML Document

5. Inthe Text view, click the down arrow to the right of the query field.

6. Inthe XPath Query Editor window, click the New Query button ([0)).
Stylus Studio adds a new tab for each query you define.

7. Type //company and click the Execute Query button ([ ).
Stylus Studio runs the new query and displays the results.

8. Closethe XPath Query Editor window by clicking the x in that window’s upper right
corner.

Deleting and Saving Queries

You cannot explicitly delete aquery. In addition, queries you define are not saved with an
XML document unlessthat document belongsto a Stylus Studio project —if you closethe
XML document and then reopen it, the queries you defined in the previous editing session
are no longer there.
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For more information
See “Using the XPath Query Editor” on page 694 to learn more about the X Path Query
Editor.

See “Working with Projects’ on page 100 to learn more about projects and their rolein
Stylus Studio.

Updating the Schema of a Sample Document
This section provides instructions for updating the internal DTD for your-quotes.xm1.

When an XML document has an external DTD, you can view the external DTD in the
Schema tab of the XML Editor, but you cannot edit it. To be ableto edit an external DTD,
you must open it in the DTD editor. When an XML document has an internal DTD, you
can view and edit it in both the Schema tab and the Text tab of the XML editor.

You should have already performed the steps in “ Updating the Text of a Sample
Document” on page 12. Each of the following topics containsinstructions for editing the
sample XML document. You should perform the stepsin each topic before you move on
to the next topic. After the first topic, some steps depend on actions you performed in a
previous topic.

This section includes the following topics:

« “Creating a Sample Schema’ on page 20

« “Defining a Sample Element” on page 22

« “Adding an Element Reference to a Sample Schema’ on page 24

o “Defining an Entity in a Sample Schema” on page 25

« “Exploring Other Featuresin a Sample Schema’ on page 25

For more information, see “ Defining aDTD — Getting Started” on page 61.

Creating a Sample Schema

0 To create the schema of a sample XML document:

1. If itisnot already open, open your-quotes.xml. See “Opening a Sample XML
Document” on page 10 if you need help with this step.

2. At the bottom of the XML editor window, click the Schema tab.
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Stylus Studio displays the Schema tab, and opens the Properties window. The
Schema tab displaysa DTD tree, which is currently empty.

Stylus Studio - [your-quotes.xml]

Eile Edit Yiew Project Debug XML DTD XMLSchema SourceContral Tools Window Help
= = Ei ? dh
Froperties x your-quol...‘
F & WS |§| v T T2 [ |z: //company v
PCEE oo |
N

Figure 10. Default Schema Tab for Document With no Schema

3. To create aschemafor your-quotes.xml, select XML > Create Schema from XML
Content from the Stylus Studio menu.

Stylus Studio displays the Create Schema or DTD dialog box. By default, Stylus
Studio generates an internal DTD and insertsit in aboCTYPE element at the beginning
of the document. You can also use this dialog box to generate an external XML
Schemaor DTD.

Create Schema or DTD fXI

Use this dialog box to generate =ML Schema or a DTD based
on the current XML document's content

(%) Generate %MLS chema

Output File: | B

() Generate DTD

[ 0K ] [ Cancel ]

Figure 11. Create Schema or DTD Based on XML Content
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4. Click Yes toinstruct Stylus Studio to create a DTD based on the XML document

content.

Stylus Studio displays atree representation of the new, internal DTD. It also displays
the Properties window.

@ Stylus Studio - [your-quotes.xml *] =1
[Z File Edit Wiew Project Debug XML DTD XMLSchema SourceConfrol Tools \Window Help x
& s = = B &
Froperties x youl-quo_._"
ra 4
:[= & Em
"E ticker
"5 quote
"® company
"8 symbol

®® sxchange
Enk "% change
Bt "3 last

®® potchange

"% yrhighlow

"8 volume
"% prevelose
®® open

T i %

®® davhighlow

\Text }‘Tree }‘ Grid ;\Sehama l{r

For Help, press F1

UM

Figure 12. Result of Generating a Schema Based on XML Content

Defining a Sample Element

Thistopic is part of asequence. If your-quotes.xm1 iSnot open, see “Opening a Sample
XML Document” on page 10. The sequence starts with “ Creating a Sample Schema’ on

page 20.

0 To define a new element in the Schema view of the sample schema:

1. Click the company element in the Schema tab.

22
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This selectsthe company element definition and displaysthe propertiesfor the company
element in the Properties window.

Stylus Studio - [your-quotes.xml]

wa Fila Edit VWiew Project Debug XML DTD SourceControl Tools Window Help x
# 2@l BT s
Properties x 5
| yOUr-quo....
Type Element 5 |
MName COmMpany e
Content Model Mixed W @ fdebv x <.g + ¥ WS E'“
% B & DTD ~
®® ticker
1 "% gquote
"o
B symbol

"% exchange

hance .
Tewt p Tree f Giid Schemal,rJ

JFor Help, press F1 UM
Figure 13. Properties Window Displays Element Properties

The Content Model property indicates the allowable contents for a company €lement.
Inthisexample, itisMixed, which meansthat a company €lement can contain specified
elements (as opposed to all elements defined in this DTD), attributes, and raw data.

Tip Windowslikethe Properties and Query Output windows are docking windows—you
can changetheir location within the Stylus Studio window, or separate them from the
Stylus Studio entirely, by dragging them to the desired location.

2. Click the DTD node.

Intheleft tool bar, Stylus Studio activates only those buttonsthat are applicableto the
DTD —you can add elements, entities, comments, and so on. But you cannot add an
attribute definition, a reference to an element, or a #PCDATA node, for example.

3. Inthelefttool bar, click New Element Definition ¥:® . Stylus Studio displaysan entry
field at the bottom of the tree.

+ U preve lose
+-®% open
|

-]

Iy
Figure 14. Entry Field for a New DTD Element

4. Typelocation and press Enter. Stylus Studio displays the properties for the new
location element in the Properties window.
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5.

In theleft tool bar, click New Modifier 5. Stylus Studio displays a drop-down menu
of optionsthat specify the rules for the occurrence of the children of the new element.

+-®® prevelose
+-®% open
=™ location

0 v

Cptional

Cne or More
Choice
Segquence
One

Figure 15. Drop-Down List for Modifier Values

Double-click zero or More (or click onceto select it and press Enter).

In the left tool bar, click Add #PCDATA #3 . Your definition of the Tocation element
specifiesthat it can contain only raw data.

Adding an Element Reference to a Sample Schema

Thistopic is part of asequence. If your-quotes.xm1 iSnot open, see “Opening a Sample
XML Document” on page 10. The sequence starts with “ Creating a Sample Schema’ on

O

page 20.

To update the definition of the quote element to include an optional location

element:

1. Inthe Schema tab, expand the quote element.

2. Click its Sequence modifier.

3. Intheleft tool bar, click New Modifier §J.
Stylus Studio displays an entry field for the new modifier at the end of thelist of
modifiers that already apply to the Sequence modifier. The entry field consists of a
drop-down list of available values for the new modifier.

4. Inthe drop-down list, double-click Optional.

5. Intheleft tool bar, click New Reference to Element E: Stylus Studio displays an
entry field after the new Optional modifier.

6. Typelocation and press Enter.

7. Tomovethelocation element to be earlier in the sequence, click its Optional

modifier.

24

Stylus Studio® 2010 User Guide



Updating an XML Document — Getting Started

8.

In the XML editor top tool bar, click Move Up 4l repeatedly until thelocation
element is where you want it to be.

Defining an Entity in a Sample Schema

Thistopic is part of a sequence. If your-quotes.xm1 iSnot open, see “Opening a Sample
XML Document” on page 10. The sequence starts with “Creating a Sample Schema” on

page 20.

[0 To define an entity in the internal DTD for your-quotes.xml:

1.
2.

Click the DTD node.

In the left tool bar, click New Entity .

At the end of the schema, Stylus Studio displaysEnt and aentry field for the name of
the new entity.

Type TcecC for the name of the entity and press Enter.
In the Properties window, Stylus Studio displays the properties for the new entity.

In the Properties window, double-click the value field.

Type The Country’s Best Computer Company and press Enter.

Exploring Other Features in a Sample Schema

Thistopic is part of a sequence. If your-quotes.xm1 iSnot open, see “Opening a Sample
XML Document” on page 10. The sequence starts with “ Creating a Sample Schema’ on

page 20.

0 To toggle white space or validate your document:

1.

Click Toggle Display of White Space w5 to display nodesthat represent white space
inthe DTD. Click the button again to hide the white space nodes.

Stylus Studio® 2010 User Guide 25



Getting Started with Stylus Studio®

2.

Click validate Document .

Stylus Studio displays a message in the Output window that indicates that the
document is valid.

Stylus Studio - [your-quotes.xml *]

Eile Edit Wiew Project Debug XML DTD XMLSchema SourceControl Tools Window Help X
= M & B Ei ] ? &4
Properties b4 A
Type DTD 2 your-quo... | - -
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Modifir  Dptiondl § & X £+ % ws G| ve TV EE
1) EF yrhighlow _ﬁ
ﬂ' # E’}: davhighlow
EF location v
\Tekt ;’\Tree l}‘Glit:l }‘ Schema I,IJ
Output WWindaw 2

Walidating yvour—-guotes.xml...

The HML document your-guotes.xml is walid

HUM

Figure 16. Output Window After Schema Validation

Updating the Tree Representation of a Sample Document

This section provides instructions for updating the DOM tree representation of the your-
quotes.xm1 document.

You should have already performed the stepsin “Updating the Schema of a Sample
Document” on page 20. Each of the following topics containsinstructions for editing the
sample XML document. You should perform the steps in each topic before you move on
to the next topic. After the first topic, some steps depend on actions you performed in a
previous topic.

This section includes the following topics:

“Adding an Element to a Sample Document Tree” on page 27

“Changing an Element’s Data in a Sample Document Tree” on page 27

“Adding Attributes and Other Node Types to a Sample Document Tree” on page 28
“Adding an Entity Reference to a Sample Document Tree” on page 29

26
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Adding an Element to a Sample Document Tree

[0 To add an element to the tree representation of your-quotes.xml:

1.

Tip

If it isnot already open, open your-quotes.xml.
See “Opening a Sample XML Document” on page 10 if you need help with this step.

At the bottom of the XML Editor window, click the Tree tab.
Stylus Studio closes the Properties window.

You can close the Output window if it is still open from the previous exercise.

Click the plus sign next to the ticker element to expose the children of the ticker
element.

Click New Element ¥:® in thel€ft tool bar to add a quote element to the document.
Stylus Studio displays a drop-down menu that lists the elements you can add at that
position in the tree.

Click quote and press Enter.

Stylus Studio displaysafield next to the new quote element. The DTD allowsagquote
element to contain data.

Click outside the field to close it without entering data.

Changing an Element’s Data in a Sample Document Tree

Thistopic is part of asequence. If your-quotes.xm1 iSnot open, see “Opening a Sample
XML Document” on page 10. The sequence starts with “Adding an Element to a Sample
Document Tree” on page 27.

0 Inthe Tree tab of your-quotes.xml, to change the data that an element contains:

1.
2.
3.

Expand the third quote element.
Click the symbol element.

In the XML Editor top tool bar, click Change Value 3 .

Stylus Studio activates the field to the right of the symbol element and selects the
current value.

In the active field, type xsoL and press Enter.

To theright of the exchange element, right-click Nasdag NMS.
Stylus Studio displays a shortcut menu.
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6.
7.

Click Change Value. Stylus Studio activates the value field for the exchange element.

In the active field, type NYSE and press Enter.

Adding Attributes and Other Node Types to a Sample Document Tree

O

Thistopic is part of a sequence. If your-quotes.xm1 iSnot open, see “Opening a Sample
XML Document” on page 10. The sequence starts with “Adding an Element to a Sample
Document Tree” on page 27.

To add attributes and other types of nodes to your-quotes.xm1:

1.
2.

Click the last quote element in the tree.

Click New Attribute .

Stylus Studio displays an attribute name field immediately below the selected quote
element.

youl-qun...’|
% wi V| T2 [ |
Tag Walue
+-®% cuote
o
@
*:@ company HTML Promises
" symbol ETHULP
"% exchange Nasdag NHS

Figure 17. Adding a New Element to a Document Tree

In the attribute name field, type agent and press Enter.

Stylus Studio displays a default value for the attribute, Text, in an entry field to the
right of the new attribute.

In the attribute value field, type Star Brokers and press Enter.

Stylus Studio displays an entry field for a new attribute name, allowing you to easily
add anumber of attributes, one after the other.

Click outside the attribute name field to close it.

Inthe XML editor top tool bar, click Validate Document [%4.

Stylus Studio displays a message in the Output window that indicates that the
document is not valid. The DTD does not specify the agent attribute for the quote
element. Stylus Studio allows you to modify your document in invalid ways, which
you might want to do during application design. The validation feature informs you
that your document is invalid when you try to validate the document.

28
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Click the agent attribute.
In the XML Editor top tool bar, click Delete Node 3 .

Click validate Document again.

Stylus Studio displays a message in the Output window that indicates that the
document is now valid.

Adding an Entity Reference to a Sample Document Tree

Thistopic is part of a sequence. If your-quotes.xm1 iSnot open, see “Opening a Sample
XML Document” on page 10. The sequence starts with “Adding an Element to a Sample
Document Tree” on page 27.

[0 To add an entity reference to your-quotes.xml:

1.
2.

If itisnot already selected, click the quote element you defined in the previoustopic.
In the | eft tool bar, click New Element ¥:#® to add subelements to the new quote
element.

Stylus Studio displays adrop-down menu that listsanumber of elementsthat you can
insert at this point. Scroll the list to view them all.

Click company, whichisfirst in the list, and press Enter.

Stylus Studio displaysafield next to the element name. You can enter data here, such
asthe name of the company. But rather than entering data, suppose you want to refer
to an entity. To refer to an entity:

Click outside the field or press the Esc key.

Click New Entity Reference (], which isthe last button in the left tool bar.

Stylus Studio displays a drop-down menu that lists the defined entities.

If the New Entity Reference button is not active, click Toggle Display of Entity
References [Ft inthe XML editor top tool bar. This button allows you to control
whether you can refer to entities.

Double-click TCBCC.

Stylus Studio inserts the text The Country’s Best Computer Company asthe value for
the company €lement.

Click the Text tab at the bottom of the XML editor window.

Stylus Studio displays the &TBCC; entity reference in the new company element.
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8. Click the Tree tab.

Updating a Sample Document Using the Grid Tab

/= The XML Editor Grid tab is available only in Stylus Studio XML Enterprise Suite

|-} ¥

and Stylus Studio XML Professional Suite.

This section provides instructions for updating the your-quotes.xm1 document using the
Grid tab of the XML Editor. The Grid tab is useful for displaying structured data. Itisa
convenient way to view adocument that contains multiple instances of the same type of

element, for example.

Watch it! You can view a video demonstration of this feature by clicking the
television icon or by clicking this link: watch the XML Grid Editor video.

A complete list of the videos demonstrating Stylus Studio’s featuresis here:
http://www.stylusstudio.com/xml_videos.html.
0 To update an XML document using the Grid tab:

1. If itisnot already open, open your-quotes.xml.
See “Opening a Sample XML Document” on page 10 if you need help with this step.

2. At the bottom of the XML Editor window, click the Grid tab.
Stylus Studio displays atable that contains the XML data.

youl-quol...‘
* F1| T2 b/
"% Tag Hame
= ticker -
®® Tag Hame " company " symbol ®® exchange
gquote HML Innowvations EMLI MNasdag NMS
quote H3L Solutions EIL3 Nasdag NMS
quote HTHL Promises HTHLF HNasdag NHM3
4 3
\ Text }‘Tree }‘Grid j{ Schema f’[

Figure 18. Grid Tab

The left most column, with the Tag Name heading, contains the children of the
<ticker> element. The remaining columns contain the grandchildren of the <tickers
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element. The heading of each column identifies the element name — company,
symbol, and so on.

Tip You can resize columns by dragging the handle on the column heading’s right side.
You can change the element order in the document by dragging the handle on the

column heading’s | eft side. Stylus Studio swaps positions with the column on which
you come to rest.

3. Sdlectthelast row by clicking to the | eft of the last <quote> element.
Therow is highlighted in blue.
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4. Click the Insert row after () button.

A new instance of the <quote> element is added to the document. The cursor is placed
in the <company> element cell.

"% Tay Hame
= ticker
®® Tag Hame " company "® symbol ®® exchange
quote XML Inncovations XMLI Nasdag NMS
quote 3L Solutions HZL3 Nasdag NMS
quote HTML Promises HTMLP Nasdag NM3

Figure 19. Grid with a New Row
5. TypexMmL Designs and press Enter.
Stylus Studio creates the value for the <company> subelement.
6. PressTab (or usetheright arrow key) to move the cursor to the next cell in the row.

7. Repeat Step 5 and Step 6 to create values for the <symbo1> and <exchange>
subelements.

8. If you want, you can continue to add the data contained in a quote €lement.

Modifying Values
It is easy to change and delete values in grid fields:

« To changethe value of any field, double-click the field and type the new data. Press
Enter to save the change.

. Todeetethevalueof afield, double-click thefield, select the text you want to delete,
and press the Del ete key.

Moving Around the Grid
You can move around the grid using the mouse and the keyboard.
Using the mouse, click where you want to place the cursor.

Using the keyboard:

« Usethe Tab key to advance the focusto the next cell; use Shift + Tab to move the
focusto the previous cell

o Usethe arrow keysto move the focusin the direction of the arrow you choose
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Working with Stylesheets — Getting Started

Thissection helpsyou get started working with XSLT stylesheets. To focuson stylesheets
that map XML to XML, see“Using the XSLT Mapper — Getting Started” on page 44. To
learn about using XML Publisher to generate XSLT for dynamic HTML reports, see
Chapter 15, “Publishing XML Data”

Except for the first topic, each of the following topics contains instructions for working
with asample XSLT stylesheet. You should perform the stepsin each topic before you
move on to the next topic. After the first topic, some steps depend on actions you
performed in a previous topic.
Thisintroduction to working with stylesheets in Stylus Studio is organized as follows:
« “Opening a Sample Stylesheet” on page 33

“XSLT Stylesheet Editor Quick Tour” on page 34

“XSLT Scenarios’ on page 38

To get started, you'll need to start Stylus Studio if you haven't already. See “ Starting
Stylus Studio” on page 8 if you need help with this step.

Opening a Sample Stylesheet

[0 To open the your-quotes.xs1 sample XSLT stylesheet in Stylus Studio:

1. IntheFile Explorer or Open dialog box, navigate to the examples\quotes directory in
your Stylus Studio installation directory.
Alternative: If the Stylus Studio examples project isopen, you can accessthisfilefrom
the Project window. To open the examples project, open examples.prj in the Stylus
Studio examples directory.
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Double-click your-quotes.xsl. Stylus Studio displaysthe your-quotes.xs1 document
in the XSLT Source tab of the XSLT editor.

il Stylus Studio - [your-quotes.xml]

wr File Edit Wiew Project Debug XSLT SourceControl Tools Window Help o
A 5 I =

4 M S c+ B THOE 0 % |

it i youl-quol...|

| s S ;T: your-quotes v D 3 EEI =

v =& ticker
<IDOCTYPE xsl:stylesheet [ ® smns
<lENTITY nhsp "e#160; "> g 5 c:mt:mlns
1= Company
. symbal
<xsl:stylesheet version="1.0" zmlns:xsl="http://www. w3.org/19¢ sxchangs
change
<xsl:template match="text() | @*"»<xsl:value-of select="."/»=</x: last
pctchange
<xsl:template match="*|/"s<usl:value-of select="."/ =</ xsl: tem whighlows
dayhighlow
<xsl:template match="/"><HTML> walurme
<HEAD> prevclose
<TITLE>Your-gtock-Quote. com</TITLE> open
</ HEAD>
<BODY link="#006363" vLink="#006363">
< face="Arial" size="Z2"> v
3 Al »
\XSLT Source AMapper }‘Params.-"ﬂther .'}
LnicColl UM

Figure 20. Stylus Studio’s XSLT Editor

Aswith the XML Editor, Stylus Studio uses different colors to distinguish markup,
tag names, and datain the XSLT Editor.

XSLT Stylesheet Editor Quick Tour

When you usethe Stylus Studio X SLT stylesheet editor, youwork with XSLT stylesheets,
XML source documents, and result documents. This quick tour is organized to introduce
you to some of the main features for working with XSLT in Stylus Studio:

“Parts of the XSLT Editor” on page 35
“Exploring the XSLT Source Tab” on page 35
“Exploring the Paramg/Other Tab” on page 38
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Parts of the XSLT Editor

The XSLT Editor consists of four tabs that allow you to work with XSLT in different

ways, based on your preferences and the functionality that you desire.

e XSLT Source. Usethe XSLT Source tab when you want to directly edit or view the
XSLT source code that comprises your stylesheet. The XSLT Source tab can also be
agood way to learn more about XSLT.

Tip XSLT sourceis aso visible from a pane within the Mapper tab.

« Mapper. The Mapper tab allows you to create XSLT by graphically mapping source
document nodesto nodesin atarget document. Stylus Studio interpretsthe mappings
to generate X SLT that will yield adocument conforming to the document described
in the Set Target Document pane.

Note Using the Mapper tab is discussed in detail in “Using the XSLT Mapper — Getting
Started” on page 44.

« Params/Other. You use the Params/Other tab to specify the encoding Stylus Studio
uses to store the stylesheet, the stylesheet’s output method, and the encoding Stylus
Studio uses for the document that results from applying this stylesheet. You can also
use this tab to view default values for parameters used by your stylesheet.

Exploring the XSLT Source Tab

Thistopic is part of asequence. If your-quotes.xs1 iSnot open, see “Opening a Sample
Stylesheet” on page 33.

0 To work with the XSLT Source tab:

1. Inthe stylesheet text, click anywhere below the third xsl:template instruction (line
11).
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Tip

In the status bar just below the XSLT Editor tool bar, Stylus Studio displays match: /.
Thisindicates that the location you clicked isinside atemplate that matches the root
node.

..... #] your-quot. .. |
e e B |vourquates v 3 B % ==
@ v |E- g ticker
1 <IDOCTYPE xsl:styleshest [ ~ # sk, quote
2 <IENTITY nhsp "&fled; ">
3 1>
4
] <x3l:styleshest version="1.0" mlns:xsl="http://wmm.
(=1
z <xsl:template mateh="text () |@*"=<uxsl:valus-of select
8
=] <xsl:template match="*|/"><xsl:value-of select="."/>
10
11 <xsl:template match="/"><HTML>
12 <HEAD
13 <TITLE*Your-Stock-COuote. com</TITLE>
14 </ HEAD>
15 <BODY link="#006363" vIink="#006343"> b
< >
\XSLT Source AMapper }\Params.-"Dther .}

Figure 21. Current Template Identity Is Displayed at the Top of the Editor

Click in the xsl:stylesheet instruction (line 5).
Now the status bar is blank. Thisinstruction is not part of atemplate.

In the XSLT Editor tool bar, click Add a new template T .

Stylus Studio inserts the following after the last template already specified in the
stylesheset.

<xsT:template match="NewTemplate">
</xs1:template>

To define anew template, replace NewTemplate With the match pattern you want, and
add contents to the new template as needed.

You can also create a new template by double-clicking a node on the schematree.
Templates that match nodesin the XSLT document are displayed with acheck in the
schema tree, as shown here.

W B volume

& prevolose

e l open
Yellow indicates that the text cursor inthe XSLT source is within that template.
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4. IntheXSLT Editor tool bar, click Template Mode = , whichistheright most button.
Stylus Studio displays only the new template.

%j_voul-qun...‘|
R B prane VD 3 K[ @
@EWW_—@ - |- g ticker
1 <xzl:template mateh="NewTemplate'> - ifa QUOtE
‘ |
3 </xsl:template>

Figure 22. Use Template Mode to Focus on a Single Template

You can edit the stylesheet in either template mode or in full source mode. Intemplate
mode, Stylus Studio displays one template at atime. In full source mode, Stylus
Studio displays the whol e stylesheet.

Tip In large or complex stylesheets, use the XSLT Editor’s status bar to identify the
current template.

5. Inthe upper right corner of the editing pane, click the down arrow.

Stylus Studio displays alist of the templates in the stylesheet with their match
patterns.

ﬁjyoul-qun...‘|
F. T3 P |yourquotes v = R

L ticker
-k quote

match: texti)|i@*
mateh: *|f
match:/

mateh: Mew Template

Figure 23. You Can Show Individual Templates in a Stylesheet

6. Click match: */. This displays the template that matches every element and the root
node.

Every stylesheet that Stylus Studio createsincludes two built-in templates. One built-
in template matches every el ement and the root node. The other built-in template
matches all text and attribute nodes. See “ Using Stylus Studio Default Templates’ on
page 437.

To delete atemplate, click the match pattern for the template you want to delete and
then click Delete template ¥ inthe XSLT Editor tool bar. You must bein template
mode to delete atemplate.
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7. Click Full Source Mode

Stylus Studio displays the complete stylesheet. The cursor is at the beginning of the
template that was being displayed in template mode.

Exploring the Params/Other Tab

00 Click the Params/Other tab:

Drop-down menus let you specify the encoding format used to store the stylesheet in
Stylus Studio, as well as method and encoding output attributes. A simple grid displays
the name, source URL, and default value of any global parameters used by the active
stylesheet, as well as by any imported ones.

ﬁ:ﬂyoul-qun...’|

#5LT Encaoding:

Output method:

unspecified

UTF-3

<xzhoutputs attributes:

b

Output Encoding:

b

[ Indent

Fead-anly list of global parameters from this and included/imparted stylesheets:

Farameter

Source File

Default alue

iXSLT Source R td apper }\F’arams/Dlher /
Figure 24. Specify XSLT Parameters Here or in XSLT Source

All information that you can specify in the Params/Other tab can a so be specified in the
XSLT source. For example, you can specify the XSLT encoding in the processing
instruction at the beginning of the stylesheet; you can specify the output method and
encoding with the xs1:output instruction. Stylus Studio automatically updates the XSLT
source with any changes you make in the Params/Other tab, and vice versa.

XSLT Scenarios

Thistopic is part of asequence. If your-quotes.xs1 iSnot open, see “Opening a Sample
Stylesheet” on page 33. The sequence starts with “Exploring the XSLT Source Tab” on

page 35.
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To apply a stylesheet to an XML document in Stylus Studio, you use a scenario. A
scenario isagroup of customizable settings that allows you to experiment with different
source XML documents (that is, the XML document to which you will apply the XSLT),
processors, parameter values, post-processors, and profiling settings. You can also use
scenariosto perform validation on the XML document that results from the XSLT
processing. (Validation is always performed before any post-processing you specify.)

—

Scenario Properties @

Existing scenarnios:

__ Frofiling Options “alidation Post-piocess
i ario 1

General Parameter Values Frocessor

Scenario hame:

Source #ML URL:
file: /¢ /c: /Program Files/Stylus Studio %ML Professional Edition/ex s E]

Output URL [optionall:

3 ()
Base URL for HTML links resclution [optional):
file: /##c: /Program Files/Stylus Studio #ML Professional Edition/ex

Store paths relative to %5LT document path

[] Preview result in an external application

I 0k l [ Cancel ]

Figure 25. Scenarios Let You Easily Test Stylesheets and XML Source

You can define multiple scenarios using different settings to see how each affects
document processing. Stylus Studio also supports scenarios for Web service calls,
XQuery, and XML pipelines.

An XSLT scenario is defined by a single stylesheet-X ML document pair. You can
associate any number of scenarios with a stylesheet, though only one scenario can bein
effect at the time the XSLT is processed. Similarly, you can associate any number of
scenarios with an XML source document.

Tip Stylus Studio lets you work with several XSLT processors, including Saxon, MSXML
and .NET.

A scenario has already been created for the your-quotes.xs1 stylesheet, using the your-
quotes.xml asthe source XML document. Run the scenario now and look at the output
created by the XSLT defined in your-quotes.xsT.
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Tip

00 To run ascenario, click Preview Result & .

Stylus Studio processesthe source XML document using the X SLT stylesheet you specify
and displays the results in the Preview window.

v File Edit View Project Debug XSLT SourceControl Tools Window Help x
A = [ ™. e =
4 Hi s sl OGS = 0 &
7
iy i your-quol...|
[ AR, S vl = =
match: text(@* - B g ticker
<IDOCTYPE xsl:stylesheet [ ~ @ xmlr:s
<IENTITY nhsp "&fflé0; "= = ala ol
]=
<xsl:stylesheet version="1.0" zmlns:xsl="http:/ wmm. w3, org/ls
<xsl:template match="text() | @*"><xsl:valus-of select="."/></2
e
4 2 b
\XSLT Source AMapper }‘Params.-"tlther }'
Processing complete [B81 ms)
Presvigw x
> S
Your-Stock-Quotes.com
-
______
SUMMARY
Symbol: Last: Change: % Change:
HMLI 2714 16 -1.58
KELS 45 316 916 -1.23
HTMLP AN +1/8 +1.14 a
\your-quotes [wour-quotes ksl l,rf
JFor Help, press F1 Lnlcoll TLIM

Figure 26. XSLT Processing Results are Shown in the Preview Window

By default, results are displayed using a Web browser. If you choose, you can display

resultsin tree or text format, by clicking Preview in Tree |'L: and Preview Text inthe
Preview window tool bar.

Usethescroll bar to review theHTML inthe Preview window. You can seethat the values
come from the XML document your-quotes.xml.

If it isnot already open, you can open the source XML document specified in a scenario
by clicking Open XML From Scenario &7 inthe XSLT Editor tool bar.
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Working with Scenarios

To defineadditional scenarios, click the down arrow next to the scenario fieldinthe XSLT
Editor tool bar, and click Create Scenario. After you have more than one scenario, click
the same down arrow to select the scenario you want to use to preview aresult.

To changethe properties of ascenario, or to delete a scenario, select the scenario you want
to change or delete, and then click Browse | ... | to the right of the scenario name field.
Stylus Studio displays the Scenario Properties dialog box.

About Preview

When you preview aresult, Stylus Studio automatically savesthe changesyou have made
to the document. If you want to revert to the document’s previous state, you can use the
undo function (Edit > Undo).

Working with a Sample Result Document

Thistopic is part of a sequence. If your-quotes.xs1 iSnot open, see “Opening a Sample
Stylesheet” on page 33. The sequence starts with “Exploring the XSLT Source Tab” on

page 35.

0 To work with a sample result document, follow these steps:

1. InthePreview window, click anywherein the display.
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Using its back-mapping functionality, Stylus Studio displays the template in the

XSLT Editor’s status bar and flags the line that generated the line you clicked with a

blue pointer.

: Stylus Studio - [your-quotes.xml]
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Figure 27. Back-mapping Shows which XSLT Generated a Result
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Note

In the | eft tool bar of the Preview window, click Preview Text [£]. Stylus Studio
displays the HTML file that generates the browser display.

-

Teview x

[ = = = http-equiv="Content-Type" < onteil Back-map Stack
e XMLI) : szl template match="/"".. in your-quates.=sl [line ...
- =/ Bx= == e ==
& TELE) :
</Bw< >< >< =<
§ HTMLE) :
T < = = =< =

1 _’|L|‘| | ¥

A our-quates. html [your-quotes. xz|

Figure 28. You Can Render XSLT Results as Plain HTML

Click anywhereintheHTML display. The gray background identifiesany HTML that
was generated by the same template.

Thisworksin reverse aswell. If you click aline in atemplate (full source mode or
template mode), Stylus Studio uses a gray background to display the HTML
generated by that template.

In the left tool bar, click Export Preview ‘ Stylus Studio displays the Save As
dialog box. If you want, you can enter afile name and click Save to preserve the
generated HTML file. Otherwise, click Cancel.

Notice the tab at the bottom of the XSLT Preview window. It specifiesyour-quotes
[your-quotes.xsl]. After you create another scenario and apply the stylesheet in that
scenario, another tab with the name of that scenario will be displayed. You can click
the tab for the result you want to view and easily compare result documents from
different scenarios.
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Using the XSLT Mapper — Getting Started

é;;

The XSLT Mapper is available only in Stylus Studio XML Enterprise Suite and
Stylus Studio XML Professional Suite.

This section helps you get started using the XSLT Mapper to create stylesheets that
aggregate data and transform XML. The sample filesused in this section arein the Stylus
Studio examples\simpleMappings directory. If you follow the proceduresin this section,
you create the BooksToCatalog.xs1 stylesheet. A sample version of this styleshest,
sampleBooksToCatalog.xs1, iSaso in the examples\simpleMappings directory of your
Stylus Studio installation directory.

Each of the topicsin this section contains instructions for working with sample XML
documents that you can use to familiarize yourself with the XSLT Mapper. You should
perform the stepsin each topic before you move on to the next topic — after thefirst topic,
some steps depend on actions you performed in a previous topic.

This section covers the following topics:

o “Opening the XSLT Mapper” on page 44

o “Mapping Nodes in Sample Files’ on page 46

« “Saving the Stylesheet and Previewing the Result” on page 50

. “Deleting Linksin Sample Files’ on page 51

« “Defining Additional Processing in Sample Files’ on page 51

In addition to the topics described in this section, the Stylus Sudio® 2010 User Guide
contains other sources of information on XSLT:

o Tolearn more about XSLT, see “Working with XSLT” on page 377.

o Toget started XSLT Editor features for stylesheets, see “Working with Stylesheets—
Getting Started” on page 33.

o Tolearn about the XSLT mapper in greater detail, see “ Creating XSLT Using the
XSLT Mapper” on page 507.

To get started, you will need to start Stylus Studio if you haven't already. See “ Starting
Stylus Studio” on page 8 if you need help with this step.

Opening the XSLT Mapper

This procedure describes how to open the XSLT Mapper and select the files you want to
use for the drag-and-drop operations that will define your XSLT stylesheet.
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0 To open the XSLT Mapper:

1. From the Stylus Studio menu bar, select File > New > XSLT Stylesheet.
Stylus Studio displays the Scenario Properties dialog box.

2. Click the Cancel button to dismiss the dialog box.

3. Click the Mapper tab.

Stylus Studio displays XSLT editor with the Mapper tab selected. The source pane
beneath the mapper panes appears by default, allowing you to see how the mappings
of XML document elements are rendered as XSLT. The source paneisfully editable
and synchronized with the XSLT Mapper. Of course, you can always click the XSLT
Source tab for afull-screen view of your XSLT code.

4 Stylus Studio - [Untitled4.xsl *] =1
@ File Edit View Project Debug XSLT WYSIANYG SourceContral Tools Window Help x
P BB ?

49 Untitied..."

= Create Scenario... v ] E | | :T:

Add Source Document match=""" w Set Target Document

-
<?xml wversion=T1.0"7> P
<xsl:styleshest wversion="1.0" smlns:xsl="http://wmr.w3.org/1999/281

1

-

3

4  <xsl:template match="/"> r
= %
<

5

#5LT Source hMapper AF’arams.-"Dther }

MM

Figure 29. XSLT Editor Mapper Tab for a New Stylesheet

Tip The Project window also appearsif it was open the last time Stylus Studio was
closed. You can closeit.

4. Click the Add Source Document button at the top of the mapper’s | eft pane.
Stylus Studio displays the Open dialog box.
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5. For this example, navigate to the examples\simpleMappings directory in the Stylus

Studio installation directory.

6. Double-click books.xml.

7. Click the Set Target Document button at the top of the Mapper’s right pane.
Stylus Studio displays the Open diaog box.

8. For this example, navigate to the examples\simpleMappings directory in the Stylus

Studio installation directory.

9. Double-click catalog.xml.

Stylus Studio displays tree diagrams of these XML documents. The default XSLT
source code has not been altered at this point.

i Stylus Studio - [Untitled4.xsl *]
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Catalng %2
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<?xml version="1.0" ?>

<xsl:template match="/"/>
</msl: styleshest>

<

<
1
2 <xsl:styleshest versiorn="1.0" mmlns:xsl="http://wmr.w3.org/1999/%21
3
4
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Figure 30. XSLT Mapper Tab with Source and Target Documents

Mapping Nodes in Sample Files

Thistopicis part of a sequence that starts with “ Opening the XSLT Mapper” on page 44.
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0 To define links and examine the stylesheet Stylus Studio creates:

1. Inthe Mapper tab, expand the tree for both books.xm1 and catalog.xm1.

Tip You can display an entire tree using the asterisk key (*) on your keyboard's number
pad.

2. Inbooks.xm1, place the pointer over the book repeating el ement.

3. Pressand holdtheleft mouse button, and drag from book to the Book repeating element
in catalog.xm1.
Stylus Studio draws aline as you drag.

4. Release the mouse button to create the link between book and Book.

Stylus Studio creates an xs1: for-each block that links the book and Book repeating
elements. (If you mouse over the block, xs1: for-each appearsin apop-up to indicate
the XSLT operation represented by the link.)

Tip If you prefer, you can render xs1: for-each asasimpleline. You might want to do this
to simplify the appearance of the mapper canvas. Select Tools > Options from the
menu, and then navigate to Module Settings > XSLT Editor > Mapper.

k| Unlilled...‘|
B hooks sml ~ () = El | T
Add Source Document match="" v Set Target Document
Al = books,xml catalog.xrml = |
=& books Catalog W&
? nama -gb___,—JJ Book k=
=i OOk ———— /—/OL[% Tite &
@ bookid suthors & -2
¥ pubdate Author o
i title Fublisher &
bt =& authors PubDate & Y,
3 > < >
2 <xsl:template match="/"> ~
4 < =
5 p <xsl:for-each select="hooks/hook"™= &
< : ' >
#5LT Source l:’\Mapper l({F’arams.fﬂlher }

Figure 31. xsl:for-each Block Displayed by the XSLT Mapper

Also notice that the complete xs1:for-each instruction has been added to the XSLT
source, which appearsin the XSLT source pane under the XSLT Mapper canvas. The
back-mapping pointer identifies the line of XSLT that was just added to styleshest.
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Tip

Note

Thetemplate contains an xs1: for-each instruction that selects the book €lement,
which isthe node you selected in Step 2. The output from this template is an empty
Book element, which isthe node that was the target of the link. Stylus Studio created
the Catalog element automatically, to provide the document structure necessary to
support the Book element.

By default, Stylus Studio creates an xs1:value-of instruction when you link one
element to another; Stylus Studio creates an xs1: for-each instruction if you link two
repeating elements. You can also create other types of instructions graphically,
including xs1:1if, xs1:choose, and xs1:apply-template.

Click the Params/Other tab.

In the Output method: field, display the drop-down list and select xml. (Even if the
setting for Output method isunspecified, Stylus Studio still generates XML.) Other
choices for the output method include text and HTML.

Click the Mapper tab.
The xs1:output instruction is added to the XSLT source:

<xs1:output method="xml"/>

Create another link from the title e ement to the Title e ement.

When you map, you always map from the source document to the destination
document.
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8. Click the XSLT Source tab to see the new instructionsin the template. (If you prefer,
you can simply adjust the splitter between the XSLT source pane and the XSLT
Mapper canvas.

#] Untitled...~ ‘

Sk B | [books.sml VO = B s =
match: /
|-<?x:ml version="1.0" 7> A
<xsl:stylesheet version="1.0" zmlns:xsl="http://wwmw. w3, org/1999/%8
<xsl:output method="xml"/ >
<xsl:template match="/">
< =
<xsl:for-each select="hooks/book">
< >
<Title=
<xsl:value-of select="title"/ />
10 </ Title>
11 - >
12 </xsl: for-each>
12 < = s

Mo~ m ot bW k=

o

< ' >
\XSLT Source AMapper th'arams.-"Dther }

Figure 32. Stylus Studio Builds XSLT Based on the Mapper Links

For each link you define, Stylus Studio addsinstructionsto the template that matches
theroot node. Inthe XSLT you have composed so far, the XSLT insertsaBook element
for each book element it finds in the source document. In the Book €lement, the
stylesheet selectsthe title elements. For each title dement, it insertsaTitle
eement. Finally, in each Tit1e element, the stylesheet extractsthe value of the current
context node, whichisthe title node.

Why does the stylesheet extract the value of the tit1e hodes but not the book nodes?
The title node has only atext node asits child. In this situation, the default is that
the XSLT Mapper insertsan xs1:value-of instruction.
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Saving the Stylesheet and Previewing the Result
Thistopicis part of a sequence that starts with “ Opening the XSLT Mapper” on page 44.

0 To save the stylesheet and preview the result:
1. Click Save . Stylus Studio displays the Save As dialog box.
2. Inthe URL: field, type BooksToCatalog.xs]1.

3. Click the save button.

This saves the stylesheet that Stylus Studio has generated. It does not matter that you
have not finished mapping all nodes.

4. Inthe upper left corner of the XSLT Mapper, click Preview Result | = .

Tip When you create a stylesheet using the XSLT Mapper, Stylus Studio automatically
creates a scenario for you, using the source document you specify as the source
document for the scenario. Scenarios and their value in the application devel opment
process are described earlier in this chapter. See “XSLT Scenarios’ on page 38.

Stylus Studio displays the result of processing books. xm1 with the stylesheet you
created in the XSLT Mapper in the Preview window.

Preview x
<7tuml version="1.0" 7= ~

- =Catalog=

- - <Book=
<Title=Java Web Services</Titlex

</Book=

B - zBook:=

«Title>Java Message Service</Title>
=/Book=

G

\ baoks.#ml [BaoksT aCatalog.=sl] ./

Figure 33. Result of Applying XSLT to books.xml

The result document uses the same schema as the target document, catalog.xml in
this example. Because not all nodes have been mapped yet, the result document does
not contain al nodes found in books .xm1 (author and subject nodes, for example).

5. You can confirm that the result document isincomplete by viewing books .xm1. Click
Open XML From Scenario :j, which is at the top of the Mapper tab.
Stylus Studio displays the books.xm1 document in the Stylus Studio XML Editor.

6. Review the XML document, and then click the document tab for the
BooksToCatalog.xs! stylesheet to re-display the XSLT Editor.
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Deleting Links in Sample Files
Thistopicis part of a sequence that starts with “ Opening the XSLT Mapper” on page 44.
0 To delete links:

1. Click the Mapper tab if it is not already selected.
2. ClickthetitletoTitle link to select it.

Add Source Document match="/"' - Set Target Document
= biooks. xml catalog.xml = [
=& books Catalog W=
? name F____r__oﬁb———ﬁ_ﬁ Book =
=it book ———— Title &
@ bookid duthors & @
# pubdate Fublisher &
i fite —— PubDate &
© & authors shstract &
+ @ subject Pages &

Figure 34. Click a Link to Select It

3. Pressthe Delete key, or
a. Right-click the selected link. This displays a shortcut menu.
b. Click Delete to delete the selected link.

Tip In addition to Delete, the shortcut menu displays the following options:

« Go To Source displaystheline of XSLT code represented by the link you select
in the XML Editor.

o Carry Value allowsyou to create <xs1:value-of select="."/> statements. This
option is available for links representing xs1: for-each instructions only.

Defining Additional Processing in Sample Files

The stylesheet that the XSLT Mapper createsis not limited to the instructions that Stylus
Studio adds. You can edit the template as you would any template. Stylus Studio
automatically incorporates any changesyou maketo thetemplate and displaystheminthe
Mapper tab, if it is appropriate to do so.

In addition, you can perform external processing by, for example, defining Javafunctions
and incorporating those functions in your XSLT stylesheet. Like standard supported
XSLT functions, user-defined Java functions can be created graphically in the XSLT
Mapper —just right click on the mapper canvas, select Java Functions from the shortcut
menu, and select any registered Java function you want to use.
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See “Processing Source Nodes’ on page 534.

Debugging Stylesheets — Getting Started

The Stylus Studio debugger alows you to follow XSLT processing and detect errorsin
your stylesheets. Stylus Studioincludes samplefilesthat you can experiment withto learn
how to use the debugger. To get you started, this section provides step-by-step instructions
for using the debugger with these samplefiles. You should perform the stepsin each topic
in the order of the topics.

For compl ete information about how to use the debugger, see“ Debugging Stylesheets’ on
page 551.

In addition, Stylus Studio alows you to observe and debug the interaction between your
Java code and XML data. See “Debugging Java Files” on page 561.
This section includes the following topics:
o “Setting Up Stylus Studio to Debug Sample Files’ on page 52
« ‘“Inserting a Breakpoint in the Sample Stylesheet” on page 53
“Gathering Debug Information About the Sample Files’ on page 55

To get started, you' |l need to start Stylus Studio if you haven't already. See “ Starting
Stylus Studio” on page 8.

Setting Up Stylus Studio to Debug Sample Files

[0 To set up Stylus Studio to debug sample files:

1. Open the videosDebug.xs1 stylesheet, located in the examples\VideoCenter directory
where Stylus Studio was installed.

Alternative: If the Stylus Studio Project window is open, you can access this
stylesheet from the examples project.

Stylus Studio displays the videosDebug.xs1 stylesheet in the XSLT editor.

2. Inthe XSLT editor tool bar, click Preview Result B to run the predefined scenario
DebugVideosScenario. The source XML document is videos.xm1.

52
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Stylus Studio applies the stylesheet and displays the results (a finished HTML page
that displays information about a single video) in the Preview window.

Stylus Studio - [videosDebug.xsl]

4=
LT
o]
i |
i
(B
[
L5
W
)
>
=
il
Ifi

“if, B [DebugvidessScen.. v [0 21 |[KG) e =
match: f

<?xml wversion="1.0" encoding="UTF-8"?>
<xsl:stylesheet version="1.0" xmlns:xsl="http:// wwmw.w3.org/1995/%

<xzl:param name="VideoName"/> 3

Al B DR s

\XSLT Source AMapper }\F'arams.-"Dther }

Processing complete [10 mz)

Preview

Genre Format Price

A scientist drama  §iiS’ $16.99
makes contact
e 8.89
= with intelligent ® 3
Bl = »
\Debug\ﬁdeosScenano [ideosDebug.=sl] f’r

Ln 48 Col 1 UM

Figure 35. Preview of videosDebug.xsl

Inserting a Breakpoint in the Sample Stylesheet
Thistopicispart of asequencethat startswith “ Setting Up Stylus Studio to Debug Sample
Files” on page 52.

Aswith any debugger, in the Stylus Studio X SLT debugger you insert abreakpoint where
you want to suspend processing and examine what is going on. You can do this using the
Debug menu or the debug set of toolsin the tool bar.

Tip Toolsinthetool bar arein grouped by function. These groups, likethe onefor debug tools
shown here, are dockable and can be moved anywhere you please.

& & "o n 0P @
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0 To insert a breakpoint in the sample stylesheet:

1. Inthe XSLT Editor, click in line 202. Line numbers appear in the lower right corner
of the XSLT Editor window. Line 202 starts with

<xsT:template match="director">

Tip To display lines in Stylus Studio text editors, click Tool > Option > Editor General,
and select Show line numbers.

2. Inthe Stylus Studio tool bar, click Toggle Breakpoint & .
Alternative: If you prefer, select Debug > Toggle Breakpoint, or press F9.

Stylus Studio displaysared circleto theleft of thelinethat containsthe xs1: template
match="director" instruction. The XSLT processor will stop processing when it gets
to the instantiation of this template.

201

202. |<xsl :template match="director”sDirector: <xsl:value-of select="."/>
203

204 <xsl:template match="studio"=3tudio: <xsl:value-of select="parent::

£
\XSLT Source AMapper hParamsKDlher }

Figure 36. A Red Circle Shows Where Breakpoints Are Set

Do not do it, but to remove a breakpoint, you click in the line that has the breakpoint
and then click Toggle Breakpoint (or F9). The Toggle Breakpoint button and F9 key
operate astoggles.

3. PressF5 to start debugging.
Alternative: In the Stylus Studio tool bar, click Start Debugging .
The XSLT processor displaysayellow triangle to indicate where processing has been
suspended. Instead of thefinished HTML created when you first ran the scenario, the

Preview window displays just the HTML code because complete processing of the
XSLT was suspended before the finished HTML could be rendered.

201

2024y <xsl:template mateh="director"»Director: <xsl:value-of select="."/>
203

204 <xsl:template mateh="studio">Ztudio: <xsl:value-of select="parent::

<
\XSLT Source AMapper ;\F‘arams.-"Dther }'

Processing paused

Figure 37. Yellow Triangle Shows Where XSLT Processing Stopped

Do not do it, but to stop debugging, you can click Cancel in the lower right corner of
the X SLT editor window, or click Stop Debugging in the Stylus Studio tool bar.
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If you click Preview Result [ instead of pressing F5, Stylus Studio appliesthe
stylesheet without running the debugger. Pressing F5 always invokes the debugger. I
there are no breakpoints, and no errors, processing completes and Stylus Studio
displays the result in the Preview window.

Gathering Debug Information About the Sample Files

Thistopicispart of asequencethat startswith “ Setting Up Stylus Studio to Debug Sample
Files’” on page 52.

When XSLT processing is suspended at a breakpoint, Stylus Studio displaysthe
Variables, Call Stack, and Watch windows.

Warigbles X | | Call Stack b4
MHame Walue &j xzltemplate match="director”... in videosDebug.xzl (line 203)
$ideoMame | Contact @j vzl template match="video"... in videozD ebug. xsl [ine 146]
H- [Contest] Aresult(1)videns{1]videa|3]/ @j sl template match="/"... in videosDebug.xsl [ine 90)
Watch X

Mame Walue

Figure 38. Variable, Call Stack, and Watch Windows Appear During Debugging
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You can usetheinformation in these windowsto learn about potential and actual problems

encountered in your XSLT processing.

You can also control the display of these windows using the Debug menu, shown here, or

the tool bar.

=] Start Debugging FS

T Breakpaints Cirl+8
Al Toggle Breakpoint ~ F9
T StepInto Fi1
¥ Step Over Fi0
{3 Step Out Shift+FLL
i Stop Shift-FS

Watch Window

[Debug| xSLT wvsIwG Sourcs

@ ‘Warizble Window

@ Call Stack \Window
B output wWindaw

The Variables Window

The variables window displays alist of variables and their values when processing was

suspended.
Wariables
M ame W alue
$WideoM ame Contact

<director: M/A

= [Context] Aresull][1]4videos[1)video[9]/director1]

Figure 39. Variables Window

Asyou can see, the stylesheet defines the videoName parameter, which had no value when
processing was suspended. In addition, the Variables window shows you that when

processing was suspended, the processor was operating onthefirst director child element
of thefirst video child element of thefirst videos child element of thefirst result element.
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The Call Stack Window

The Call stack window displays a history of the steps the processor performed to reach
the point at which processing was suspended, including the names of the templates that
are currently instantiated, in most recent-to-oldest order.

Call Stack x
@ sl template match="director'” . in videasDebug 2l (line 203)

@ szl template match=""video"... in videosDiebug.xsl (line 14E]

@ szl template match="7"... in videosDebug.xzl [ine 80)

Figure 40. Call Stack Window

In thisexample, the XSLT processor has instantiated the di rector template, which is part
of theinstantiation of the video template, which is part of theinstantiation of the template
that matches the root node.

00 To step out of debug Step out E or press Shift+F11.
The processor completes the instantiation of the director template, which adds some
HTML to the Preview window. Theyellow triangle movesto show the new locationin the
XSLT source.
g videosDe...‘ ariables | | Call Stack x
Mame Walue ~ @ szl template match="videa"... in videosDebug.xsl [ine 207)
¥ DebugvideasScen... $ideoM ame Contact @ wslternplate match=""... in videozD ebug x4l [line 20]
=l [Context] Aresult[1]/videos[1]/videal 9]
match: / i = <videor
144  <td width="153"> - (@id id1263000
145 <font size="-Z"= <title> Contact
148 D <xsl:iapply—temp <genier drama
147 <hr/= v <rating: PG
< r 5 <zummany> | A scientist makes contact with i... Wiatch X
detail D d Dr. Ellie ...
\XSLT Source AMapper }\Params.-"Dther } zy::;s) 1:;?9 astronomer D. Elle A Ru s
Processing paused Cancel <director: | N/ w

Figure 41. Stepping Out Advances the Processor

Asyou can seein the Call Stack window, the processor is now two levels deep in the
template that matches the root node, instead of three levels deep asit was previoudly. The
value of the context node in the Variables window is /result[1]/videos[1]/video[9] (it
Was /result[1]/videos[1]/video[9]/di r'ector[l]).
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The Watch Window

If your application contains alot of variables, the Watch window allows you to focus on
the variables in which you are particularly interested.

Wwiatch x
M ame alue
=l title: <title» Contact< Aitles

<title Contact

Figure 42. Watch Window Lets You Track Variables

0O To enter a variable to watch:
1. Double-click the Name field.

2. Typethe name of the variable you want to watch and press Enter.
As processing continues, the Watch window displays the values of the variables you
specify.

Ending Processing During a Debug Session

0 To end processing during a debug session:

1. Inthe Preview window, click any line of text.

In the XSLT Source tab, Stylus Studio displays the blue back-mapping triangle that
indicates the line in the stylesheet that generated the output line you clicked.
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2. Inthelower right corner of the XSLT editor, click the Cancel button to end

processing.

] videosDe...|

e CebugvideosScen... Pa =

match: /

50 .r <centers A
51 <img align="bottom" width="&00" sro="ima
52 <hr/=

a3 <img align="bottom" width="&00" src="ima
54 <hr/>

55 </centers>

56 “centers

57 <table cellS8pacing="0" width="600" horde w
< >
\XSLT Source AMapper }‘Params.-"Dther }

Processing paused Cancel )

Figure 43. Cancelling Processing During Debugging

Stylus Studio displays a notification message that indicates that processing has been
stopped and, optionally, allows you to jump to the location where processing ended.

Stylus Studio

9,  Processing has been cancelled
\ﬂ/ URL: file:/ffc: forogram files/stylus studiofexamples/VideoCenter videosDebug.xsl
Line:146
Cal: 9
Jump to location?

| Yes | [ o I

Figure 44. You Can Jump to Where XSLT Processing Ended

3. Click Yes to jump to the location where processing ended.

The cursor appears on line 146 of the XSLT Source tab, which contains
<xsT:apply-templates select="director"/>.
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4. Inthe XSLT editor tool bar, click Open XML from Scenario ] .

Stylus Studio displaysthe XML source document that the stylesheet operateson. As
you can see, the first result element is the document element.

24| videos.xml |
Gwmut €| @
1 }<?xml version="1.0" encoding="UTF-§"?=< =
2 < =
2 < >
4 < >
5 < Faction< =
5 < Foomedy< >
T - >drama< =
= < =family< =
=} < =foreign< =
10 = Fhorror< =
14 < Fmusical< =
12 < =special< =
12 < >
14 < >
15 < G =
156 = FPE = v
< ¥
\Text ;{‘Tree I}‘Grid }‘Schema ;’[

Figure 45. Viewing the XML Source for an XSLT Transformation

This section demonstrated some of the major features of Stylus Studio’s debug tools,
including specialized windows for presenting call stack and variable information. For
complete information on using the XSLT debugger, see “Debugging Stylesheets’ on
page 551.
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Defining a DTD — Getting Started

This section provides a quick tour of the main features of the DTD Editor. It provides
instructions that you can follow to actually define asimple DTD. For complete
documentation about how to use the Stylus Studio DTD Editor, see“ Defining Document
Type Definitions” on page 665.

Process Overview

When you use Stylus Studio to defineaDTD, the main steps you perform are:

1.

2
3.
4

Create anew DTD schemafile.
Define the e ements that contain the raw data.
Define the e ements that contain other elements.

In the container elements, specify the rules for the contained elements. That is,
specify whether a contained element is optional or required, whether there can be
more than one, and what order contained elements must bein.

This section provides step-by-step instructions for defining the bookstore.dtd schema
file. You should perform the steps in each topic in the order of the topics. This section
includes the following topics:

“Creating a Sample DTD” on page 61

“Defining Data Elementsin a Sample DTD” on page 62
“Defining the Container Element in a Sample DTD” on page 63
“Defining Structure Rulesin a Sample DTD” on page 63
“Examining the Tree of a Sample DTD” on page 65

To get started, you'll need to start Stylus Studio if you haven't already. See “ Starting
Stylus Studio” on page 8.

Creating a Sample DTD

O To create anew DTD schema file:

1.
2.

From the Stylus Studio menu bar, select File > New > DTD Schema.

Click save .

Stylus Studio displays the Save As dialog box.
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3.
4.
5.

Navigate to the Stylus Studio examples directory.
In the URL: field, type bookstore.dtd.
Click the Save button.

Defining Data Elements in a Sample DTD
Thistopic is part of a sequence that starts with “ Creating a Sample DTD” on page 61.

O

Inyour DTD, suppose you want a book element to be optional. Further, if abook €lement
is present, it must always have exactly one title element and it can have any number of
author elements. The title and author €elements contain only raw data.

To accomplish this, perform the following steps:

1.
2.
3.

At the bottom of the DTD editor, click the Tree tab.
Click the DTD node at the top of thetreeiif it is not already selected.

Click New Element Definition #t® , which isthe top button in the tool bar on the left
side of the DTD editor window.

Stylus Studio displays an entry field for the element name.
Type title and press Enter.

Stylus Studio displays the new element, title, and the element’s propertiesin the
Properties window.

Stylus Studio - [bookstore.dtd *]

Eile Edit Yiew Project Debug DTD SourceControl Tools Window Help

E & = B R @ | = ?
Properties bt bookslol...’|
Type Element
Name litle:
Content Emply # X <-g WS £ ﬁ"
Model = & DTD

il it le

¢
9]
e
&
Figure 46. New Element in the DTD Editor

Click New Modifier %j.
Stylus Studio displays an entry field for the element’s modifier.

62

Stylus Studio® 2010 User Guide



Defining a DTD — Getting Started

6. Double-click zero or More.
The new modifier is added to the element.

7. Click Add #PCDATA .

8. To define the author element, repeat Step 2 through Step 7. In Step 4, type author
instead of title.

When you are done, the Stylus Studio desktop should resemble the following:

Properties

=

Type

FCOATA

hookslol..."

& XA WS
= &% DTD
=-®8 ritle
=-() Zero or More
# HPCDATR
= .'IZ: author
=-() Zero or More

Fr i

Figure 47. Creating a DTD with Two Elements

Defining the Container Element in a Sample DTD
Thistopic is part of a sequence that starts with “Creating a Sample DTD” on page 61.

O To define the book element:

1. Click the DTD node at the top of the tree.

2. Click New Element Definition #= .

3. Type book and press Enter.

Defining Structure Rules in a Sample DTD
Thistopic is part of a sequence that starts with “Creating a Sample DTD” on page 61.

0 To specify the rules for the structure of the book element:
1. Click thebook nodeinthe DTD treeif it isnot already selected.
2. Click New Modifier %J.

3. Inthedrop-down list that appears, scroll down and double-click Sequence. This
indicates that the book element can include one or more elements.
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O

4. Click New Reference to Element A" .

5. Typetitleintheentry field and press Enter.

Because the reference to the tit1e element appearsimmediately after the Sequence
modifier, the DTD editor assumesthat the default behavior iswhat iswanted. That is,
the book €lement must contain exactly one instance of the title element.

6. Click the sequence modifier.
7. Click New Modifier %J.

8. Double-click One or More. (There can be one or more author €lements in each book
element.)

9. Click New Reference to Element (I |
10. Type author in the entry field and press Enter.

At this point, the definition of the book element is complete, and the tree diagram of
bookstore.dtd should look like this;

Properties X|| o ,‘
Type PCOATA T
¢ X & ws[f@] w2 ¢ £ &
= o DTD
=" title
= () Zero or More
# HPCDATR
= .'IZ: author
=-() Zero or More

Figure 48. Early Steps of bookstore.dtd

However, you have not yet specified that you want the book €lement itself to be optional.
You need to do thisin the element that references the book element. For example, suppose
the bookstore element isthe root element in XML documents that use this DTD. Further
suppose that you want the book element to be a child of the bookstore €lement.

You can define the bookstore element as follows:

1. Click the DTD node at the top of the tree.

2. Click New Element Definition %% .

3. Typebookstore in the entry field and press Enter.

4. Click New Modifier ).

5. Inthedrop-down list that Stylus Studio displays, double-click Optional.
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6. Click New Reference to Element A" .

7. Type book in the entry field and press Enter.
8. Click save ﬂ

Examining the Tree of a Sample DTD

Thistopic is part of a sequence that starts with “Creating a Sample DTD” on page 61.
Your DTD should now look like Figure 49.

Properties X bookstor
Type Ref T = -

Element

Name book, ¢ X & WS 7 &
=& DTD
=" title
= () Zero or More
# HPCDATL
=7, author
= () Zero or More
# HPCDATL
= "E: hook
= () Segquence
7 title
= () One or More
E’}: author
= "E: hookstore
= () Optional

Figure 49. Finished bookstore.dtd

To complete this DTD, you could define magazine and newsletter e ements. In the
bookstore element definition, you could add references to the magazine and newsletter
elements. You could also expand the definition of the book €lement to include information
about the publisher, price, publication date, and number of pages.
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Defining an XML Schema Using the Diagram Tab —
Getting Started

This section provides a quick tour of the main features of the Diagram tab of the XML
Schema Editor and shows you how to define a simple XML Schema. For complete
documentation about how to usethe XML SchemaEditor, see* Creating an XML Schema
in Stylus Studio” on page 568.

Thetopicsin this section provide step-by-step instructions for defining the
bookstoreDiagram.xsd XML Schema document. You should perform the stepsin each
topic in the order of the topics.

This section includes the following topics:

“Introduction to the XML Schema Editor Diagram Tab” on page 67

“Editing Tools of the XML Schema Diagram Tab” on page 76

“Description of Sample XML Schema’ on page 81

“Defining a complexType in a Sample XML Schemain the Diagram View” on

page 81
“Defining Elements of the Sample complexType in the Diagram View” on page 90

To get started, you will need to start Stylus Studio if you have not already. See “ Starting
Stylus Studio” on page 8.
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Introduction to the XML Schema Editor Diagram Tab

The recommended way to define an XML Schemain Stylus Studio isto start with the
Diagram tab of the XML Schema Editor, which is shown in Figure 50.

€ Stylus Studio - [purchaseOrder._xsd *]

L File Edit Yiew Project Debug XMLSchema Diagram SourceControl Tools Window Help x
i i | [ e —|
T 1 Gl 1« & & = @
il r.-
Froperties x m pulchas...'|
Marne alue
1D = =] £ i M ] === |:
Hame comment T e
Type wad sting on browser ﬂ
Substitutio.... v
Default
Fized Value
Hillable False
Abstract Fal
Bloscz::i 5. e B I:"[EpurchaseOr(Ier T
Final Subs... .
nal suhs Type PurchaseOrderType XML Schema diagram pane
Properties
window
I |GE] Purchase OrderType B2 shipTo B5] USAddress & @= Iy
= Type | USAddress v Tyri
< | 3
it In Sync
= =
<xad: element name="purchaseOrder” type="PurchaseOrderType"/> ~
} <xad: element name="comment" type="xsd:string"/> Text
ext pane
<xsd: complexType name="FurchaseOrderType"> bl
< | =
\Diagram .({\ Tree hDocumentation ./
For Help, press F1 UM

Figure 50. Diagram Tab of the XML Schema Editor

When you use the Diagram tab to define an XML Schema, you can create XML Schema
nodes directly on the XML Schema diagram pane using tools on the tool bar or from the
XML Schema > Diagram and shortcut menus. You can also type in the text pane, which
appears under the Diagram tab. The text pane displays the XML Schema syntax Stylus
Studio creates for you as you work in the diagram pane.

Stylus Studio ensures that the XML Schemayou create isvalid. For example, any nodes
you define are created in the required order in the XML document that containsthe XML
Schema definition, regardless of the order in which you create them.
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The Diagram tab, shown in Figure 50, consists of three main areas:
“Diagram Pane” on page 68

o “Text Pane” on page 73

o “Definition Browser” on page 75

This section describes these areas and how to work with them.

Diagram Pane
Thediagram pane contains graphical representations of the elements, attributes, and other
nodes that make up your XML Schema.

v purchas...™ ‘

LR R B [ et v o4 X y 48] 28

purchaseOrder. xsd

E= I ‘D@P“’C"aseo'de’ T’* ES]PurchaseOrderType o
=

Type PurchaseOrderType

PurchaseOrder Type

[ [FEcomment
Type | xsd:string

u EPurclmse()r(lerType =
=

1t In Sync

\ Diagram ./\ Tree }\ Documentation l/

Figure 51. Schema Diagram Pane

Nodes

Each node displayed in the diagram pane is represented by its own symbol; toal tips,
which are displayed when you hover over anode in the diagram, identify the node'stype
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(element, attribute, sequence, and so on). The symbols used in the diagram are

summarized in Table 1.

Table 1. Symbols Used in the XML Schema Diagram

Symbol

Represents

schema (xsd: schema)

annotation (xsd:annotation)

documentation (xsd:documentation)

element (xsd:element)

attribute (xsd:attribute)

attributeGroup (xsd:attributeGroup)

simpleType (xsd:simpleType)

complexType (xsd: complexType)

EEREEREE

&

choice (xsd: choice)

)

sequence (xsd: sequence)

key (xsd:key)

key reference (xsd:keyref)

unique (xsd:unique)

group (xsd:group)

simpleContent (xsd:simpleContent)

complexContent (xsd: complexContent)

restriction (xsd: restriction)

extension (xsd:extension)

union (xsd:union)

D2 = 5= © & |==E

list (xsd:11st)
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Nodes can be expanded and coll apsed using the plusand minus symbols, respectively, that
appear on the right side of the node. In Figure 54 for example, the PurchaseOrderType
complexType has been expanded. The shipTo element has not.

Displaying Properties

To streamline the diagram, most nodes are displayed with their properties hidden by
default. Exceptionsinclude element, extension, and restriction nodes, for which the type
isdisplayed, as shown in the productName element in Figure 52.

o seieimg
Figure 52. Most Nodes Appear with Properties Hidden

You can change the display for classes of nodes (all elements, for example) using the
Diagram Properties dialog box, shown in Figure 53. (In addition, the Properties window
displays all the properties for any node you select.)

Schema Diagram Properties §|
Schema Detals | \wSDL Details

Categony/Property Inline wigibility in diagram ~
BEE Y crrooion L He
® gn Ay Hide

B =" Anpdttribute Hide

® P Applnfo Hide

[ = Abtrbute Hide

# @ AttibuteGroup Hide

& Ff ComplexContent Hide

2] Eﬂ ComplexT vpe Hide

# &% Documentation Hide
# B3 Element =
# T8 Ewtension -
® Lo Field Hide

® [H Group Hide

T, Key Hide

[ [Ah KeyRef Hide

el = Teas b
[ Hide a&ll ] [ Bestore Defaults ]

Figure 53. Schema Diagram Properties Dialog Box

For each node property, you can choose to

« Show the property

«  Show the property only if it is not empty
« Hidethe node
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If all of anode's properties have the same show/hide setting, that valueisdisplayed in the
Inline Visibility in Diagram field. If no valueisdisplayedintheinline Visibility in Diagram
field, it means that two or more properties have different show/hide settings.

0 To display the Diagram Properties dialog box:
o Select Diagram > Properties from the Stylus Studio menu
o Select Properties from the diagram shortcut menu
Tip You can also change schema diagram properties on the Diagram page of the Options

dialog box — Tools > Options > Module Settings > XML Schema Editor > Schema
Details.

0 To change node properties display:

1. Display the Diagram Properties dialog box, or the Schema Details page of the
Options dialog box.

2. Select the node whose properties display you want to change.

Tip To hide al properties, click the Hide All button. To restore defaults, click the Restore
Defaults button.

3. Click OK.

Background color
Background color is used as another visual cue for information about the XML Schema:

« Atan,orlight brown, color identifies global nodes—these are elements, types, and so
on, that are defined as children of the schema (xsd: schema). In Figure 54, the
purchaseOrder element is an example of a globally defined node.
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« Alight yellow background identifies local instances of globally defined types. In
Figure 54, the PurchaseOrderType complexTypeisalocal instance of that type.

4

IEE

I P18 purchaseOrder ‘@Pu[chase()[derType OEshipTo

Type PurchaseOrderType i Type USAddress
BiE billTo
Type USAddress

I:"[gReferem:e: comment @
Mgitems T‘ - Items i
Type ltems

Figure 54. Background Colors Show Global and Local Types

PurchaseOrderType

Displaying documentation

By default, text associated with documentation elements (xsd: documentation) is hidden.
You can expand documentation elements in the diagram by clicking the Show
Documenation ([£]) button, or by selecting Diagram > Show Documentation from the
Stylus Studio menu. When you do, the text associated with all documentation elements
defined in the XML Schema appears, as shown in Figure 55.

ww purchase. . ‘

e E ) r o J

==

purchaseCrder. xsd "

—

—
B @Purchase order schema for Example.com.
Copyright 2000 Example.com. Rll rights reserwved.
——\—u________________.———

D‘[gship'ro
Type Uilddress
H2hillTo
Type U3kiddress

Figure 55. Show Documentation with the Click of a Button

H

I D-[E purchaselrder PurchaseOrderType
Type PurchaseOrderType -

Moving around the diagram
There are several ways to move around the diagram pane:
« To move from node to node in the diagram, press the arrow keys.
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« You can use the scroll bars to explore the diagram; the zoom slider |ets you change
the magnification.

. Click Go to Definition ([#]) on the shortcut menu to display anew page that shows
just the type definition.

o Click Display Definition ( ) on the shortcut menu to jump to the placein the XML
Schema where the type is defined.

Text Pane

The text pane appears directly beneath the XML Schema diagram pane. It displays the
XML Schema code represented by the nodes you create in the diagram. The default font
is Courier New, but you can change it to whatever font you want by clicking the Change
Font button ([£) ).

Stylus Studio synchronizesthe diagram and text views of the XML Schema-—any changes
you make in the diagram are reflected in the text pane, and vice versa. Synchronization
information is displayed in the bar that separates the diagram and text panes. Current
statusis displayed on the right. When the two views are synchronized, Stylus Studio
displaysthisgraphic: mmsne |. When Stylus Studio detects a change, such as achangeto
the text, it displays a message and changes the status graphic, as shown in Figure 56.

bt pulchas..."
GmAYE & £ o ! )

purchaseOrder. xsd =
|—D'[Ezip =
Type  xsd decimal

BEname

Type | xsdstring

UBstreet ‘

Twne xsd:string

w
<

¥
Text has been modified. .. # Synchronizing
=

</xad: sequence> -~
<xsd: sequence>
<xsd: element name="name" type="xsd: string"/>
<xsd: element name="street

Figure 56. Synchronization Status is Monitored and Displayed
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Stylus Studio also flagsany XML Schemaerrorsin thetext pane—linesthat contain errors
areidentified with ared dot, and the type and location of the error isdisplayed in the status
area at the top of the text pane, as shown here:

@L—JE value (2,23)

1 <?xml version=T1.077=>
2@ saulns:xsd=http://www. w3, org/2001/EMLEchema ">

<xsd:annotations
<x=sd:documentation>
Purchase order schema for Example.com.
Copyright 2000 Example.com. A11 rights reserved.
</x=d:documentation>
</x=d: annotation>

Figure 57. Text Pane Highlights XML Schema Errors

LR R R 6 R 1

When you click the error message, Stylus Studio jumpsto that part of the XML Schema
containing the error. When you correct one error, information about the next error
detected by Stylus Studio (if any) is displayed in the status area.

You can use the splitter to resize the text paneto view more or less text, or you can hide
it entirely using the controls on the splitter’sright side.

H&[Estreet ‘

Twne xsd:string

Bt In Sync

="xsd:string"/>

Figure 58. Splitter Controls Change Size of Text and Diagram Panes

Stylus Studio supports back-mapping between the text pane and the XML Schema
diagram pane —if you click a node in the diagram, Stylus Studio scrolls the text pane to
display the line of XML Schemathat defines the node you clicked. A bluetriangleis
displayed to the left of the exact line of code.
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Definition Browser

The definition browser is a drop-down list that displays all the child nodes of the schema
node. It islocated at the top of the Diagram tab.

Estylus Studio - [purchaseOrder.xsd *] M=
b

we File Edit Miew Project Debug XMLSchema SourceControl Tools Window Help

sl D& % & 0

= purchase._. |

= | EE | 0O e EE X 7

(3] Items

E_T; PurichazelrderType
[3 UStddress

D‘[S comment

02 internationalPrice
02 purchaseOider

W SKU v

I
L type : USAC
B

< | ¥

Figure 59. Definition Browser

When you select anode from the definition browser, Stylus Studio displaysanew pagein
the XML Schema diagram pane that shows the definition of the node you select. In
addition, the definition browser displays information about that node.

o purchas. ™ |

Gt -

omrment, defined in purchaseOrder.xsd

M8 comment
Type  xsdistring

Figure 60. Information About the Selected Node

To return to the page you were viewing previously, press the back ([£=]) button.

Note When you display anode using the definition browser, the focus of the text pane does not
change. Clicking the node jumps you to that part of the XML Schemawhere the nodeis
defined.
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Editing Tools of the XML Schema Diagram Tab

Many of the operations you perform in the Diagram tab can be performed in anumber of
ways. This section briefly describes menu and tool bar use, and introduces additional
features for defining XML Schema.

This section covers the following topics:

« “Menusand Tool Bars’ on page 76

« “In-place Editing” on page 77

« “Drag-and-Drop” on page 77

o “QuickEdit” on page 78

. “Refactoring” on page 79

Menus and Tool Bars

The complete set of available operations is defined by the menu system. The tool bar
provides a subset of frequently performed operations. The top-level menu (XMLSchema
> Diagram), the shortcut menus, and the tool bar are context sensitive — only operations
that are permitted given the current context are available. For example, if you want to add
an element to a sequence, you can

o Select XML Schema > Diagram > Add > Element from the main menu

« Select Add > Element from the sequence shortcut menu

o Click the Add button on the tool bar and select Element from the drop-down list
it displays

Each of these actions lets you add a new node, in this case, an element, to your XML
Schema definition.
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In-place Editing

In-place editing allows you to change node names and properties directly in the diagram.
For example, say you want to change the vaue of the Mixed property of the
PurchaseOrderType complexType. Just double-click the property. Stylus Studio opens the
property for editing, as shown in Figure 61.

[35] PurchaseOrderType

D

Mame PurchaseCrderType
Abstract True

Mined

Blocked Substitutions

Final Substitutions
-

True

Figure 61. In-Place Editing

Similarly, if you double-click a node name, Stylus Studio places the property in edit
mode, allowing you to type a new name.

Tip Todisplay all of anode's propertiesin the diagram, see “Displaying Properties’ on
page 70.

Drag-and-Drop

An alternative to using the menu and the tool bar isto use drag-and-drop, which letsyou
add an existing node to another node' s definition. For example, say you wanted to add an
existing element t0 a sequence. You can do this by dragging the element icon to the
sequence icon, as shown in Figure 62.

-@

Figure 62. Using Drag-and-Drop to Define a Node

Use drag-and-drop any time you want to define a node using a node already defined in
your XML Schema.

Tip When you drag and drop, you remove the element from its current context. If you want
to make a copy an element, press and hold the CTRL key when you perform the drag
operation.

Typical targets of drag-and-drop operations include the following nodes
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Tip

e schema

e sequence
e choice

e all

. Tist

e annotation
e restriction
e union

Typical sources for drag-and-drop operations include the following nodes
e simpleType

e element

e annotation

Any node you drag to the schema node is created as a child of the schema node.

QuickEdit

QuickEditisafeature of the Diagram tab that streamlines common editing operations. For
example, you can use QuickEdit to

o Change a sequence to achoice Or toanall
o Specify arestriction for asimpleType
o Create sequence, choice, any, and a11 element definitions

For example, the following structure was created by selecting QuickEdit > Add Elements
Choice from the comp1exType’'s shortcut menu.

[FEziems b G5B
Figure 63. QuickEdit Creates Complex Definitions With a Click

QuickEdit appears on the top-level and shortcut menus in those contextsin which it is
available, and it is also available on the tool bar by pressing the QuickEdit button [/].
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Refactoring

Refactoring is a process that allows you to copy globally defined nodes from one XML
Schema and paste them in anew XML Schema. The difference between refactoring and
asimple copy isthat refactoring includes both the node you select and all its
dependencies. Consider the following example: here is how the purchaseOrder node
appearswhen it is copied from purchaseOrder.xsd and pasted into anew XML Schema

document;

i copyPlJo...| o
AL AN o 3
copyPConly. xsd

= B2 purchaseOrder é‘a

Type PurchaseOrderType

| |1

1t In Sync

<?xml wersion="1.0"7%>
<xsd: schema smlns: xsd="http: //www. w3, org/2001/EMLIchemna ">
} <xad:element name="purchaseQrder-0" type="PurchaseOrderType”/>

</xad: schema>

\ Diagram A Tree I}\ Documentation rn'r

Figure 64. Simple Copy/Paste of a Node
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Asyou can see, the copy action copies only the selected node to the clipboard. When the
same node is copied using refactoring and pasted into another XML Schema document,
the node, and all its dependencies copied as well.

xin lefaclolP...| xin
Gomatay g g | oe %= e O ) alX|D (4
refactorP O xsd =|
L ~
HSpurchaseOrder E5jPurchaseOrderType
Type PurchaseOrderType .
= arderDate Type : wsd:date

BZhillTo

Type USAddress

PurchaseOrderType O

< ¥
B In Sync
= =
<xsd:restriction base="xsd:string"> ~
<xsd:pattern wvalue="\d{3}-[a-2]{2} "/~
</xsd:restriction®
meeesimpleType>
’ <xzd:element name="purchaseorder” type="PurchaseCrderType"/>
</ x=d: schema> b
< ¥

Diiagram ATree }‘Documentation /{

Figure 65. Refactoring Copy/Paste of a Node

Not all of thediagram or text are displayed in thisillustration, but it isclear that more than
just the purchase0rder node was copied to the clipboard. For example, the
purchaseOrder’'Stype, PurchaseOrderType complexType has been copied, aswell as
PurchaseOrderType's € ement and sequence nodes, such as shipTo, bi11To, and items.

If you wereto scroll up either the text pane or the diagram pane, you would also see, for
example, the complete definitions for other global complexTypes such as sku and
USAddress.

0 To refactor a node:
1. Right-click the node you want to refactor.
2. Select Refactoring > Copy from the node's shortcut menu.

Note If the node is not globally defined, refactoring is not available.

The node and all its dependencies are copied to the clipboard.
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3.

To paste the node in the target XML Schema document, select Refactoring > Paste
from the shortcut menu.

Description of Sample XML Schema

Suppose you want to define an XML Schemathat defines book, magazine, and newsletter
elements. The type of each of these elementsis PubTlicationType. The XML Schema
definesthe PublicationType complexType. An element that isaPublicationType hasthe
following description:

The genre attribute specifiesthe style of the publication. That is, whether it isabook,
magazine, or newsletter.

Thereisalways exactly one title element.
The subtitle element is optional.

There must be at least one author element and there can be more. Each author
€lement contains one first-name element and one 1ast-name element.

Of the following three elements, exactly one must always be present:

O  ISBNnumber

O  PUBnumber
0  LOCnumber

The elements must be in the order specified in thislist.

The following topicsin this section describe how to define this XML Schema using the
Diagram tab of the XML Schema Editor.

Defining a complexType in a Sample XML Schema in the Diagram

View

Thistopic is part of a sequence that begins with “Description of Sample XML Schema’
on page 81.

The steps for defining the Pub14 cationType complexType described in “ Description of
Sample XML Schema” on page 81 are presented in the following topics:

“Defining the Name of a Sample complexType in the Diagram View” on page 82
“Adding an Attribute to a Sample complexType in the Diagram View” on page 84
“Adding Elements to a Sample complexType in the Diagram View” on page 85
“Adding Optional Elements to a Sample complexType in the Diagram View” on
page 86
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o “Adding an Element That Contains Subelements to a complexType in the Diagram
View” on page 86

« “Choosing the Element to Include in a Sample complexType in the Diagram View”
on page 88

Defining the Name of a Sample complexType in the Diagram View
Thistopic is part of a sequence that begins with “Description of Sample XML Schema’
on page 81.
0 To define acomplexType in a sample XML Schema:

1. From the Stylus Studio menu bar, select File > New > XML Schema.

Stylus Studio displays the XML Schema Editor. Maximize the XML Schema Editor
window. If the Project window is visible, you can closeit.

2. At the bottom of the XML Schema editor, click the Diagram tab.
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Stylus Studio displays the Diagram view for the new schema.

Stylus Studio - [Untitled1.xsd *]

s File Edit Wiew Project Debug XMLSchema Diagram SourceConfrol Tools Window Help x
A | e S = G e e
2 + el mnoa = 0
Ap =
o R = ]
(A &
Froperties b4 » Untitled..*
Marne Walue
1D C3 Mo g £. o ol o
Default Attri_.. e & &
Default Ele... ] v
Default Bloc...
Default Fina... ﬂ
Target Ham...
Yersion
Mamespace wed
It In Sync
= =

<?xml wversion="1.0"7%=

}<xsd: schema zmlns: xsd="http://www, w3, org/2001/ EMLEchema”
</x=ad: schema>

<
\ Diagram A Tree .h Documentation l/

For Help, press F1

UM

Figure 66. The XMLSchema Editor Diagram Tab

3. Right-click the schema node in the XML Schema diagram pane and select Add >

ComplexType

from the shortcut menu.

Alternatives. Thisactionisalso available from the XML Schema > Grid Editing menu.
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Stylus Studio displays arepresentation for the new node in the diagram. The
complexType properties appear in the Properties window. The new complexType has
adefault name of ComplexType-0.

Hiopeties X L Untitled...”|

M ame Yalue

B 838|028 8 X
Hame ComplexType0

Abstract False Untitledl.xsd

Mixed False

Blocked =
Substitutions CDmplEXTYpE o

Final

Substitutions

Figure 67. New complexType

Type PublicationType in the Name property in the Properties window and press
Enter.

Stylus Studio updates the diagram and the XML Schemain the text pane.

Click save .

In the Save As dialog box, in the URL field, type bookstoreDiagram.xsd, and click
Save. You can save it in the examples directory of the Stylus Studio installation
directory or in adirectory of your choice.

Adding an Attribute to a Sample complexType in the Diagram View

O

Thistopic is part of a sequence that begins with “Description of Sample XML Schema’
on page 81.

To add the genre attribute to the PublicationType complexType:

1.

2.

Right-click the Pub1icationType node.

In the shortcut menu that appears, select Add > Attribute.
Stylus Studio displays a node for the new attribute (untitled).

PublicationType
&
—untitled

Figure 68. Adding an Attribute in the Diagram Tab

IntheProperties window, type genre asthe name of the new attribute and press Enter.

In the Properties window, click the Type field.
Stylus Studio displays a drop-down list of built-in types.
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5.

Tip

6.

Scroll down to xsd:string and click it, or type xsd: string and press Enter.
The diagram should now look like the one shown in Figure 69.

Mz

E PublicationType
o

I = genre type @ xsdistring

Figure 69. The Finished genre Attribute

You can toggle the display of attributes by clicking the small triangle at the bottom of
the complexType node.

Click save 4.

Adding Elements to a Sample complexType in the Diagram View

Thistopic is part of a sequence that begins with “Description of Sample XML Schema’
on page 81.

The elements belonging to this complexType must occur in a specific order. Before
defining the first element, you need to create a sequence node to define this requirement
in the XML Schema.

[0 To add the title element to the PublicationType complexType:

1.
2.

Right-click the Pub1icationType node.

In the shortcut menu that appears, select Add > Sequence.

The sequence node is added to bookstoreDiagram.xsd. The sequence modifier
indicates that if an instance document contains the sequence node’s child elements
(the elements you will add next), they must be in the order in which they are defined.

Type title and press Enter.
Right-click the sequence node .

In the shortcut menu that appears, select Add > Element.
A child element is added to the PubT1icationType node.

In the Properties window, click the Name field and enter title.

In the Properties window, click the Type field.
Stylus Studio displays adrop-down list of built-in types.

Scroll down to xsd:string and click it, or type xsd: string and press Enter.
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According to the XML Schema requirements described earlier, the title element can
occur only once. By default, the default value for theMin Occur. (Minimum occurrences)
and Max Occur. (Maximum occurrences) propertiesis 1. You want exactly oneinstance of
the title element in PublicationType, SO you can accept these defaults.

Adding Optional Elements to a Sample complexType in the Diagram View

Thistopic is part of a sequence that begins with “Description of Sample XML Schema’
on page 81.

[0 To add the optional subtitle element to the PublicationType complexType:

1.
2.

[~]
Right-click the sequence node .

In the shortcut menu that appears, select Add > Element.
Below the tit1e element, Stylus Studio displays arectangle for the new element

definition.

Rename the new element subtitle.

Give the new element a data type of xsd:string.

Give the new element a minimum occurrences va ue of 0.
You can accept the default of 1 for the Max Occur. property.

Click save [

At this point, the XML Schema diagram should look like Figure 70:

xsd:string

= EPublicat,iDnType = @: D'[Et,it.le
e type
= genre type : xsd:istring ‘
D'[gsubcicle

Lype @

xsd:string

Figure 70. PublicationType complexType

Adding an Element That Contains Subelements to a complexType in the
Diagram View

Thistopic is part of a sequence that begins with “Description of Sample XML Schema’
on page 81.

The sample schema requirements (see “ Description of Sample XML Schema” on
page 81) state that the PublicationType complexType must include at least one author
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element. Further, an author element must include a first-name € ement and a 1ast-name
element.

Each element that can contain one or more subelementsis acomplexType. Consequently,
to add the author element to the Pub1icationType complexType, you must first define the
AuthorType complexType. You can then add an element that is of AuthorType to the
PublicationType complexType.

[0 To define the AuthorType complexType:

1.

Right-click the schema node in the XML Schema diagram pane and select Add >
Complex Type from the shortcut menu.

Alternatives. Thisaction isalso availablefrom the XMLSchema > Grid Editing menu.

Stylus Studio displays a representation for the new node in the diagram. The
complexType properties appear in the Properties window.

Type AuthorType in the Name property in the Properties window and press Enter.
Stylus Studio updates the diagram and the XML Schemain the text pane.

Right-click the AuthorType node in the diagram.

In the shortcut menu that appears, select Add > Sequence.
Stylus Studio displays the sequence node .

Right-click the sequence node.

In the shortcut menu that appears, select Add > Element.

Type first-name in the Name property in the Properties window and press Enter.
Change the Type property to xsd:string and press Enter.

Repeat Step 5 through Step 8 to add anew element to the sequence, using 1ast-name
as the name of the new element.

[0 Now you can add the author element to the PublicationType complexType:

1.

2.

Right-click the sequence node belonging to the Pub1icationType node.

In the shortcut menu that appears, select Add > Element.

Stylus Studio displays a representation for the new node in the diagram. The
complexType properties appear in the Properties window.

Type author in the Name property in the Properties window and press Enter.
Stylus Studio updates the diagram and the XML Schemain the text pane.
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4, Click the Type field in the Properties window. Stylus Studio displays a drop-down
list of built-in types plus any types you have defined, such as the AuthorType you
defined in the previous procedure.

5. Select AuthorType from the drop-down list.

Tip A plus sign appears on the right side of the author element. You can click the plus

sign to display the definition of the AuthorType complexType, which was just added
to the author element.

6. Click the Max Occur. field.
7. Inthedrop-down list that appears, click unbounded.

Tip When you give an element an unbounded maximum number of occurrences, Stylus
Studio renders the node using two outlines, to indicate that multiple occurrences of
this element are allowed.

8. Click save .

At this point, the XML Schema diagram should look like Figure 71:

type @ xadistring

D‘[gsubcicle
type @ x=sd:string

U8 author

type : AuthorType%

D'[E first-name
type @ xsd:istring

D'[Elastﬁname
type : xsdistring

Figure 71. author Element with AuthorType complexType

Choosing the Element to Include in a Sample complexType in the
Diagram View

Thistopic is part of a sequence that begins with “Description of Sample XML Schema’
on page 81.

In the sample XML Schema, you want PublicationType €lementsto contain an
ISBNnumber, PUBnumber, Or LOCnumber €lement.
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0 To specify this:

1.
2.

Right-click the sequence node belonging to the PublicationType node.

In the shortcut menu that appears, select Add > Sqeuence.

Stylus Studio displays arepresentation for the new sequence node in the diagram.
Sequence properties appear in the Properties window.

We added the sequence node in error — the specification requires that this node be a
choice node. The QuickEdit feature makes it easy to correct errors such asthis.

Right-click the new sequence node. In the shortcut menu that appears, select
QuickEdit > Switch to Choice.

Stylus Studio changes the sequence node to the choice node ().
Right-click the new choice node.

In the shortcut menu that appears, select Add > Element.

In the Properties window, change the Name to ISBNnumber and press Enter.
In the Properties window, change the Type xsd:int and press Enter.

Repeat Step 4 through Step 7 twice: once to add the PuBnumber element, and onceto
add the LoCnumber element.

Click save .
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Thedefinition of the PubTicationType complexTypeisnow complete and should look like
Figure 72:

in hookslol...|
) e a X ]
file:///c:/Program Files/3tvylus Studio XML Professional Edition/examples/bookstoreliagram.xsd

= ‘PubllcationType {I}[& title
oy

type @ xadistring

I = genre type : xsd:string I

_D'[gsubcicle
type @ xad:string

D'[Eaut,hor
type @ AuthorType

@nuthanype =!

&

ﬁgfirst—nsme
type @ Hodistring

D-[g last-narme
type @ x=sd:string

AuthorType, used

@ U8 ISENnunber

type : xsd:inc

D‘[ELOCnumber
type @ x=sd:int

AuthorType = D‘[Efirs:—name

type @ xsdistring

ﬁglast—name
type : xsdistring

Figure 72. PublicationType complexType Fully Defined

Defining Elements of the Sample complexType in the Diagram
View

Thistopic is part of a sequence that begins with “Description of Sample XML Schema’
on page 81.

In the fina step of defining bookstoreDiagram.xsd, you define elements that are of the
PublicationType complexTypes you defined earlier — book, magazine, and newsletter
elements.

[0 To define the book, magazine, and newsletter elements in the sample XML Schema:
1. Right-click the schema node in the diagram.

2. Inthe shortcut menu that appears, select Add > Element.
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Stylus Studio displaysanode for the new element inthe XML Schemadiagram pane.
The properties for the new element appear in the Properties window.

3. Type book asthe name of the new element and press Enter.

4. IntheProperties window, click the Data Type field. Stylus Studio displays adrop-
down list of built-in types plus any types you have defined.

5. Click PublicationType.

6. Repeat Step 1 through Step 5 twice: once to add the magazine element, and once to
add the newsletter element.

7. Click save .
The bookstoreDiagram.xsd document is now complete.

8. Select XMLSchema > Validate Document from the menu to validatethe XML Schema
document you created.

The validation message appears in the Output window, as shown in Figure 73.

Stylus S5tudio - [bookstoreDiagram.xsd *]

s File Edit VWiew Project Debug XMLSchema SourceControl Tools Window Help X
5] I L ="
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1D *EAE | O |F ¥ E a X 7
Hame newsletier
Type PublicationType |(£ile:///c:/Program Files/Stylus Studio XML Professional Edltian!ﬂ
Substitutio... 3
Nillable Falze Mowagazine
Abstract False type : PublicationType
Blocked Su...
Final Substi...
- T
3t In Sync
<xad:element name="hook" type="PuklicationType"/> &
<xsd:element name="magazine” type="PublicationType" -
} <xsd:element name="newsletter" type="PublicationTyf
< | >
\ Tree }‘ Diagram ."(. Documentation I,IJ
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The EML document bookstoreliagram.xsd is walid
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Figure 73. Validation of bookstoreDiagram.xsd
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Opening Files in Stylus Studio

This section describes the types of files Stylus Studio recognizes, how to add new file
types to Stylus Studio, and how to open files using the Stylus Studio File Explorer and
other methods. This section covers the following topics.

o “Types of Files Recognized by Stylus Studio” on page 92

« “Using the File Explorer” on page 94

« “Dragging and Dropping Filesin the Stylus Studio” on page 97
o “Other Ways to Open Filesin Stylus Studio” on page 98

« “Adding File Typesto Stylus Studio” on page 99

Tip You can set an option so that when you open Stylus Studio, Stylus Studio automatically
opens any files that were open the last time you closed Stylus Studio. See “Options -
Application Settings” on page 1319.

Types of Files Recognized by Stylus Studio

Stylus Studio recognizes over ten types of files by default. Each file is associated with a
Stylus Studio module, or editor, appropriate for its type, as shown in the following table.

Table 2. File Extensions and Associated Modules

File Name Extension

Stylus Studio Module

.conv

Custom XML Conversion Editor

Ldff XML Diff Viewer

.dtd DTD Schema Editor
.java Java Debugger
.pipeline XML Pipline

.prij Project framework
.report XML Publisher

.sef EDI to XML Conversion

.WSCC, .WSC

Web Service Call Composer

.wsdl

Web Service Description Language
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Table 2. File Extensions and Associated Modules

File Name Extension Stylus Studio Module
.xm1 XML Editor

.xquery XQuery Editor

.xsd XML Schema Editor
.xs1, .xslt XSLT Stylesheet Editor

You can add your own file typesto thislist, specify the module you want them opened in,
and, optionally, specify Stylus Studio as the default application for viewing and editing
files of that type. See “Adding File Typesto Stylus Studio” on page 99.

Opening Unknown File Types

When you try to open afile of atypethat isnot recognized by Stylus Studio, Stylus Studio
displays the Choose Module for dialog box, which allows you to specify the module or
editor you want to use to open thefile.

Choose Module for ".txt" BI

Choose a module to open the
unknown file extension

.
wieb Service Cal ~

L Dift

ML Schema

HQuery File

®ELT: Mapper

HSLT: Teut Editar

HELT: WS G b

] Always uze this module for this file tipe

Figure 74. Choose Module Dialog Box

When you respond to this dialog box, you can optionally indicate whether you want all
files of that type to be associated with the Stylus Studio module you select in the future.
File types you associate with a Stylus Studio modul e are added to the File Types page of
the Options dialog box. You can remove or change the module association at any time.
See “Adding File Typesto Stylus Studio” on page 99 for more information.

Opening Files Stored on Third-Party File Systems

Stylus Studio provides access XML documents stored on third-party file systems like
Raining Data™ TigerLogi c® XML DataM anagement Server (TigerLogic XDMS).
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See Integrating with Third-Party File Systems on page 1163 for more information.

Modifications to Open Files

Using

If afilethat is openin Stylus Studio is modified (changed, and saved) outside Stylus
Studio, Stylus Studio alerts you that the file has been changed and gives you the chance
to reload it.

the File Explorer

The Stylus Studio File Explorer is a dockable window that provides easy access to any
file system accessible from the computer on which you are running Stylus Studio. You
can use the File Explorer to quickly add files to Stylus Studio and open filesin Stylus
Studio, as well as to perform typical file management tasks (like renaming and deleting
files, for example).

Stylus Studio - [sampleYideo.xsl]
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F
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<?xml version="1.0" encoding=Tutf-877> A
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<xsl:styleshest version="1.0" zmlns:xsl

<xsl:output method="html"™ encoding="UTF

<xsl: template match="/">

<html><heads>

<meta http-egquiv="Content-Type" content

<title>VideoCenter - Video Listing</tit

<style type="text/css"> b
g 3 @ |
\XSLT Source {{‘Mappel }‘Paramsfﬂther I}

Ln 1 Col1 Char 60 {0x003C) UM

Figure 75. Stylus Studio File Explorer

By default, the File Explorer window appears on the right side of the Stylus Studio
window, but you can drag it anywhere on your desktop. You can close/open the File
Explorer window from the View menu.
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How to Use the File Explorer to Open Files

There are several ways to open files using the File Explorer:
« Double-click thefile
« Right-click thefile and select Open or Open With from the shortcut menu

Tip Open With allows you to select the module you want to use to open the file.

« Dragand drop thefile. See Dragging and Dropping Files in the Stylus Studio on
page 97.

When you open afile by double-clicking or using the Open shortcut menu, Stylus Studio
opens the file in the modul e associated with the file type (the XML Editor for .xm1 files,
for example). If thefiletypeisnot currently registered with Stylus Studio, you can register
the file at thistime using the Choose Module for dialog box. See “Types of Files
Recognized by Stylus Studio” on page 92 for more information about file type/module
associationsin Stylus Studio.

Other Features of the File Explorer

Thetool bar in the File Explorer window has several features that can help you navigate
the file systems associated with your computer and work with individual documents.

File Explarer x
=% & v bt [#

Figure 76. File Explorer Tool Bar
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These features are summarized in the following table.

Table 3. File Explorer Tools

Tool

Description

(] New Folder

Creates anew folder asachild of the folder with current focus. The
default folder nameis New Folder.

Read Document
Structure

Displays the structure of XML documentsin tree form. You can
drag exposed nodes onto the document tab area to open the
document associated with that node. If you drag a node into an
existing XQuery or XSLT document, Stylus Studio creates the
document function with the X Path expression for that node. For
example, if you drag the title element from books.xm1 into an
XQuery document, Stylus Studio builds the following function:

doc("file:///c:/Program Files/Stylus Studio 2010 XML
Enterprise Suite/examples/simpleMappings/
books.xm1") /books/book/title

Refresh

Refreshes the File Explorer window.

Reset Filters

Resets the File Explorer filter from its current content to the
wildcard (*.*).

(=] Stylus File Types

Changesthe File Explorer filter to display only file types associated
with Stylus Studio: .xml, .xsd, .dtd, .java, .conv, and others.

Working with the File Explorer Filter

By default, the File Explorer window uses awildcard filter to display all file types (*.*).

File Explarer

i

X

Figure 77. File Explorer Filter

You can

« Typeyour ownfilter (*.txt, for example). If you want to use multiplefilters, separate
them with asemicolon (*.txt; *.htm1, for example).

« Usethe Stylus File Types [£] button to change the filter to display only file types
associated with Stylus Studio (.xm1, .xsd, .dtd, .java, .conv, and others)

Stylus Studio remembers the filters you create and adds them to the drop-down list.
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Dragging and Dropping Files in the Stylus Studio

You can open afilein Stylus Studio by dragging the file from the File Explorer (or other
file system browsers, like Windows Explorer) and dropping it inside Stylus Studio. How
Stylus Studio behaves depends on where you drop the file, as summarized in Table 4.

Table 4. How Stylus Studio Handles Dragged-and-Dropped Files

If You Drop the File Here

Stylus Studio Does This

On the document editor area
(when no documents are open)

Opens the document editor associated with the type of file
you selected. See Types of Files Recognized by Stylus
Studio on page 92. If the file typeis not currently
registered with Stylus Studio, you can register thefile at
thistime using the Choose Module for dialog box. See
Opening Unknown File Types on page 93.

On the document editor tab area

Opens the document editor associated with the type of file
you selected. See Types of Files Recognized by Stylus
Studio on page 92. If the file typeis not currently
registered with Stylus Studio, you can register thefile at
thistime using the Choose Module for dialog box. See
Opening Unknown File Types on page 93.

In an active document

Addsthefile's URL to the end of the document.

On another filein the File
Explorer

Performs the operation associated with the target file and
opens the resulting document in its own editor. For
example, you might usethis operation to convert atext file
to XML by dropping the . txt file on a converter file
(.conv).

Inaproject in the Project
window

Addsthefileto the project. If thefile typeisnot currently
registered with Stylus Studio, you can register thefile at
this time using the Choose Module for dialog box. See
Opening Unknown File Types on page 93.
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Other Ways to Open Files in Stylus Studio

In addition to the File Explorer and drag-and-drop, you can also open filesin Stylus
Studio from the following places:

The Open dialog box (displayed when you select File > Open from the menu, for
example). By default, Stylus Studio opens the file in the editor associated with files
of the type you select (see Types of Files Recognized by Stylus Studio on page 92).
If you want, you can choose a different editor — you might want to open an XSLT
stylesheet inthe XML Editor, for example—when opening filesfrom the Open dialog
box.

To specify adifferent module, click the down arrow to the right of the Open button
and select the module you want to use from the drop-down list as shown in Figure 78.
eren EJE|

|@ Look jn: | (3] quates - ﬂ prge
= your-quotes. kml

E your-quates. xsl

4y Camputer

D

‘webDaY

TigerLogic XDMS AL 7 2
Files of bwpe: | Stylus Studio Documents [*java;”.corm:” pipling, v Custom AML Conversion
Java

Project Files [] Open using $ML Converter weh Service Call Composer

%ML Editar k

%ML Pipeline
#ML Publisher
KOuery

®SLT Editor

Figure 78. Choose the Module to Use When Opening a File

Project window — either double-click thefile, or select Open or Open With from the
file's shortcut menu.

Other file system browsers (like Windows Explorer, for example) —for files
recognized by Stylus Studio, just double-click the file. See “ Opening Unknown File
Types’ on page 93.
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Adding File Types to Stylus Studio

You use the procedure described in this section to associate afile type (. txt, for example)
with a specific Stylus Studio module or editor. Once you do this, any time you open afile
of that type from within Stylus Studio (using the File Explorer, for example), that fileis
opened in the editor you specify.

You can optionally specify that you want to use Stylus Studio asthe default editor for files
of thistype, regardless of where thefileis opened (from a file browser like Total
Commander, for example).

Note You do not need to specify the usual extensions, such as xm1, xs1, and java. Use the
procedure described in this section for file name extensions peculiar to your application
or environment.

0 To add a file type to Stylus Studio:

1. From the Stylus Studio menu bar, select Tools > Options.
Stylus Studio displays the Options dialog box.

2. Under General, click File Types.
TheFile Types page appears.

Options X
I Gereral ~ File tppe/Styluz Studio module associations:
Application Settings Type todule Open With Stylus Studia
E:\:nr Eener;a\ [ .cony Convert to ML falze
B [ .df #ML Dif fakse
Sac:" EEDDEQ @ did OTD Schema tiue
he SCEINg ™ java Java: Text Editar falze
- ) & pi e
Jcav::- V"l#al IMac:hme ™ bl DB toxML Data Source | falze
E:;Ez Fl‘l::SSystems [ wscc ‘web Service Call falze
arml HMLD b b
Customn Document Wizards g A SEumen Tus
- X .ug #uery File falze
Customn Validation Engines
Custorn ¥ML Corvverters @ quey <Uuery File frue
5 Module Sett & wad #ML Schema tiue
E; ;;to;h‘:[gs @ sl #5LT: Mapper tiue
Default Cormection & xsh #5LT: Mapper tie
false
£ Java
Debugger
Jawva Compiler
External Jy't
£ ML Diff
Engine

Figure 79. Associating File Types with Stylus Studio Editors
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3. Toadd anew file type/module association, click the Add
Alternative: Double-click the Type field.

4. Typethe new extension, including the period, and press Enter.
Stylus Studio adds the file type and selects a default module in the Module field.

5. Optionaly, select adifferent module using the drop-down list in the Module field.

6. If youwant to always use Stylus Studio to open files of thistype, changethe valuein
the Open with Stylus Studio field to True.

7. To add another file type, repeat Step 3 through Step 6.

8. When you are done, click OK.

Deleting File Types

0 To delete afile type:
1. Click thefile type you want to delete.
2. Click the Delete | %] button,
3. Click OK.

Working with Projects

A projectin Stylus Studio isagroup of filesrelated to agiven XML application. A project
might include XML, XML Schema, and XQuery files, aswell as OASIS catalogs, for
example. A project can contain subprojects, and subproj ects can contain subprojects. The
Stylus Studio project framework allows you to name projects (project files are saved with
a .prj extension), and it provides several tools for managing the projects you create.

Projects are smply a convenience for organizing files — afile does not have to belong to
aproject in order for you to edit it in Stylus Studio. For example, Stylus Studio includes
all sample application filesin the examples project. You can find the examples.prj filein
the examples directory of your Stylus Studio installation directory.

This section discusses the following topics:

. “Displaying the Project Window” on page 101

« “Creating Projects and Subprojects’ on page 103

« “Saving Projects’ on page 103
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o “Opening Projects’ on page 103

« “Adding Filesto Projects’ on page 104

« “Copying Projects’ on page 105

« “Rearranging the Filesin aProject” on page 106

« “Removing Filesfrom Projects’ on page 106

« “Closing and Deleting Projects’ on page 106

o “Setting aProject Classpath” on page 107

« “Using Stylus Studio with Source Control Applications’ on page 109

Displaying the Project Window

When you open Stylus Studio for thefirst time, Stylus Studio displaysthe Project window
with the examples project. (The File Explorer window is displayed on the right.)
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Figure 80. Project Window with Default Project DIsplayed

There are several ways to toggle the display of the Project window. You might want to
close the Project window in order to gain more space in the editor you are working with,
for example.
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0 To toggle Project window display:
o From the Stylus Studio menu, select View > Project Window.
« Inthe Stylus Studio tool bar, click Toggle Project Window [+].

Tip TheProject window is dockable — you can move it anywhere on your desktop.
0 To hide Project window:
Click the X in the upper right corner of the Project window.

Tip When you hide the Project window, any open files remain open.

Displaying Path Names
You can control whether the Project window displays absolute or relative path names for
filesin projects. The default display is relative names.
0 To toggle the way path names appear:
1. Display the Project window.
2. Inthe Project window, right-click to display the pop-up menu.
3. Click Show Full URL Info.

Other Documents

Stylus Studio displays documents that are not associated with a project in the Other
Documents folder, which appears after the last folder or document in the currently

displayed project. In addition, when you remove afile from a project, it is placed in the
Other Documents folder.

Project X
= Ei‘ MyPraject *

@ profilel.xsl
ookstoreDiagram. xsd

@ readme. hirn
videos. sl
@ wzdlToDoc. xslt

Figure 81. Other Documents Folder

You can add these documents to a project at any time. See “Adding Filesto Projects’ on
page 104.
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Creating Projects and Subprojects

You can create projects and organize any project into multiple levels of subprojects. You
can add files to projects and save the project under a name you specify.

0 To create a project, select Project > New Project from the menu:

Stylus Studio displays the new project in the Project window. The Project window
displays information for only one project at atime.

0 To create a subproject:

1. Right-click the project name, and click New Project Folder in the pop-up menu.
Stylus Studio displays a default subproject folder name (NewFolderi, for example).

2. Type anew subproject name.
3. PressEnter.

There are several waysto add filesto your projects and subprojects. See “Adding Filesto
Projects’ on page 104.

Saving Projects

[0 To save a project, select Project > Save Project.

Thefirst time you save a project, Stylus Studio prompts you to specify a name for your
project. Stylus Studio appends .prj to the name you specify. It does not matter whether
or not you specify the .prj extension. Stylus Studio does not allow a project to have any
other file name extension.

When you save aproject, referencesto the files part of the project are saved relative to the
path of the project file. This allows you to move or share projects easily.

Opening Projects

You can have only one project open at onetime. If you have a project open and you open
a second project, Stylus Studio closesthefirst project and then opens the second project.

If the Project window is not visible when you open a project, Stylus Studio automatically
displays the Project window.
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0 To open a project:

1.
2.

From the Stylus Studio menu bar, select Project > Open Project.

Navigate to and select your project file. For example, you can open examples.prj in
the examples directory of your Stylus Studio installation directory. The examples

project contains the fi

lesfor al Stylus Studio sample applications.

Click the Open button.

Recently Opened Projects

Projects that were recently opened are displayed at the bottom of the Project drop-down
menu. Click the project you want to open.

|Er0ject| Debug SourceContral Tools W

Mew Project

Mewe Project Wizard. ..
Cpen Project...

Save Project

Save Project As...

Add Eile..,
4dd Base Catalog
Add User-defined Catalog...

Remove Iem From Project

1 test.prij

2examplesprj

Figure 82. Recently Opened Projects Are Listed on the Project Menu

Adding Files to Projects

The easiest way to add afile to a Stylus Studio project isto drag the file from the File
Explorer or ancther file browser (like Total Commander, for example) into the desired
project folder. You can drag-and-drop multiple files at atime.

If thefile type is unknown to Stylus Studio, the Choose Module for dialog box appears,
which allowsyou to associate the file with a Stylus Studio modul e or editor. See Opening
Unknown File Types on page 93 for more information.

104

Stylus Studio® 2010 User Guide



Working with Projects

Other Ways to Add Files to Projects

The following procedures describe other ways to add files to a project. Note that these
procedures vary based on whether or not the file is already open in Stylus Studio.

When Files are Open in Stylus Studio

0 To add an open file to a project:
1. Open the project to which you want to add thefile.

2. Click thewindow (the Web Service Call Composer, for example) that containsthefile
you want to add.

3. Inthe Stylus Studio tool bar, click Add Document to Project 3.
Alternative: Select Project > Add Document from the Stylus Studio menu bar.

When Files are Closed

0 To add a closed file to a project:
1. Open the project to which you want to add thefile.

2. Inthe Stylus Studio tool bar, click Add File to Project [ .
Alternative: Select Project > Add File from the Stylus Studio menu bar.
The Open dialog box appears.

3. Navigate to the file you want to add and click the Open button.

Copying Projects

0 To copy a project:
1. Open the project you want to copy.

2. From the Stylus Studio menu bar, select Project > Save Project As.
The Save As dialog box appears.

3. Navigate to the location for the project copy.
4. Inthe URL: fied, type the name of the new project.
5. Click the Save button.
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Rearranging the Files in a Project

The order in which files are displayed in the Project window has no effect on the project.
You might want to place related files near each other, or place more frequently used
project files toward the top of the project tree.

0 To rearrange files in a project:

1. If the Project window is not visible, click Toggle Project Window [& in the Stylus
Studio tool bar.

2. Inthe Project window, click the file you want to move.

3. Dragittoitsnew location.

Removing Files from Projects

When you remove afile from aproject, it is added to the Other Documents folder in the
Project window.

0 Toremove afile from a project:

1. If the Project window isnot visible, click Toggle Project Window [&] in the Stylus
Studio tool bar.

2. Inthe Project window, click the path for the file you want to remove.

3. From the Stylus Studio menu bar, select Project > Remove File from Project.
Alternative: Pressthe Delete key.

Closing and Deleting Projects

Closing

0 To close a project, open another project or create a new project.

Tip Toggling or closing the Project window does not close the project.
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Deleting

0 To delete a project, remove its .prj file from the file system.

Setting a Project Classpath

You can set a classpath at the project level. When Stylus Studio compiles or runs Java
code, it always checks the project for alocally defined classpath.

Specifying Multiple Classpaths

You usethe Project Classpath dialog box to specify one or more classpathsfor a project.
If multiple classpaths have been defined, Stylus Studio searches them in the order in
which they arelisted in the Project Classpath dialog box. You can use the up and down
arrows at the top of this dialog box to change the classpath order.

Project Classpath

Locations:

Figure 83. Use Arrow Buttons to Change the Order of Classpaths

How to Set a Project Classpath

0 To set aclasspath for a project:
1. Open the Project Window if it is not aready displayed.

2. Right-click the project node.
The project shortcut menu appears.
Alternative: Select Project > Set Classpath from the Stylus Studio menu.

3. Select Set Project Classpath.
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The Project Classpath dialog box appears.

Project Classpath

Locations:

Figure 84. Project Classpath Dialog Box

Click the browse folders (| #:]) button.

A new entry field appearsin the Locations list box. Two buttons appear to the right
of the entry field.

To add a JAR file to the classpath, click the browse jar files button ([E3]).
Stylus Studio displays the Browse for Jar Files dialog box.
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Figure 85. Browse for Jar Files Dialog Box

To add afolder to the classpath, click the browse folders button ( g).
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6.

Stylus Studio displays the Browse for Folder dialog box.
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Figure 86. Browse for Folder Dialog Box

When you have located the JAR file or folder you want to add to the classpath, click
OK.

Optionally, add other JAR files or folders to the classpath by repeating Step 5 and
Step 6.

Using Stylus Studio with Source Control Applications

Stylus Studio supports the Microsoft Source Code Control Interface, allowing you to use
Stylus Studio with any source code control system that supports the same interface used
by Microsoft Visual Studio or Microsoft Visual Studio .NET.

Stylus Studio’s source control support allows you to

Add afile to source control

Remove afile from source control

Get the latest version of a source-controlled file
Check out afile

Check in afile

Un-check out afile

Show the source control history of afile

Show differences between versions of afile
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In this section

This section covers the following topics:

« “Tested Source Control Applications’ on page 110

« “Prerequisites’ on page 110

« “Using Stylus Studio with Microsoft Visual SourceSafe” on page 111
« “Using Stylus Studio with ClearCase” on page 113

« “Using Stylus Studio with Zeus CVS’ on page 116

« “Specifying Advanced Source Control Properties’ on page 117

Tested Source Control Applications

Integration with the following source control applications has been tested:
« Microsoft Visual SourceSafe

o Clearcase/Attache

« CVS

Prerequisites

To use Stylus Studio’s source control features, you must have already installed the client
software for your source control application, as shown in Table 5.

Table 5. Working with Source Control Clients

When Data Is In You Need to Install

SourceSafe repository SourceSafe client or SourceOffSite
ClearCase Attache client

CVsS Zeus-CV S product

In addition, files must belong to a Stylus Studio project before you can use them with a
source control application.

Recursive Selection

When you build aproject using filesfrom asource control application, Stylus Studio gives
you the option of recursively importing all projects that are subordinate to the project
folder you select. This option, Recursively import all subprojects, appears on the Build
Project from SCC dialog box, which appears when you start the New Project Wizard.
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Selecting the Recursively import all subprojects option has the effect of selecting al the
siblings of the selected file or directory, as well as any descendants of the selected item
anditssiblings. Stylus Studio createsa project that containsall filesthat Stylus Studio can
open (for example, .xm1, xs1t, and . xsd files) and that arein the directory hierarchy of the
file or directory you select.

For example, suppose you check Recursively import all subprojects, and you select
c:\work\myproject\documentation.xml. Stylus Studio creates a project that contains all
Stylus Studio-editable filesin c:\work\myproject and its subdirectories.

If you do not check Recursively import all subprojects, only the file you select is added
to the new Stylus Studio project you create. You cannot select a directory if you do not
select this option.

Using Stylus Studio with Microsoft Visual SourceSafe

0 To use Stylus Studio to operate on files that are under SourceSafe source control:

1. From the Stylus Studio menu bar, select Project > New Project Wizard.
The Project Wizards dialog box appears.

Project Wizards X

Available project wizards:

[ Cancel |

Praject from
SCC

Figure 87. Project Wizards Dialog Box

Stylus Studio® 2010 User Guide 111



Getting Started with Stylus Studio®

Click Project from SCC, and click the OK button.
The Build Project From SCC dialog box appears.

Build Project From SCC X

Provider to uge: |{REE[REESS

[ Becursively impaort all subprojects
Figure 88. Build Project From SCC Dialog Box

Select Microsoft Visual Sourcesafe from the Provider to use drop-down list.

If you want to use Stylus Studio to access more than onefile in adirectory hierarchy,
click the check box for Recursively import all subprojects. See “Recursive
Selection” on page 110 if you need help with this step.

Depending on your installation, you might need to specify other properties. See
“ Specifying Advanced Source Control Properties’ on page 117.

Click the OK button.

The Visual SourceSafe Login dialog box appears:

Visual SourceSafe Login @I

Usemame: ‘ |

Pazsword ‘ |

IO Er o byl Studio on MT Stulus Browse...

Figure 89. Visual SourceSafe Login Dialog Box

Specify the username and password; optionally, use the Browse... button to access a
database other than the default database displayed in the Database field.

Click OK.

112

Stylus Studio® 2010 User Guide



Working with Projects

The Create Local Project from SourceSafe dialog box appears.

Create local project from SourceSafe @

Create a new project in the folder: m
Sources afe project to download:

.
=-Ea

Documentation
SharedComponents
Shuzzo

Shuzzo Versions

T

Figure 90. Create Local Project from SourceSafe Dialog Box

Select the folder in which you want to create the new project.

Click OK.

Theproject iscreated in Stylus Studio. A message displays the names of any filesthat
were not added to the project because their extensions are not associated with a Stylus
Studio editor.

Using Stylus Studio with ClearCase

0 To use Stylus Studio to operate on files that are under ClearCase source control:

1.

Note

2.

Use Attacheto copy the files you want to work on from a ClearCase view to thelocal
file system.

If you move these files from this directory after you create the project, you must
specify the new directory that containsthefilesin the Local Project Path field of the
Source Control Properties dialog box. To access this dialog box, select
SourceControl > Source Control Properties from the Stylus Studio menu bar.

From the Stylus Studio menu bar, select Project > New Project Wizard.
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The Project Wizards dialog box appears.

X

Project Wizards

Available project wizards:

[ Cancel |

Froject from
SCC

Figure 91. Project Wizards Dialog Box

Click Project from SCC, and click the OK button.
The Build Project From SCC dialog box appears.

Build Project From SCC X

Provider to uze: | {REEIREE

[] Becursively impart all subprojects
Figure 92. Build Project From SCC Dialog Box

Select Clearcase from the Provider to use drop-down list.

If you want to use Stylus Studio to access more than onefile in adirectory hierarchy,
click the check box for Recursively import all subprojects. See “Recursive
Selection” on page 110 if you need help with this step.

Depending on your installation, you might need to specify other properties. See
“Specifying Advanced Source Control Properties” on page 117.

Click the OK button.
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The Browse for Folder dialog box appears.

Browse for Folder @@

Select Rational ClearCase Yisw Folder

= i)
5 Lé D Drrive (D)
+-5#, corp on 'nbdata’ (G
+ _ﬁ dfoster an 'ntdata\corpiusers' (H:)
+ _'“z wiew on view' (J:)
+-5# depts on ‘nkdata’ (M:)
+- 5% groups on 'ntdata’ (N2}
+ _ﬁ 3rd-party on 'peppino.bedford. progress

+)- 5% apps on ‘ntdata’ (P:) B
< >

Figure 93. Browse for Folder Dialog Box

7. Navigate to and select thefile or directory you want to operate on, or one of thefiles
or directoriesin the topmost level of the directory hierarchy that you want to access,
and click the OK button.

Stylus Studio creates a new project that contains the file you selected, or all files that
are editable by Stylus Studio and that were in the directory hierarchy of thefile you
selected. The default name of the project is Projectn. To rename the project, select
Project > Save Project As from the Stylus Studio menu bar.

Adding Files After the Project is Created

After you create the project, you can add additional ClearCasefilestoit. If thefileis
already in ClearCase, it must be asibling of the original file you selected, or it must be a
descendant of one of its siblings. If the file you want to add is not in the directory
hierarchy of the original file, you must create a new Stylus Studio project and specify a
directory in the source control hierarchy that contains all the files you want to be in your
Stylus Studio project.

If youwant to add afilethat isnot already in ClearCase, open thefilein Stylus Studio and

then click Add To Source Control = in the Stylus Studio tool bar.
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Using Stylus Studio with Zeus CVS

Stylus Studio supports the latest version of the Zeus CV S Provider, and with some
additional configuration needed in the SourceControl > Properties dialog box.

0 To use Stylus Studio to operate on files that are under Zeus CVS source control:

1.

From the Stylus Studio menu bar, select Project > New Project Wizard.
The Project Wizards dialog box appears.

Click Project from SCC, and click the OK button.
The Build Project From SCC dialog box appears.

Select Zeus SCC-CVS from the Provider to use drop-down list.

Click the check box for Recursively import all subprojects.

Click Advanced. Several new fields appear.

IntheUser Name field, typethe user name you want to useto loginto the CV S server.

In the Project Name field, type the name of amodulein the source control hierarchy.
This should be the name of adirectory that contains al files that you want to openin
Stylus Studio.

Inthe Auxiliary Path field, type the contents of the CvSROOT environment variabl e that
you use to access the CV S server.

For example, suppose you are required to enter the following commandsin a DOS
console or UNIX shell:

cvs.exe -d:pserver:user@server.company.com:/cvsroot/projectname login
Password: w¥w=¥*

cvs.exe -d:pserver:user@server.company.com:/cvsroot/projectname co module

The value you should enter in the Auxiliary Path field would be:
:pserver:user@server. company.com:/cvsroot/projectname

In the Working Dir field, type the name of alocal directory.
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10. Click the OK button.

Stylus Studio downloads the selected files and places them in the directory you
specified in the Working Dir field. If you move these files from this directory, you
must specify the new directory that contains the filesin the Local Project Path field
of the Source Control Properties dialog box. To open this dialog box, select
SourceControl > Source Control Properties from the Stylus Studio menu bar.

All filesthat can be opened in Stylus Studio are now in the new Stylus Studio project. The
default name of the project isprojectn. To renamethe project, select File > Project > Save
Project As from the Stylus Studio menu bar.

Note The cvs. exe file must be in your PATH environment variable.

Specifying Advanced Source Control Properties

The Advanced button in the Build Project From SCC dialog box displays several
additional fields.

Build Project From SCC X

Provider to uge: |{REE[REESS

[ Becursively impart all subprojects '

User Mame:
Project Mame:
Augiliary Path:

Warking Dir; E]

Figure 94. Advanced Source Control Settings

« User Name is the name of the source control user. Stylus Studio uses this nameto
establish a connection with the source control server.

« Project Name isthe name of the source control repository you want to access. The
syntax of the project name depends on the source control provider you want to
connect with. For example, SourceSafe uses $/Name/Name, ClearCase uses the name
of the view, and CV S uses the name of the module. Some source control providers
change this description to something more suitable to their model. For example,
ClearCase changesit to ClearCase Attache.
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o Auxiliary Path contains source control provider-specific information. Thisfield
allowsyou to enter any other information required to find your source control server.
For example, if you are using SourceSafe, you would specify the directory of the
SourceSafe client here. If you are using CV'S, you would specify the contents of the
CVSROOT environment variable.

« Working Dir isthelocal directory into which you copied thefiles under source control
that you want to access. It isthelocal counterpart for the source control repository.
For example, suppose you copied the contents of the SourceSafe repository
$/Company/OneProject to the local directory c:\work\myproject. Your local files
would map to the source control hierarchy as shown in Table 6:

Table 6. Local/Repository File Mappings

Local File Repository File
c:\work\myproject\documentation.xml $/Company/OneProject/documentation.xml
c:\work\myproject\subdir\root. java $/Company/OneProject/subdir/root.java
c:\work\anotherproject\root.java $/Company/anotherproject/root. java

Customizing Tool Bars
Stylus Studio allows you to customize the appearance, location, and content of tool bars,
and even to create tool bars of your own. This section covers the following topics:
“Tool Bar Groups’ on page 118
« “Showing/Hiding Tool Bar Groups’ on page 119
« “Changing Tool Bar Appearance’ on page 120

Tool Bar Groups

Tool bars are organized by functional group within Stylus Studio (Default, Edit, Source
Control, and so on). Customizations available for these groups include

« Show/hide

o Look, feel, and size

« Group position

Tip Tool bars are docking windows — you can drag them anywhere on your desktop.
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You control all these customizations from the Toolbars tab of the Customize diaog box.

Customize E|
Toolbars

Toolbars:

[REDTEM 7] Show Tookips L.
[wiDefault Cool Look
:
Large Buttares

ik 0

[ 0K H Cancel ][ Help ]

Figure 95. Toolbars Tab of Customize Dialog Box

O To display the Customize dialog box, select Tools > Customize from the menu.

Showing/Hiding Tool Bar Groups
Tool bar groups are displayed by default. Use this procedure to hide/re-display them.
Tip Consider maximizing Stylus Studio on your desktop in order to view as much of the tool
bar as possible when making changes.
0 To hide/show a toolbar group:
1. Display the Customize dialog box (Tools > Customize).

2. Inthe Toolbars group box, deselect the check box of the group you want to hide.
Thetool bar is removed from the Stylus Studio window.

3. Tore-display ahidden tool bar group, follow Step 1 and Step 2 and resel ect the check
box,
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Changing Tool Bar Appearance

Changes you can make to the tool bar’s appearance include

«  Whether or not to show tooltips when the mouse pointer is placed over atool bar
button

«  Whether tool bar buttons are rendered in a size larger than the default

Note Appearance settings affect all tool bars. You cannot control the appearance of individual
tool bar groups.

0 To modify toolbar appearance:
1. Display the Customize dialog box (Tools > Customize).

2. Click show Tooltips to toggle the display of tooltips when the pointer is placed over
atool bar button.

3. Click Large Buttons to toggle the size of the tool bar buttons.
4. Optionally, click the Reset button to restore default settings.
5. Click the OK button.

Specifying Stylus Studio Options

Stylus Studio allows you to set avariety of options for Stylus Studio modules, and it
provides the ability to define custom tools to run different editors and processors. This
section covers the following topics:

o “Setting Module Options’ on page 120
« “Registering Custom Tools” on page 122

Setting Module Options
Stylus Studio allows you to set avariety of options for the Stylus Studio modul es.

0 To change module options:
1. From the Stylus Studio menu bar, select Tools > Options.

2. Inthe Options dialog box that appears, expand Module Settings to display alist of
choices.
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XML Diff

You usethe Engine and Presentation pages to define settings used by the XML Diff tool.
See “Diffing Folders and XML Documents’ on page 176 for more information.

XML Editor

Click XML Settings to specify the following:
o Refreshinterval for Sense: X

« Number of errors after which you want Stylus Studio to stop validation, and whether
or not you want Stylus Studio to display a message when validation is complete

Click custom Validation Engines to specify an alternate validation engine. See“ Custom
XML Validation Engines’ on page 1170 for more information.

XSLT Editor

Module settings for the XSLT Editor let you specify external XSLT processors, settings
used by the Mapper tab, and general editor behavior.

Click External XSLT to specify default values for external XSLT processors. Note that
Stylus Studio’s back-mapping and debugging features are not supported for all XSLT
processors. The XSLT processors that support back-mapping and debugging are
identified on the Processor tab of the Scenario Properties dialog box.

In ascenario, you can specify that you want to use an external XSLT processor. If you use
aparticular XSLT processor frequently, specify default values here. Then, in the scenario
properties, you just need to specify which external XSLT processor you want to use. If
you specify default values and you then specify different valuesin ascenario’s properties,
the scenario properties override the defaults. You can specify thefollowing external XSLT
options:

« Default custom processor command line

« Default additional path for custom processor

« Default additional classpath for custom processor
Click Mapper to specify how xs1: for-each instructions should be rendered on the M apper

canvas, and to specify element creation for unlinked nodes. See “Mapping Source and
Target Document Nodes” on page 526 for more information on using the XSLT Mapper.
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Click XSLT Settings to specify the following:

«  Whether Stylus Studio displaysthe Scenario Properties dialog box when you create
anew stylesheet

« Whether Stylus Studio saves scenario meta information in stylesheets
o  Whether Stylus Studio detects infinite loops

o Maximum recursion level

« Allocated stack size

Java
To modify Java settings, see “ Configuring Java Components’ on page 133.

Registering Custom Tools

Stylus Studio allows you to register custom tools to run alternative editors, processors,
preprocessors, or postprocessors. For example, you can register a custom tool that
configures Internet Explorer to display the document you are working on.

After you register a custom tool, Stylus Studio adds an entry to its Tools menu — select
Tools and then your tool. The order in which the tool names appear in the Custom Tools
options pageisthe order in which the tool names appear in the Stylus Studio Tools menu.

You can register custom tools from within Stylus Studio or from the command line.

Using Stylus Studio

0 To register a custom tool in Stylus Studio:

1. From the Stylus Studio menu bar, select Tools > Options.
Stylus Studio displays the Options dialog box.

2. Click Custom Tools to display the Custom Tools page.
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10.

Stylus Studio displays an entry field for the tool name.

Ed

Options

55 General ~ ools 0
Application Settings
Editar General %
Editar Sensei
Editar Format
B ack-mapping
Spell Checking
File Types
Java Virtual Machine Command:
Components
#ML Conwverters ForJava
#ML Converters For MET Initial directaory:
DataDirect XEuerny
g Custom Tools
Custom Document ‘Wizards
Cugstorn ¥ alidation Engines [ Prompt for arguments [ Use Output ‘window
I Module Settings
£ EDI to ML []5ave Al documents before execution
ED| Yiewer Settings
£ Java
Debugger
79 ‘Web Service Call Composer

Lo g

Figure 96. Defining a Custom Tool

Arguments:

X
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#
-
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Fath:

Enter the name as you want it to appear in the Stylus Studio Tools menu.

In the Command field, specify or select the absolute path for the command that runs
your tool. Thismust be a .exe, .bat, or .cmd file.

In the Arguments field, specify any arguments your tool requires. You can click k-
to display adrop-down list that includesFile Path, File Dir, File Name, File Extension,
and Classpath.

In theInitial Directory field, type the absolute path for the directory that contains any
files or directories needed by your custom tool.

In the Path field, type any paths that need to be defined and that are not already
defined in your PATH environment variable.

If you want Stylus Studio to prompt for arguments before it runs your tool, click
Prompt for Arguments.

If you want Stylus Studio to display output from your custom tool in its Output
Window, select Use Output Window.
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11. If you want Stylus Studio to save al open documents before running thistool, select
Save All documents before execution.

12. Click the OK button.

Using the Command Line

0 To register a custom tool using the command line:
The format for the command lineis:

struzzo /newCustomTool "Tool n:=Tooln; Args= value; Command=value;
Description=value; Initial Directory=value; Path=value; PromptArgs=value;
RedirectOutput=value; DoSaveAll=value"

Example:

struzzo /newCustomTool "Tool 0:=Tool 0;Description=Avalon Uploader;
Command=AVRPTLDR.exe;Args= ${FilePath}"

Arguments for the newCustomTool function are described in the following table:

Table 7. Properties for Registering Custom Tools

Name Description

Tool n: The full syntax for this property is Tool n:=Tool n, where n is some
number. The number, n, specifies the order in the Tools menuin
which the custom tool you are registering appears. You might use 0
for the first tool you register, 1 for the second, and so on. Valid
values are numbers starting with O.

Thefirst part (Tools n:=) is used to create a key in the Windows
registry. The second part (Tools n) is used as a prefix for other
entriesin the registry key that correspond to thistool. The two
values should always be the same (Tools 1:=Tools 1, for example).

Args Command line arguments for the tool you are registering.

Command The absolute path for the command that runsyour tool. Thismust be
a.exe, .bat, or .cmdfile.

Description The tool name as you want it to appear on the Stylus Studio Tools
menu.
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Table 7. Properties for Registering Custom Tools

Name Description

Initial Directory The working directory for the tool. Thisisthe absolute path for the
directory that contains any files or directories needed by your
custom tool.

Path Any pathsthat need to be defined and that are not already defined in

your PATH environment variable.

PromptArgs Whether you want Stylus Studio to display the Parameters dialog
box each timethistool isrun. Valid values are 0 (do not display the
Parameters dialog box) and 1 (display the Parameters dialog
box).

RedirectOutput Whether you want the output directed to the Stylus Studio Output
window. Valid values are 0 (do not redirect) and 1 (redirect).

DoSaveAll Whether you want Stylus Studio to save all open documents before
running thistool. Valid values are 0 (do not save) and 1 (save dl).

Defining Keyboard Shortcuts

You can define akeyboard shortcut for many of the tasks you perform with Stylus Studio.
If you find that you repeatedly perform the same action, define a shortcut to speed your
work. You can use a keyboard shortcut right after you defineit.

How to Define a Keyboard Shortcut

0 To define a keyboard shortcut for a Stylus Studio task:

1. From the Stylus Studio menu bar, select Tools > Keyboard.
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The Shortcut Keys dialog box appears.

Shortcut Keys

Select a macro: [rezcription oK

iBlock. LontextCollapss ~

Block_ContextDelete =
Block_ContextExpand
Block_ContextGo to 35LT Source

Block_ContextGoto to Function Defi Reset 4
Block_Context Properties
DBt Cancel Query - i
DBtoL:Database Schema masedeolcus
DBtoixML: Execute

DBtoixML:Load Database Schema

DebugAttach To Yk
Debug:Breakpaints
Debug:Call Stack 'wWindow v

Create Shortcut

Figure 97. Defining Shortcut Keys

2. IntheSelect a macro: field, select the macro for which you want to define a shortcut.

Tip When you select a macro, Stylus Studio displays a description of what that macro
does.
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3.

Click Create Shortcut.
The Assign Shortcut dialog box appears.

Assign Shortcut

Fress new shortcut key:

Cancel
Nore

Figure 98. Assigning a Shortcut Key

Pressthe key or keysthat you want to be the shortcut. For example, Ctrl+E, F7, Alt+P.
The Assign Shortcut dialog box displays a message indicating whether or not that
key combination is currently in use.

If the shortcut key is not already in use, click the OK button. Otherwise, try another
shortcut key.

Stylus Studio closes the Assign Shortcut dialog box.

Click OK inthe Shortcut Keys dialog box.

Deleting a Keyboard Shortcut

> w

To delete a shortcut:

From the Stylus Studio menu bar, select Tools > Keyboard. The Shortcut Keys dialog
box appears.

In the Select a macro: field, select the macro you want to delete a shortcut for.
In the Assigned shortcuts field, click the shortcut you want to remove.

Click Remove.

Click OK inthe Shortcut Keys dialog box.
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Using Stylus Studio from the Command Line

Stylus Studio provides several command line utilities that allow you to perform Stylus
Studio operations, such as starting Stylus Studio and executing XML Diff. Command line
utilities are provided as a convenience for use during development and testing.

Available command line utilities, and where to find more information on them, are
described in the following table.

Table 8. Stylus Studio Command Line Utilities

Utility Name Description Where to Find More Information

struzzo Invokes Stylus Studio “Invoking Stylus Studio from the Command
Line” on page 128

StylusDiff Diffstwo XML documents | “Running the Diff Tool from the Command
Line” on page 204

StylusValidator | Validates XML “Validating XML from the Command Line”
on page 129

You can also execute DataDirect XML Converters™ (componentst that let you convert
non-XML like EDI and CSV to XML, and vice versa) from the command line. To learn
more about the DataDirect XML Converters™ for Javaand .NET, see the DataDirect
XML Converters™ documentation at
http://www.datadirect.com/techres/xmlconvertersproddoc/index.ssp.

Command Line Executables Location

The executables for Stylus Studio command line utilities are located in the \bin directory
where you installed Stylus Studio.

Invoking Stylus Studio from the Command Line

You use the Struzzo utility to invoke Stylus Studio from the command line and open a
particular file. Stylus Studio recognizes the file extension and opens the file in the editor
associated with that filetype. If Stylus Studio isalready running, the sameinstanceisused
to open the file specified in the fi1e parameter.

You can optionally usethe styTesheet or XQuery parameter to create a scenario with the
stylesheet or XQuery you specify.

128
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The struzzo utility takes the following format:

Struzzo file [stylesheet or XQuery]

Table 9 describes the parameters for the Struzzo command.

Table 9. Struzzo Command Line Parameters

Parameter

Description

file

The path of the document you want to open in Stylus Studio. This document
is used as the source document in a scenario when you provide the
stylesheet or XQuery parameter.

[stylesheet or
XQuery]

The path of the stylesheet or XQuery you want to use to create a scenario.

Validating XML from the Command Line

You use the Stylusvalidator Utility to validate XML from the command line.
StylusValidator uses the built-in Stylus Studio XML validator. All output from this
utility goesto stdout.

The Stylusvalidator utility takes the following format:

StylusValidator [-q] [-noval] [-schema] filename

Table 10 describes the parameters for the Stylusvalidator command.

Table 10. StylusValidator Command Line Parameters

Parameter Description
[-al Quiet mode — errors are not printed to stdout.
[-noval] Checks only for well-formedness. Does not check for errors.

[-schema file]

Validatesthe XML document against the XML Schemaspecifiedinthe fi7e
parameter.

filename

The path of the XML document you want to validate.
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Managing Stylus Studio Performance

Stylus Studio uses the TEMP directory to store temporary files such asthetrandation in
UNICODE of the current XML or XSLT document. File systems are usually quite fast
when handling files that are in the range of afew hundred megabytes. Stylus Studio
performance should be smooth and quick when the TEMP windows environment variable
points to alocation where

o Thereisaminimum of 1 gigabyte of free space.
o Thehost disk isreasonably fast.
Stylus Studio is regularly tested against files that are up to 120 MB. How well your

installation of Stylus Studio can create, open, and manipulate such large files, or even
larger files, depends on

« Available physical memory
« Dimension of the pagefile
« Current load of the machine

Troubleshooting Performance

Table 11, Performance Symptoms, summarizes performance symptoms you might
experience and where to find information on addressing them.

Table 11. Performance Symptoms

Symptom See

XML editing is slow Changing the Schema Refresh Interval on page 130
Checking for Modified Files on page 131

Errors or crashes during XSLT Changing the Recursion Level or Allocated Stack Size on
processing page 132

Stylus Studio is slow to start Automatically Opening the Last Open Files on page 132

Changing the Schema Refresh Interval

Asyou edit an XML document, Stylus Studio displays a pop-up menu that lists the
elements and element attributes you can create. Stylus Studio retrieves thisinformation
from the document’s schema. The frequency with which Stylus Studio retrieves this

130
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information can affect XML editing performance. The default refresh interval is 10
seconds.

If XML editing performance is slow, increase the refresh interval that Stylus Studio uses
to refresh the schema information.
0 To change the refresh interval:

1. From the Stylus Studio menu bar, select Tools > Options.
The Options dialog box appears.

2. Click Module Settings > XML Editor > XML Settings.
The XML Settings page of the Options diaog box appears.
3. IntheRefresh interval field, type alarger number.
Tip If the schema used by your document is almost never modified, you can safely
increase the interval to as much as 10,000 seconds.

4. Click oK.

Checking for Modified Files

When you are working with files that Stylus Studio must open through network
connections that might be slow, you might not want Stylus Studio to automatically check
for modified files. Turning off this option can improve XML editing performance.

0 To turn off checking for modified files:

1. From the Stylus Studio menu bar, select Tools > Options.
The Options dialog box appears.

2. Click Application Settings if it is not already selected.
The Application Settings page of the Options dialog box appears.

3. If the Automatically check for externally modified files is selected, deselect it.

Alternatively, you can select Disable check on hidden files, which allows Stylus
Studio to skip thesefiles. Hidden files arefiles that are in the Stylus Studio project or
the Other Documents folder but are not currently open in Stylus Studio.

4. Click OK.
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Changing the Recursion Level or Allocated Stack Size
If you are getting errors or crashes when you use the internal Stylus Studio XSLT
processor, there are two options you can change to fix this.

o TheMaximum recursion level isthe number of levels Stylus Studio alows you to
recurse on a template invocation.

o TheAllocated stack size isthe amount of memory allocated to the XSLT processing
thread stack.
0 To change the recursion level or the allocated stack size:

1. From the Stylus Studio menu bar, select Tools > Options.
The Options dialog box appears.

2. Click Module Settings > XSLT Editor > XSLT Settings.
The XSLT Settings page of the Options dialog box appears.

3. Adjust the Maximum recursion level and the Allocated stack size as heeded. For
information about how Stylus Studio uses these settings see “ Options - Module
Settings - XSLT Editor - XSLT Settings” on page 1364.

4. Click OK.
See also “Managing Stylus Studio Performance” on page 130.

Automatically Opening the Last Open Files

When you start Stylus Studio, it automatically opens any filesthat were open thelast time
you closed it. Thisfeature can affect performance if many files were open when you last
closed Stylus Studio.

If Stylus Studio is taking along timeto start, you can do one of the following:

o Close most or al files before you shut down Stylus Studio.

« Turn off the option that automatically opensthe filesthat were open the | ast time you
closed Stylus Studio.

0 To prevent Stylus Studio from automatically opening documents:

1. From the Stylus Studio menu bar, select Tools > Options.
The Options dialog box appears.

2. Click Application Settings if it is not already selected.
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The Application Settings page of the Options dialog box appears.

3. If Openlast documents automatically when Stylus Studio starts isselected, deselect
it. For information about how Stylus Studio uses this settings see “ Options -
Application Settings’ on page 1319.

4. Click oK.

Configuring Java Components

Several modulesin Stylus Studio are written using Java, and therefore require either Java
runtime or Java compiler components to be installed on your computer. These Java
components, the Java Runtime Environment (JRE) and the Java Devel opment Kit (JDK),
are available from Sun Microsystems and are installed separately from Stylus Studio.

You can install these components either before or after you install Stylus Studio. When
you start Stylus Studio, it attemptsto identify thelocation of the Javaruntimelibrariesand
compiler automatically.

This section identifies the Stylus Studio modules that require Java runtime and Java
compiler components, where you can downl oad these Java components, and how to force
Stylus Studio to detect new or changed Java components.

This section covers the following topics:

o Stylus Studio Modules That Require Java

o Verifying the Current Java Virtual Machine

« Downloading Java Components

« Modifying Java Component Settings

Stylus Studio Modules That Require Java
The following modules in Stylus Studio require that Java runtime and/or Java compiler
components are installed on the machine on which you have installed Stylus Studio:
o Saxon XSLT and XQuery engines
o Built-n Java XSLT processor
. FOP
o Web Service Call Composer Axis client
« DataDirect XML Converters accessed via URL
« SenseX in the Java editor
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Rather than trying to determine in advance which Stylus Studio modules you might use

in your XML application development, consider installing the JDK or JRE on your
machine.

Settings for Java Debugging
See “Debugging Java Files’ on page 561 for more information on this topic.

Verifying the Current Java Virtual Machine

TheJavaVirtua Machine (JV M) interprets runtime commands and compiler instructions;
it is part of the Javainstallation. You can check to see the current version of the VM
installation by selecting Help > About from the Stylus Studio menu:

Framework version:  Buid 733

Madule versions: dbgmgr.dll: Build 733 ~
debugger.dil: Build 733
flat.dll: Build 733
pipeline.dl: Build 733
prezentation.dll: Build 733
zqwml.dl: Build 733 b,

Java Virtual Machine: ¥1.4.2_06-b03 Java HotSpat(TH] Client M Sun Microsystems Inc.

debug mode port: 3000

Figure 99. Verifying the Current JVM Installation

The Java Virtual Machine field displays information about the VM installed on your
machine.

Downloading Java Components

Java runtime and compiler components are available for download from Sun
Microsystems; they are packaged in the Java 2 Platform Standard Edition (J2SE).

Either of the following versions is compatible with Stylus Studio 2010:
o J2SE 1.4.2 (download it here: http://www.java.sun.com/j2se/1.4.2/download.htm1)
o J2SE 5.0 (download it here: http://www.java.sun.com/j2se/1.5.0/download. jsp)
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Modifying Java Component Settings

Propertiesfor VM and JDK components are displayed on the Java Virtual Machine page
of the Options dialog box, shown in Figure 100. When you start Stylus Studio, it
automatically detectsthe JavaVirtual Machine (JVM) and compiler componentsinstalled
on your machine and sets the properties for these components accordingly.

Options E|
=] Ge”z'a' R o Enable Jy
pplication Settings
Editor General JRE Yersion: 1:41.03 bt
Editor Format Parameters: +#debug +<noagent <unjdwp:iansport=dt_socket zerver=y s
B ack-mapping
S.pall Checking DK
- Rl 1.41_03 v
2 Java Virtual Machine JDK Version: =
Trterrew Javac Parameters: il
Custom File Systems
Customn Document Wizards
Extemal J'/b
Custom ¥ alidation Engines R ; em? }
I3 Module Settings b
3 Java Debugging Parameters: | -debug *$hoagent +runjdwp:tiansport=dt_socket server=y,s
Debugger
£ Web Service Call Composer Display console window when possible
Proxy Settings
£ =ML Diift
Engine
Fresentation
£ %ML Editor
#ML Settings
et

Figure 100. Reset Java Properties in the Options Dialog Box

Once these properties have values, Stylus Studio uses them until you either

« Usethe auto detect feature to change them. You might want use auto detect if you
have been using Stylus Studio with the J2SE 1.4.2 and later install the J2SE 5.0, for
example.

« Change them manually. You can manually specify that Stylus Studio use a different
jvm.dIl or javac.exe, for example.

How Auto Detect Works

Theauto detect feature prompts Stylus Studio to fetch the settingsfrom the registry setting
Qurrent Versi onunder thekey HKEY_LOCAL_MACH NE\ SOFTWARE\ JavaSof t \ Java Runt i ne
Envi ronnent to find the version, and then adds the version number to that same location
to get the settings.
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Note that if you manually change your settingsto use another local version of the JDK, it
may fail toload properly unlessyou also point the Qur rent Ver si on setting to match. This
is because the VM itself might try to load DLLsfrom the location of the current version
instead of the location you specify.

About JVM Parameters

Asarule, you should never change the default valuesin the Parameter fieldsfor the Jvm
or the External JVM. This option exists to accommodate unusual configurations. In such
situations, Stylus Studio Technical Support might instruct you to change this value.

About JDK Parameters

The -g parameter instructs the compiler to add debugging information to the generated
.class filg; it is set by defaullt.

How to Modify Java Component Properties

0 To modify Java component properties:

1. Start Stylus Studio if it is not already running, and select Tools > Options from the
menu.

The Options dialog box appears.
2. Select General > Application Settings > Java Virtual Machine.

3. If youwant Stylus Studio to update Java component propertiesto the latest installed
version on you machine, click the Auto detect button.

Otherwise, make the changes manually.
4. Click OK.

5. If you made changesto any VM properties, you need to restart Stylus Studio for
those changes to take effect.
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Stylus Studio makesit easy to create, edit, and query XML documents. Depending on the
structure of the datain your XML document, you can chooseto work with raw XML text,
aDOM tree diagram, or agrid representation. Any changes you make in one view are

immediately visible in every other view. You can easily create an XML Schemaor DTD
based on the content of your XML document if it isnot already associated with aschema.

Watch it! You can view a video demonstration of this feature by clicking the
television icon or by clicking this link: watch the XML Editor video.

You can see other Stylus Studio video demonstrations here:
http://www.stylusstudio.com/xml_videos.html.

This section covers the following topics:

o “Creating XML Documents’ on page 138

« “Using Document Wizards to Create XML” on page 139
» “Updating XML Documents’ on page 141

o “Using the Text Editor” on page 143

o “Updating DOM Tree Structures’ on page 157

« “Using the Grid Tab” on page 161

. “Diffing Folders and XML Documents’ on page 176

« “Using Schemaswith XML Documents’ on page 207

« “Converting XML to Its Canonical Form” on page 210
o “Querying XML Documents Using X Path” on page 210
o “Printing XML Documents” on page 210

o “Saving XML Documents’ on page 211
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Creating XML Documents

You can create XML documentsin Stylus Studio manually, using the XML Editor, or
automatically, using document wizards, the Stylus Studio Custom XML Conversions
module, DataDirect XML Converters, and other features.

Using the XML Editor

To create an XML document using the XML Editor, select File > New > XML Document
from the Stylus Studio menu.

Stylus Studio displays a new, untitled document in the XML Editor. The document
contains only the XML declaration:

<?xml version="1.0"7>

The XML Editor provides several viewsof an XML document, each onitsown tab —Text,
Tree, Grid, and Schema. See* Updating an XML Document —Getting Started” on page 10
for an overview of these XML editing tools. See “Updating XML Documents” on

page 141 for more detailed information.

Other Ways to Create XML

You can also create XML using

« Document wizardsthat convert HTML, DTD, and XML Schemato XML. See“Using
Document Wizards to Create XML” on page 139, later in this section.

« DataDirect XML Converters, which convert CSV, fixed-width, EDI, and other flat file
formatsto XML. See“How XML Convertersare Used in Stylus Studio” on page 214.

« Custom XML conversions that you build using Stylus Studio’s Custom XML
Conversion module. See “Custom XML Conversions’ on page 221.

@i‘? DataDirect XML Converters and the Stylus Studio Custom XML Conversions
module are available only in Stylus Studio XML Enterprise Suite.
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Using Document Wizards to Create XML

Stylus Studio provides several document wizards that automatically create XML
documents from XML Schema, DTD, and HTML. This section describes how to work
with these document wizards; it covers the following topics.

o “How to Use a Document Wizard” on page 139

o “Creating XML from XML Schema’ on page 139
o “Creating XML from DTD” on page 140

o “Creating XML from HTML” on page 140

How to Use a Document Wizard
Most document wizards operate in the same general fashion:
1. Select the document wizard you want to use.

2. Specify the file from which you want to create an XML document (an HTML file or
an XML Schema, for example).

3. Specify additional settings that will affect the resulting XML document (the root
node, for example).

4. Runthewizard.
Converted files are opened as new, untitted XML documentsin the XML Editor.

All document wizards are listed in the Document Wizards dialog box. Select File >
Document Wizards to display this dialog box.

Creating XML from XML Schema

When you usethe XML Schemato XML document wizard, you specify the XML Schema
from which you want to create an XML document, aswell asits root node, and whether
or not you want to generate commentsin the XML.

Note If the XML Schema containsan element defined using abuilt-in type, theinstance of that
element inthe XML document is created using the minimum value of the range specified
for that type. For example, if the XML Schema contains a <part> element defined as
type="xs:integer”, the <part> element in the resulting XML document appears as
<part>-9223372036854775808</part>.
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Creating XML from DTD

Inadditionto XML Schema, you can useaDTD to create an XML file. When you use the
DTD to XML document wizard, you specify the DTD from which you want to create an
XML document in the DTD File field. Next, specify the element that you want to be the
root element in the new XML document, and whether or not you want expand each
element only once (thisresultsin asmaller XML document file).

Creating XML from HTML

You can create an XML document from an HTML file using the HTML to XML

document wizard. Simply specify the HTML file you want converted to XML and runthe
document wizard.

Tip Stylus Studio also has a document wizard that converts HTML to XSLT. See Creating a
Stylesheet from HTML on page 415.
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Updating XML Documents

{;**'5 The XML editor Grid tab is available only in Stylus Studio XML Enterprise Suite
and Stylus Studio XML Professional Suite.

Stylus Studio provides Text, Tree, and Grid views for updating any XML document you
open. The view you choose for editing depends on how structured your datais and your
personal preferences. This section describes how to choose an XML document view to
work with and other features related to editing XML.

This section discusses the following topics:
« “Choosing aView” on page 141
o “Saving Your Work” on page 142
« “Ensuring Well-Formedness’ on page 142
« “Reverting to Saved Version” on page 142
“Updating Java Server Pages as XML Documents” on page 143

Choosing a View

You can add and modify the data and structure of an XML document in any view. When
you switch to a different view, any changes you made appear in the new view. To move
from view to view, click the Text, Tree, or Grid tab at the bottom of the document you are
working with.

To add contents to an empty XML document, consider the structure of the data you plan
to add. The Grid view ismost useful for creating very structured data that includes
multiple instances of the same elements. The Tree view makes it easy to add many
different elements. In order to useit, however, the XML must be well-formed.

Each view of the document allows you to query the contents of the document. See
“Querying XML Documents Using XPath” on page 210.

Watch it! You can view a video demonstration of the Grid tab by clicking the
television icon or by clicking this link: watch the XML Grid Editor video.

A complete list of the videos demonstrating Stylus Studio’s featuresis here:
http://www.stylusstudio.com/xml_videos.html.
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For More Information

To learn more about a specific XML view, see one of the following sections:
o “Using the Text Editor” on page 143

“Updating DOM Tree Structures’ on page 157
o “Using the Grid Tab” on page 161

Saving Your Work

The procedure for saving your work is the same regardless of which view you use to edit
XML —make sureyour work isin the active window, and then select File > Save from the
Stylus Studio menu bar, or click Save in the Stylus Studio tool bar.

Ensuring Well-Formedness

0 To ensure that your XML document is well formed, click the Tree tab at the bottom
of the XML editor window.

If the document iswell formed, Stylus Studio displays the tree representation. If the
document is not well formed, Stylus Studio displays a message that indicates the reason
the document is not well formed and the location of the error or omission. Correct the
document, and click the Tree tab.

If you are already viewing the Tree representation of your document, the document iswell
formed. When you edit the Tree view, the XML that Stylus Studio generatesis aways
well formed.

Reverting to Saved Version

You might make some changesto an XM L document and then decide that you do not want
to save them. In the Stylus Studio tool bar, click Reload [&]. Stylus Studio displays a
message that warns you that you will lose any changes, and prompts you to confirm that
you want to reload the version of the document that is in the file system. After you
confirm, Stylus Studio displays the last saved version of the document.
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Updating Java Server Pages as XML Documents

0 To open a .jspfile as an XML document:
1. Inthe File Explorer, navigate to the JSP file you want to open.
2. Rignht click the file name, and select Open With from the shortcut menu.
3. Click XML Editor.

Using the Text Editor

You use the Text tab of the XML editor to edit XML text. The Text tab provides the usual
tools you expect to find in atext editor. These tools are described in this section.

@ Stylus Studio - [books.xml] =13

wa File Edit VWiew Project Debug XML SourceConfrol Tools \Window Help X

EAE 1 - B 0 @ = 0 -« & o7
&) 7

wa  books xml |

oo malRr £ £ 2 4 KType a new querys v|
f7:ml version="1.0"2=
§<books name="My books">

>

<hook bookid="1" pubdate="03/01/2002">
<titlerJava Webh Services</titlex ==
<authors>
<authorsDavid &A. Chappel</authors
<author>Tyler Jewell</authors
</authors»>
<subjectrWeb Hervices</subjects
</hook>
c] <hook bookid="2" pubdate="01/01/2000"=[_]
] <hook hookid="3" pubdate="03/01/2002">
I <title*Professional ebXML Foundations</titlex
] <authors>
<authorsColleen Evans</authors
<author=David A. Chappel</suthors

\Text ATree lh[ilit:l .h Schema l/

| £

Ln1Col 1 Char 60 {0x003C) MU

Figure 101. Text Tab in the XML Editor

This section covers the following topics:
o Text Editing Features on page 144
« Useof Colorsinthe Text Tab on page 149
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o Using the Spell Checker on page 151
« Moving Around in XML Documents on page 155

Text Editing Features

This section describes some of the more common text editing tools and featuresin Stylus
Studio.

Simple Text Editing

Select the text you want to edit and then do any of the following:

« Click the right mouse button to display a pop-up menu of edit commands.

« Click the appropriate button in the Stylus Studio tool bar.

« Pressthe standard control keys to copy, cut, paste, undo, or redo.

You can select aportion of text and move it to anew location by dragging it. You can drag

text from one document to another. You can drag text from documents outside Stylus
Studio to adocument in Stylus Studio.

Code Folding

Code folding is the ability to collapse three or more lines of code in XML -based editors.
For example, this code segment:

<aut hor >

<first-nane>Joe</first-name>

<l ast - nane>Bob</ | ast - nane>

<awar d>Trenton Literary Revi ew Honorabl e Menti on</ awar d>
</ aut hor >

when collapsed, appears asthis:

<aut hor >

Codefolding allows you to ssimplify the visual presentation of XML -based code; folding
does not affect the underlying code.

In editors in which code folding is supported, Stylus Studio displays atree control in the
gutter to the left of editing canvas; thisis the same area of the editor used to display line
numbers, debugging symbols, and back mapping symbols. By default, all codeis

displayed.
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What You Can Fold

In XML-based editors, you can fold
o Internal DTD

« Comments

. CDATA

o XML elements

In the XQuery Source editor, you can fold

o Comments

o Expressions delimited by curly braces ({ and } )
o XML elements

How to Fold Code

0 To unfold a segment of code, click the [-] symbol associated with that code.

When you fold code, Stylus Studio displays aboxed ellipsis symbol at the end of theline
of code you have folded, as shown here:

E< name="My bhooks"=>
= < bookid="1" pubdate="03/01/Z00Z">
< =Java Web Services< =
®
= Wuthorss
= = <Lauthor:=David 4, Chappel</authors>
= < hookid="] <author>Tyler Jewell</author>
i < o Tay S Buthors>
= < =
< =David &. Chappel< =
= =

<« =Java Message Jervice (JM3)< >

Figure 102. Example of Folded Code

If you place the pointer in the élipsis symbol, Stylus Studio displaysatool tip that shows
you the collapsed code. The amount of code that appears in the tool tip depends on the
areaon your desktop you have given the Stylus Studio application.

Tip You can unfold afolded segment by double-clicking the tool tip.

Sense:X Speeds Editing

Asyou type, Sense:X prompts you with the possible tags that you can insert at a given
location based on the XML Schema associated with the document you are editing. As
S0on as you type atag's open bracket, Stylus Studio displays a scrollable list of the
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elementsthat are allowed at that location of the document. As shown in Figure 103, there
are two entries for book, for example:

et ol
=%yl version="1.0"?>
E'ﬂ:uuks name="My hooks" xmlns:xsi="http://www, w3, org/2001/ZML3chema- instance”

<hook bookid="1" pubdate="03/01/2002">
=title>Java Web Services</title>
<authors>
<author»David &. Chappel</author>
<author=Tyler Jewell</author>
</authora>
<subjectrWel Services</subdect>

<6hnnk>

e book 2" pubdate="01/01/2000">
ﬂ}:aak o Meaoage Serviess/oiles

& o -- By
U4 1 [opATA r=David A. Chappel</author>

B
? . .
< ava Message Service (JM3)</subject>

=] <hook bhookid="3" pubdate="03/01/2002">

Figure 103. Choose Element Name or Element Fragment

If you choose the first book item (*=r-ax ), Stylus Studio completes the <book tag for you.
If you choose the second book item (=Fx-cx ), Stylus Studio completes the entire XML
fragment for you, including al attributes and default values described in the associated
XML Schema, as shown in Figure 104:

<hook bookid="-9" pubdate="undefined”>
<titlerstring</title>
<authors>
<author>string</author>
</authaors>
<subject class="-9"/>
</hook>

Figure 104. Complete XML Fragment Inserted Using Sense:X

Use the arrow key to move the selection, and press Enter to insert the value you want.

Indent

Note

Indent XML tags to show the hierarchy relationships. Click Indent XML Tags «4. Stylus
Studio indents all text in the active XML document window.

After you click the Indent XML Tags button, you cannot automatically undo or redo any
changes you have been making. After you make more changes, you can press Ctrl+Z and
Ctrl+Y to automatically undo and redo those changes until you click Indent XML tags
again.
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Line Wrap

Stylus Studio automatically wraps lines whose length exceeds 16k characters. You can
turn off this feature by selecting Disable from the Line wrap field on the Editor General
page of the Options dialog box (Tools > Options).

You can override line wrap settings by selecting Edit > Wrap Lines from the Stylus Studio
menu or by clicking the wrap lines button on the tool bar([Z]).

When line wrapping is on, Stylus Studio wraps lines to fit in the available window; the
place at which the line wraps moves as the width of the window changes. Green arrows,
as shown in Figure 105, indentify lines that have wrapped.

<
<

=

< bookid="9" pubdate="11/12/1999">
= =Instant UNIX< =
< =
= =Andrew Evans< =
< =Neil Matthew< =
< =Richard Stones< >

»In what many are calling the UNIX masterpiece of the decade,

Evans

G

Matthew,

and #tones have come up with a hook that 1s as lyrical as it is technic

1lly astute and thorough.
= =

=

=ENU/ Linux<

=

<

=

Figure 105. Green Arrows Identify Lines That Have Wrapped

Spell Checking

By default, Stylus Studio spell checkstext as you type using an internal spell checker.
Words the spell checker believes are misspelled (or repeated) are underlined with a
squiggly line, as shown in Figure 106.

= bookid="5" pubdate="11/10/2000">
< *Beginnerfapos; s Guide to Access 2.0< =
>
< uthor Team< >
< sminollofminello. com< >
< =
< class="1"xAccess< =
< =

Figure 106. Typographical Errors Are Highlighted by the Spell Checker

For more information, see Using the Spell Checker on page 151.
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Font

Com

Tip

You can change the font of the text display in Stylus Studio. This change affects only the
Stylus Studio display. Beyond personal preference, you might choose to change the font
for localization purposes— the avail able fonts are the fonts that can display the characters
in your XML file. For example, in a Japanese file, only two or three font names appear.
Click Font Change [£-] to display alist of fonts.

ments

Select the text that you want to be acomment. In the Stylus Studio tool bar, click
Comment/Uncomment Selection [=]. To remove comment tags, select the commented
text, and click Comment/Uncomment Selection.

To select an entire ling, click the gray areato the left of the line you want to select.

Bookmarks

You can set bookmarks in the XML display. Bookmarks allow you to jump to important
linesin your file. See “Using Bookmarks® on page 556.

Search/Replace

Search for and replace text you specify. Click Find or Replace in the tool bar.
You can also enable Find by pressing Ctrl + F.

Find X
Find what: | b Find Mext
[ Match whale word only Diirection Mark Al
[ Match caze Clp
[] Reqular expression @ Down

[ Search only inside:

Figure 107. Find Dialog Box

When you enable Find, Stylus Studio displays the word in which the cursor islocated —
whether the cursor iswithintheword or immediately adjacent toit —inthe Find what field
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of the Find dialog box. Similarly, any text you have selected —whole, partial, or multiple
words —is displayed in the Find what field.

Tip You can scroll through alist of the other words you have searched for by clicking the
down arrow when the Find what field is active.

Note that in addition to specifying case, you can also indicate whether or not you want to
useregular expressionsinthe Find what field and Replace with field. Thisallowsyou, for
example, to search for aline and replace it with multiple lines, as shown in the following

example.
Replace @
Find what: <onex<fones w Find Mest
Replace with: <0ne><a"0ne®wo>text<a’two> w RBeplace

Replace In Feplace Al

) Whle file Cancel

Figure 108. Replacing Text Using Regular Expressions

See “ Sample Regular Expressions’ on page 258 for examples of regular expressions and
to learn about other sources of information.

Use of Colors in the Text Tab

Stylus Studio text editors use colors to distinguish the types of datain XML documents.
The default colors for the XML Editor are described in the Table 12.

Table 12. Text Colors in Stylus Studio

Color Type of Data

White Document background

Royal blue Markup

Black XML declaration and text node contents
Pale blue Schema definition
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Table 12. Text Colors in Stylus Studio

Color Type of Data

Purple Element names defined in the DTD
Red Attribute names

Dark blue Attribute values

Orange Element names not defined in the DTD

How to Change Colors

You can set colors for the text editors associated with different document types (XML,
XQuery, XSLT, and so on) individually.

0 To change colors:
1. Select Tools > Options to display the Options dialog box.
2. Click Editor Format.
3. Select the editor type from the Editor drop-down list.
4. Setthefont, size, and color for different document categories as desired.
5. Click OK to close the Options dialog box.
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Using the Spell Checker

You can use the Stylus Studio Spell Checker with all of Stylus Studio’stext-based editors
(like editors for XQuery and XSLT, for example) to both actively and passively check
your documents for typographical errors such as misspellings and repeated words.

< bookid="5" pubdate="11/10/2000">
< rBeginner&apos; s Guide =
< > Spelling X
< faek: puthor Team
< la@minollo.
< =
< class="l"rAccess< Peplace with: |Row
: ;oakid="6" pubdate="il/1z,|  FereenalDictonay
< rBeginning Java Z<
< >
< *Iwvor Horton<
< >
Zeub ectogavas .
< =
< bookid="7" pubdates="02/07/
< *Beginning ATL COM Pro
< >
< >Richard Grimes<
< rGeorge Reilly<
< FAlex 8tockton< =

Figure 109. Stylus Studio’s Spell Checker

Default Spell Checking

The Spell Checker ison by default for most editors. This means that when you open a
document in a Stylus Studio text editor, and as you type in that document, Stylus Studio
checks the document for typographical errors. Words that the Spell Checker identifies as
possibly containing atypographical error are underlined with ared “squiggle’, like the
word Worx shown in Figure 106.

Tip You can right-click aword with a squiggle and select Spell Checker Suggestions for to
display alist of suggestions for the word identified by the Spell Checker.

Manual Spell Checking

At any time, you can manually spell check a document by selecting Tools > Check
Spelling from the Stylus Studio menu. When you do this, Stylus Studio starts the Spell
Checker, which reads through the current document. When it finds a possible
typographical error, Stylus Studio displays the Spelling dialog box, as shown in
Figure 109.

Using the Spelling dialog box, you can
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« Ignore the current occurrence of the word the Spell Checker has selected
« Ignoreal occurrences of the word

« Replace the current occurence of the word

o Replace all occurrences of the word

« Add new wordsto the dictionary

. Edit exigting dictionary content

Specifying Spell Checker Settings
You specify Spell Checker settings using the Spell Checking page of the Options diaog

box.
Options X
= Genzral oot St A5 Diefault Language: | English [United States) v
pplication Settings
Editor General Skip Ignare
Ed‘tir Format [] Capitalized words [e.g. "ltaly") [ICase
ackmappin
& \_Zhliiw:l [ Mized-case wards [e.g. "Datalirect"’) Accents
File Types N [ Uppercase words (e.q. "USDA")
Java Virtual Machine []'wWards with embedded digits [e.q. '"w3C")
Euslum PIJUISS E-mail and URIs [e.q. v stylusstudio.com''|
Caztzz Dl:c:ui:;z:n\ifizards Words with |0 o fewer characters
Customn Validation Engines [ Bepeated words
= dCIUStSDn:t_XML Converters Suggestion Mods Keyboard Layout
odule Settings : ;
3 DBteiL () Abridged [for quick checks] @) Standard
Default Connection O Expanded O Matural (5pit)
3 Java @ Standard ) Dwarak
Crebugger ) Unabridged (for mast alternatives)
Jawva Compiler
External Jy't
£ ML Dift
Engine
R F'iels..entatwon r

Figure 110. Options for the Spell Checker

Spell Checker settings include

« Wordsto skip based on certain characteristics — you might decide to skip e-mail
addresses and URLSs, for example. Skipped words are not considered by the Spell
Checker.

o Characteristics in words that you wish to ignore — you might not care about case or
accents marks for spelling purposes. In this case, two words that share the same
spelling, except for the characteristic you specify, are considered to be equivalent
(méme and meme (accent), or BMW and brmw (case), for example).
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« Thetypeof dictionary you want the Spell Checker to use when providing alternatives
to thetypographical errorsit locates. Settings range from Abriged to Unabridged and
show the fewest to the most aternatives, respectively. The Abridged setting resultsin
fewer aternative suggestions for misspelled words than Standard (the default) or
Unabridged, for example, but it requires less time to spell check a given document.

« Thelayout of the keyboard you are using. The Spell Checker usesthisinformation to
offer meaningful suggestions to words you might have mistyped.

How to Spell Check a Document

0 To spell check document:

1. Select Tools > Check Spelling from the menu.

Stylus Studio starts checking the document for typographical errors. If it findsa
typographical error, it displays the Spelling dialog box.

If You Want To Then

Replacethe misspelled word withtheword | Click Replace. Click Replace All to
suggested by the Spell Checker replace all occurrences of that word.

You can also replace the misspelled word
with another word selected from the
Alternatives list box, or with aword you
typein the Replace with field.

Ignore the misspelled word Click Ignore. Click Ignore All to ignore
al occurrences of that word.

Add the misspelled word to the personal Click Add.

dictionary

Edit the personal dictionary Click Edit. See Using the Personal
Dictionary on page 154 for more
information.

2. Once you select an action, the Spell Checker continues checking the document.

When you have addressed al identified errorsin the document (either by replacing,
correcting, or ignoring them), the Spell Checker stops.
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Using the Personal Dictionary

The Stylus Studio Spell Checker comeswith itsown dictionary. You can create apersonal
dictionary and fill it with your own entries. Personal dictionaries are used in conjuction
with the Spell Checker dictionary across all Stylus Studio editors.

To add entriesto the personal dictionary, you can

« Typeentriesindividually

o Import lists formatted as . txt files

o Automatically add entries while you check the document

The personal dictionary is stored in the c:\Documents and Settings\username\
Application Data\Stylus Studio directory.

Warning Do not modify thefilesin this directory by hand. Use the Personal Dictionary Editor
dialog box to make any changes to the personal dictionary.
0 To add a word to the personal dictionary:

1. Start the Spell Checker and display the Personal Dictionary Editor dialog box (click
Edit on the Spelling dialog box).

2. Enter aword in the New Word field.

3. Click the Add button.
The word appears in the Words in Personal Dictionary list box.

4. Click the Close button.

Tip You can also add any word identified as a misspelling to the personal dictionary by
pressing the Add button on the Spelling dialog box.
0 To import lists into the personal dictionary:
Note Listsyouimport into the personal dictionary must be unformatted . txt files, with each

entry on its own line. Do not use tab- or comma-separated files.

1. Start the Spell Checker and display the Personal Dictionary Editor dialog box (click
Edit on the Spelling dialog box).

2. Click the Import button.
The Open dialog box appears.

3. Sdlect the . txt file you want to import into the personal dictionary and click Open.
Thewordsin thelist you import appear in the Words in Personal Dictionary list box.
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4. Click the Close button.

0 To export the personal dictionary to a .txt file:

1. Start the Spell Checker and display the Personal Dictionary Editor dialog box (click
Edit on the Spelling dialog box).

2. Click the Export button.
The Save As dialog box appears.

3. Navigate to the directory in which you want to save the copy of the personal
dictionary.

4. Enter anamein the File name field.

5. Click Save.
The contents of the personal dictionary is saved to the text file.

6. Click the Close button.

Moving Around in XML Documents

Stylus Studio provides several tools for easily moving around in an XML document.

Line Numbers

To go to aparticular line, click Go to a specified location & in the Stylus Studio tool
bar. Stylus Studio displaysthe Go To diaog box. Type the number of theline you want to
go to and click OK. The cursor moves to the line you specified.

Stylus Studio displays line numbers and column numbersin the lower right corner of the
Stylus Studio window. If you want, you can set a Stylus Studio option that displaysline
numbers to the left of each line in the editor you are using.

To do this, from the Stylus Studio menu bar, select Tools > Options. Inthe Options page
that appears, click Editor General. In the Editor field, select the editor in which you want
to display line numbers. Select the Show Line Numbers check box.
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Bookmarks

To quickly focus on a particular line, insert abookmark for that line. You can insert any
number of bookmarks. You can insert bookmarks in any document that you can open in
Stylus Studio.

To insert a bookmark, click in the line that you want to have a bookmark. Then click
Toggle Bookmark in the Stylus Studio tool bar. Stylus Studio inserts a turquoise box
with rounded corners to the left of the line that has the bookmark. To move from
bookmark to bookmark, click Next Bookmark IE or Previous Bookmark |#¥g. See
“Using Bookmarks™ on page 556.

Tags

To move to the closing tag for an element, click in the tag name for the element. In the
Stylus Studio tool bar, click Go to Matching Tag *%; . Stylus Studio moves the cursor to
the closing tag for the element you clicked.

Find

In any view of an XML document, and in the XSLT Source view of a stylesheet, you can
click Find in the Stylus Studio tool bar. In the Find dialog box that appears, specify
the string you want to search for and click Find Next. Stylus Studio highlights the first
occurrence of the string you entered. In the Text view, you can specify that you want
Stylus Studio to highlight all instances.

Depending on which view you are examining, Stylus Studio allows you to specify

constraints on the search. The congtraints you can specify include the following:

« Match whole word only

« Maich case

o Find aregular expression

« Searchinside only element tags, only element values, only attribute names, and/or
only attribute values

To learn more about regular expression syntax, visit
http://www.boost.org/1ibs/regex/doc/syntax.html.
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Updating DOM Tree Structures

To update the DOM tree for an XML document, click the Tree tab at the bottom of the

window that contains the document.

Stylus Studio - [books.xml]

Eile Edit “iew Project Debug XML DTD ¥MLSchema SourceConfrol Tools \Window Help x
& & = B % dth ¥
books.xml |
B s @X L AR v
Tag A
‘_t= EE Y rooks
b @ name My books
@ =-®% book
LY % bookid 1
e # pubdate 03/01/2002
é,? "8 ritle Java Web Services
5 =-*® suthors
.T= author Dawvid A. Chappel
"% author Tyler Jewell
"[: subject eb Services
=™ nook
% hookid 2
# pubdate 01/01/2000
" ritle Java Meszage Jervice
=-*® authors
'[: author David A. Chappel
"8 subject Java Message Service (JM3)
=-*® hook v
;‘Text }\Tree AGrid hSchemal/
UM

Figure 111. Tree Tab in XML Editor

Whileyou are editing, if the display doesnot appear to correctly represent the current tree,
click Reload Document in the main tool bar. If you want to perform a certain action
and Stylus Studio has grayed out the button for that action, try clicking Refresh first.

To save your file, select File > Save from the Stylus Studio menu bar or click Save in the

Stylus Studio tool bar.

This section discusses the following topics:

. “Displaying All Nodes in the Tree View” on page 158
« “Adding aNodein the Tree View” on page 158

« “Deleting aNodein the Tree View” on page 159

« “Moving aNodeinthe Tree View” on page 159

« “Changing the Name or Value of aNode in the Tree View” on page 159
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« “Obtaining the XPath for a Node” on page 160

Displaying All Nodes in the Tree View

To expand atree so that you can see all the nodesin thetree, click the root node and then
pressthe asterisk (*) key in the numeric key pad. To expand any particular node, click that
node and press = in the numeric key pad.

The default tree view of your document does not include nodes that contain only blank
spaces, linefeeds, or tabs. To toggl e between the default view and aview that does display
all nodes, click White Space w5 inthe Stylus Studio tool bar. Thisview is most helpful
when you are operating on the DOM and need to know the exact structure of the tree.

Adding a Node in the Tree View

O

Along the | eft side of the window that contains your DOM tree, there are buttons that
represent the types of nodes you can add to your document. The procedure for adding a
nodeis similar for all types of nodes.

To add an element:

1. Click the element that you want to be the parent of the new element, or click an
element that you want to be a sibling of the new element.

2. Toadd achild element, click New Element ¥:® . To add asibling element, hold down
the Shift key and click New Element.

Alternative: To add a child element, press Ctrl+E. To add a sibling element, press
Ctrl+Shift+E.

If your XML document specifiesaDTD, Stylus Studio displaysalist of the elements
that you can add at that location. If your document isassociated withan XML Schema
or does not specify aDTD, Stylus Studio prompts you to specify the name of the new
element.

3. Double-click the element you want to add, or type the name of the new element and
press Enter. If you added a child node, Stylus Studio addsit asthe last child.

4. If the new element contains data, type a value for the new element and press Enter.
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Deleting a Node in the Tree View

Along the | eft side of the window that contains your DOM tree, there are buttons that

represent the types of nodes you can add to your document. The procedure for deleting a
nodeis similar for all types of nodes.

0 To delete anode:
1. Click the node you want to delete.
2. Click Delete Node ¥ .

Moving a Node in the Tree View

Along the | eft side of the window that contains your DOM tree, there are buttons that

represent the types of nodes you can add to your document. The procedure for moving a
nodeis similar for all types of nodes.

0 To move a node:
1. Click the node you want to move.

2. Click the up and down arrows at the top of the document window to move the node
up or down the tree.

Alternative: Drag the node to its new location.

Changing the Name or Value of a Node in the Tree View

Along the | eft side of the window that contains your DOM tree, there are buttons that

represent the types of nodes you can add to your document. The procedure for renaming
anodeissimilar for all types of nodes.

0 To rename a node:
1. Click the node you want to rename.

2. Click Change Name <# . If your document specifiesa DTD, Stylus Studio displays
alist of the possible names. If your document does not specify aDTD, Stylus Studio
opens an edit field.

3. Double-click the new name, or type the new name and press Enter.
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0 To change the value of a node:
To change the value of a node:
1. Click the node whose value you want to change.

2. Click Change Value 3# . Stylus Studio displays an update field.
3. Typethe new value and press Enter.

Obtaining the XPath for a Node

[0 To obtain the XPath expression that returns a particular node:
1. Inthe XML editor, click the Tree tab.

2. Right-click the node for which you want the X Path expression.
3. Inthe shortcut menu that appears, click Copy XPath Query to Clipboard.
4. Press Ctrl+V to paste the X Path expression where you want it.
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Using the Grid Tab

£

firgs "':d

and Stylus Studio XML Professional Suite.

The XML Editor Grid tab is available only in Stylus Studio XML Enterprise Suite

The Grid view of an XML document is useful for structured data— it is a convenient way

to view and work with documents that contain multiple instances of the same type of
element.

Stylus Studio - [books.xml *] =1
Z File Edit Wiew Project Debug XML DTD XMLSchema SourceControl Tools Window Help x
HrEE AR # B o2& 2 #h &
books.xml x|
ES R H = ¥, <Type a new querys v|
"% Tag Hame @ name
= bhooks My books o
<books>
"% Tag Hame ¢ hookid @ pubdate " title " subject
book 1 03/01/2002 Java Weh Zervices Web Services
hook 2 01/01/z2000 Java Message Jervice Java Message Service (O
book 3 03/01/2002 Professional ebXML Foundat ebXML
Bl book 01/03/1997 Beginning Visual C++ 6 Dat|Database

<book><authors:

®® Tag Hame Text # 1
suthor John Connell
i author Minollo
-
\ Text. }\ Tres hGrid f{‘ Schema l/

For Help, press F1

HUM

Figure 112. Grid View of books.xml

This section describes the features of the Grid tab and how to useit to edit XML

documents. This section covers the following topics:

« “Layout of the Grid Tab” on page 162
« “Features of the Grid Tab” on page 162
« “Moving Around the Grid Tab” on page 166

“Working with Rows’ on page 168
“Working with Columns” on page 170
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o “Working with Tables’ on page 172

Watch it! You can view a video demonstration of this feature by clicking the
television icon or by clicking this link: watch the XML Grid Editor video.

A complete list of the videos demonstrating Stylus Studio’s featuresis here:
http://www.stylusstudio.com/xml_videos.html.

Layout of the Grid Tab

The Grid tab consists of atool bar and adisplay area. Thetool bar has buttonsto perform
actions and operations on both the grid itself and on the underlying XML document
represented in the grid. An example of theformer isthe ability to show the child el ements
of the document’sroot element; they are hidden by default. An example of the latter isthe
ability to add anew instance of an element or to change avalue. These operations are also
accessible from the XML > Grid Editing menu, as well as from the grid shortcut menu
(right-click on the grid).

Thetool bar also includesaquery field, which allows you to enter an X Path expression to
guery the XML document. Results are displayed in the Query Output window, which
appears when you run the query if it is not already displayed. See “Querying XML
Documents Using XPath” on page 210 for more information on this feature.

The display area shows the XML document, both its structure and content, rendered in a
tabular, or grid format.

Features of the Grid Tab

This section describes the features of the Grid tab. It covers the following topics:
« “Expanding and Collapsing Nodes’ on page 163

o “Collapsing Empty Nodes’ on page 163

« “Renaming Nodes’ on page 165

« “Resizing Columns’ on page 165

« “Showing Row Tag Names’ on page 166
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Expanding and Collapsing Nodes

When you first display a document in the Grid tab, the document is collapsed so that it
showsjust theroot element (hereit is <books>) and its name attribute (My books), asshown
in Figure 113.

booksz.xml |

Figure 113. Default Display — Document Elements Are Collapsed

A plus sign displayed to the left of the node name indi cates that this node has child nodes.
You can click the plus sign to display a subgrid that displays the child nodes, as shownin

Figure 114.
books /book
4 bookid @ pubdate " title " subject
1 03/01/2002 Jawva Web Zervices Tebh Services
2 01/01/2000 Java Message Service Java Message Service (JHI)
3 03/01/2002 Professional ebXML Foundations eh XML
4 01/03/1997 Beginning Visual C++ 6 Database Progr Datshase
5 11/10/2000 EBeginner's Guide to Access 2.0
& 11/12/1999 Beginning Java 2 Java
7 02/07/1998 EBeginning ATL COM Programming C++
a 10/01/1295 XML Applications EML
9 11/12/1999 Instant TNIZ GNU/Linux

Figure 114. Click Plus Signs to Expand Collapsed Tables

You can continue to drill down in thisfashion to view all values.

0 To expand a node, click the plus sign ().

Collapsing Empty Nodes

Some nodesin adocument are simply containers—they have no content of their own. An
example of acontainer node is the <authors> element in books . xm1. The <authors>
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element issimply acontainer for one or more <authors> €lements, as shown in this excerpt
of books.xm1:

<aut hor s>
<aut hor>David A Chappel </ aut hor >
<aut hor >Tyl er Jewel | </ aut hor >

</ aut hor s>

To streamline the display, Stylus Studio hides the tables that represent container nodes.
Information about container nodes is displayed in the child node’s header. Figure 115
shows the default display for the author element. Notice that the header,
book/authors/author, contains information about the container node, authors.

i name

[ My books

books /book
@ bookid i pubdate " title
:
48 hook /authors /authory
ErTer

Dawvid A. Chappel
Tyler Jewell

Figure 115. Table Headers Show Full Path

If you want, however, you can display the tables associated with container nodes, as
shown in Figure 116.

i name

[ My books

books /book

@ bookid i pubdate " title
= 03/01/2002 Java Web Services

1
= book faut hors
=

Text

Dawvid A. Chappel
Tyler Jewell

Figure 116. Container Nodes Are Hidden by Default
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Thetable associated with the authors node now appearsin the grid; it isempty (it hasno
rows) because it isacontainer. The elementsit contains are displayed in their own table,
authors/author.

0 To display container nodes, click Simplified View ().

Thisaction isalso availablefrom the XML > Grid Editing menu and from the grid shortcut
menu.

Renaming Nodes
You can rename container nodes directly in the grid.

0 To rename a node:

1. Double-click the header that represents the node you want to rename.
The node name is selected.

2. Type the name you want to use for the node.

3. PressEnter (or click elsewherein the grid or grid background).

Resizing Columns

When you expand a node, Stylus Studio displays it in uniform columns. You can resize
columns to any width you prefer by dragging the handle on the right side of the column
header, as shown in Figure 117.

i name

[ My books

books /book

00 P e
hookid ubdat

03/01/2002

2 01/01/z000

Figure 117. Resize Columns by Dragging the Right Handle

0 To resize a column, drag the handle on the right side of the column header.
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Showing Row Tag Names

Inthegrid view of astructured XML document, each child element of anode corresponds
to arow in atable. For example, the <books> node of books.xm1 contains nine child
elements; each row isan instance of the <book> element. To preserve space in thegrid, the
tag names of child elements are not displayed as a separate column in the table. Rather,
as shown in Figure 114, thisinformation is displayed in the table header itself.

If you want, you can display the tag name for child elementsin their own columns, as
shown in Figure 118.

@ bookid % pubdate A title
03/01/2002 Jawva Web Zervices
01/01/2000 Java Message Service
03/01/2002 Professional ebXML Foundations
01/03/1997 Beginning Visual C++ & Database Progy
11/10/2000 EBeginner's Guide to Aecess 2.0
11/12/1999 EBeginning Java 2
02/07/1998 Beginning ATL COM Programming
10/01/19295 XML Applications
11/12/1999 Instant UNIZ

HHEHEBKHRBH
- 5
wom - ok W N e

®H

Figure 118. Displaying the Root’s Child Element

0 To toggle the display of child element names, click Toggle Row Tag Name ().

This action is also available from the XML > Grid Editing menu.

Moving Around the Grid Tab

You can move around the grid using the mouse (click where you want to go) and the
keyboard. Keyboard navigation is presented in the following table.

Table 13. Keyboard Navigation in the Grid

Key Action

Up/Down arrow keys Moves the row highlight in the direction of the arrow key you press.

Left/Right arrow keys Moves the focus from one cell to the next, in the direction of the
arrow key you press.

Page Up Moves the row highlight to the root node’s attribute.

166

Stylus Studio® 2010 User Guide



Using the Grid Tab

Table 13. Keyboard Navigation in the Grid

Key Action
Page Down Moves the row highlight to the last row in the document.
Tab Moves the focus forward to the next cell in the row; movesto the

first cell of the next row when you hit the last cell in arow.

Shift + Tab Moves the focus backward to the previous cell in the row; movesto
the last cell of the previous row when you hit thefirst cell in arow.

Selecting Items in the Grid

When you select acell in atable:

« Therow is selected; you can perform row-oriented actions like changing the row’s
order in the table. You can also select arow by clicking the plus sign to the left side
of the row.

« Thecolumn is selected; you can perform column-oriented actions like adding a new
column or renaming an existing one.

o Thecdl getsfocus.
Tip Pressing Enter places a selected cell in Edit mode.

How Grid Changes Affect the XML Document

When you make a change to the document structure or content on the Grid tab, those
changes are reflected immediately in the underlying XML document. You can see your
changes affect the document on the Text tab.

Consider the following excerpt from books. xm1.

<aut hor s>
<aut hor >Davi d A. Chappel </ aut hor >
<aut hor >Tyl er Jewel | </ aut hor >

</ aut hor s>
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If you move the rows in the authors table, for example, as shown in Figure 119,

book/authors/author

Tyler Jewell
David A. Chappel

Figure 119. Moving a Row Affects XML

the underlying XML changes accordingly:

<aut hor s>
<aut hor >Tyl er Jewel | </ aut hor >
<aut hor >Davi d A. Chappel </ aut hor >
</ aut hor s>

Types of Changes that Affect the Document

The following changes, all of which can be made using Grid tab, affect the underlying
XML document:

« Adding, deleting, reordering rows

« Adding, deleting, reordering, and renaming columns

« Adding, deleting, reordering, and sorting tables

« Changing element and attribute values

« Renaming container e ements

Changesyou make affect the current instance only. For example, in the example shownin

Figure 119, only that instance of the nested table is affected. If you add a column to
books/book, however, every instance of books/book gets that new column.

Working with Rows

Stylus Studio provides several features to help you work with table rows in the Grid tab.
Changes you make to tablesin the Grid tab, such as adding a new row or modifying a
value, arereflected in the underlying XML document.

This section covers the following topics:

« “Reordering Rows’ on page 169

« “Adding and Deleting Rows’ on page 169
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Reordering Rows
You can move rows up and down within the same table. Changes you make to row order
affect the e ement order in the underlying XML document.
0 To move arow:
1. Select the row you want to move.

2. Click the Move Up (Ji=) or Move Down ([=]) button to move the row to the desired
location in the table. These actions are also available from the XML > Grid Editing
menu and from the grid shortcut menu.

Adding and Deleting Rows

You can add and delete rows in atable. Changes you make to the table in this way affect
the number of instances of the element in the table. When you add a row, you can insert
it in the table above or below the currently selected row.

Tip You can move rows up and down within atable.

0 To add a row:
1. Select the row next to which you want to insert a new row.

2. Click thelnsert Row Before ([*=) or Insert Row After (=) button to add the new row
to the table. These actions are also available from the XML > Grid Editing menu and
from the grid shortcut menu.

The row is added to the table.

0 To delete arow:
1. Select the row you want to delete.

2. Click Delete (). This action is also available from the XML > Grid Editing menu
and from the grid shortcut menu.

The row is deleted from the table.
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Working with Columns

Stylus Studio provides several features to help you work with table columnsin the Grid
tab. Changes you make to tablesin the Grid tab, such as adding a new column or
reordering existing columns, are reflected in the underlying XML document.

This section covers the following topics:

« “Selecting a Column” on page 170

« “Adding Columns’ on page 170

o “Deleting Columns’ on page 171

« “Reordering Columns’ on page 171

« “Renaming Columns’ on page 172

« “Changing aValue’ on page 172

Selecting a Column

Column operations can be performed when you select any cell in a column. When acell
(and, therefore, its column) is selected, it is highlighted with ayellow outline. As shown
in Figure 120, the <tit1e> column is selected —the cell containing Java Message Service
isthe one that is highlighted.

| books /book
@ bhookid @ pubdate " title "% subject

03/01/2002 Java Teb Services Web Services
01/01/2000 E: Java Message Jervice ([JM]

03/01/2002 Professional ebXML Found: ebXML

H|H
-

=
w

Figure 120. Selected Cells are Highlighted in Yellow

0 To select a column, click any cell in the column you wish to select.

Adding Columns

You can add two types of columnsto tablesin the Grid tab — attribute columns and element
columns. The procedure for adding both types of columnsis the same. When you add a
column, itisinserted immediately after thelast column of itstype. You can move columns
after you create them.
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0 To add a column:
1. Select the row in which you want to add a column.

2. Click Add Attribute Column ([]) or Add Element Column ([Z]). These actions are
also available from the XML > Grid Editing menu and from the grid shortcut menu.

The column is added to the table.

3. If you want, move the column to a new location in the row. See “ Reordering
Columns’ on page 171.

Deleting Columns

O To delete a column:

1. Select acell inthe column you want to delete.
A yellow border appears around the cell you select.

2. Click Delete Column (). Thisactionis also available from the XML > Grid Editing
menu and from the grid shortcut menu.

The column is deleted from the table.

Reordering Columns

You can reorder columnsin the grid by dragging them to the position you desire.

0 To reorder a column:
1. Place the pointer on the left handle in the column header.

2. Press and hold mouse button one.
The cursor changes shape, as shown here.

"= subject

{hb SGervices

Jawa Message Service

ehXHL

Figure 121. Moving a Column

3. Drag the column to the location in the row you want.

4. Release the mouse button.
The column is placed in the new location within the row.
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Renaming Columns

You can rename columnsin the grid. This has the effect of renaming the corresponding
attribute or element name in the underlying XML document.

Note You cannot rename the root element from the Grid tab.

00 To rename a column:

1. Select acedll inthe column you want to rename.
A yellow border appears around the cell you select.

2. Click Rename Column ([F]). Thisactionisalso available from the XML > Grid Editing
menu and from the column shortcut menu.

The column is renamed.

Changing a Value
You can change element and attribute val ues.

0 To change avalue:

1. Double-click the cell whose value you want to change.
The cell field becomes editable, as shown here.

" title
Java Web Services‘

Figure 122. Changing a Value

2. Edit the vaue as required.
3. PressEnter.

Working with Tables

Stylus Studio provides several features to help you work with tables in the Grid tab.
Changes you make to tables in the Grid tab, such as adding anested table, arereflected in
the underlying XML document.
This section covers the following topics:
« “Adding aNested Table” on page 173
« “Moving aNested Table” on page 174

“Deleting a Table” on page 174
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o “Sorting aTable” on page 175
« “Copying aTable as Tab-Delimited Text” on page 175

Adding a Nested Table

You add nested tables to adocument in the Grid tab using the Add Nested Table dialog
box, shown in Figure 123. This dialog box allows you to specify the path to the root for
the new table, arow e ement name, and the number of rows.

Add Nested Table X
Path ta the root :
! '

Fiow element name:

Mumber of rows: |2

S
-

Figure 123. Add Table Dialog Box

A nested tableis created as a child of the current element. The nested table shown in
Figure 124, myTable, was created as a child of the <book> element.

i name

[ My books

@ bookid i pubdate " title " subject
=1 03/01/2002 Java Web Services Teh Services

book /authors /author
[E] Text

Dawid L. Chappel
Tyler Jewell

book/myTable
[E] Text
row 1

rov 2

Figure 124. Default Nested Table

Nested tables are created with two default rows, which use the element name you provide
in the Row Element Name field of the Add Nested Table dialog box. Rows get a default
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text value of Row n text, where nisan incrementing value starting with 1. You specify the
number of rows using the Number of rows field.

0 To add a nested table:

1.

2.

Select the element to which you want to add a nested table.

Click Add Nested Table ([FF). This action is also available from the XML > Grid
Editing menu and from the grid shortcut menu.

The Add Nested Table dialog box appears.

Optionally, specify the path to the root. If you leave thisfield blank, the nested table
is created as a child of the current element.

Enter arow element name.
Optionally, change the number of default rows.

Click OK.
The nested table is added to the document and appears in the grid.

Moving a Nested Table

You can change the order of nested tables within arow.

0 To move a nested table:

1.
2.

Select the heading of the nested table you want to move.

Click the Move Up ([f=) or Move Down ([=]) button to move the table to the desired
location. These actions are also avail able from the XML > Grid Editing menu and from
the grid shortcut menu.

Deleting a Table

O

To delete a table:

1.

2.

Select the heading of the table you want to delete.

Click Delete (). This action is also available from the XML > Grid Editing menu
and from the grid shortcut menu.

The table is deleted from the document.
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Sorting a Table
You can sort tables on any column in ascending or descending order.

0 To sort atable:
1. Select acel inthe column on which you want to sort the table.

2. ClicktheSort Ascending ([£]]) or Sort Descending ([Z]]) button to sort the table rows
in ascending or descending order, respectively. These actions are also available from
the XML > Grid Editing menu and from the grid shortcut menu.

Tip You can also display sort options by right-clicking the column heading.

The table rows are sorted based on the order you select.

Copying a Table as Tab-Delimited Text

You can copy atab-delimited text version of atable to the clipboard. This makes it
possible to paste document contents from the grid into spreadsheets and other editors that
can manage tab-delimited files. Figure 125 shows books/book in books .xm1 pasted into
Microsoft Excel, for example.

£ Microsoft Excel - Book1

@ File Edit “iew Insert Format Tools Data  Window Help Adobe POF
PEESIESRY LA -F v - @x-4HBE0D 2 ari
= = # g2 o
TIEE.

A1 > # bookid

A B © o]

1 [bookid __lpubdate title subject
2 1 3/1/2002 | Java Yeb Services WWeb Services
3 2 1/1/2000 Java Message Service Java Message Service (JMS)
4 3 3172002 Professional ebXML Foundations ebihL
5] 4 1/31957 Beginning “isual C++6 Database Programming  Database
B 5 1141072000 Beginner's Guide to Access 20
7 <] 114121999 Beginning Java 2 Java
g 7 2f711998 Beginning ATL COM Pragramming C++
9 3 10141999 XML Applications ML
10 9 1141241999 Instant UNEX GMUALinux

Figure 125. Pasting a Table into a Spreadsheet

Note that when you usethisfeature, the entiretableis copied — column headings (element
and attribute names) are not distinguished from cell contents (element and attribute
values) in the spreadsheet.
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0 To copy atab-delimited table to the clipboard:

1
2.

Select the heading of the table you want to copy.

Select XML > Grid Editing > Copy as Tab-Delimited from themenu. Thisactionisalso
available from the grid shortcut menu.

Diffing Folders and XML Documents

@i‘? XML differencning is available only in Stylus Studio XML Enterprise Suite and
Stylus Studio XML Professional Suite.

During application development, it can be useful to be ableto compare two or more XML
documents, or to compare the contents of two folders, in order to identify the type and
number of differences between them. The process of comparing one document (or folder)
with another isreferred to as diffing. Stylus Studio provides utilitiesfor diffing foldersand
documents.

@ Watch it! You can view a video demonstration of this feature by clicking the
television icon or by clicking this link: watch the XML Diff video.

A complete list of the videos demonstrating Stylus Studio’s featuresis here:
http://www.stylusstudio.com/xml_videos.html.

This section covers the following topics:

“Overview” on page 177

“Diffing Folders’” on page 182

“The XML Diff Viewer” on page 186

“Diffing aPair of XML Documents” on page 193

“Diffing Multiple Documents” on page 195

“Modifying Default Diff Settings’ on page 200

“Running the Diff Tool from the Command Line” on page 204
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Diffing Folders and XML Documents

Overview

Stylus Studio’s Diff tool lets you easily compare two or more versions of the same
document in the XML Diff Viewer (as shown in Figure 126), or the contents of two
folders (as shown in Figure 130).

4 Stylus Studio - [authors.dff] =109
E? File Edit “iew Project Debug XML Diff SourceControl Tools Window Help x
B2 aulhols.dﬂ|
B ':°|;_'=: T !-ll o|<? EntlEE] f.
] v |@ |file:.l’.fl\vv:.ftes‘ting.idiff_target.xml ||§||
=-*® surhors =-®% suthors A
=3 row Source document %3 row Target document
"Eﬂ <unchanged: "Eﬂ <unchanged:>
= au_lname = au_lname
Y Hennings o White
"E: <unchanged: "E: <unchanged:>
- = ™ city "# <unchanged:
- Menlo Fark =8 row
.'[: <unchanged: "[: <unchanged:>
=-®8 row +* =8 city
"Eﬂ <unchanged: Oakland
®® cunchanged:> ,CUI_'"S and symhols Ll = *" state
indicate the type of * en
difference detected
4 =" zip
+ 24618 7
\ Split Wiew - Tree f{‘ Split Wiew - Text }‘ Merged View .'f
For Help, press F1 UM

Figure 126. Example of Diffed Documents in the XML Diff Viewer

Customizable color-coding lets you quickly determine how one document differs from
another — green, for example, identifies objects (such as elements and attributes) that are
present in the target document, but which do not exist in the source document. When you
hover the pointer over symbols displayed in the side bars of the source and target
document windows, Stylus Studio displays atool tip that indicates the specific nature of
the change.

This section covers the following topics:

« “Sourcesand Targets’ on page 178

« “The Diff Configuration File” on page 178

« “What Diffs Are Calculated?’ on page 178

« “Tuning the Diffing Algorithm” on page 179

« “When Doesthe Diff Run?’ on page 180
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o “Running the Diff Manually” on page 181
“Symbols and Background Colors” on page 181

Sources and Targets

Tip

The

When you use Stylus Studio to diff documents (or folders), you select a source and a
target. Stylus Studio considersthe source document or folder to bethe baseline, or current
standard; the target document or folder is assumed to be some other version (it might be
older or newer, for example) of the source. The Stylus Studio Diff tool illustrates how this
other version, the target, differs from the source (or sources) you have selected.

You can open source and target documentsin the XML Editor from the XML Diff Viewer
—right click on the XML Diff Viewer background and select the document you want to
edit from the short-cut menu of source and target documents displayed by Stylus Studio.
Thisfeature is context-sensitive—if you right-click on anode that has been removed, the
target document will not be listed, for example.

Diff Configuration File

You can save the information associated with a given XML diff session in a diff
configuration file. Diff configuration files make it easy to perform a diff on the same set
of XML documents over time. Examples of the information saved with the diff
configuration file include the URL s of the source and target documents, and any settings
made on the XML Diff menu or tool bar. Diff configuration files are created with a .dff
extension.

Changes made to the source and target documents are detected by Stylus Studio the next
time you open the diff configuration file, allowing you to diff the files at that time.
(Whether or not the diff is run automatically when you open the diff configuration file
depends on Autorun Diff settings on the Engine page of the Options dialog box. See
“When Does the Diff Run?’ on page 180 for more information.)

What Diffs Are Calculated?

This section describes how Stylus Studio diffs XML documents and folders.

Documents — The Stylus Studio Diff engine compares source and target documentsin
their entirety. If you want, you can use the Engine page of the Options dialog box to
exclude certain items from the diff calculation. These itemsinclude:

o« Comments
o« Text
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. Entities
o Attributes
« Processing instructions

You can also specify whether or not you want Stylus Studio to:

« Use URIsto compare namespaces

« Expand entity references

« Ignore text formatting characters (new lines, carriage returns, and tabs)

See“Modifying Default Diff Settings’ on page 200 to learn how to set these and other diff
options.

Folders — Options for diffing XML documents do not affect how Stylus Studio diffs
folders. When diffing folders, Stylus Studio compares one folder’s contents with another.
See “Diffing Folders’ on page 182for more information on this topic.

Tuning the Diffing Algorithm

The purpose of any diffing tool is to identify the list of logical operations required to
change the source document into the target document. Examples of logical operations
include additions, revisions, and deletions. Even diffs between simple XML documents
canyield along list, sometimes with redundant operations. Ideally, the list of operations
should be reduced to make it as economical as possible; that is, the list should be ableto
answer the question, What are the fewest number of changes required to turn the source
into the target?

Calculating such alist can be time-consuming and resource intensive, and these costs
might not be worth the benefits to a given user. For this reason, Stylus Studio provides
settings that |et you tune the diffing algorithm used by the XML Diff engine. Tuning
settings are displayed in the Performance group box on the Engine page of the Options
dialog box.

Performance

(®) Autodetect () Optimize change descripion () Optimize calculation time

Optimize for large documents with few changes

Figure 127. Performance Settings Let You Tune the Diffing Algorithm
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You can

« Select atuning that optimizes the a gorithm to provide the most economical set of
changes possible (Optimize change description). As described earlier, this
calculation, though it yields the best results, can be costly in terms of time and
processing resources.

« Select atuning that optimizes the algorithm to provide the set of changesin the
shortest time possible (Optimize calculation time).

o Let Stylus Studio decide (Autodetect). By default, Stylus Studio triesto provide the
most economical set of changes possible, but if it determines that processing
resources are limited or that the calculation will take too much time, it revertsto the
algorithm tuning that is optimized for speed.

Handling Large Documents

The Optimize for large documents with few changes setting helps speed the diffing of
large (greater than 1M B) documents. This setting can be used in conjunction with any of
the algorithm tuning settings and is on by default.

When Does the Diff Run?

Stylus Studio runs the diff automatically, as soon as you specify the target document or
folder. Whether or not subsequent changes cause Stylus Studio to automatically
recalculate the diff is determined by the Autorun Diff settings on the Engine page of the
Options dialog box. Changesthat can make a diff recal culation necessary include adding
new source and target documents, changing the underlying source and target documents
themselves, or to changes to certain Engine settings.

Options That Affect When the Diff Runs

These settings, on the Engine page of the Options dialog box, determine when and
whether Stylus Studio automatically recal culates the diff.

« On changes — Certain types of changes to the diff configuration file require Stylus
Studio to recalculate the diff. These changesinclude:

= Adding anew source document

= Changing the target document

= Changing the Use URI to compare namespaces Setting
» Changing the Expand entity references setting
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If the On changes setting ison, Stylus Studio automatically runsthe diff when any of
these changes occurs.

« Iffiles modified —If you make and save changesto a source or target document, Stylus
Studio automatically runs the diff if this setting ison.

Note These settings do not affect the diffing of folders.

See “Moadifying Default Diff Settings” on page 200to |earn more about setting these and
other Diff options.

Running the Diff Manually

You can run the diff manually by clicking the Calculate diff button (| b ). Stylus Studio
activates this button when it detects the need to recalculate the diff, and the On changes
or If files modified settings are off. These settings, as described in “When Does the Diff
Run?’ on page 180, cause Stylus Studio to run the diff automatically.

You can also run the diff from the command line. See “Running the Diff Tool from the
Command Line” on page 204.

Symbols and Background Colors

Stylus Studio uses symbols and background colors to alert you to differences in diffed
documents and folders. The following table summarizes the symbols and default
background colors, and the types of changes they represent.

Table 14. Default Colors Used for Diffing Files and Folders

Symbol Background Color | Identifies

Light green Added items; appears in the target document and
identifies an item that is present in the target but
absent from the source

|E| Light red Removed items; appears in the source document and
identifies an item that is present in the source but
absent from the target.

Light yellow Changed items; can appear in both source and target
documents.

|:| Light gray Collapsed item containing changes (such as an added,

changed, or removed node).
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Tip

You can change the background colors on the Presentation page of the Options dialog
box.

Combined Symbols

Asdescribed in Table 14, Default Colors Used for Diffing Files and Folders,, Stylus
Studio displays aturquoise block (| 1) when anode that you have collapsed contains
changes. Sometimes, the nodeitself haschanges. In thiscase, Stylus Studio combinestwo
symbols — one indicating the change of a child within the collapsed node, and one to the
node itself. Consider the following illustration:

|E + 8 cicy
Figure 128. Sample of a Collapsed Node with Changes

Here, the city node displays a combined symbol — the turquoise box indicates that a
change exists within the collapsed node; the minus sign indicatesthat the city nodeisnot
present in the source document. Expanding the city node makes the scope and nature of
the changes explicit:

- - "R ity
— Menlo Park

Figure 129. Expanded Node with Changes

Hover the mouse point over these symbols to display tool tips that describe the nature of
the change.

Additional Symbols for Diffing Multiple Sources

Stylus Studio uses other symbolsin the target document window when you diff multiple
source documents. See “ Symbols Used in the Target Document Window” on page 196.

Diffing Folders

Stylus Studio alows you to diff two folders. As shown in Figure 130, the Diff Folders
dialog box displays the contents of each folder; symbols and colors, described in
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“Symbols and Background Colors” on page 181, identify the types of changesin the
respective folders.

Diff Folders X
Source falder: Target folder:
|fi|e:#z’c “Program FileshStylus Studio®<MLdIF [ |fi|e:f’x’c:\DeveIop><ML =
=7 file: ¢ /Program Files/Stylus Studio =ML =7 flesd e /D evelop<ML
[0 authors. dff [ authors.df
B [ authars_rew.sml 0 [ authors_mods. sl
N [ authars_old.xml N [ authors_cld.aml
[ diff_source.xml ] [ boakstore.ded
j diff_sourcel sl =" D bookstorelliagram.xsd

ff_source. «mi iff_source. sml
diff 2wl diff |

j diff_target. xml D diff_sourcel .xml
- [ doc.sml [ diff_source2.sml
- [ doc2.sml [ diff_target sml
= [ docs._dif.dif
- [ report.sml

<> Splitter
< ¥

Shew files of type: Filter for file type
A1l Files () o

| DifFiles |
Figure 130. The Diff Folders Dialog Box After a Diff

This section covers the following topics:
“Features’ on page 183
« “How to Diff Folders’ on page 184
« “How to Diff Documents from the Diff Folders Dialog Box” on page 186

Features
The Diff Folders dialog box has several features that make it easy to diff folders and the
XML documents they contain:

« A gsplitter letsyou change the width of the source and target folder windows. Thiscan
be especialy useful if you are working with afolder that has nested directories.

o Afiletypefilter limitsthe display to fileswith a .xm1 extension; if you choose, you
can display (and diff) all file types, as shownin Figure 130.

« An Abort button, shown here, appears at the bottom of the Diff Folders dialog box if
the operation you are performing (loading or diffing a directory with alarge number
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of files, for example) is taking more time than usual. Clicking the Abort button
cancels the operation.

Shaws files of type:

|Loading zource folders tree. .. Ahbort
Figure 131. Abort Button Lets You Cancel Long Load Operations

Tip Thisfeatureis aso part of the XML Diff Viewer.

« The Diff Files button allows you to perform a diff of XML documents in the source
and target folders. See “How to Diff Documents from the Diff Folders Dialog Box”
on page 186for more information on this topic.

How to Diff Folders

O To diff folders:

1. Select Tools > Show Differences In > Folders from the Stylus Studio menu.
The Diff Folders dialog box appears.

Diff Folders X
Source folder: Target folder.
| =1ji of
/
Choose Folder buttons
Show files of type:
ML Files (*.sml] v |
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2. Click the Choose Source Folder button (g).
The Select Source Folder dialog box appears.

Select Source Folder

Desktop Open |
8
My Camputer

“webDAY Server

FTP Server

3. Expand the Desktop tree and navigate to the folder you want to use as the source
folder for the diff.

4. Click Open.
Thefolder is displayed in the Source folder window of the Diff Folders dialog box.

5. Repeat Step 2 through Step 4 for the target folder.
Stylus Studio performs the diff as soon as you select the target folder for comparison.
6. Optionally, usethe Show files of type drop-down list to filter the display to show only

thosefiles of the type you specify. (By default, Stylus Studio shows XML files—files
with a .xm1 extension.)
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How to Diff Documents from the Diff Folders Dialog Box
You can diff XML documents in the source and target folders directly from the Diff
Folders dialog box.
0 To diff two files from the Diff Folders dialog box:

1. Click thefile you want to diff.

The document is shown as selected in both the Source folder and Target folder
windows. In thisillustration, the document authors_new.xm1 was selected.

Diff Folders

Source falder: Target folder:

|fi\e:./'x’c:\Program Files\Stylus Studich<MLdifF [ |Ii|e:z’x’c:\Deve\op><ML ([
=7 file:/ e Program Files/Stylus Studio/=L =[] file: e ADevelopstL
[ authors.dif 01 authors. dif

[ authors_mods.wmi

~ avthors_new.sml N
S [ authors_old.xml N [ authars_ld.sml
[ diff_source.xml & [] bookstare.did
Tip Noticethat, even though the file names are different, Stylus Studio isableto infer that

authors_new.xm1 and authors_mods.xm1 are actually the same document.

If you select a document that cannot be diffed, you will not see the selection in the
opposite window.

2. Click the Diff Files button.
Stylus Studio displays the XML Diff Viewer window.

For more information on diffing documents, see “ Diffing a Pair of XML Documents’ on
page 193.

The XML Diff Viewer

Thissection describesthe XML Diff Viewer and itsfeatures, including the different views
available for comparing documents, the XML Diff Viewer tool bar, and tools for loading

documents.

This section covers the following topics:
“Split View - Tree” on page 187
“Split View - Text” on page 188
“Merged View” on page 189

186 Stylus Studio® 2010 User Guide



Diffing Folders and XML Documents

“View Symbols and Colors’ on page 190
« “The XML Diff Viewer Tool Bar” on page 190
« “Toolsfor Working with Documents” on page 193

Split View - Tree

You use the XML Diff Viewer to compare two or more XML documents. By default, the
XML Diff Viewer displays the diffed documents on the Split View - Tree tab. This view,
shown in Figure 132, shows the documents side-by-side using a tree/node representation.

@ Stylus Studio XML Enterprise Edition - [authors.dff] =1
AP File Edit Wiew Project Debug XML Diff SourceControl Tools Window Help x
- Buttons for adding and
£2 a“‘h"“‘-d"| removing documents
ull | @ | file: fifc: jprogram files/zonicsoftwaresstylus studiofexamplesidiff_target > @.
= "g:a‘;t.rl'xoo‘:s Source = "g.a[:t.rl';a‘:s Target ~
'[: <unchanged: "[: <unchanged:>
=™ au_lname =-®T§ au_lname
oy Hennings . White
.'II= <unchanged:> "II= <unchanged:>
- =-™8 city "% <unchanged:
= Menlo Park =-®*® row
'II: <unchanged:> Split‘ter ] "II: <unchanged:>
=% row +* =-™§ city
" cunchanged:> Ll Oakland
"% <unchanged:> +* =% state
& Ci
+ =8 zip
£ 94618
& =-*® contract -
\ Split Wiew - Tree A Split Wiew - Text }‘ Merged View ./
Status bar
For Help, press F1 UM

Figure 132. XML Diff Viewer — Split View - Tree

Insplit views (thereisalso asplit view that shows documentsin XML), source documents
are displayed on the left, the target document on the right. A splitter between the two
panes allows you to change the width of the source and target document panes by
dragging the splitter to the left and right.

Stylus Studio® 2010 User Guide 187



Editing and Querying XML

Split View - Text

The Split View - Text tab also shows source and target documents side-by-sidein plain

XML.

Stylus Studio - [authors.dff]
_Ff'J File Edit “iew Project Debug XML Diff SourceControl Tools Window Help

_FPJ authors. dff |

!-|| o|<?|Ent|E|3

f.

E[%]wr
1l

<?xml version="1.0" encoding="UTF-8" A
<authors> ¥ |
= o
€au 1d=lTZ2-32-1176</au id=

<?xml wversion="1.0" encoding="UTF-2'~a
<authors> ¥ |
o
<au 1d»l72-32-1176</au id=

N <au_lname>Hennings</au lname! N, <au_lname>White</au lname> —
<au fname=Johnson</au fname> <au_ frname>Johnson</au frname:
<phone>408 496-722Z23</phone> <phone>408 496-72Z3</phonex
<address»10932 Bigge Rd.</ad <address»10932 Bigge Rd.</ac

Il “city»Menlo Park</ it
<state>CA</state> <state>CA</state>
<zipx94025</ zip> <zipx94025</ z1ip>
<contractrtrue</contracts <contractrtrued/contracts

</ o </ ow
L O r O
<au 1d=Z13-46-8915</au_ id= <au 1d>213-46-8915</ a0 1d>
[ (R R — [ [ S —
< | > < | >
;‘ Split View - Tree }\ Split iew - Text ‘/{ Merged Yiew /
For Help, press F1 UM

Figure 133. XML Diff Viewer — Split View - Text
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Merged View

If you prefer, you can select the Merged View tab, which folds the nodes from the source
and target documentsinto a single window, as shown in Figure 134.

EEX
B9 File Edit Wiew Project Debug XML Diff SourceControl Tools Window Help X

[ aulhors.dﬂ|

o |<?|Ent| £,

i @| file: fffc: jorogram files/zonicsoftwareistylus studiofexamplesidiff_tarm |@|

= ™5 authors \\

BmE oy Add and remove source files

Ll
'[: <unchanged:
=™ au_lname
- a=
"3 <unchanged:>
S t}:;nlu iy Red for removed items...

Yellow for changed items...

"1 <unchanged:>
=-® row
"3 <unchanged:>
B cicy And green for new items
Oakland
=-™8 state
cL

plit Wiew - Tree }\ Splitigw - Text }\ Merged View ./

w4 g g g

For Help, press F1

MM

Figure 134. XML Diff Viewer — Merged View

The merged view displays changed itemsin pairs — the item from the target document
appearsfirst, the item from the source document is shown second, as shown in Figure 135.

=™ authors
=-*® row
.'[: <unchanged’- .
o %® au lname |~ Item in target document

R White //

Heabhihos  ——|tem in source document

Figure 135. Close-up of Merged View

In this example, the line through the <au_1name> element in the source document,
Hennings, indicates that it has changed to white in the target document.
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View Symbols and Colors

All views use the same symbols and color schemes to identify the types of changes
detected by the Stylus Studio diff calculation — by default, green for added items, yellow
for changed items, and red for removed items. In addition, the text font and size are
controlled by the settings for the XML Editor on the Editor Format page of the Options
dialog box.

See “ Symbols and Background Colors” on page 181 for more information on thistopic,
and to learn how you can assign custom colors to the results of standard differencing
operations.

The XML Diff Viewer Tool Bar

The XML Diff Viewer tool bar, shown in Figure 136, provides toolsto help you

o Manually start the diff calculation

« Navigate source and target documents

« Change default display and diff settings

« Show or ignore differences in document items such as text nodes and attributes

FEl authors.dif |

y o B (8| 5| o [<?|ent]em| £

Figure 136. The XML Diff Tool Bar

-0 =0
= | Be

The following table identifies the individual tools and tells you where to find more
information.

Table 15. XML Diff Tool Bar Buttons

Tool Button Description

Calculatesthe differencesin the documents you have selected. Thisbuttonis
active only when Stylus Studio detects the need to calcul ate differences. This
button is disabled if you have selected On changes and If files modified
settings. See “Engine Settings’ on page 202.

Skips to the next (previous) diff in the currently selected document. You
must select aline in the document to enable these buttons.
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Table 15. XML Diff Tool Bar Buttons

Tool Button Description

By default, Stylus Studio displays collapsed documents when the diff isrun.
You can override this setting using the tool bar button, or you can change it
permanently on the Options. page. See “Engine Settings’ on page 202.

2l By default, Stylus Studio collapses any unchanged blocks to smplify the
display. You can override this setting using the tool bar button, or you can
change it permanently on the Options. page. See “Engine Settings’ on
page 202.

= By default, Stylus Studio uses URIsto compare namespaces when diffing
documents. You can override this setting using thetool bar button, or you can
change it permanently on the Options. page. See “Engine Settings’ on
page 202.

Note that changing this setting requires documents to be diffed again.

ol By default, Stylus Studio expands entity references when diffing documents.
You can override this setting using the tool bar button, or you can change it
permanently on the Options. page. See “Engine Settings’ on page 202.

Note that changing this setting requires documentsto be diffed again.

T By default, Stylus Studio considers text formatting characters (new lines,
carriage returns, tabs) when diffing documents. You can override this setting
using the tool bar button, or you can change it permanently on the Options.
page. See “Engine Settings’ on page 202.

I By default Stylus Studio shows differences in comments. You can override
this setting using the tool bar button, or you can changeit permanently onthe
Options. page. See “Engine Settings’ on page 202.

Note that this feature affects only the display, and not the cal culation, of
comment differences.

£ By default Stylus Studio shows differencesin text blocks. You can override
this setting using the tool bar button, or you can changeit permanently onthe
Options. page. See “Engine Settings’ on page 202.

Notethat thisfeature affects only the display, and not the calculation, of text
block differences.
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Table 15. XML Diff Tool Bar Buttons

Tool Button Description

¢ By default Stylus Studio shows differences in attributes. You can override
this setting using the tool bar button, or you can changeit permanently onthe
Options. page. See “Engine Settings’ on page 202.

Note that this feature affects only the display, and not the calculation, of
attribute differences.

=7 By default Stylus Studio shows differences in processing instructions. You
can override this setting using the tool bar button, or you can change it
permanently on the Options page. See “ Engine Settings’ on page 202.

Note that this feature affects only the display, and not the cal culation, of
processing instruction differences.

Ent By default Stylus Studio shows differencesin entities. You can override this
setting using the tool bar button, or you can change it permanently on the
Options page. See “Engine Settings’ on page 202.

Note that this feature affects only the display, and not the calculation, of
entity differences.

By default Stylus Studio shows differences in entity references. You can
override this setting using the tool bar button, or you can change it
permanently on the Options page. See “ Engine Settings’ on page 202.

Note that this feature affects only the display, and not the calculation, of
entity differences.

Allows you to change the font of documents displayed in the XML Diff
Viewer.
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Tools for Working with Documents

The XML Diff Viewer provides several tools for working with source and target
documents:

« Add/Remove document buttons. When you click the add or set document button,
Stylus Studio displays the Open diaog box. The add button for source documents
displaysagreen plussignonit () to alert you to the fact that you can add multiple
source documentswhen diffing XML documents. You can specify only asingletarget
document, however.

You use the remove button, the fol der with the red minus sign on it ([(=1]), to remove
the current source document from the XML diff calculation.

Tip If Stylus Studio determines that the load or diff operation for agiven XML document
will take more than amoment, it displays a message and an Abort button at the
bottom of the XML Diff Viewer window. You can click the Abort button to terminate
the operation at any time. The message and the button are removed from the XML
Diff Viewer window once the operation is complete or cancelled.

« Drop-down list. You use the drop-down list to change the current document in the
XML Diff Viewer. When you change the current doc in a multi-document diff, the
target document display — specifically, the symbols and colors used to identify
documents—typically changes, aswell. See“ Symbols Used in the Target Document
Window” on page 196 for more information.

Removing a Target Document

You cannot remove atarget document. You can specify a different target document by
clicking the set target button (|(=]) again. This replaces the current target document with
the document you select.

Diffing a Pair of XML Documents
This section describes how to use Stylus Studio to diff apair of XML documents.

Before continuing with this section, you should read “ Overview” on page 177, which
describes basi ¢ information about the Stylus Studio Diff tool, and “ The XML Diff
Viewer” on page 186, which describes features of the XML Diff Viewer and how to use
them.
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How to Diff a Pair of Documents

0 To diff a pair of documents:

Tip

1.

Select Tools > Options > Show Differences > Files from the Stylus Studio menu.
Stylus Studio displays the XML Diff Viewer.

In the source document window, click the add button () to add the source
document.

Stylus Studio displays the Open dialog box.

You can drag and drop afileinto the entry field to load the document in the XML Diff
Viewer.

Navigate to the document you want to load in the XML Diff Viewer.

Click Open.

Repeat Step 2 through Step 4 for the target document, using the set button for the
target document window ([)).

By default, Stylus Studio runs the diff calculation automatically when you select the
target document. If the default On changes setting has changed, you need to run the
diff calculation manually by clicking the Calculate diff button (| | ).
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Diffing Multiple Documents
This section describes how to use Stylus Studio to diff multiple XML documents.

Before continuing with this section, you should read “ Overview” on page 177, which
describes basi ¢ information about the Stylus Studio Diff tool, and “ The XML Diff
Viewer” on page 186, which describes features of the XML Diff Viewer and how to use
them.

This section covers the following topics:

“Document Focus’ on page 195
o “Symbols Used in the Target Document Window” on page 196

Document Focus

Diffing multiple XML documentsis much the same as diffing a pair of documents—you
specify the source documents (one at atime), atarget document, and Stylus Studio
calculates the diff.

Note When you diff multiple source documents against the target, Stylus Studio considersthe
target document to be the baseline, and the XML Diff Viewer shows how the source
documents vary from the target.
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When you diff multiple documents, however, only one source document can have focus
at atime. Consider the following illustration, which shows three source documents
(sourcel.xml, source2.xml, and source3.xm1) and atarget document (target.xm1).

(ﬂ

Figure 137. Example of Document Focus

In this example, the sourcel.xm1 document currently has focus. You set the focus on a
given source document by selecting that document from the drop-down list at the top of
the source document window.

When a source document has focus:

. Diffsaredisplayed for that document only, even if you have selected the Merged View
tab for display.

. Clicking the remove document button (|(=|) removes that document from the XML
diff calculation.

Symbols Used in the Target Document Window

When diffing multiple documents, Stylus Studio uses an additional set of symbolsin the
target document window. These symbols, which are displayed in the side bar of the XML
Diff Viewer window alongside the standard set of symbols described in “ Symbols and

Background Colors’ on page 181, indicate the ways in which the change identified in the
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current source document differs from changes to the same node in other source

documents.
Change relative file: ftfc: Program Files/Stylus StudioMMLdiftidiff_target xml @
to current target
and current source = .'[: authors Y

=- %" row

. + au id
Change in current source o

relative to other source =% au_lname
documents — '} =

+- au_fname

Figure 138. Example of Symbols Used When Diffing Multiple Documents

Asshown in Figure 138, symbolsin the column closest to the document tree identify the
changesrd ativeto the currently selected source. Here, the edit symbol () indicatesthat
the value in the target document, whi te, differs from that in the currently selected source
(which happens to be Black in this example).

Thefirst column of symbols characterize changesin the currently selected source relative
to other source documents. Here, for example, the red exclamation point ( 1) indicates
that there are conflicting modifications in other source documents — that is, other source
documents contain a value other than Black. As shown in Figure 139, when you click on
asymbol in the first column, Stylus Studio displays

« A message describing the precise nature of the change
« A menu that identifies the documents in which the change occurs.

file: fic: DevelopHMLIIF_target sxmi @

=T, authors -
=-®8 row
+ % au_id

+-®® address

Figure 139. Easily Navigate to Changed Nodes in Other Source Documents

Clicking on a document in this menu changes the current focus to that source document,
allowing you to easily navigate to the same node in a different document.
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The additional symbols used by Stylus Studio when diffing multiple documents are
described in Table 16.

Table 16. Symbols Used to Specify Changes in Source Documents

Symbol

Description

Meaning

A

Yellow circle

Modified in other documents — The abject in the target and
the current source document are the same, but another source
document is different.

Red exclamation
point

Conflicting modification in other documents—The object in
the current source differs from that in the target document.
Other source documents differ from both the current source
and target.

Yellow diamond

Same modification in other documents — The source
documents all differ from the target document in the same
way.

L1

Yellow equal sign

Unchanged in other documents — The current source
document differsfrom thetarget, but other source documents
are the same as the target.

Consider the example in Figure 140, which illustrates diffing three documents. In this
example, the node in question is circled in red.

Figure 140. Diffing Three Documents
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Notice that:

o sourcel.xml currently hasfocus.
« sourcel.xml and the target document node have the same value (<abc>)
« Thenodein question variesin both of the remaining source documents (it is<abc> in

one and <abc> in the other).

Table 17 shows the symbols that might appear based on changing valuesto the node in
guestion. The exampleillustrated in Figure 140 is shown in the first row. Asvaluesin the
source documents change, Stylus Studio changes the diff symbol accordingly.

Table 17. Symbols Used to Specify Changes in Source Documents

Symbol target.xml sourcel.xml source2.xml source3.xml
A <abc> <abc> <Xyz> <123>
! <abc> <Xyz> <jk1> <mno>
P <abc> <Xyz> <Xyz> <Xyz>
— <abc> <Xyz> <abc> <abc>

Note Changingthetarget-sourcepairing, that is, changing the current source document, affects

the symbols that are displayed.

How to Diff Multiple Documents

0 To diff multiple documents:

Tip

1. Select Tools > Options > Show Differences > Files from the Stylus Studio menu.
Stylus Studio displays the XML Diff Viewer.

2. Inthe source document window, click the add button () to add the first source
document.

Stylus Studio displays the Open diaog box.

You can drag and drop afileinto the entry field to load the document in the XML Diff
Viewer.

3. Navigate to the document you want to load in the XML Diff Viewer.
4. Click Open.
5. Repeat Step 2 through Step 4 for additional source documents.
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6. Repeat Step 2 through Step 4 for the target document, using the set button for the
target document window (|C1).
By default, Stylus Studio runs the diff calculation automatically when you select the
target document. If the default On changes setting has changed, you need to run the
diff calculation manually by clicking the Calculate diff button (| J= ).

Modifying Default Diff Settings

Default settings for the behavior of the Diff engine and the appearance of diffed
documents and folders are on the Engine and Presentation pages, respectively, of the
Options dialog box. The Engine page, shown here, has settings that determine the
conditions under which Stylus Studio runs the diff automatically, which itemsin a
document (comments and text, for example) you want the diff engine to ignore, and
settings that allow you to choose diffing algorithm tunings optimized for change
description or time, for example.

Options

B ack-mapping
Spell Checking
File Types
Java Virtual Maching
Custom Tools
Custom File Systems
Customn Document Wizards
Customn Validation Engines
Custom <ML Converters
i3 Module Settings
£ DBtoxML
Default Connection
3 Java
Debugger
(£33 %ML Diff
N
Presentation
£ %ML Editor
#ML Settings
3 %ML Schema E ditar
Diagram
ML Schema to XML
Documertation

-

by o

General
Autorun diff
[ Automatically expand al diffs On changes
Collapse unchanged blacks [11f fles madified
Engine Options
Uze URI to compare namespaces [ lgnore text farmatting characters
Expand entity references
Show differences in
Comments Attributes
Text Processing instructions
Entities Entitiy References
Perfarmance
(¥) Autodetect () Optimize change description () Dptimize calculation time
[ Optimize: for large documents with few changes

Figure 141. Engine Options Page for XML Diff
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Settings on the Engine page are reflected in the Diff editor tool bar, and in the XML Diff
menu, shown here.

il Stylus Studio - [authors.dff]

6 G ; 3 : "
F? File Edit VWiew Project Debug KML,PIFF SourceContral Tools Window Help

0= W) Add source document &

Remove source document
L] aulhors.d[[| Set target docurment
CAEIESESIal
| file: fifc: forocram filesfzonicsoftwareistylus igram filesfzoniceoftwareistylus studicexamplesidiftf_target xml |@|
=-®% authors [ Expand &l Differences authors =
=8 row [t} collapse identical blocks " row

"3 <unchanged:>

| "% <unchanged:
- au_lname

o Use LRI to
se L compare namespaceslk 5% au_lnewe

Expand Entity References

s Jefferson ) White
=2 cunchanged> TT Ignore text for matting "= cunchanged>
=-®8 row [1=] compare comments "3 row
"3 <unchanged:> Corpare Text "3 <unchanged:>
" <unchanged> Iz‘ Cornpare Attributes &M city
Cormpare Processing Instructions e Sl
state
i Compare Entities
T ci
=8 zip
* 94615 v
\ Split View {i Merged View /'
Instructs XML diff engine to use URIs to compare narmespaces. MU

Figure 142. XML Diff Menu

Tip YoucanoverrideEngine page settings using the Diff editor tool bar or the XML Diff menu.
Overrides do not change the settings on the Engine page.

This section covers the following topics:
“Opening the Options Dialog Box” on page 201
“Engine Settings” on page 202
“Presentation Options’ on page 204

Opening the Options Dialog Box

0 To open the Options dialog box:

1. Click Tools > Options on the Stylus Studio menu.
The Options dialog box appears.

2. If necessary, expand the tree for Module Settings > XML Diff.
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3.
4.

Click the page that contains the settings you want to modify.

To save achanged setting, click OK. Click Cancel to revert to closethe dial og box and
revert to the previous settings.

Engine Settings

This section describes the settings that affect the behavior and performance of the Diff
engine.

General

Thefieldsin the General group box affect the initial display of diffed documents and the
conditions, if any, under which Stylus Studio runs the diff automatically.

Automatically expand all diffs — By default, Stylus Studio collapsesthe display of the
diffed documents. If you select this option, all nodes containing diffs are expanded
when the diff is run.

Collapse unchanged blocks — By default, Stylus Studio collapses any block that does
not contain any changesto save spacein the XML Diff Viewer window. These blocks
aredisplayed as <unchangeds> in the document tree. You might prefer to havetheentire
document structure visible, to provide context for changed nodes, for example.

Autorun diff — By default, Stylus Studio runs the diff operation if you make a change
to one of the settings on the Engine page of the Options dialog box. You can also
specify that Stylus Studio run the diff operation when the source or target documents
change. If you select If files modified, Stylus Studio runsthe diff operation when you
saveasourceor target file. If neither of these optionsis selected, you must run the diff
manually. See “When Doesthe Diff Run?’ on page 180 for more information on this
topic.

Engine Options

Thefieldsin the Engine Options group box affect how Stylus Studio diffs source and
target documents.

Use URI to compare namespaces — Controls whether or not URIs are used to
compare namespaces in source and target documents.

Expand entity references — Controls whether or not entity references, whichin some
cases can includefiles external to the source or target document, are expanded by the
Stylus Studio diff engine for purposes of comparing one block with another.
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« Ignore text formatting characters — Controls whether or not text formatting
characters (new line, carriage return, and tab) are ignored when comparing source and
target documents. This option is off by default.

« Show differences in — Provides granular control of what itemsin XML documents
are diffed. There are separate settings for comments, text, entities, attributes, and
processing instructions.

Performance

Diffing large, numerous, or complex documents can be time-consuming. Stylus Studio
provides controls that let you choose agorithm tunings that have been optimized for
change description or calculation time.

o Autodetect — Stylus Studio determines which algorithm tuning to use based on the
number, content, complexity, and size of the source and target documents. Stylus
Studio first tries to use the tuning that is optimized for change description; if it
determines that processing resources are limited, it reverts to the algorithm tuning
optimized for speed. This setting is on by defauilt.

« Optimize change description — Provides the most economical set of changes
possible. This calculation, though it yields the best results, can be costly in terms of
time and processing resources.

« Optimize calculation time — Provides the set of changesin the shortest time possible.

« Optimize for large documents with few changes — Helps speed the diffing of large
(greater than IMB) documents by folding similar blocks before comparing nodes.
This setting can be used in conjunction with any of the algorithm tuning settings and
ison by default.

Tip The default setting, Autodetect and Optimize for large documents with few changes,
yields the best results when time and processing resources are not considerations.
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Presentation Options

Presentation options allow you to modify the settings for the background colors Stylus
Studio uses to identify the types of changes detected in diffed documents and folders

Options ['S_<|

Back-mapping ,\ Added items
Spell Checking |
File Types
Java Virtual Maching
Custom Tools Removed items
Custom File Systems
Customn Document Wizards
Customn Validation Engines
Custom <ML Converters Changed items
I3 Module Settings
5 DBtoxmL Background colaor:
Default Connection
£ Java
Debugger
55 =ML Dift Background colar:
Engine

Background colar:

Background colar:

Collapzed items with changes

i 3 3 3

&
£ %ML Editor
#ML Settings
[ %ML Schema E ditor
Diagram
ML Schema to XML

Figure 143. You Can Change Colors Used to Identify Document Changes

You can change the background colors for the following:
o Addeditems

« Removeditems (that is, items that are present in the target, but are not present in the
source, for example)

« Changed items (the same element or attribute, but a different name, for example)
« Collapsed items with changes

Running the Diff Tool from the Command Line

In addition to using the Diff tool from the Stylus Studio user interface, Stylus Studio also
provides acommandl line utility, StylusDiff.exe. This command line utility allows you
to perform many of the same functions, and to use many of the same options, as the
graphical Diff toal.
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Restrictions

The following restrictions exist for using StylusDiff.exe:
« You cannot use StyTlusDiff.exe to diff folders
o StylusDiff.exe can diff only one pair of documents at atime

Usage

The stylusDi ff.exe utility has the following usage:

StylusDiff -source <sourceURI> -target <targetURI>
[-expandPrefixes/collapsePrefixes] [-expandERs/colTlapseERs]
[-comments/nocomments] [-attributes/noattributes] [-text/notext] [-pi/nopi]
[-er/noer] [-entities/noentities] [-formatting/noformatting] [-fold/nofold]

[-auto/best/fast]

Table 18 describes the usage for the Sty1usDiff command. For a complete description of
these and other options that affect the XML Diff engine, see “Engine Settings’ on

page 202.

Table 18. StylusDiff Command Line Parameters

Parameter

Description

-source <sourceURI>

The path of the XML document you want to use as the source
document in the diff. Required.

-target <targetURI>

The path of the XML document you want to use as the target
document in the diff. Required.

-output <outputURI>

Saves the differences between the source and target files, if
any, to the file you specify. Output files are saved with a . dff
extension. Optional.

-expandPrefixes Whether you want the XML Diff engine to use the URI

-collapsePrefixes (-expandPrefixes) or ignore the URI (-collapsePrefixes)
when comparing namespaces. The default is
-collapsePrefixes.

-expandERs Whether you want the XML Diff engine to compare entity

-collapseERs

references (-collapseERs) or values referenced by entity
references (-expandERs). The default is -expandERs.
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Table 18. StylusDiff Command Line Parameters

Parameter Description
-comments Whether you want the XML Diff engineto compare comments
-noComments

(-commments) or to ignore comments (-noComments). The
default is -comments.

-attributes

Whether you want the XML Diff engine to compare attributes

-noAttributes (-attributes) or to ignore attributes (-noAttributes). The
default is -attributes.

-text Whether you want the XML Diff engine to compare text

-noText (-text) or to ignore text (-noText). The default is -text.

-pi Whether you want the XML Diff engine to compare

~noPI processing instructions (-p1) or to ignore processing
instructions (-noPI). The default is -pi.

-er Whether you want the XML Diff engine to compare entity

~noER references (-er) or to ignore entity references (-nokR). The
default is -er.

-entities Whether you want the XML Diff engine to compare entities

-noEntities

(-entities) or to ignore entities (-noEntities). The default
is-entities.

-formatting
-noFormatting

Whether youwant the XML Diff engineto compareformatting
characters (-formatting) or to ignore formatting characters
(-noFormatting) when comparing text nodes. The default is
-formatting.

-fold Whether you want the XML Diff engineto fold similar blocks

-nofFold before diffing (-foldunchangedBlocks) or to expand and diff
nodes (-diffunchangedBlocks). The default is
-foldUnchangedBTocks.

-auto Controlsthat let you choose between diffing algorithm tunings

:?:i that have been optimized for time (-fast) and thoroughness (-

best). A third choice, -auto, lets Stylus Studio determine
which tuning to use. The default is -auto.
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Using Schemas with XML Documents

Stylus Studio allows you to associate one or more schemas with each XML document. A
schema can beaDTD or an XML Schema.

There are several ways to associate a schema with an XML document:

To associate an external schema with a document, ensure that an XML document is
active. Then, from the Stylus Studio menu bar, select XML > Associate XML with
Schema.

To define an internal DTD, specify itinthe XML editor Text tab or Schema tab.
To have Stylus Studio generate aschema, in the XML editor, click the Schema tab. If
the XML document has some contents, Stylus Studio promptsyou to indicate whether

you want Stylus Studio to generate a schema from the contents. See “Having Stylus
Studio Generate a Schema” on page 208.

This section discusses the following topics:

“Associating an External Schema With a Document” on page 207

“Having Stylus Studio Generate a Schema” on page 208

“Validating XML Documents’ on page 208

“Updating a Document’s Schema” on page 209

“Removing the Association Between a Document and a Schema” on page 209

Associating an External Schema With a Document

0 To associate an external schema with an XML document:

1.

4.

Open the XML document you want to associate with a schema. See “Opening Files
in Stylus Studio” on page 92.

From the Stylus Studio menu bar, select XML > Associate XML with Schema.

In the Open dialog box that appears, navigate to and select the schema you want to
associate.

Click Open. The selected schema is now associated with the document.

To associate an XML document with an XML Schema, the XML document must contain
aroot e ement.
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After you associate a schema with a document, you can view atree representation of the
schemain the XML editor window. Click the Schema tab. See “Updating a Document’s
Schema” on page 2009.

Having Stylus Studio Generate a Schema

Inthe XML editor, you can click the Schema tab to view the schema for your document.
If your document does not specify a schema, Stylus Studio displays the Schema Not
Found dialog box. This dialog box prompts you to indicate whether you want Stylus
Studio to create a schema for your document based on its contents.

You can select Generate XML Schema or Generate DTD. If you select Generate XML
Schema, you must specify an absolute path for the file that contains the new schema.

If you select Generate DTD, you must indicate whether you want the DTD to be internal
or external. If itisinternal, Stylus Studio insertsitimmediately after the XML declaration.
If it isexternal, you must specify or select an absolute path for the file that contains the
new DTD.

After you click OK, Stylus Studio displays the new schemain the Schema tab.

Validating XML Documents

Note

At any time, you can validate your XML document against its schema. Click Validate
Document in the window of the document you want to validate.

Stylus Studio displays a message that indicates whether or not your document isvalid. If
your document does not conform to its schema, Stylus Studio displays alist of error
messages that describe the inconsistencies. Thislist includes line and column numbers
that indicate thelocation of the error. When you click inan XML document, Stylus Studio
showstheline and column number in the bottom right corner of the Stylus Studio window.

When Stylus Studio validates a document, it also checks for well-formedness.

Stylus Studio uses font color to indicate valid and invalid element names. Purple fonts
indicate valid elements. Orange fonts indicate el ements that are not in the schema.

Stylus Studio uses Apache's Xerces XML Parser to validate XML documents. Error
messages about invalid documents are generated by the Xerces XML Parser. Stylus
Studio has no control over the contents of these messages. If you have trouble
understanding such a message, try searching the W3C XML Schema Recommendation
for the main phrase in the error message.
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Updating a Document’'s Schema

How you update your document’s schema depends on whether the schemaisinternal or
external. If the schemaisan internal DTD, you can update it in the Schema tab of the
XML editor.

If the schemaisnot aninternal DTD, you can updateit only inthe DTD editor or the XML
Schema editor. You can, however, view the schemain the Schema tab of the XML editor.

When Stylus Studio displays the schemafor your document, you can also view the
properties for each node in the schema. If the Properties window isnot already in view,
select View > Properties. Click on any node in the schema view to see the properties for
that node.

To view the text of an externa schema or to edit an external schema, you must display it
inthe DTD editor or the XML Schema editor. To do this, select XML > Open Associated
Schema from the Stylus Studio menu bar, or click Open Schema &%, inthe Stylus Studio
tool bar.

Instructions for updating aDTD arein “Defining Document Type Definitions’ on

page 665. Instructions for updating an XML Schemaarein “Creating an XML Schemain
Stylus Studio” on page 568. If you update a schema in Stylus Studio and that schemais
associated with an XML document that is open in Stylus Studio, Stylus Studio refreshes
the schema information for the open XML document.

Removing the Association Between a Document and a Schema

To remove the associ ation between adocument and an external schema, you must edit the
XML document in the Text or Tree tab. Remove the text or nodesthat specify the external
schema.

To remove an internal DTD from a document, delete the text or nodes that specify the
internal DTD.
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Converting XML to Its Canonical Form

By default, Stylus Studio creates XML that conforms to the W3C XML 1.0
recommendation. You can also convert any XML document to its canonical form. When
you convert XML to its canonical form, the resulting document conforms to the W3C
Canonical XML 1.0 recommendation.

Tip Although you can undo conversion to canonical form, consider using Save As to create
acopy of the XML document prior to conversion.

0 To convert an XML document to its canonical form:
1. Openthe XML document you want to convert to canonical XML.

2. Select Edit > Make Canonical XML from the Stylus Studio menu.
Alternative: Click the Make Canonical XML button ([4]) on the tool bar.
The XML document is converted to its canonical form.

You can undo this operation (Edit > Undo) if necessary.

Querying XML Documents Using XPath

You can usethe XML Path Language (X Path) to query XML documentsto obtain asubset
of theinformation in that document. You can also query XML Schemaand XSLT,
provided you open the XSLT using the XML Editor. (You cannot query DTD schema
becauseit isnot XML.)

In Stylus Studio, you query XML documents using the X Path Query Editor. To learn more
about X Path and how to use the X Path Query Editor, see“Writing X Path Expressions’ on
page 691.

Printing XML Documents

You can print the raw XML text view of your document. You cannot print the other views
of your document.

0 To print a document:
1. Inyour XML document, click the Text tab.
2. Inthe Stylus Studio tool bar, click Print or press Ctrl+P.
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0 To preview your document before you print it, select File > Print Preview from the
Stylus Studio menu bar.

0 To specify print options for your document before you print it, select File > Print
Setup from the Stylus Studio menu bar.

Saving XML Documents

When you save adocument, Stylus Studio savesit in the encoding that is specified in the
initial XML processing instruction.

0 To save an XML document:
1. Ensure that the window that contains your XML document is the active window.

2. From the Stylus Studio menu bar, select File > Save.
Alternatives. Press Ctrl+Sor click Save in the Stylus Studio tool bar.

Options for Saving Documents

TheApplication Settings page of the Options dialog box contains two optionsthat affect
when and how documents are saved in Stylus Studio. You can choose to have Stylus
Studio

« Save modified documents every few minutes. This option is off by default, and has a
default setting of 10 minutes.

« Create abackup copy of adocument wheniit is saved.

More About Backup Files

Backup copies are created with a* .bak extension appended to the original document
name when saved to the Stylus Studio file system. For example, the backup copy of
books .xm1 would be books .xm1.bak. If you are saving to an external file system (such as
Raining Data® TigerLogic® XDMS), the file system manages the backup file name.

Backup files are written to the same file system as the original document. They are not

displayed in the Project window, and they appear in the File Explorer window only if you
change the filter to display * .bak files.
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Opening a Backup File
You can open a backup file

« FromtheFile Explorer window, by double-clicking the file name or selecting Open
or Open With from the file's shortcut menu, for example

« From the Project window, by selecting the file and then selecting either
0 Open Latest Backup from thefile's shortcut menu (right-click to display), or
0 Project > Open Document’s Latest Backup from the Stylus Studio menu
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{f"ﬁ DataDirect XML Converters™ and custom XML conversions are available only
in Stylus Studio XML Enterprise Suite.

Stylus Studio uses DataDirect XML Converters™ to convert incoming streams of data
from native formats to outgoing streams of XML, and vice-versa. XML Converters™
support standard file formats, including EDI, CSV, binary, and many others. XML
Converters al so support the conversion of custom or proprietary formats that you specify
using a custom XML conversion definition.

This chapter describes how to use DataDirect XML Converters to convert standard and
proprietary filesto XML in Stylus Studio, how to create your own custom XML
conversion definitions, and how to use files you convert on-the-fly elsewherein Stylus
Studio —as asource for XQuery and XSLT design, for example.

Watch it! You can view a video demonstration of this feature by clicking the
television icon or by clicking this link: watch the Introduction to the Custom XML
Conversions module video.

You can read about other video demonstrationsfor the custom XML conversion definition
module here: http://www.stylusstudio.com/Tearn_convert_to_xml.html#converttoxml.

A complete list of al the videos demonstrating Stylus Studio’s featuresis here:
http://www.stylusstudio.com/xml_videos.html.
This chapter covers the following topics:
“Introduction” on page 214
o “Custom XML Conversions’ on page 221
« “Creating a Custom XML Conversion Definition” on page 222
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o “The Custom XML Conversion Definition Editor” on page 225

« “Partsof an Input File” on page 236

« “Working with Regions’ on page 238

o “Working with Fields” on page 247

« “Controlling XML Output” on page 255

o “Using Custom XML Conversion Definitionsin Stylus Studio” on page 266
o “The Converter URI Scheme” on page 269

« “Working with EDI Conversions’ on page 276

« “Custom XML Conversion Definitions Properties Reference” on page 280

Introduction

DataDirect XML Converters are high-performance Javaand .NET components that
provide bi-directional, programmatic accessto virtually any non-XML fileincluding EDI,
flat files, and other legacy and proprietary formats. DataDirect XML Converters allow
developers to seamlessly stream any non-XML data as XML to industry-leading XML
processing components or to any application. They support StAX, SAX, XmlReader,
XmlWriter, DOM and I/O streaming interfaces, and can be embedded directly for
tranglation purposes, or as part of achain of programsincluding XSLT and XQuery, or
even inside XML pipelines. DataDirect XML Converters maximize developer
productivity and provide afast, scalable solution for converting between EDI and other
legacy formats and XML.

How XML Converters are Used in Stylus Studio

The DataDirect XML Converters conversion engine is used throughout Stylus Studio to

convert non-XML filesto XML and vice-versa. You can access DataDirect XML

Converters:

« When you open and save files

o Inthe EDI to XML module (see Chapter 4 “ Converting EDI to XML"” for more
information on this module)

o As XML pipeline ConvertToXML and ConvertFromXML nodes (see Chapter 14
“Building XML Pipelines’ for more information)

« Using the converter:URI scheme
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Example

When you open or save afile in Stylus Studio, you have the option of converting that file
to or from XML using DataDirect XML Converters, as shown in the following

illustration:
Open @g|
'\@ Look i | (] testing iy 1 =g FE”E” E:
My Eio-mjputer E] autormap_command. bt @ bikes_fied_ansi tat i
E bar.jpg E] bikes fiwed_new_line.tst E]
@ R barmjpg [Z] bikes_fixed_nao_end_space.tst
W_E.[TQV batch. sl @ bikes_fiwed_wariable_row.txt
= e batch.xsd @ bikes_header_fixed.txt
Eg@ [Z] bikes.tst [Z] bikes_region.tst
— E] bikes_comma.txt @ bikes_space.tut
Secure WebDAY [Z] bikes_component.txt [Z] bikes_tab.tat =
@ [Z] bikes_components. et [Z] bikes_toss.tat &
& [Z] bikes_delimited tat books. small.xml £
[ErfF r% bikes_fixed.tat baoks. small. xml.bak ,Q]
ral < >
|| 2 :
TigerLIUEi'c':'XDMS URL: bikes_region. bt
% Files of tvpe: | Al Fles (7]
Froject Files pen uzing #ML Converter g >

Figure 144. Open Using XML Converters Check Box

In the Open dialog box and elsewhere in Stylus Studio, you can choose an XML
Converter for a

« Specificfileformat (likeEDI, CSV, dBase, or RTF, for example). See*“ Typesof XML

Converters’ on page 216 for a complete list of standard files supported by the XML
Converters.

« Custom file definition created using the Stylus Studio Custom XML Conversion
Definition Editor. You can create custom XML conversion definitions to handle

proprietary file formats or extensions to formats already supported by DataDirect
XML Converters™.

XML Converters Run-Time Components

DataDirect XML Converters are also available as a standal one run-time component on
both Java™ and .NET platforms. DataDirect XML Converters are bundled with Stylus
Studio 2010 XML Enterprise Suite.

This chapter describes how to use DataDirect XML Convertersin Stylus Studio. Tolearn
about the DataDirect XML Converters standalone componentsfor Javaand .NET, seethe
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DataDirect XML Converters documentation at
http://www.datadirect.com/techres/xmlconvertersproddoc/index.ssp.

Other Ways to Convert Files to XML

In addition to using XML Converters, you can convert filesto XML using Stylus Studio
document wizards — Stylus Studio document wizards help you convert XML Schema,
DTD, and HTML to XML. See“Using Document Wizardsto Create XML" on page 139
for more information.

Types of XML Converters

DataDirect XML Converters support numerous file formats, as shown in the following
table.

Table 19. Types of Files Handled by XML Converters

File Type Description

Base-64 Converts any file, text or binary (such asan image), into a
XML document with asingle element containing the Base-64
encoded content of the input file.

Binary Similar to the Base-64 XML Converter, except with
hexadecimal output. Other options allow output in other
bases, such as decimal or octal or even binary.

Comma-separated Converter for comma-separated values (CSV) files. Supports
value (CSV) multiple encodings and options to tune the quote and escape
characters. Supports delimiters besides commas.

Custom Custom or proprietary file formats described using a Stylus
Studio custom XML conversion definition.

dBase Support for dBase 1, I11, 11+, IV, and V formats.

Data Interchange Data Interchange Format (DIF) is a spreadsheet-based file

Format (DIF) format. There are also XML Convertersfor SDI and SY LK.

DotD Support for Progress Software's OpenEdge text dump file
format.
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Table 19. Types of Files Handled by XML Converters

File Type Description

EDI Automatically detects and parses ATIS, Cargo-IMP,
EANCOM, EDIFACT, Edig@s, HIPAA, HL7, NCPDP,
PADIS, TRADACOMS, and X12 EDI message types, with
options for custom message types and message extensions to
cover proprietary EDI-based formats.

JavaProps Support for Java .properties file format, which are used for
program configuration, translation, and data storage.

JSON Uses the algorithms on the JSON.org website to read from
XML and write to JISON (JavaScript Object Notation), and
vice-versa

Line Readsin text one line at atime, wrapping an element around
each line and escaping any embedded & or > or < symbols.

Pyx Support for this line-oriented notation for expressing tree-
oriented data.

RTF Convertsrich-text format (RTF) into XML, and vice versa.

SDI Super DataInterchange (SDI) is another popular spreadsheet-
based fileformat. Therearealso XML Convertersfor DIF and
SYLK.

SYLK SYLK (Symbolic Link) isanother popular spreadsheet-based
file format. There are also XML Convertersfor DIF and SDI.

TAB Tab-separated values format commonly associated with MS
Excel spreadshests.

Winlni Converter for Windows .ini configuration files.

WinWrite Converter for Microsoft WinWrite files; renders XHTML.
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XML Converters Can Be Configured

Each of the DataDirect XML Converters has numerous properties that allow you to
configure the converter to suit your needs, like those for the EDI XML Converters shown
here:

Select XML Converter E|

Hi| BaseBd encoding of a binary file a: A Property Walue
k] Comma-Separated Values [C5Y) Line g#Baratar crlf
EH] Custom ML Conversion oding utfg
:a Drata Interchange Format [DIF) wtension map file

] dBase |l [dBase_ll] Enabile validation yes

| dBase Il [dBase_lll) Comment code list data pes

| dBase lll+ [dBase_lll_plus) Comment element types pes

| dBase [V [dB ase_IV] Strict validation on value leng... | no

| dBaseV (dBase V) Strict segment-ordering chec... | yes
L= o Tt orce error if walue notin cad... | pes

datatype content chec...

lectranic Data Interchange [EDI)

»
5

Add linefeeds between seqmm.

URL: ‘ converter: ED| Hile:/ v \estinghbikes_region. txt

[ 0K ] [ Cancel ]

Figure 145. Select XML Converter Dialog Box

Some XML Converters, for example, let you specify the line separator character, escape
character, root element name, and other aspects of the output format.

See Chapter 4, XML Converters™ Properties, in the DataDirect XML Converters™

User’s Guide and Reference for more information. Documentation for DataDirect XML

Converters™ isavailable:

o Inthe\doc folder for DataDirect XML Converters where you installed Stylus Studio
—\components\XML Converters for .NET\doc, for example

e« OntheDataDirect XML Converters™ web site:
http://www.datadirect.com/techres/xmlconvertersproddoc/index.ssp
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Using XML Converters to Open a Non-XML File as XML

0 To open anon-XML file as XML using XML Converters:

1.

Select File > Open from the Stylus Studio menu.
Stylus Studio displays the Open diaog box.

Navigate the file system that contains the file you want to open as XML. If necessary,
change the value in the Files of type field to filter the files that are displayed.

Select the Open using XML Converters check box.

'\@ Look in: |Dtesting V| 1 =g FE”E”

My Eio-mjputer E] autormap_command. bt @ bikes_fied_ansi tat m
E bar.jpg E] bikes fiwed_new_line.tst E]

@ R barmjpg [Z] bikes_fixed_nao_end_space.tst
W_E.[TQV batch. sl @ bikes_fiwed_wariable_row.txt

= s batch.xed @ bikes_header_fixed.txt
Eg@ [Z] bikes.tst [Z] bikes_region.tst
— E] bikes_comma.txt @ bikes_space.tut
Secure WebDAY [Z] bikes_component.txt [Z] bikes_tab.tat -j
@ [Z] bikes_components. et [Z] bikes_toss.tat &
L E] bikes_delimited et books. small =ml @

r% bikes_fixed.tat baoks. small. xml.bak @]

i kS
TigerLogic XDMS  JRL: |b|kes_reg|0n.txt ‘ [ Open: i]
% Files of type: [l Files 7] v [ cancel |

Froject Files pen uzing #ML Converter g >

Figure 146. Open Using XML C_onverters Check Box

Click the Open button.
Stylus Studio displays the Select XML Converter dialog box. (See Figure 145.)

Select the XML Converters you want to use to convert your non-XML fileto XML.

Optionally, change the default values of the conversion properties to be used when
converting your file. See Chapter 4, XML Converters™ Properties, in the DataDirect
XML Converters™ User’s Guide and Reference if you need help with this step:
http://www.datadirect.com/techres/xmlconvertersproddoc/index.ssp.

Click OK.

Stylus Studio converts the file you specified in step 2 to XML using the DataDirect
XML Convertersyou selected in step 5. Thefileis displayed in anew instance of the
XML Editor.
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Saving an XML File in Another Format

Most DataDirect XML Converters are bi-directional —you can use them to convert native
fileformatsto XML, and vice versa. (Custom XML conversions you define using the
Stylus Studio Custom XML Conversion Definition Editor convert proprietary filesto
XML only.) In order to save an XML file in another format, however, the XML file you
are saving needs to have an XML Schema consistent with that expected by the XML
Converters. There are a number of waysto achieve thisin Stylus Studio:

« Saveback apreviously converted file. Imagine using the CSV XML Convertersto
convert bikes. txt t0 bikes.xml1. You could modify the datain bikes.xm1 and save it
back using the CSV XML Converters. Stylus Studio could savethe XML fileas CSV
as long as you made no changes to the document structure (adding no new € ements
or attributes, for example).

« UseaDocument Wizard to createan XML Schemafrom an EDI messagetype (ATIS,
Cargo-IMP, EANCOM, EDIFACT, Edig@s, HIPAA, HL7, NCPDP, PADIS,
TRADACOMS, or X12, for example), and use that XML Schema as the target
document in an XQuery or XSLT mapping. The XML document resulting from the
XQuery or XSLT transformation based on that XML Schema would conform to the
XML Schema expected by the EDI XML Converters.

For more information on Document Wizards, see “Using Document Wizardsto
Create XML" on page 139. For more information about working with EDI files as
XML, see “Working with EDI Conversions’ on page 276.
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Custom XML Conversions

In Stylus Studio, you can create a custom XML conversion definition that allows the
DataDirect XML Converters™ engine to convert proprietary files and extensionsto
standard formatsto XML.

You create a custom XML conversion definition by selecting an input file and then using
the Custom XML Conversion Definition Editor, shown in Figure 147, to specify the
properties you want to use to convert that file— and other filesthat share the same format.

4 Stylus Studio - [Untitled3.cony *] CEX
;"‘m Eile Edit ¥iew Project Debug CornwertToxML SourceContral Tools Window Help x
1 a e
HIEAE ™ 09w 0 =
F ] T
* E 1
prete Properties window L x| ;
== Input File Heotfburftestin,., o~ | = Untitled...
=] Input Encoding windows-1252 3 ] = [ee| — |[ex
= [2 WML Dutput URL > & i = (58] = |[EE[=] ]
[Z» Output Encoding > ficld Document pane ~ | |- oot
2> Root Element Name oat vl Eike Inventory Overview 2004- £ (Region1)
[=» Mamespace Prefix ) oo - ® raw
[ Namespace vIPAE uropean; . R i
[2» DOCTYPE Syster ID viEERake Model Year Mile R fickd
[® DOCTYPE Publc ID g 4 R1150RS | 2004 1427 "= field
[=» %ML Schema Document vEDucati 5TZ 19977 240C
[5 XML Schema Namespace vREJictoGuzzi LeMans 2001 1235
7 =
,__\E%’!”de{“xw' e % 7 e R1150R | =002 1743
=B eqion Tppe Ine-orente f Schema pane
Riegion Element Name v DucgtJl_ Mongter | 2000 156E
Elemert Mame 5 ource Uszer-Supplied v Oﬁ)rllla Futura 2001 173z
Rows to Skip a (%410 598 T
Ot from Output false vilBlTapanese |
IgineTetrm\nator EH'LF 41 2 ILENE Mode 1 Tear Mile,
5 Separator : p__ = PN K P P PP B PR Y P pm Py
Dielimiter Pairs < > B
Eomment String |1 Bike Inventory Dverview 2004-10-01 03
For Help, press F1 Row 1 Col 1 Char 35 (0x0023) UM

Figure 147. Custom XML Conversion Definition Editor

The Custom XML Conversion Definition Editor displaysinformation read from the input
file, aswell anumber of other propertiesyou can specify (such aswhether or not you want
element names based on the file'sfirst row, for example) that are used when thefileis
converted from its native format to XML.
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When to Create a Custom XML Conversion Definition

Consider creating a custom XML conversion definition any time

« You need to convert afile that does not conform to one of the standard file types
already supported by DataDirect XML Converters

« You want to exercise more control over the XML that is output by the conversion

Converting Non-Conforming EDI

The Custom XML Conversion Definition Editor lets you create custom conversion
definitions for many file types, including EDI. You can learn more about using the
Custom XML Conversion Definition Editor to convert custom EDI formats here:
“Working with EDI Conversions’ on page 276.

However, Stylus Studio and XML Converters both support the Standard Exchange Format
(SEF), which allows you to defined extensionsto EDI standards. The Stylus Studio EDI
to XML module allows you to easily create SEF files to manage conversion of custom
EDI formats. Its graphic user interface can simplify the process of converting non-
conforming EDI to XML —and vice versa. See Chapter 4 “Converting EDI to XML” for
more information.

Creating a Custom XML Conversion Definition

This section describes how to create and save acustom XML conversion definition (. conv
file) in Stylus Studio.

Choosing an Input File

Theinput file you specify when creating acustom XML conversion definition can be any
type. If you plan to usethe custom XML conversion definition to convert other non-XML
filesof thistype, theinput file should be representative of that broader class of files—files
with the same extension (. txt, for example), encoding, numbers and types of regions, and
so on. You can aways fine-tune the custom XML conversion definition to accommodate
characteristics that are not embodied in the input file, but as a general rule, use afile that
is as close to others of itstype as possible.

Stylus Studio’s heuristics are also used to determine the field separator character being
used (if any), the delimiting character being used (if any), and so on. The assumptions

222

Stylus Studio® 2010 User Guide



Creating a Custom XML Conversion Definition

Stylus Studio makes are reflected in the Properties window in the Custom XML
Conversions Editor once the input file is opened.

Specifying File Settings
Stylus Studio also allows you to specify thefile's

« Encoding (Windows-1252 or ANSI, for example)
« Layout (line-oriented or fixed-width, for example)

Unless you are certain of the file's encoding and layout, consider |eaving the default
settings as they are — Stylus Studio will determine encoding and layout properties when
it reads thefile.

How to Create a Custom XML Conversion Definition

0 To create a custom XML conversion definition (.conv file):

1. Select File > New > Custom XML Conversion from the Stylus Studio menu.
The New Custom XML Conversion Definition dialog box appears.

MNew Custom XML Conwversion Definition

1. Select an input file to be converted ta kML

2. Specify the encoding

(%) Let Stylus Studio determine the encading automatically

) The encoding is

() The file iz binary and haz no encading

3. Specify the general layaut of the file

(%) Let Stylus Studio determine the layout automatically

() Line-oriented [comma-separated valugs or EDI files, for example)

) Fized-width [database dumps o textual printer capture files, for example)

Cancel

Figure 148. New Custom XML Conversion Definition Dialog Box

2. Click the browse button (_..]) and select the file you want to use to configure the
custom XML conversion definition settings. See “ Choosing an Input File’ on
page 222 if you need help with this step.
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Tip

Tip

10.

11.

The Open dialog box appears. By default, the Files of Type field filter is set to display
.txt, .edi, .csy, .tab, .log, and .bin files.

Thefileyou select should be representative of other files of thistype that you wish to
convert to XML using the custom XML conversion definition you are creating.

Click the Open button.

Stylus Studio displaysthefile URL in thefirst field of the New Custom XML
Conversion Definition dialog box.

Optionally, change the default file encoding and layout settings. See “ Specifying File
Settings” on page 223 if you need help with this step.

Click OK.

Stylus Studio displays the file you selected in the Custom XML Conversion Editor.

Examine the file and its properties as it was read into the Custom XML Conversion
Editor by Stylus Studio.

Modify thefile layout, itsregions, and its fields as needed. See “Working with
Regions” on page 238 and “Working with Fields” on page 247 if you need help with
this step.

Modify the properties that govern XML output as needed. See “Controlling XML
Output” on page 255 if you need help with this step.

Click the Preview Results button ( B ).
Stylus Studio displays the Save As dialog box.
Enter a name for the custom XML conversion definition and click Save.

If the results are not what you expect, return to step 7 and to step 8. You might also
considering revisiting the input file, making fundamental changes there, and then
reloading it.

The steps in this process are described in greater detail in the following sections.

Once you have created and saved a custom XML conversion definition, you can useit to
open other non-XML files of the same type, just as you would with any other DataDirect
XML Converter. See “Using XML Convertersto Open a Non-XML Fileas XML” on
page 219 for more information.
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The Custom XML Conversion Definition Editor

You use the Custom XML Conversion Editor, shown in Figure 149, to build a custom
XML conversion definition. The Custom XML Conversion Editor appears when you
create anew custom XML conversion definition, or open an existing one (a . conv file).
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Figure 149. Custom XML Conversion Editor

Theinput fileis displayed in a document pane; properties that both describe the existing
file (encoding and size, for example) and define the XML output that will be generated
when converting thisfile (root and field element names, and whether or not you want the
XML to be indented, for example) are displayed in the Properties window. The schema
pane shows arepresentation of the XML Schemathat will be output for the converted file.
Finally, in addition to current row and column position, note that the status bar also shows
the Unicode value of the current character.
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This section describes the main features of the Custom XML Conversion Editor,
including how it interacts with the XML Converters engine. This section coversthe
following topics.

« “Document Pane” on page 226
o “Properties Window” on page 233
« “SchemaPane” on page 235

Document Pane

The document pane displaystheinput file'slayout, including spaces, field separators, and
control characters. Theinput file's appearance in the document pane is determined, in
part, by itsformat.

This section covers the following topics:

. “Example— .txt Files’ on page 226

. “Display of Delimiting and Control Characters’ on page 228
. “Field Names’ on page 229

« “Document Pane Display Features’ on page 230

« “Moving Around the Document” on page 232

Example — .txt Files

Stylus Studio usesdightly different displaysfor character-separated and fixed-width . txt
files. Consider this file, which uses commas as the field separator:

Make, Model , Year, M | eage

BMN R1150RS, 2004, 14274
Kawasaki , GPz1100, 1996, 60234
Ducat i, ST2, 1997, 24000

Mot o Quzzi, LeMans, 2001, 12393
BMN R1150R, 2002, 17439

Ducat i , Monst er, 2000, 15682
Aprilia, Futura, 2001, 17320
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Figure 150 shows how this character-separated input file appears in the Custom XML
Conversion Editor’sdocument pane. By default, Stylus Studio alignscolumnsand fillsthe
empty cells of the shorter rows with alight blue to aid readability:

i UnlilledB....‘

P& B o == [E= ==

field field fieldfield

1 MEYEE Model vearfiileage |
2 EXlint r1150rsf=0n0 414274 ]
Elxawasaki crz1l100f199efs0z234 0]
[dDucati 3T 199724000
Hicto GuzzifLeMans B2001412323
(B MTT R1150R 2002417439
fADucati Monsterfe 00015682
faprilia Futura M2001817320

Figure 150. Character-Separated File with Aligned Fields

You can remove these spaces from the display and view thefilein its native format by
clicking the Align Fields button ([Ei] ) on the tool bar, or by selecting
CustomXMLConversion > Align Fields on the menu. Thisresultsin the layout shown in

Figure 151.

% Untitled6.__|

e o === E
akeModelYearMileage.‘ A
Hlevwlr1150rs 200414274
Elxawazakiflerz1100f1996cfs0234
Moucatiflstzf1o978z4000

uoto cuzzifieMansfzo01f12333
Herwlr1150rR2 00217439 :
oucatiflMonsterflzooofis6sz2
flipriliaffruturaljzoo1 17320

Figure 151. Character-Separated File without Aligned Fields

Fixed-width files are displayed in adlightly different fashion. Consider this fixed-width

input file:
Deep- sea oct opus Bat hypol ypus arcticus http://ww:. dal . ca/ ~ceph/ TCP/ barcti c. ht m
Bl ue-ri nged octopus Hapal ochl aena | unul at ahtt p: // www. dal . ca/ ~ceph/ TCP/ | unul at a. ht m
Cari bbean reef octopusCctopus bri areus http: //ww. dal . ca/ ~ceph/ TCP/ obri ar. ht m
G ant oct opus Cct opus dof | ei ni http: //ww. dal . ca/ ~ceph/ TCP/ gi ant . ht m
Common oct opus Cct opus vul gari s http: //wwmn. dal . ca/ ~ceph/ TCP/ Cct opusvul gari s. ht
Red oct opus Cct opus rubescens http://ww. dal . ca/ ~ceph/ TCP/ r edoct o. ht m
Cctopus Sal uti i Cct opus sal utii http: //wwm. dal . ca/ ~ceph/ TCP/ Gsal utii . ht m
Cct opus Macr opus Cct opus nmacr opus http://ww. dal . ca/ ~ceph/ TCP/ Ovacr opus. ht m
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In afixed-width file, the empty cells represent actual values (spaces) in the input file. In
the second row of thisinput file, for example, there are three spaces between the first and
second columns:

5 Untileds.. |

P e@ e == =l

field field
plElc e p-=ca octopus Bathypolypus arcticus httpl//www. dal.ca/~ceph/TCE/barctic. html
FAElus-ringed cctiopus Hapalechlaena lunulatahttpf//www. dal.ca/~ceph/TCE/lunulata. html
ElCcaribbean reef octopusOctopus briareus http@/ / www. dal.ca/~ceph/TCP/obriar. html
[1ciant octopus Octopusz dofleini httpfll/ /www. dal. ca/~ceph/TCE/ giant. html
FCommon ectopus Octopus vulgarils httplll/ / www. dal.ca/~ceph/TCP/Dctiopusvulgaris. htm
[JrRed cctopus Octopus rubescens http@/ / www. dal.ca/~ceph/TCE/ redoctio. html
octopus Salutii Octopus =alutii httpfll/ /wwwi. dal. ca/~ceph/TCE/ Ogalutii. html
[Joctopus Macropus Octopus macropus httpl/ / www. dal.ca/~ceph/TCE/Omacreopus. html

Figure 152. Fixed-Width File

Display
Styl

of Delimiting and Control Characters
us Studio displays delimiting and control charactersin away that distinguishes them

from plain text values.

Delimiting characters, like the comma used in the example in Figure 150, are
displayed with adark blue background. For filesthat include sub-fields or arrays (like
EDI, for example), the sub-field separator character is shown in a different shade of
blue. Sub-sub-fields delimiting characters are shown in a shade of purple.

Control characters(linefeedsand carriagereturns, for example) are shown using their
abbreviated ASCI| value. A carriagereturn (0xOD) line feed (0xOA) is shown as [25],
for example. ASCI| abbreviations are aligned vertically, to preserve space, as shown
in this representation of the ASCI| value for tab (0x09): [3].

Stylus Studio understands all Unicode characters,. When editing Line-Oriented
Region and Field Name values in the Properties window, you can enter mnemonic
values for the C1 and CO control charactersin the following ranges:

= CO control characters with a value from >= 0x00 to <= Ox1F

» C1 control characters with a value from >=0x80 to <= Ox9F

For example, you could enter TAB or HT in the Field Separator field in the Properties
window, and Stylus Studio would correctly interpret that value. For alist of
commonly used control characters, see* Specifying Control Characters’ on page 311.

Charactersthat are discarded from output (like line terminators such as CR and LF
and comment lines) are displayed against a gray background.
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You can hide control characters by clicking the Toggle Control Characters button ([3z])
on the tool bar, or by selecting ConvertToXML > Toggle Control Characters from the
menu.

Field Names

User-defined field names — values that Stylus Studio uses to create the element namesin
converted XML — are displayed in green, as shown here:

Pl %! E Untitled1
Collapse Cons... | false A~ |
Diouble Delimit... | true s | (0] | =z |[E2E
=-*= Row Element Mame | row i x_u.u..
IR gt e field fieldfield
=i Field Element Name_ field Model vearfuileage
: e Tompanent rR11c0rsfzo0al1427 40"
:E :uh'cﬂ“[’)'j?”i ;Lt"?mm'j””e”‘ ] awasaki zrz 1100l 199 cls0z34 .“\f-‘;
T Left Padding TAB." ot GuzziMLeMans 2001 12393.“\5\
T RightPad.. Tag' rR1150r MzoozM17439: 2
T Omit Only then ... Monsterflzoooficaszi
% TMiDuT"{ slement Aaprilia Futura Mz001l1732000
ookup List

Figure 153. User-defined Field Names are Shown in Green

You can edit these names
« In-place, by double-clicking the field name
« IntheField Element Name field of the Properties window

If the field names are taken from arow within thefileitself, Stylus Studio displays ablue
arrow in the document pane margin to indicate this.

Properties x| = Unlilled...’|
. Heglon Tupe Line-Oriented A

Region Elementtlarms

Ao sae oo D © [ED
B Fows fo skl i c Rlake Model Year Mlleage.,.,.\
Line Terminator CRLF PAE T Bri1c0rzfz004@14274, 2
Separator vEJkawasaki WMerpziioof12s6cfenz2340 0
ga“f""e'tp;"s vlpucat i . B j1oo7f240000 0

Ll e > wa viEpicte CuzzifLeManz Be00 112393,
E:cape Characters e
Key=\ialue Character v[AEMT BE1150FR BZ00ZH 17439._-,_-:
Toss Characters vilDucati Bionster@200 015682, 0
Component S eparator vilaprilia Brutura Wz001817220,
Sub-Component Sepa...

Figure 154. Blue Arrow Indicates Field Names Taken from the File

See “Naming Fields’ on page 247 to learn more about naming fields for XML output by
custom XML conversion definitions.
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Document Pane Display Features

In addition to aligning fields in character-delimited files, the Custom XML Conversion
Editor’s document pane has several other features that aid readability.

Ruler
You can display aruler that identifies each column:

s Untitleds...|
2@ o =EEEN

field ‘ | field
ililc=p-=ea octopus Bathypolypus arcticus httpf//www.dal.ca/~ceph/TCP/barctic.html
PlElue-ringed octopus Hapalochlaena lunulatahttpl// www.dal. ca/~ceph/TCE/lunulata. html
ElCaribbean reef octopusOctepus briareus httpl/ / www.dal.ca/~ceph/TCP/obriar. html
LIciant octiopus Octopus dofleini httpl/ / www.dal.ca/~ceph/TCP/giant. html
Flcommon octopus Octopus wulgaris httpl/ /www. dal. ca/~ceph/TCE/ Octopusvulgaris. html
JRed occteopus Octopus rubsscens httpl/ / www.dal. ca/~ceph/TCP/redocto. html
octopus Balutii Octopus salutii httpl// www.dal.ca/~ceph/TCP/Osalutii. html
Bloctopus Macropus Octopus macropus httpll/ /www. dal.ca/~ceph/TCP/ Omacropus. html

Figure 155. Ruler Helps Identify Columns

To display the ruler, click the Toggle Ruler button ([=]) on the tool bar, or select
CustomXMLConversion > Toggle Ruler from the menu.

Displaying Pattern Matches

You can define match patterns using regular expressions to control which rows are
converted to XML and, optionally, the nameto use for theserows. You can highlight rows
that match the patterns that you have defined, as shown here:

Properties x
Sub-Compone... ~
Region T ermin
. Collapse Cons... | false
. Double Delimit... | tue

% Untitied__=|

=k <oty

jldlccp-seca cctopus Bathvpolypu = Regian
PdElue-ringed occtopus Hapalochlas @

ElCaribbean reef coctopusOctopus bri

== Row Element Name | o
= Match F'attem oct
=- e F|s i T Tield

d
i ] Enmpnnant EI companent

"8 Sub-Compone... | subcomponent jiCont] oStiopus PSEilEus] diolf
= ™ SouceData Sting FConmorn octopus Octopus wul
T Momalize . | tue (JR=d occtopus Cctopus rub
T LetPaddi. | TAB," Xlcctopus Salutii Octopus sal
% S'Dhtpad--- ;AFWh = xiJoctopus Macropus Octopus mas
mit hly =l
T #ML Outp... | lement < > |
$ Lookup List =] Deep sea Uclupus BalhyDDbqus arclicus hllp

hlnbon

Flgure 156. Matchmg Rows Are Dlsplayed in Yellow

To highlight matching rows, click the Highlight Matching Rows button ([Z]) on the tool
bar, or select CustomXMLConversion > Highlight Matching Rows from the menu.
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Matching rows are displayed in light yellow, with agreen check in the pane’s margin. A
red X identifiesrowsthat do not match the current pattern. Gray squaresidentify rowsthat
match a pattern other than the pattern defined for the row that currently has focus. See

“Specifying Multiple Match Patterns’ on page 259 for more information on this feature.

Tip Only rowsthat match the same pattern that the current row matches are highlighted. Also,
tooltips appear when you hover the pointer over the match symbols. These tooltips
display the pattern that the row matches.

See “Pattern Matching” on page 257 to learn more about using regular expressions to
define match patterns.

Grid Lines

The document pane displays both vertical and horizontal lines by default; you can
hide/show them independently. In the example shown in Figure 157, horizontal lines are
hidden from the display:

B Untited.."|

rem o =M=EH=N) =
field field

- cp-=2ea octopus Bathypolypus arcticus httpl// www.dal. ca/~ceph/TCE
MElue-ringed cctopus Hapalechlaena lunulatahttpf//www.dal.ca/~ceph/TCP
ElCaribbean reef octopusOctopus briareus httpf// www. dal.ca/~ceph/TCP
Iciant occtopus Octopus dofleini httpfl// www.dal.cal~ceph/TCD
Hcommon octopus Octopus wulgaris httpfl/ /www. dal. ca/~ceph/TCP
[Jred octopus Octopus rubsscens httpl// www. dal. ca/~ceph/TCP
flcctopus Salutii Octopus salutii httpfl// www.dal. caf~ceph/TCD
Hloctopus Macropus Octopus macropus httpll/ /www. dal. ca/~ceph/TCP

< >

Figure 157. You Can Hide Horizontal and Vertical Grid Lines

To hide horizontal and vertical grid lines, click the Toggle Horizontal Grid Lines (&)
and/or Toggle Vertical Grid Lines ([|]]]) buttons on the tool bar, or select ConvertToXML >
Toggle Horizontal Grid Lines and/or Toggle Vertical Grid Lines from the menu.

Tip Hiding horizontal lines while displaying the ruler is an effective way to quickly scan
columns.

Fonts

By default, the input document is displayed using the Courier New font in 12pt. You can
change the display font to suit your personal preference using the Edit > Change Font and
Edit > Font Size menus.
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Moving Around the Document

You can move the cursor around the document using
o The Space bar on your keyboard

« Thedirectiona arrows and Page Up, Page Down, Home, and End keys on your
keyboard

« Your mouse (click on the character on which you want to place the cursor)
o TheGo To dialog box

Go To §|

GoTo M asimuirn:
1 - 752

1
() Cursar Pasition in Flegion 7h2
() Row in Cunent Region: 8
() Column in Cunent Row: 94

[ Cancel 1 [ ok ]

Figure 158. Use the Go To Dialog Box to Navigate the Document

Using Go To

You use the Go To dialog box to jump to a specific location in the file you are using to
create your custom XML conversion definition. You can use it to move the cursor to a

specific
« Positionin thefile
« Region

« Position or row within aregion
o Column within the current row

When you first display the Go To dialog box, valuesin the Go To fieldsreflect the cursor’s
current location within the file. The valuesin the Maximum fields display the maximum
valuesfor each category (file size, number of regions, and so on) for the portion of thefile
read into the Custom XML Conversion Editor Editor by Stylus Studio.
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0 To display the Go To dialog box, select Edit > Go To from the menu.

Properties Window

TheProperties window, like the one shown in Figure 159, displaysinformation about the
input file, aswell as settings that Stylus Studio will use convert filesto XML.

Properties b4
= —:B Input File file: /v Mtestinghbikes_... &
—:ﬁ Input Encoding ulf-8
€ Physical Size 208 bytes
€ Portion Loaded 208 bytes
e Characters Loaded 208

e Character Unicode VYalue | 77 [Ox4d)
=-[= <ML Output URL

[= Root Element Name oot

E) Mamespace Prefis

E) Mamespace

[5 DOCTYPE System 1D

[® DOCTYPE Public ID

[= %ML Schema Document

E) #ML Schema Namesp

E) Indent XML? true
= Fiegion Type Line-Oriented

Region Element Mame

Element Mame Source Fram First Baw

Rows to Skip 1]

e Size 208 characters
€ Portion of File 1 to 208

€ Row Count 8

e Longest Row Lenath 30

Line T errinator CR.LF
Separator '

Delimiter Pairs
Comment String
J Y R

v

Figure 159. Properties Window for a .txt File

Information in the Properties window includes

« Information read or inferred from the input file when it isfirst opened in the Custom
XML Conversion Editor. Examples include the file name, file size, and number of
characters that were read. Some values, such as the type of encoding, can be edited.
Informational fields that cannot be edited are identified with ablue circle: .

« Vauesyou want the XML Converters engine to use when converting this input file
and other files of thistypeto XML. Output propertiesinclude the root element name,
the namespace and namespace prefix, and the field element name. Thesefields are
identified with a green arrow over a document icon: [=].
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How Properties are Organized

Properties displayed in the Properties window are organized in the following categories.

Input File —read-only information read or inferred from the input file, and editable
propertiesthat affect XML output. These properties affect the file asawhole when it
is converted to XML. Input file properties are identified by thisicon: [2]].

XML Output URL — properties that affect the XML document created by the custom
XML conversion definition, including the name you want to use for the root element,
and whether or not you want to indent the XML. Output URL propertiesareidentified
by thisicon: [=.

Region Type —read-only information inferred from the input file, and editable
properties that affect XML output. Examples include line terminating and escape
characters. These properties affect a contiguous portion of the file (that is, agiven
line-oriented or fixed-width region) when it is converted to XML. Region properties
areidentified by thisicon: [&].

Row Element Name — properties that affect which rows of the input file are output to
XML and how they are output, including the name you want to use for the row. Row
properties are identified with thisicon: P=].

Field Element Name —read-only information read or inferred from the input file, and
editable properties that affect XML output. These properties affect only fieldsin a
given region of the file when it is converted to XML. Field properties are identified
by thisicon: [*&].

Note Informational properties, that is, propertiesthat do not affect XML output, are displayed
with the following icon: . These properties are displayed when you click the Toggle
Informational Properties button.

Properties for Fixed-Width and Line-Oriented Input Files

Fixed-width and line-oriented input files have different properties — line-oriented
propertiesinclude the line terminator and field separator characters, and fixed-width files
have arow length, for example. See “ Custom XML Conversion Definitions Properties
Reference” on page 280 to learn more about individual properties.
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Schema Pane

The schema pane displays a representation of the XML Schema for the XML document
that will be output when the input file is converted to XML.

i wa edi.cony = | i
» 2@ o E=h=m=l B EE
1 el [l : | | [l : | = cediz
pAcslcrle o877 6651122334455 =0 [ = Regond
3B T!B 3 l!D 0ilzE0nn1l~ <!ntelchange_control_hefader?m ISﬁ.
. <interchange_control_trailers ""1E&:
id AF GNHD D'B 8=00)0/0 1l2 DD41=01x <functional_group_header> ""GS:"
L 9!}3 T!B 8200001~ <transaction_set_headers ""ST:"
6 i RN!llB 8200001~ <beginring_segmenty "“BGN:"
7B MT!Z!l ooooo. o0~ <reference_identifications "N3:"
8 [l Y! 4 6! 1B <functional_group_trailer> ""GE:"
<hanzaction_set_trailers "SE:"
E)==f7@o01z8001~ caquantis 0T
10 = l 1! 128~ <monetary_amounts "AMT:"
BR e f] 1 foooo3z1z235~ <traces " TRM:"
112 B
< ¥ p
BGH

Figure 160. Schema Pane Shows Output Schema Representation

You can double-click on arow element to display the Set Node and Match Pattern dialog
box, shown in Figure 161. This functionality provides an alternative to editing the row
name and specifying a match pattern in the Properties window. (To learn more about
patterns and how to use them in your custom XML conversion definitions, see “Pattern
Matching” on page 257.)

Set Node and Match Pattern

Fiow Element Name:

Match Patterm: "M

[ 0K ] [ Cancel ]

Figure 161. Set Node and Match Pattern Dialog Box

You can also edit schema node names directly in the schema pane —just click twice to
place the node name in edit mode.

See “Rows’ on page 237 to learn more about specifying conversion properties for rows.
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Parts of an Input File

Input files displayed in the Custom XML Conversion Editor’s document pane consist of
regions, rows, and fields. Each section hasits own set of properties. Some, like Region
Type, areread or inferred from thefile; others, like Region Element Name, are valuesyou
provide that affect the XML output.
This section covers the following topics:
. “Regions’ on page 236

“Rows’ on page 237
. “Fields’ on page 238

Regions

A region isthe largest organizational component in an input file. Regions are interpreted
by Stylus Studio when theinput fileisfirst read into the Custom XML Conversion Editor.
You can use the editor to define your own, aswell.

Aninput file can contain one or more regions; every input file has at least one region that
starts at offset 0. Multiple regions are common in binary files, which often contain afixed-
size header and then one or more records containing the actual data. Regions arefixed in
size and cannot repeat.

In the Custom XML Conversion Editor, regions are numbered, starting with 1, followed
by the row number. For example, in an input file with two regions, you might see rows
labeled asfollows; 1:1, 2:1, 2:2, 2:3, and so on, as shown here:

» & @ [0][E =k= E=]
fieldfield [fieldfield
: 1 IGE=NY hModethearhMlleage
field field fleldfleld
R1150rRsfz004f1a274 02
AR wasaki crzllnof19oclenz34, "
iDL cat i gT2 19978240000
Hhicte cuzzifuemans Wzooi1f1z39200
R1150R Wzoozf17439: 2
Hjrucati Monsterfzo0ol1s6520 0
% 2 : 7 EC e Futura Wzoo1l173z0. 0

Figure 162. Rows in Regions Are Numbered Independently
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Region Types

Regions can be fixed-width or line-oriented. You can also set the Region Type property
to No-output. Regions that are marked as No-output are grayed out in the Custom XML
Conversion Editor, and they are not converted to XML.

Managing Regions

Stylus Studio provides tools that let you create new regions, and join one region with
another. You can also change a region’stype, define different line terminators across
regions, and mark aregion sothat it isexcluded from output. For information on these and
other topics, see “Working with Regions’ on page 238.

Rows

A row iseguivalent to arecord, line, or tuplein the input file; arow is made up of fields.
An example of arow is an employee record; examples of fields in an employee record
include employee_id, Tast_name, first_name, and So on.

Every region can have one or morerows. (A region cannot be empty.) In addition, aregion
can have multiple row types. Rows are selected for conversion to XML based on the
match patterns expressed in the Match Pattern field of the Properties window. See
“Omitting Regions and Fields, and Rows” on page 256 for more information.

Rows in afixed-width region have the same width as the region itself; fields within each
row are defined by afixed number of columns. Stylus Studio uses a default value of 80
characters for row length in fixed-width regions, but you can adjust this as required from
within the Custom XML Conversion Editor. See “Adjusting Fixed-Width Regions’ on
page 241 for more information.

In afixed-width region, you can

o Explicitly specify the fields within a row

« Adjust the size of the fields you specify

In aline-oriented region, fields are separated by a separator character or string. These

characters are inferred by Stylus Studio when it first reads the file, but you can change
these and other characters if needed.

See “Working with Fields” on page 247 for more information.
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Fields

A field isone or more columnsin arow that contains data. Each different row type hasits
own independent set of fields. An example of afield in an employee record is
empTloyee_id.

Stylus Studio supports many data types (string, Boolean, number, date, time, and so on)
and recognizes many different input formats (like different date formats, for example).
Properties vary based on datatype —the Base property, for example, is applicable only to
Number data types.

You can define your own fields in fixed-width input files. See “ Defining Fields’ on
page 250 for more information.

Component and Sub-Component Fields

Some fileformats, including many EDI dialects, allow fieldsto be subdivided into arrays,
sub-fields, or composite fields. Collectively, these fields are referred to as component
fieldsin custom XML conversion definitions, and they are fully supported, both in terms
of recognition and output. You can name the container element using the Component
Element Name and Sub-Component Element Name properties.

Working with Regions
This section describes some of the features you can use to work with input file regions. It
covers the following topics:
« “Converting the Region Type” on page 239
« “Adjusting Fixed-Width Regions’ on page 241
« “Defining and Joining Regions’ on page 243
« “Controlling Region Output” on page 246
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Converting the Region Type

The Region Type field in the Properties window displays information about the type of
region Stylus Studio inferred when the file was first read. Its value is either Fixed-width,
Line-oriented, or No-output.

Tip Information about No-output regions is not displayed in the Properties window.

Regions with CR/LF control characters are interpreted as line-oriented regions. There
might be occasions, however, when you want to change the region type from line-oriented
to fixed-width, or vice versa. This section describes the tools you can use to change a
region from one type to another.

Consider the following file fixed-width file:

Make Model Year M | eage
BMV R1150RS 2004 14274
Kawasaki GPz1100 1996 60234
Ducat i ST2 1997 24000
Mot oQuzzi LeMans 2001 12393
BMV R1150R 2002 17439
Ducat i Monster 2000 15682
Aprilia Futura 2001 17320

Itisasimple .txt file with fields (Make, Mode1, and so on) that have been created using
spaces. Each new row was created using the Enter key in the text editor, resulting in
CR/LF control characters at the end of each line that cause Stylus Studio to interpret the
file asasingle line-oriented region, like this:

P & (2

field £
ake IIIIIIIModel

BMW 1] Bl=1150Rs |2DD4 Bl <=74
Kawasaki [N 1100 | MEEE || EilEEe
Ducati || HEEEE - -Blll= <000

Blzoo01 1] e
Blzo0z= ||| Pl

| BEEIE || | PG
Figure 163. Fields are Aligned by Default

B M
Ducati

ield field fiel:«
||| NS Hlilcagei
I::::

For display purposes, we can remove the spaces Stylus Studio hasinserted for readability
(the cells with the light blue shading) by clicking the Align Fields ([Ef] ) button. This
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resultsin adisplay that resembles the source (Figure 164), but Stylus Studio till
considers the region to be line-oriented.

= == s=[N]  E
IModelIIIIYearIIIIMileageﬁi
|

L
7 itverad | ||| | dereEeees | B | | | EEEEE |
8 [N | [ | | SR | | B | | | EelslEn) |

Figure 164. Turning Off Align Fields Can Aid Readability

When you convert aline-oriented region to a fixed-width region, Stylus Studio removes
spaces it added for readability and depicts only the spacesin the original input file used
to create the fields and the field va ues themsel ves, as show in Figure 165.

p2@ O ==k=EE

field

ake Mode 1 Year Mileage, EBMW R1150RrRS | 2004 14274 | | Eawal
=aki GPz1100 1296 60234 | .Ducati 5TZ 1297 24000 . MotoGuzz
i LeMans 2001 12393 o BME R1150R 2002 17439 coDucat i
onster | 2000 15682 | Aprilia Futura 2001 17320

Figure 165. Line-Oriented Regions Converted to Fixed-Width

By default, Stylus Studio displays fixed-width files using an 80-character row. This
accounts for the input files appearance when it isfirst displayed as a fixed-width file — if
you scan the document, you can see that all of the file’'s original information, including
the CR/LF control characters has been retained, but that the formatting differs —the
original input file had eight rows; now it has four rows of 80 characters.

Tip You can adjust the width of fixed-width regions. See “Adjusting Fixed-Width Regions”
on page 241.
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How to Convert a Region Type

0 To convertaregion type:

1. Place the cursor anywhere in the region you want to change.

2. Click the Convert to Fixed-Width Region (|EE)) or Convert to Line-Oriented Region
([E)) button. These actions are a so accessible from the CustomXMLConversion
menu and the shortcut menu in the Custom XML Conversion Editor.

3. If you have converted aline-oriented region to a fixed-width region, adjust the row
length as needed. See “Adjusting Fixed-Width Regions” on page 241.

Adjusting Fixed-Width Regions

If you specify the layout of the file you are converting as fixed-width, Stylus Studio uses
adefault row length of 80 characters. (If you let Stylus Studio determine the file layout,
Stylus Studio will attempt to determine record length based on the line terminating
character, if any.) You might need to adjust the row length of aregion if your input file
uses adifferent row length, or when converting aline-oriented region, like the one shown
in Figure 166, to fixed-width.

Figure 166. Line-Oriented Region

There are several ways to specify the row length for a fixed-width region:

« Using the Row Length property —simply change the default value, 80, to the value
that is appropriate for the current region and press Enter.

« Dragging the document paneto the left or right — move the pointer to the right border
of the document pane. When it changes shape, press and hold mouse button 1 and
drag the right border of the grid until the input file's fields are aligned.

« Holding the Shift key and pressing theright arrow (to add width) or the left arrow (to
decrease width).
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Each of these methods | etsyou explicitly set therow length. Alternatively, you can specify
aLine Terminator character manually, as shown in Figure 167.

= FRegion Type Fixed-width
Fegion Element ... | region
Element Mame 5... | User-Supplied
Fiows to Skip 0

Ornit from Dutpul
5 How Length
&4 Line Terminator
5 Lommer )
Region Terminatar
=-*= Raow Elemnent Name
b= Watch Patten
=- ™™ Field Element Name
®® Component Elem...
®® Sub-Component ..
=-®% Souce Data Type
T Momalize'w'.. | tue 3

Figure 167. Manually Setting the Line Terminator Character

Specifying a Line Terminator character means that the rows in the region can be of
variable length, based on the where the specified Line Terminator character occursin the
record.

Tip Whenyou specify aLine Terminator character for afixed-width region, the value shown
in the Row Length property represents the value of the longest row in the region.

Example

After converting the line-oriented region shown in Figure 166 to fixed-width, it lookslike
this:

p2@ O ==k=EE

field

ake Mode 1 Year Mileage, EBMW R1150RrRS | 2004 14274 | | Eawal
=aki GPz1100 1296 60234 | .Ducati 5TZ 1297 24000 . MotoGuzz
i LeMans 2001 12393 o BME R1150R 2002 17439 coDucat i
onster | 2000 15682 | Aprilia Futura 2001 17320

Figure 168. Line-Oriented Region Converted to Fixed-WIdth
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Figure 166 shows the same fixed-width file after it has been resized by dragging the
document pane.

= =[g]= E & EE

Model Year Mileage |
R1150RZ 2004 14274 | |
GPz/1100 @ 1926 60234 GD
ST2 1997 24000
LeMans 2001 12393
R1150R 2002 17439
Monster | 2000 15662
Futura 2001 17320

Figure 169. Resized Fixed-Width Region

Defining and Joining Regions

Aninput file can contain any number of regions; fixed-width and line-oriented regionscan
exist in the samefile. The Custom XML Conversion Editor providestools that allow you
to define new regions and join existing ones.

This section covers the following topics:
“Defining a Region” on page 243
« “Joining Regions’ on page 246

Defining a Region

When you define aregion in an input file, Stylus Studio splits the region at the current
cursor lacation. The new region startswith the character on which the cursor resided when
the region was defined, but it can be of either type — fixed-width or line-oriented —
regardless of the type of the original region.

Consider the following input file:

# Bi ke | nventory Overvi ew 2004-10-01 09: 00: O7EDT
Make, Model , Year, M | eage

BMA R1150RS, 2004, 14274

Kawasaki , GPz1100, 1996, 60234

Ducat i, ST2, 1997, 24000

Mot o Quzzi, LeMans, 2001, 12393

BMA R1150R, 2002, 17439

Ducat i , Monst er, 2000, 15682

Aprilia, Futura, 2001, 17320

Stylus Studio® 2010 User Guide 243



Converting Non-XML Files to XML

By default, Stylus Studio reads this as afile with a single region. You might decide you
want your XML to distinguish headers from actual records and treat the two accordingly
(not generating headers as XML, for example).

When you define a new region, the Custom XML Conversion Editor renumbers all the
rows, using aregion:row number format. In addition, each regionisdisplayed withitsown
field name row, which is displayed in light green with the default field element name,
field, asshownin Figure 170.

» field fieldfield
ViBER# Eike Inventory Overview 2004-10-01 DQhDD hD?EDT;‘:fi
» field field fieldfield

02 : 1 ey Model vearfMileage
(g2 : 2 )i rR1150Rslz00 4142742
(42 : 3 ZERTEVAEY crzlloof159cfenz34 0
vEREIDucati STZ 1997824000,
ViR oto GuzzifLeMans 200112393,
(2 : 6 )20 R1150E ZO00zZ17439,
vVEEMAT uCcat 1 Monsterf=z00 015652,
ViR prilia Futura @=Z001417320

Figure 170. Regions Are Numbered and Colored Differently

Field and row values are independent across regions. For example, the <row> element
might be <reg1>, <reg2>, and so on for each of the regionsin an input file.
0 To define aregion:

1. Placethe cursor in the document pane on the character with which you want to start
the new region.

2. Click the Start New Region Here ([fg)) button, or select CustomXMLConversion >
Start New Region Here from the Stylus Studio menu.
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Stylus Studio displays the Start New Region dialog box.

Start New Region §|

Fiegions stait at a fixed offzet in the file and divide the file into logical sections.

They should be used when the file structure changes. az when a Fised-width
header is followed by a variable-width section, or when the row separator or field
delimiters change.

In most cases, a new Pattern can be used more effectively to split out records of
different ypes.

() Fired-width

) Mo-output
Eegin Mew Region

() it pow 4

() &4t 78 bytes from the start of the file

[ Ok ] [ Cancel ]

Figure 171. Start New Region Dialog Box

3. Choose the type of region you want to create (line-oriented, fixed-width, or no-
output).

4. Choose where you want the new region to start (at the current row, or at a specific
number of bytes from the start of thefile).

Tip If the .conv file you are creating will be used with different input files, it is possible
that the line lengths could vary from file to file, changing the byte offset. Consider
using the row setting (the default) for the Begin New Region property in this case.

5. Click OK.
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Joining Regions

You can join regionsthat you define aswell asregionsthat Stylus Studio interpreted when
it first read the input file. You can join the current region to either adjacent region —the
previous region, or the next region.

The region type after the join operation depends on whether you are joining with the
previous region or the next region.The region you are joining assumes the type of the
region to which it is being joined.

Table 20. Region Type After Joining Regions

Region Joined With Resulting Region Type
Next The region you are using to perform the join
Previous The region to which you are joining

0 To join aregion:
1. Place the cursor anywhere in the region you want to join with another region.

2. Click the Join with Previous Region () or Join with Next Region () button.
These actions are also accessible from the CustomXMLConversion menu and the
shortcut menu in the Custom XML Conversion Editor.

Stylus Studio joins the region you specified in step 1with the adjacent region.

Controlling Region Output

By default, Stylus Studio generates output for al fixed-width and line-oriented regions.
No-output regions are never converted to XML. In addition to pattern matching, which
controls whether or not individual rowsin aregion are output based on a pattern you
define, you can omit entire regions from output by selecting Yes from the Omit from
Output drop-down list in the Region Type section of the Properties window.
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Working with Fields

This section describes some of the features you can use to work with input file fields. It
covers the following topics:
o “Naming Fields’ on page 247
“Defining Fields” on page 250
« “Component and Sub-Component Fields’ on page 253

Naming Fields

Every field in an input file — including fieldsin the same region and row — can have its
own field element name. All field element names (<field> is the default) include the
namespace prefix in the XML output if one was specified.

Field names are determined by two properties — Element Name Source in the Region
Type properties, and Field Element Name, as shown in Figure 172.

Froperties b4

[= Indent $ML? true A

= Fegion Type Line-Oriented

(PP ETement Mame e

CEi Element Name Source
= -

B e = H
Line T erminatar CR.LF
Separator '
Drelimiter Pairs

Comment String

Escape Characters

Kep=/alue Character

Tozs Characters

Component Separator

Sub-Component Separator

Region Terminatar

Collapse Consecutive Separatars | fake
Double Delimiter to Escape true

=-*= Row Element Name raw
PR stk Pt

= GE Ficld Element Name field >
= o Componeht

®® Sub-Component Elernent Marme | subcompar...

Figure 172. Sources for Field Names in XML Output

TheElement Name Source indicatesthe origin of the field name used in the XML output
when converting the input file. The Field Element Name property specifies the actual
value used to name the <field> element.
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Using the Element Name Source Property

There are three values for the Element Name Source property:

o User-Supplied — Specifies that you will supply names for the <field> element. You
can do this by editing the Field Element Name property, or by double-clicking the
field element name in the document pane to edit the field name directly in the
document pane.

Thedefault value of theField Element Name property isfield. If you use other values
for the Element Name Source property, Stylus Studio providesthevaluesfor theField
Element Name property.

User-Supplied isthe default setting for the Element Name Source property.

o From First Row — You can use this setting to take <field> e ement names from the
first row in the region. If you have used the Rows to Skip property to skip rowsin a
region, the first available region is used to supply the <field> element names.

Consider the following input file:

Make: Mbdel : Year
BMWV R1150RS: 2004
MZ: Scor pi on: 1995
Ducat i : ST2: 1997

If you set Element Name Source to From First Row, the XML output uses Make,
Modd, and Year for the <field> € ement names, as shown here;

<?xm version="1.0" encodi ng="ut f-8"?>
<r oot >
<r ow>
<vake>BMM/ Make>
<Mbdel >R1150RS</ Mobdel >
<Year >2004</ Year >
</ row>
<r ow>
<Make>MZ</ Make>
<Mbdel >Scor pi on</ Model >
<Year >1995</ Year >
</ r ow>
<r ow>
<Make>Ducat i </ Make>
<Mbdel >ST2</ Mbdel >
<Year >1997</ Year >
</ row>
</root >

You can specify any row asthe sourcefor field namesusing the Get Field Names from
This Row from the row’s shortcut menu.
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o WS-EDI Standard — This setting allows rows and fiel ds to be named based onthe WS-
EDI Standard level 0. See http://www.ws-edi.org for more information on this
standard.

More About Using Rows for Field Names

When you use an existing row as the source for field namesin the XML output, Stylus
Studio changes the display of that row in the document pane to adarker blue to indicate
this, as shown here:

i

fieldfield
w2004-10-01 oo@on 07EDT. |
aa

Figure 173. Using a Row for Field Names

In addition, preceding rowsin that region, if any, are grayed out, and the value of theRows
to Skip field in the Region Type properties changes to reflect this.

In the event that the first row has fewer names than there are fields in one or more
subsequent linesin the file, Stylus Studio names the extrafields <fieldn>, where nisthe
field number relative to other fieldsin the row. Also, if the valuesin the row are not valid
XML identifiers, they are converted using the following rules:

«  Whitespace and nulls are trimmed from both ends

o SQL/XML rulesareused, except that underscores(*_") arenot convertedto _x005F _
symbols

« Beyond these exceptions, strict rules are used. See section 9.1 (page 91) of
http://www.sqlx.org/SQL-XML-documents/5FCD-14-XML-2004-07. pdf.

How to Name Fields

0 To provide user-supplied field names:

1. Display the Properties window if it isnot already displayed (click View > Properties
on the Stylus Studio menu).

2. Placethe cursor anywhere in the field you want to name.
The Field Element Name property displays the current value for the field.

3. Typethe new namein the Field Element Name property and press Enter.
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Alternative:

1. Double-click the field name in the document pane.
The field name field becomes editable.

> D o = =[k= =]

field

# Bike Inventory Overwview 2004-10-01

i

R1150RS

fieldfield
Mode 1l e alr]

2004

Mileage
14274 B8

Figure 174. You Can Edit the Field Name Directly in the Document Pane

2. Typeanew vauefor field and press Enter.

0 To specify alternate sources for field names:

1. Display the Properties window if it isnot already displayed (click View > Properties

on the Stylus Studio menu).

2. Select the field name source you want to use from the Element Name Source drop-

down list.

3. Press Enter.

Defining Fields

You can define fields in any region in a fixed-width input file, as shown in Figure 175.
Onceyou have defined afield, you can changeits size by simply dragging it to any column

in the grid.

p2@B O ==kll=  [=IE
i ield

odel Tear
1150Rs 2004
Pz 1100 1596
T2 1997
eMans 2001
1150R 2002
oenster 2000
utura 2001

>E »E

Mileage, .

14274
a0234
24000
12393
17439
15682
17320

Figure 175. Line Identifying a Field in a Fixed-Width Input File

Each fidld you define is treated as a separate element in the XML output by the custom
XML conversion definition. Theinput file shownin Figure 175, for example, would result

250
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in XML with two <field> elements, one consisting of the make of motorcycle, and one
consisting of the model, year, and mileage. You can use the field feature to exercise
control over the XML — defining separate fields for make, model, year, and mileage, for
example.

Consider the following input file:

Make Model Year M | eage
BMNV R1150RS 2004 14274
Kawasaki GPz1100 1996 60234
Ducat i ST2 1997 24000
Mot oQuzzi LeMans 2001 12393
BMV R1150R 2002 17439
Ducat i Monster 2000 15682
Aprilia Futura 2001 17320

By default, each row is considered to have asinglefield, containing Make, Mode1, Year, and
Mileage, resulting in XML output like this:

<?xm version="1.0" encodi ng="ut f-8"?>
<r oot >
<r ow>
<fi el d>Vake Model Year M | eage

</field>
</ row>
<r ow>
<fi el d>BMN R1150RS 2004 14274

</field>
</ r ow>
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If you specify fields for Mode1, Year, and Mi1eage, the XML output by the custom XML
conversion definition looks like this:

<?xm version="1.0" encodi ng="ut f-8"?>
<r oot >
<r ow>
<fi el d>Make</fi el d>
<fi el d>Model </ fi el d>
<fiel d>Year</fiel d>
<fiel d>M | eage

</field>
</ r ow>
<r ow>
<fiel d>BMN/fi el d>
<fi el d>R1150RS</ fi el d>
<fi el d>2004</fi el d>
<fiel d>14274

</field>
</ r ow>

Neither approach isalways correct, but thisfeature gives you the ability to define the type
of XML output that is appropriate for your use.

Tip Of coursg, inthisexample, the next logical step might beto usethefirst row (Make, ModeT,
Year, and MiTeage) as the field names as described in “Naming Fields’” on page 247.

0O To define a field:

1. Place the cursor in the document pane on the character with which you want to start
the new field.

2. Click theBegin Field in This Column ([gZ]) button. Thisaction isalso accessiblefrom
the CustomXMLConversion menu and the shortcut menu in the Custom XML
Conversion Editor.

Stylus Studio displays athin orange line that identifies the start of the newly defined
field.

O To remove afield:

The procedure for removing afield is the same as the procedure for defining one — place
the cursor on any character adjacent to the field line you want to remove and click the
Begin Field in This Column ([]) button.
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Creating Notes for Fields

Stylus Studio allowsyou to create noteson individual fields. These notesarefor reference
purposes only; they are not output in the XML.

00 To create notes for a field:
1. Click the entry field for the Notes property.

Tip The Notes property isin the Field Element Name > Source Data Type treein the
Properties window. These properties appear only for rows for which a match pattern
exists. See “Pattern Matching” on page 257 for more information on this topic.

The Notes dialog box appears.

Figure 176. Notes Dialog Box

2. Type the notes you want to associate with the field and click the OK button.

Tip If afield has anote defined for it, it is displayed in atooltip which appears when you
hover the mouse pointer over the field in the Custom XML Conversion Editor.

Component and Sub-Component Fields

Some file formats — many EDI variants, for example — allow fields to be subdivided into
arrays, sub-fields, or composite fields. Collectively, these fields are referred to as
component fields in custom XML conversion definitions. Typically, the headers of these
files contain information about the character used to specify component fields. Stylus
Studio uses this information to set the default value for the Field Component Separator
property and render XML output accordingly.
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Consider thefollowing input file, which uses a semi-colon (;) to specify component fields:

Make; Mbdel ; Year ; Col or ; Seat

BMA RL150RS; 2004; gr ey, net al | i c; bl ack, vi nyl
MZ; Scor pi on; 1995; gr een, cl ear coat ; bl ack, vi nyl
Ducati ; ST2; 1997; r ed, cl ear coat ; bl ack, | eat her

Using the first row to supply the field names and default Component Element Name
(component), the custom XML conversion definition creates the following XML output
(first two elements shown for brevity):

<?xm version="1.0" encodi ng="utf-8"?>
<r oot >
<r ow>
<NVake>BMM/ Nake>
<Mbdel >R1150RS</ Mbdel >
<Year >2004</ Year >
<Col or >
<conponent >gr ey</ conponent >
<conponent >mrret al | i c</ conponent >
</ Col or >
<Seat >
<conponent >bl ack</ conponent >
<conponent >vi nyl </ conponent >
</ Seat >
</ row>
<r ow>
<Make>MZ</ Make>
<Mbdel >Scor pi on</ Model >
<Year >1995</ Year >
<Col or >
<conponent >gr een</ conponent >
<conponent >cl ear coat </ conponent >
</ Col or >
<Seat >
<conponent >bl ack</ conponent >
<conponent >vi nyl </ conponent >
</ Seat >
</row>

The <component> elements are created as subel ements of the <Color> and <Seat> €l ements.

For line-oriented regionsin files containing component fiel ds, you can change the default
Field Component Separator property, and the Component Element Name and
Component Element Name properties, that is, the name you want to use for the
component fields' container elements.

254 Stylus Studio® 2010 User Guide



Controlling XML Output

Controlling XML Output

Custom XML conversion definitions provide several ways for you to control the XML
output. Most XML output is specified using properties displayed in the Properties
window. Some XML output, such as the number of regions or the number of fieldsin a
row, are specified using the Custom XML Conversion Editor.

This section describes the properties used to control some of the most common output
operations. See “ Custom XML Conversion Definitions Properties Reference” on
page 280 for detailed information on al properties.

This section covers the following topics:

« “Specifying Element Names’ on page 255

« “Specifying Format” on page 256

« “Omitting Regions and Fields, and Rows’ on page 256

o “Pattern Matching” on page 257

« “Using Lookup Lists” on page 262

o “Using Key=Value Characters’ on page 265

Specifying Element Names

You can specify namesfor the following nodes in an XML document output by a custom
XML conversion definition:

« Root element — The default for the <root> element is root. You can change the default
using the Root Element Name property.

« Region element — The default for the <region> element is region. You can change the
default using the Region Element Name property. Different regions can have different
names.

« Namespace — You can specify names for both the namespace prefix and the
namespace using the Namespace and Namespace Prefix properties, respectively. The
namespace prefix you specify is added to every element name.

o Row element — The default for the <row> element is row. You can change the default
using the Row Element Name property. Rows in different regions can have different
names.

o Field element — The default for the <field> element is field. You can change the
default using the Field Name property. Each field can haveitsown name. If your input
file defines subelements. you can use the Component Element Name and Sub-
Component Element Name properties to provide a name for the containing element.
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Specifying Format

There are several ways to exercise control over the format of the XML document output
by a custom XML conversion definition.

Indenting — By default, Stylus Studio indents the XML generated by a custom XML
conversion definition. You can remove indenting by changing the value of the Indent
XML? property to False.

Whitespace — The Normalize Whitespace property converts tabs, carriage returns,
and line-feeds to spaces. Leading and trailing whitespaces are then removed, and any
two or more consecutive whitespaces are collapsed to a single space.

XML Schema— The XML Schema Document property allows you to specify the
XML Schemayou want to associate with the XML output. There are aso fields that
alow you to specify System and Public DTDs.

Omitting Regions and Fields, and Rows

Stylus Studio allows you to omit specific regions and fields from an input file when it is
converted to XML.

Omitting regions— The Omit from Output property letsyou omit an entireregion from
XML output. (Regions with aRegion Type of No-output are always omitted from
XML output.)

Omitting fields — The Omit from Output property lets you omit afield from XML
output. You can omit afield

= Only when it is empty. Thisisthe default.

=  Whenitisempty or evaluates to a zero value.
» Always, regardless of itsvalue

= Never, regardless of its value

Comments— You can filter rows using the Comment String property — if the
beginning of arow matches the string you enter for this property, Stylus Studio
ignores the row when converting the input fileto XML. You can a so specify patterns
that rows must match in order for them to be converted to XML. See “Pattern
Matching” on page 257 for more information.

256
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Pattern Matching

You can use regular expressions to specify match patterns for the rows in the input file.
Only those rows in the input file that match the pattern you specify are output to XML
when the fileis converted. The simplest way to define a match pattern isto use the Match
Pattern property in the Row Element Name section of the Properties window.

Example
Consider the following input file:

Make, Model , Year, M | eage

BMV R1150RS, 2004, 14274
Kawasaki , GPz1100, 1996, 60234
Ducat i, ST2, 1997, 24000

Mt o Quzzi, LeMans, 2001, 12393
BMWV R1150R, 2002, 17439

Ducat i, Monst er, 2000, 15682
Aprilia, Futura, 2001, 17320

If you specify asimpleregular expression, say, AB, for the Match Pattern property, Stylus
Studio displays the input file in the Custom XML Conversion Editor as shownin

Figure 177 — green check marks identify the rows that match the pattern, and red X's
identify the rows that do not. (You can also display matching rows in a contrasting color
by clicking the Highlight Matching Rows button. See“ Document Pane Display Features’
on page 230 for more information about this feature.)

Properties x

Sub-Campa... - | i e Unlitled_._’|
Fiegion Ter.. - x = e
Collapze Ca falze L= e . . B = "B

=/ <rooty
=l Region 1

Mode 1 Year Mileage, .
R1I1S0RS=004p414=27 4

Double Deli... | tue
=-*= Row Elemen

Grz1100f199 60234
-'E‘.F:‘ds emenDt--- tc"_e sTZ f155782 4000

= JTDU';:m:“-" e ifremans Wzo01f123533
T LetPa. | TAE R1150FR M=2002p417 432
T PRightP.. | TAB." XPDucati Monzter@z000815682
T Ot fro. | Orly'when Empty Ri)aiprilia Futura MZ001M17320
T #MLOu.. | element
T Lookup ..
T Motes < 2y

"= Target Data... | BbAW

Figure 177. Match Pattern — Definition and Display

Notethat the match pattern al so appears as anew nodein the schemapane. Thisnew node,
the only one defined for the custom XML conversion definition at this point, uses the
default row element name (row) and the value of the expression.
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Since the match pattern selects only those rows that begin with the letter B, the custom
XML conversion definition creates the following XML document when it is run against
theinput file:

<?xm version="1.0" encodi ng="ut f-8"?>
<r oot >
<r ow>
<Make>BMN/ Make>
<Mbdel >R1150RS</ Mbdel >
<Year >2004</ Year >
<M | eage>14274</ M | eage>
</ row>
<r ow>
<Make>BMN/ Make>
<Mbdel >R1150R</ Model >
<Year >2002</ Year >
<M | eage>17439</ M | eage>
</ row>

See “Working with Nodes” on page 260 to learn about adding the row element
name/match pattern pairs that define them.

Sample Regular Expressions
The following table presents some commonly used regular expressions.

Expression Matches

"ABC Match all lines starting with “ABC”

NAE[Bb][Cc] Match all lines starting “ABC”, “abc” or
any mix of upper and lowercase (“*Abc”,
for example)

AAA Match all lines containing “AAA”

NDEF | GHI) Match al lines starting with “DEF” or
“GHI”

XYZ$ Match all lines ending with “XY Z"

XYZ\$ Match all lines containing “ XY Z”

Go to http://java.sun.com/j2se/1.5.0/docs/api/java/util/regex/Pattern.html tO
learn about the specific regular expression implementation supported in Stylus Studio. Go
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tohttp://www.boost.org/1ibs/regex/doc/syntax.htm1 for additional examplesof regular
expression usage.

Specifying Multiple Match Patterns

You can specify multiple match patternsfor asinglefile. If we define anew match pattern,
AK, this resultsin a new node (<row> “AK”) in the schema pane, which now displays both
nodes (see Figure 178). When an input fileis converted, Stylus Studio matches the
patterns in the order in which the nodes that represent them are defined in the schema.
Blank patterns are always matched last.

When you define multiple match patterns, the document pane displays a gray square
alongside rowsthat match apattern other than the one, if any, associated with the currently
selected row. In Figure 178, for example, row 3 is the currently selected row; it matches
the pattern Ak we have defined. Because row 3 is the active row, Stylus Studio displays
gray squaresin rows 2 and 6 (which match the pattern B defined previously).

7 7 & % Unitled. %

re@ O === E=N B CE
#»ilMake fiicde]l HWyearfdileage . <raoty

2 i Br1150rsg2004f14274 O B Regiont
VEfRawasaki Merziioof19oefenzas X
READ L cat i - By jLl227@=24000 DA
®EYicte SuzziLeMans MZ001M12393 Bal
BMW Br1150R HZ00Zp17439 A
RYADucatl Acnzter@M2000M15682
Xijiprilia Brutura MZ001817320

£ >y
K.awazaki

Figure 178. Gray Squares Identify Rows That Match Other Patterns
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Working with Nodes

In addition to defining nodes using the Match Pattern field of the Properties window, you
can also use the Set Node and Match Pattern dialog box, shown here:

O

Set Node and Match Pattern

Row Element Name:

Match Pattern: iy

Figure 179. Set Node and Match Pattern Dialog Box

Thisdialog box allowsyou to

Define a new node — even one that does not match arow in the current input file. For
example, we could define amatch pattern for Triumph motorcycles (<row> “AT”) even
though there are no Triumph motorcyclesin the input file.

Clone an existing node — this allows you to copy an existing node and modify its
match pattern to create a new node.

Edit an existing node. (You can aso do thisin the Properties window, of course.)

When you open the dialog box, the Row Element Name and Match Pattern fields contain
default values that reflect the currently selected row in the document pane or node in the
schema pane.

Defining a New Node

To define a new node:

1.

2.

Select arow in the document pane or a node in the schema pane.

Select CustomXMLConversion > Add Node and Pattern from the Stylus Studio
menu.

Alternative: Select Add Node and Pattern from the document pane or schema pane
shortcut menu.

The Set Node and Pattern dialog box appears.
Change the default values in the Row Element Name and Match Pattern fields.
Click OK.
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Cloning a Node

O To clone anode:

1. Select the node in the schema pane that you want to clone.
Alternative: Select the row in the document panethat is represented by arow element
name/match pattern pair you want to clone.

2. Select CustomXMLConversion > Clone Node and Pattern from the Stylus Studio
menul.

Alternative: Select Clone Node and Pattern from the document pane or schema pane
shortcut menu.

The Set Node and Pattern dialog box appears.

3. Change the default values in the Row Element Name and Match Pattern fields as
needed.

4. Click OK.

Editing a Node

O To edit anode:

1. Select the node in the schema pane that you want to edit.
Alternative: Select the row in the document panethat is represented by arow element
name/match pattern pair you want to edit.

2. Select CustomXMLConversion > Edit Node and Pattern from the Stylus Studio menu.

Alternative: Select Edit Node and Pattern from the document pane or schema pane
shortcut menu.

Alternative: Double-click the node.
The Set Node and Pattern dialog box appears.

3. Change the default values in the Row Element Name and Match Pattern fields as
needed.

4. Click OK.

Removing a Node

When you remove anode, you are deleting the row element name/match pattern pair from
the custom XML conversion you are defining.
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00 To remove a node;:

1. Select the node in the schema pane that you want to remove.
Alternative: Select the row inthe document panethat is represented by arow element
name/match pattern pair you want to remove.

2. Select CustomXMLConversion > Remove Node and Pattern from the Stylus Studio
menu.

Alternative: Select Remove Node and Pattern from the document pane or schema
pane shortcut menu.

Alternative: Press the Delete key.
A warning message appears.

3. Click Yes to remove the node, otherwise click No.

Using Lookup Lists

You can define lookup lists for individual fields. When Stylus Studio converts the input

file, it replacesthe string in the input file (the lookup) with the value you have defined for
itinthe Lookup List dialog box. Figure 180 shows an example of alookup list that has

been defined for a Status field:

Lookup List X
Lookup Walue -~
a0 Cantinue
1M Switching Pratocals Cancel
200 ok
20 Created

202 Arcepted
203 Mon-Authoritative Information Copy
204 Mo Content
205 Reset Cortent Paste
206 Partial Content
300 tultiple Choices Append
3m toved Permanently
anz2 Found

303 See Other

304 Mot Modified Insert
305 Use Pra=y
307 Temporary Rediect w Delete

Figure 180. Sample Lookup List

For any status fieldsin theinput document with avalue of, say, 100, Stylus Studio would
convert that value to Continue in the XML document it outputs; values of 202 would be
converted to Accepted; and so on.
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Input file values that do not match alookup are emitted in the XML document as-is,
allowing exceptional values to be decoded. For example, you might have atemperature
lookup list with these values for a <Temperature> field:

32 | Freeze

212 | Boil

All other temperatures would be emitted as-is.

Defining Lookup Lists

Lookups are case-sensitive, so, for example, alookup of bmw would not match any of the
Make fields in the following samplefile:

Make, Model , Year, M | eage

BMN R1150RS, 2004, 14274
Kawasaki , GPz1100, 1996, 60234
Ducat i, ST2, 1997, 24000

Mot o Quzzi, LeMans, 2001, 12393
BMN R1150R, 2002, 17439

Ducat i , Monst er, 2000, 15682
Aprilia, Futura, 2001, 17320

You can definelookup listsonly for fieldsin rowsfor which amatch pattern (even ablank
match pattern, as is the default) exists. Finally, you can paste comma- and tab-delimited
text directly into the lookup list. Thisallows you to easily reuse existing lookup tables
without having to re-enter text.

0 To define alookup list:
1. Select arow for which a match pattern exists.

2. Click the Lookup List entry field in the Properties window.
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The Lookup List dialog box appears.

Lookup List

Lookup WYalue

Cancel

LCopy
Paste

Append

Insert

Delete

Figure 181. Lookup List Dialog Box

3. Enter lookup/value pairsin the corresponding entry fields.

4. When you are done, click OK.
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Working with Lookup Lists

Thefollowing table summarizesthe functions of the Lookup List dialog box, which allow
you to work with new and existing lookup lists.

Table 21. Lookup List Dialog Box Buttons

Button Function

OK Commits the lookup list to the custom
XML conversion.

Cancel Closes the Lookup List dialog box
without committing any changes.

Copy Copies the lookup list.

Paste Pastes comma- and tab-separated text into

the lookup list. Replaces existing content,
regardless of which row you have selected

Append Adds comma- and tab-separated text to the
end of the lookup list. Existing lookup list
content is preserved.

Insert Adds anew row to the lookup list.
Delete Removesthe selected row from the lookup
list.

Note Copy, Paste, and Append use the system clipboard and insert at the current cursor
location. Any blank rows are discarded when you save the lookup list.

Using Key=Value Characters

The Key=Value Character Region property allows you to set the separator for key=value
pairs as seen in the input file. When Stylus Studio converts an input fileto XML, it uses
the value on the left side of the key=value character for the element name, and the value
on theright for the element value. Consider the following input file:

Triunph Inventory, Year and Quantity
Yr 2003=24
Yr 2004=12
Yr 2005=15
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If you set the Key=Value Character property to =, Stylus Studio creates the following
XML document when you preview the custom XML conversion:

<?xm version="1.0" encodi ng="ut f-8"?>
<r oot >
<r ow>
<fiel d>Tri unph I nventory</fiel d>
<field>Year and Quantity</field>
</ row>
<r ow>
<Yr 2003>24</ Yr 2003>
</ row>
<r ow>
<Yr 2004>12</ Yr 2004>
</ row>
<r ow>
<Yr 2005>15</ Yr 2005>
</ row>
</root >

Using Custom XML Conversion Definitions in Stylus
Studio

You can use custom XML conversion definitions to open any fileas XML anywherein
Stylus Studio. For example, you might want to use atext file (. txt) as the source
document for X Query Mapper. When you open afile using a custom XML conversion
definition, the XML Converters engine converts that file to XML on-the-fly, using the
settings defined in the custom XML conversion definition you select.

You can aso use the DataDirect XML Converters API to invoke a custom XML
conversion definition (or an XML Converter). See the documentation for DataDirect
XML Converters for more information:
http://www.datadirect.com/techres/xmlconvertersproddoc/index.ssp.

How to Open a File Using a Custom XML Conversion Definition
You can usethe Open dialog box to open afile using acustom XML conversion definition
in Stylus Studio.

0 To open afile using a custom XML conversion definition from the Open dialog box:

1. Display the Open dialog box (select File > Open from the Stylus Studio menu, for
example).
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2. Navigate to the directory that contains the file you want to open using the custom
XML conversion definition and select thefile.

3. Check the Open using XML Converter check box and click the Open button.

URL: | bikes bt | Open *
Files of tvpe: | Al Files (%) v| [ cancel |
c [] Open using ML Converter D

Figure 182. Check Box to Open Files Using XML Converters

Stylus Studio displays the Select XML Converter dialog box.

Select XML Converter E|

:3 B ase-64 encoding of a binary file a: »~ Property Value

=] CommaSeparated Yalues [C5Y)

EH] Custom »ML Conversion

:a Drata Interchange Format [DIF)

] dBase |l [dBase_ll)

@ dBase Il [dBase_lIl)

] dBasze lll+ [dBase_lll_pluz)

| dBasze IV [dBaze_ V]

i dBazeV [dBase_ V)|

=] E-mai mbo (MBox)

lEtd] Electronic Data Interchange [EDI)

:3 Encoding of a binary file as a seque

:a Java properties Fils [JavaProps]
| >

Line separatar crlf
Encading utf-8

5

URL: ‘ converter:Base-64 Hile: /A \testingh 831,112

| OF. | [ Cancel ]

Figure 183. Select XML Converter Dialog Box
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4. If you are using acustom XML conversion definition (.conv), select Custom XML
Conversions. Then, use the browse button in the Value field to locate the custom
XML conversion definition you want to use. Go to step 5.

Select XML Converter, g|
:a B ase-B4 encading of a binary file a: » Property Value

s Camme-Geparsted £z [CSV) Definition URL |

EH] Custorn #ML Conversion

| dBaze |l [dBasze_ll)

d dBaze Il [dBaze_lIl]

) dBase |+ [dBase_lll_plus)

] dRiass 1V (dBase V)

:a dBase " [dBaze V)

_'_'5 E-mail rmbax [MBaox)

m Electronic Data Interchange (EDI)

s Ercoding of a binary file a: a seque
:a Java properties File [JavaProps] s
< ¥

URL: ‘ converter: file: /e vestingh831.412 ‘

[ 0k ] [ Cancel ]

Figure 184. Selecting a Custom XML Conversion Definition

5. Click OK.
Thefileisconverted to XML and appearsin the editor from which you displayed the
Open dialog box in step 1.
Tip You can use the same basic procedure, from the Save As dialog box, to save afile using
acustom XML conversion definition. See “ Saving an XML File in Another Format” on
page 220.
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The Converter URI Scheme

You can usethe converter: URI schemeto reach avariety of data sourcesusing DataDirect
XML Converters and custom XML conversion definitions.

Where You Use Converter URIs

You can use converter URIs as the argument in XQuery and XSLT 2.0 doc() functions,
and in XSLT 1.0 document() functions.

Specifying a Converter URI

To specify a converter: URI, you need to specify

« The XML Converter you want to use — EDI, CSV, dBase, custom XML conversion
definition (. conv file), and so on.

o Vduesfor any XML Converters properties (separator or escape characters, for
example) for which you do not want to use the default values. Options for custom
XML conversions are part of the custom XML conversion definition and are not
specified.

« Thefileto be converted.

Example — Converter URI with a DataDirect XML Converters™

A converter: URI that invokes the DataDirect XML Converter for comma-separated
values (CSV) to convert the three. txt filein the Stylus Studio\examples directory to
XML might look like this;

converter: CSV:new i ne=lf:first=yes:?file:///c:/StylusStudi o/ exanpl es/
three. txt

Theinstructions to the XML Converters engine from this instance of the converter:URI
are described the following table.
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Table 22. URI Scheme Example

Instruction Converter URI String

Use the Comma-Separated Values XML converter:csv
Converter converter

Theline separator in the source fileisa newline=1f
line feed

Thevaluesinthefirst row of thesourcefile | first=yes
should be used to supply field names

The sourcefileis three.txt file:///c:/StylusStudio/examples/three.txt

Propertiesthat use default values (acommaisthe default separator character for the CSV
XML Converter, for example) do not have to be specified in a converter:URI.

Example — Converter URI with a Custom XML Conversion Definition

A converter URI that referencesacustom XML conversion definition might look likethis:

converter:///nyConverter.conv?file:inventory.txt

This converter uses myConverter. conv to convert the file inventory. txt to some format
(specified in the custom XML conversion definition when it was built using the Custom
XML Conversion Definition Editor in Stylus Studio). Note that individual configuration
properties are not specified — they are part of the definition described in the . conv file.

Converter URI Syntax

The converter URI syntax isthe same whether you are using them for DataDirect XML
Converters™ or custom XML conversion definitions.

converter: nane: [property_nane=val ue: | property_name=value: | ...]?file:file
URL

Where:

« nameisthe name of the DataDirect XML Convertersor the . conv file name of a
custom XML conversion definition.
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The names for XML Converters names are displayed in Stylus Studio; see “Where
Converter URIsare Displayed in Stylus Studio” on page 272. They are also described
in the DataDirect XML Converters™ documentation; see
http://www.datadirect.com/techres/xmlconvertersproddoc/index.ssp.

« property_nameisthe name of aDataDirect XML Converters™ property. You need to
specify a property and its value only if you want to configure the converter to use
something other than the default value. You do not specify properties for custom
XML conversion definitions.

XML Converters™ properties are displayed in Stylus Studio; see “Where Converter
URIs are Displayed in Stylus Studio” on page 272. They are also described in the
DataDirect XML Converters™ documentation; see
http://www.datadirect.com/techres/xmlconvertersproddoc/index.ssp.

. file URL isthe URL of thefile you want to convert.

XML Converter Properties

While the format of the converter:URI is the same from one XML Converter to another,
XML Converters have different properties. For example, the XML Converter for dBase
files has settings that the XML Converter for binary files does not.

In addition, property namesin converter URL s appear in an abbreviated format —the Line
separator property iscaled newline in a converter:URI.

XML Converters properties are displayed in the Select XML Converter dialog box, as
shown in Figure 183. Seethe DataDirect XML Converters™ User’s Guide and Reference
for compl ete properties reference information:
http://www.datadirect.com/techres/xmlconvertersproddoc/index.ssp.
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Where Converter URIs are Displayed in Stylus Studio

Converter URIs are displayed in the following places in Stylus Studio:
« TheURI field of the EDI to XML editor:

Stylus Studio 2009 XML Enterprise Suite - [Untitled3.sef *] CEX
g File Edit Wiew Project Debug EDI SourceControl Tools Window Help -3 X
SR 1 - MR 0
‘m Untitled.._=
e N ESE: | 004030 v [z ]
__________________ HIsa:00: 00 O 5 :01:51515151
£ Transaction Messa... HEE:0T: 99887 76655: 1122334455 : 20041201:1217:128: £: 004030
B Segments HarT:831:00128001
---5 Composites BGN:00:88200001: 20041201
(5 Elemens N9:BT:88200001
- Code Lists TRN:1:088200001
HAMT: 2 : 100000.00
QTv¥:46:1
@E:7:00128001
GE:1:1Z28
TEA:1:000032123
£ | »|B@ Noerrors Found, # FPiev B Mest
Ln 12 Cal 1 Char 0 {00000} NLIM

For Help, press F1

Figure 185. Converter:URI displayed in the EDI to XML Editor

You usethe EDI to XML editor to create conversion filesthat you can save and reuse.
See Chapter 4 “Converting EDI to XML” for more information.
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The URI field of the Select XML Converter dialog box displaysthe converter:URI for

.
the XML Converters or custom XML conversion definition you have selected.
Select XML Converter
Property Walue
Line separatar crlf
Encading 150-88531
Separator .
4 Firt rowe contains field names no
) dBase Il [dBase_lIl) Escape charactsr \
| dBaze lll+ [dBase_lll_plus] Quate characters "
| dBase IV [dBase_IV] Mumber rows and columns no
] dBase [dBase V) Collapse consecutive separators | no
s E-mai mpox [MBo) Doubling embedded quote esc... | no
lEtd] Electranic Data Interchange (EDN) Boot element name table
& Encoding of a binan fle as & seque Row element name Tow
:a Java .properties File [JavaProps]  »
< *
@erter:CSV?fiIe:a’a’w:\testing;Wt) ‘
e —— [ ——
i [ 0k ] [ Cancel ]
Figure 186. Converter:URI Displayed in the Select XML Converter Dialog Box
Note that XML Converters name and properties used in the converter:URI vary from
the full names displayed in the Select XML Converter dialog box. In addition, note
that only properties whose default value you change in the value field are displayed
inthe URL field.
o TheProject window (select Show Full URL from the Project window shortcut menu)

displays the converter:URI used to create an XML document:

Project [X]
ss |PED atE.java A~

wair IntDatews!
e InD ate
=8 Other Documents
e ACtors.report
lw actors.iquery
brat [ converter CSY:newline=If first=yes Tfile: /7w Aesting/bikes.at
e newHoIL@gs.txt
fn wideos.xml

Figure 187. Converter:URI Displayed in Project Window

Stylus Studio® 2010 User Guide 273



Converting Non-XML Files to XML

You can use any of these sources for the converter:URI strings you want to use in your
XQuery and XSLT code. See “Using Stylus Studio to Build a Converter URI” on
page 274 for more information.

Tip Converter URIsin the Select XML Converter dialog box are already escaped and can be
used as-is. Converter URIs taken from the Project window must be escaped manually
when you paste them into your XSLT or X Query code.

Using Stylus Studio to Build a Converter URI

If you have Stylus Studio 2010 XML Enterprise Suite, you can use Stylus Studio to
construct converter URLs. Converter URIs can be complex — property names and their
values vary from one XML Converters to another, for example — so using Stylus Studio
to construct them can reduce errors in your applications.

Using the URI in the Select XML Converter Dialog Box

0 To construct a converter URI using the URI in the Select XML Converter dialog box:

1. Usethe XML Convertersto open afile asan XML document in Stylus Studio. See
“Using XML Convertersto Open aNon-XML FileasXML”" on page 219or “How to
Open a File Using a Custom XML Conversion Definition” on page 266 if you need
help with this step.

2. Beforeclicking OK to complete the conversion, copy the converter:URI in the URI
field of the Select XML Converter dialog box (see Figure 186).

3. Click OK to completethe conversion. (You can click Cancel if you are peforming this
procedure just to obtain the converter:URI.)

4. Paste the converter URI in your XSLT or XQuery code as needed.
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Using the URI in the Properties Window

(0 To construct a converter URI using the URI in the Properties window:

1. Usethe XML Convertersto open afile asan XML document in Stylus Studio. See
“Using XML Convertersto Open aNon-XML FileasXML” on page 219or “How to
Open aFile Using a Custom XML Conversion Definition” on page 266 if you need
help with this step.

Tip New documents are placed in the Other Documents folder in the Project window by
default.

2. Openanew document in any Stylus Studio text editor (for example, File > New > XML
Document).
The purpose of this step isto provide an editor into which you can drag-and-drop the
the document you created in step 1 in order to display the associated converter:URI.
3. Drag the document you created in step 1from the Project window and drop it into the
text editor you opened in step 2.
The complete URI appears in the text editor.

Praoject L =
v sampleBooksToCatalogesl
=23 ®5LFormattingObjects
v Catalog.ss!

wa Untitled...” |

GomEWy £ & W
e Minimal-catalog. ksl <?xm]l wersion="1.07"72>

e T converter: C3Vinewline=1f: first=yes?file:///w: /testing
wn chartzml

wur Chartwsl

= a quiotes

e our-quotes. sl

wur our-guotes.xsl
-3 javak wension

v IntD ate xquery

s, [0 atejava

wr IntDate.xsl

an IntDate. il
= BB Other Documents
pue  SCtorsreport

e gs.txt%
Figure 188. Copying a URL to a Text Editor

H

4. Copy the complete converter URI.
5. Pastethe converter URI in your XSLT or XQuery code as needed.

Note: Escape characters as required for stringsin Java programs. For example,
escape=\:quotes="'"becomesescape=\\:quotes="\" (the single quote does not need to be
escaped).
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Working with EDI Conversions

You can convert EDI to XML (and vice versa) in Stylus Studio using the built-in
DataDirect XML Convertersfor EDI. The XML Convertersfor EDI handles most
versions of EDI standard dialects (see Supported EDI Dialects on page 276)
automatically, and it optionally performs validation of content, structure, and code list
values.

This section describes more about the level of support for converting EDI to XML (and
vice versa) in Stylus Studio.

Watch it! You can view a video demonstration of this feature by clicking the
television icon or by clicking this link: watch the EDI to XML Mapping video. A
complete list of the videos demonstrating Stylus Studio’s features is here:
http://www.stylusstudio.com/xml_videos.html.

This section covers the following topics:

« “Supported EDI Dialects’ on page 276

« “Converting Custom EDI Message Types’ on page 277

« “Documentation for DataDirect XML Converters’ on page 279
o “XML Schemasfor Custom EDI Message Types’ on page 279
o “Validating XML from/to EDI” on page 280

Supported EDI Dialects

DataDirect XML Converters supports the following EDI dialects:

« ATIS

« Cargo-IMP

« EANCOM

. EDIFACT

. Edig@s

« HL7

« NCPDP

« PADIS

« TRADACOMS
.« X12
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Working with EDI Conversions

Visit http://www.datadirect.com/products/data-integration/datasources/edi-
standards/index.ssp to learn detailed information about version and message support for
all suppored EDI dialects.

Converting Custom EDI Message Types

DataDirect XML Converters supports the Standard Exchange Format (SEF). SEF allows
you to describe structure of an EDI document based on an extension (or restriction) to a
standard EDI message type. You can instruct the EDI XML Converter to read your SEF
extension file and use it when converting your proprietary EDI to XML.

Working with SEF Files

You can build a SEF file based on the SEF specification. A copy of the SEF standard
specification has been placed on the DataDirect Technologies web site:

http://www.datadirect.com/docs/sefl6l.pdf

A far easier way isto usethe Sylus Sudio EDI to XML moduleto create a SEF file. Using
graphical tools, the EDI to XML editor allows you to

Take advantage of the XML Converters' repository of numerous EDI dialects and
versions

Create a SEF file based on a sample EDI document or an EDI dialect

Customize an EDI diaect to suit your needs — changing a segment from mandatory
to optional, for example

Modify XML Converters properties
Preview conversions of custom EDI to XML

See Chapter 4 “Converting EDI to XML” for more information.

Process Overview

The process for converting a custom EDI message type includes the following steps:

1.

Create a SEF file (mycustomeDI. sef, for example) that describes how the custom EDI
message type differs from the EDI standard on which it is based — its extensions or
restrictions, in other words. The purpose of this document is to teach the DataDirect
XML Converters engine about the differences between your custom EDI message
type and the EDI standard message type on which it is based.
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2. Openthe EDI file you want to convert to XML. Select File > Open, and then select
the Open Using XML Converter check box.

3. Select the EDI XML Converter in the Select XML Converter dialog box.

4. Specify thefile URL for the SEF file (mycustomEDI.sef , for example) in the
Extension map file property. See “ Specifying the SEF File Location” on page 278 if
you need help with this step.

Select XML Converter E|

:a Baze-B4 encoding of a binary file a: & Property Walue ~
:3 Comma-Separated Yalues [C5W)

Line separatar crlf
EH] Custom »ML Conversion Encoding )
:a Drata Interchange Format [DIF) CIxtension rnap file |
s dBase |l [dBase_ll) Enable walidation ‘}ETD
s dBase IIl [dBase_Il] Comment code list data yes
:a dBase lll+ [dBaze_lll_pluz) Comment element types ves
si] dBase IV [dBase_V) Strict validation on value lengths ho
s dBase v [dBase V) Strict segment-ordering checking yes
Sl Eamal e B Farce error if walue not in code list J=
EE Strict datatype content checking yes
[ E e bt S seque Treat all segments and elements a3 optio... | ho
M) Java.propetties File avaProps) % | | Enforce segment maximum counts no
< bd Add linefeeds between seqments on wite | yes b

URL: | corverter:EDI: count=no: following=sss file: A4 \testingsbatch, sml

[ 0K ] [ Cancel ]

Figure 189. Specifying a Custom EDI Message Type

5. Click OK to convert your custom EDI message type to XML.

Specifying the SEF File Location

You can specify the location of the SEF file in the Extension map file property using
o Anabsolute URL (c:/mypath/mycustomeDI.sef, for example)

« A relative path (mydir/mycustomEDI.sef, for example)

Note that if you are using arelative path, it must be relative to the same directoriesin
which the DataDirect XML Converters executables are installed:

o For XML Convertersfor NET —Stylus Studio install ation directory\ compontents\XML
Converters for .NET\bin\XMLConverters.dll

o For XML Convertersfor .Java— Stylus Studio installation directory\compontents\XML
Converters for Java\lib\XMLConverters.jar

In environments in which the location of the XMLConverters.* file cannot be determined,
you must specify the location. For example:
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o For XML Convertersfor .NET — set the registry key HKLM/Software/DataDirect/XML
Converters 5.0/ProductLocation

o For XML Convertersfor Java — set the system property
com.ddtek.xmlconverter.bindir, Or com.ddtek.xmlconverter.libdir

Documentation for DataDirect XML Converters

Documentation for DataDirect XML Convertersis available in several locations and
formats for XML Converters for both Java and .NET.

Stylus Studio Installation
You canfind XML Converters documentation in thefollowing folderswhereyouinstalled
Stylus Studio:
« .NET

= \compontents\XML Converters for .NET\doc —PDF version of the User's Guide
and Reference and Installation Guide

= \compontents\XML Converters for .NET\help—HTML version of the User’s
Guide and Reference

« Java

= \compontents\XML Converters for Java\doc —PDF version of the User's Guide
and Reference and Installation Guide

= \compontents\XML Converters for .NET\help—HTML version of the User’s
Guide and Reference

DataDirect Technologies Web Site
You can find XML Converters documentation on the DataDirect Technologies web site:

http://www.datadirect.com/techres/xmlconvertersproddoc/index.ssp

XML Schemas for Custom EDI Message Types

Warning Thisfunctionality has been deprecated in favor of support for the Standard Exchange
Format (SEF). Use SEF files to describe the XML Schemafor custom EDI message
types. For more information, see Chapter 4 “ Converting EDI to XML".
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Validating XML from/to EDI

Stylus Studio providesthe EDI to XSD document wizard to convert various EDI dialects
and message typesto XML Schema. Such an XML Schema can be useful if you are
converting XML to EDI, because it allows you to ensure that the EDI created by the
DataDirect XML Convertersfor EDI conformsto aparticular EDI message type standard.

You can also use the XML Schema created by the EDI to XSD document wizard to
validate data after you have converted EDI to XML, when URL-based error checking is
disabled, to determine how well the incoming stream conforms to the EDI standards.

See Creating XML Schemafrom EDI on page 577 for more information on using this
document wizard.

Custom XML Conversion Definitions Properties
Reference

This section provides reference information for properties displayed in the Properties
window of the Custom XML Conversion Editor. It covers the following topics:

o ‘“Input File Properties’ on page 281

o “XML Output URL Properties’ on page 282

« “Region Type Properties’ on page 284

« “Row Element Name Properties’ on page 287

« “Field Element Name Properties’ on page 288

. “DataType Properties (by datatype)” on page 290
« “Specifying Control Characters’ on page 311
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Input File Properties

Table 23. Input File Properties

Property Description Editable Affects XML
Input File The URL of thefileyouareusingas | Yes. You can No

theinput file. select anew

input file from
thisfield.

Input Encoding detected by Stylus Studio. Yes No
Encoding
Physical The size of the input file in bytes. No No
Size
Portion The size of the input file in bytes No No
L oaded loaded into Stylus Studio.
Characters The number of characters loaded. For | No No
L oaded especialy largefiles, Stylus Studio

does not read the entire fileas only a

sampleisrequired to define a custom

XML conversion definition. The

finished custom XML conversion

definition, however, reads any file you

open it with in its entirety.
Character The Unicode value of the character No No
Unicode under the cursor.
Value
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XML Output URL Properties

Table 24. XML Output File Properties

Property Description Editable Affects XML
XML Output | The URL towhichyouwantthe XML | Yes Yes
URL output when the custom XML

conversion definition is run. Optional.

If no value is specified, stdout is used.
Output The Encoding you want to use for the | Yes Yes
Encoding XML output by the custom XML

conversion definition. The default is

RAW.
Root The name you want to assign to the Yes Yes
Element root element in the XML output.
Name Optional.
Namespace | The string you want to use for the Yes Yes
Prefix namespace prefix in the XML output.

Optional
Namespace | Thenamespaceyouwanttouseforthe | Yes Yes

XML document output by the custom

XML conversion definition.
DOCTYPE | TheURL of theSystemDTD youwant | Yes Yes
System ID to associate with the XML document

output by the custom XML conversion

definition.
DOCTYPE | ThePublicID of theDTD youwantto | Yes Yes
Public ID associate with the XML document

output by the custom XML conversion

definition.
XML The URL of the XML Schema Yes Yes
Schema document you want to associate with
Document the XML document output by the

custom XML conversion definition.
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Table 24. XML Output File Properties

Property Description Editable Affects XML
XML The namespace you want to use with | Yes Yes

Schema the XML Schema document.

Namespace

Indent Whether or not you want to indent the | Yes Yes

XML? XML output.
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Region Type Properties

Note Eachregion hasitsown field and row properties. In addition, some properties apply only
to line-oriented regions. These properties are marked with an asterisk.

Table 25. Region Properties

Property Description Editable Affects XML
Region Type | The type of the region that currently Yes. You can No

has focus. change the

region type
from thisfield.

Region The name you want to assign to this Yes Yes
Element region in the XML output. Optional.
Name
Element Whether the source for the element Yes Yes
Name names in thisregion is user-supplied,
Source istaken from thefirst row in the

region, or is based on the WS-EDI

standard.
Rowsto Skip | The number of rows, starting at the Yes Yes

beginning of the region, you want to

omit from output.
Omit from Whether or not you want to omit the | Yes Yes
Output entire region from output.
Size Theregion'ssize in characters. No No
Portion of The starting and ending offsets of the | No No
File current region.
Row Count | The number of rowsin the current No No

region.
Row The number of charactersin the No No
Length* current row.
Line The type of line terminator character | Yes No
Terminator* | detected by Stylus Studio.
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Table 25. Region Properties

Property Description Editable Affects XML
Separator* The type of field separator character Yes No

detected by Stylus Studio.
Delimiter Sets of delimiting characters detected | Yes No
Pairs* by Stylus Studio.
Comment String used by the custom XML Yes Yes
String conversion definition —if the

beginning of arow matches the string

inthisfield, theconverter interpretsthe

row as acomment and does not output

itinthe XML.
Escape Allows you to distinguish escape Yes Yes
Characters* | characters from separators—if a

character in the input fileis preceded

by an Escape Character, that character

is not treated as delimiting character,

separator, or subsequent escape

character.
Toss Characters outside delimiting Yes Yes
Characters* | characters that should be ignored.
Key=Value | Allowsyou to set the separator for Yes Yes
Character key=value pairs as seen in the input

file.
Component | Thetype of character used to separate | Yes Yes
Separator* sub-fieldsdetected by Stylus Studio. If

this character appearsin astring, the

string is split into sub-fields when the

input fileis converted to XML.
Sub- The type of character used to separate | Yes Yes
Component | sub-fieldsdetected by Stylus Studio. If
Separator* this character appearsin astring, the

string is split into sub-fields when the

input file is converted to XML.
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Table 25. Region Properties

Property Description Editable Affects XML

Region The type of region terminator Yes No
Terminator character detected by Stylus Studio.
Theregion will be processed until this
string is encountered; after that point,
al remaining datain theregionis
skipped. The next region, if present,
will be handled immediately.

Collapse Whether or not multiple consecutive | Yes Yes
Consecutive | field separators should be treated as
Field one. For example, if thisproperty isset

Separators* | to Yes, X,,Y,,Zistreated as X, Y,Z.
This property is most useful when
spaces are used as delimiting

characters.
Double Whether or not to treat a pair of Yes Yes
Delimiter to | delimiting characters within a
Escape delimited string as escaped characters.

For example, if this property is set to
Yes, “abc”“xyz” istreated as
abc”xyz.

* This property isfor line-oriented regions only.

* This property is for fixed-width regions only.
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Row Element Name Properties

Table 26. Row Properties

Property Description Editable Affects XML
Row The name you want to assign to all Yes Yes
Element rowsintheregion. Thedefault valueis
Name row.
Match A regular expression you can use to Yes Yes
Pattern filter rowsin aregion. Only rows that

match the pattern you specify are

output to XML.
Current Row | Thelength of the current row. No No
Length
Fieldsin The number of fields in the current No No
Current Row | row.
Max Fields | The number of fields in the row that No No
in Row contains the largest number of fields.
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Field Element Name Properties

Note Eachregion hasitsown field and row properties. In addition, some properties apply only
to line-oriented regions. These properties are marked with an asterisk.

Table 27. Field Properties

Property Description Editable Affects XML
Field The name you want to use for field Yes Yes
Element elementsin the XML output. The
Name default valueis field.
Component | The name you want to use for sub- Yes Yes
Element fieldsdetected by Stylus Studio (based
Name on the Component Separator

character) in the XML output. The

default valueis component.
Sub- The name you want to use for sub- Yes Yes
Component | fieldsdetected by Stylus Studio (based
Element on the Sub-Component Separator
Name character) in the XML output. The

default value is subcomponent.
Source Data | The data type of the current field. No Yes
Type Stylus Studio provides support for the

following data types:

String, Boolean, number, date, time,

byte, short, integer, long, float, double.

Note that some properties are type-

specific.

See “Data Type Properties (by data

type)” on page 290 for information on

properties that are associated with

specific data types.
Target Data | Not currently used.
Type
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Table 27. Field Properties

Property Description Editable Affects XML
Number The number of thefieldin whichthe | No No
cursor islocated. Starting with 1 from
the left-most field.
Cursor The offset of the cursor’s current No No
Position location from the start of the current
field.
Offset The offset of the start of the current No No
field. Measured from the start of the
row.
Length The length of the current field in No No
characters.
Max Field The length of the longest of all the No No
Length * instances of thisfield.
Value The value of the current field. No No
This value also appears in the status
bar.

* This property isfor line-oriented regions only.
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Data Type Properties (by data type)

This section describes the properties that are specific to a given data type.

Common Properties
All data types support these properties:

Table 28. Common Properties

Affects
Property Description XML

Lookup List This property lets you build a substitution table for | Yes
output. It includes a two-column table. At runtime,
any itemwhich evaluatesto avalueintheleft column
is replaced by the corresponding value in the right
column in the output stream. A blank value on the
left can be used to set a default value for the field.
Note that thisis applied before the test to determine
if the data should be qualify for Omit from Output.

Notes Allowsyouto add internal commentsfor afield. Itis | No
not used by custom XML conversion definitions.

Omit from Output Allows afield to be omitted from XML output based | Yes
on its presence or value. Valid values include:
e Only When Empty. Thisisthe default.

e When Empty or Zero. Does not emit an e ement
containing the valueiif it evaluates numerically
to zero.

o Always. Always hides the field from the output.
o Never. Alwaysincludes the field in the output

XML Output Form Determines whether the value is emitted into the Yes
output stream as an €lement or as an attribute. The
default is element.

290 Stylus Studio® 2010 User Guide



Custom XML Conversion Definitions Properties Reference

BCD Datatype Properties

Binary Coded Decimal (BCD) isaset of waysto pack one or two decimal digitsinto each
byte. These are various related types of machine-specific encodings for numbers. The

Comp3 and Zoned types are different implementations of thisidea.

Table 29. BCD Properties

Property

Description

Editable

Affects XML

Architecture

Select the architecture that matches the
machine type that the data originated on,
or was designed for, from thislist:

« NBCD Signed

« NBCD Unsigned

o Excess3

« BCD 2421

« BCD84-2-1

o |BM 1401 Signed

« IBM 1401 Unsigned

Yes

Yes

Packed

The name you want to use for sub-fields
detected by Stylus Studio (based on the
Component Separator character) in the
XML output. The default valueis

component.

Yes

Yes

Scaling
Factor
(10™n)

The name you want to use for sub-fields
detected by Stylus Studio (based on the
Sub-Component Separator character) in
the XML output. The default valueis

subcomponent.

Yes

Yes
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Binary Datatype Properties

Binary datain raw form.

Table 30. Binary Properties

Property

Description

Editable Affects XML

Rendering

How the datais written to XML:

Base-64 Encoding — writes the data
in aform compatible with the W3C
XML Schema base64Binary type
(default)

Hexadecimal Encoding —writesthe
datain aform compatible with the
W3C XML Schema hexBinary type

— Octal Encoding — writes the data
asaseries of octal triplets

# Literal Encoding — copiesthe data
as-isto the output stream, which
may not render asvalid XML

Yes Yes

Boolean Datatype Properties

True/false values, with support for three-valued-logic (true/false’lunknown or null). The
following steps are taken to determine the value of aboolean field:

1. If thefield contains all binary zeros, it isfalse.
If thefield contains all binary ones (that is, all OxFF values), it istrue.

2
3. If thefieldis one byte long and contains a 0x01 value, it istrue.
4. |If thefirst or last bytein the field contains a 0x01 and all of the other bytes are 0x00,

itistrue.

5. If thecontents of thefield match any of theitemsinthe True Value Match List or False
Value Match List, then the value istrue or false respectively.
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6. If none of these rules apply, the value is considered unknown.

Table 31. Boolean Properties

Property

Description

Editable

Affects XML

True Value
Match List

A semicolon (";") -separated list of
values. If the input value matches any of
themin step 5, it is considered true and
the value from the True Output As
property is emitted. The default list is:
ey

o«

. yes

o ftrue

. Y.

« L

The comparisons are not case-sensitive.

Yes

Yes

False Value
Match List

A semicolon (";") -separated list of
values. If the input value matches any of
themin step 5, it is considered false and
the value from the False Output As
property is emitted. The default list is:

e N

o f

e NO

o« fase

e N

o« f

The comparisons are not case-sensitive.

Yes

Yes

True Output
As

If the value is determined to be true then

thisvalueisoutput. The defaultis"Yes".

Yes

Yes

False Output
As

If thevalueisdetermined to befalsethen
thisvalueis output. The default is"No".

Yes

Yes
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Table 31. Boolean Properties

Property Description Editable Affects XML
Unknown If the value cannot be determined astrue | Yes Yes
Output As or false, then this value is output. The
default is"?".
Left Thesetwo propertiescontrol what sort of | Yes Yes
Padding, padding is to be found on either side of
Right the field and then removed. Any
Padding characters listed here will be removed.

Characters can be specified either by
their Unicode values, their Unicode
names, or single-quoted.

The default for both is spaces (0x20) and
tabs (0x09).

If there are field delimiters, these arethe
characters that are trimmed from the
contents within the delimiters. The
region-level Characters to Toss setting
determines which characters are
trimmed outside of the delimiters. If
there are no delimiters, then the
Charactersto Toss settingisapplied first,
and then L eft Padding and Right Padding
are applied.
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Byte Datatype Properties
A single byte with arange of 0 to 255 for unsigned or -128 to 127 for signed.

Table 32. Byte Properties

magnitude) to 0 (keeps the number
exactly asit appearsin the input) to 16
(shifts the decimal 16 placesto the left,
making the number larger by n orders of
magnitude). To enter a scaling factors
from 1016 to 10, just enter the
exponent value.

Example: Entering an exponent of 3 will

cause any numbers to be multiplied by
1000 (103) before being output to XML.

Property Description Editable Affects XML
Signed o true(default) Yes Yes
o false— use thisto make the value
unsigned
Scaling Thisisavaue from -16 (shifts the Yes Yes
Factor decimal 16 places to the right, making
(10™n) the number smaller by n orders of
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Compg3 Datatype Properties

Also known as " Computational-3," "Packed" or "Packed Decimal." A COBOL storage
format similar to Zoned below but differing in internal structure. It is also related to the
BCD types.

Table 33. Comp3 Properties

Property Description Editable Affects XML
Scaling Thisisavalue from -16 (shifts the Yes Yes

Factor decimal 16 places to the right, making

(10™n) the number smaller by n orders of

magnitude) to 0 (keeps the number
exactly asit appearsin the input) to 16
(shifts the decimal 16 places to the left,
making the number larger by n orders of
magnitude). To enter a scaling factors
from 10716 to 1016, just enter the
exponent value.

Example: Entering an exponent of 3 will
cause any numbers to be multiplied by
1000 (10°) before being output to XML .

Date Datatype Properties
A date, stored either asa string or in binary form.
The parsing rules are:

1. If thelengthis 3, then the day, month and year are read as binary valuesin the Date
Format order. The Window for Two-digit Yearsvalueisused to determinethe century.
If the format is 'Y J, then the first byte is the year, and the second two are the day
number in the year, stored as LSB, M SB.

2. If thelength is 6, then the sameis used, except each day/month/year istaken as two
digits.

3. If thelength is 8 and there are no separators, then the day and month each get two
digits and the year gets four.

4. Otherwise, it is parsed using the Y MD Separator characters.
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5. For months, the names or abbreviations in English, German, Spanish, French,
Portuguese and Italian are recognized.

Table 34. Date Properties

Property Description Editable Affects XML
Date Format | Thedefaultisread fromthelocal system | Yes Yes

settings at the time the custom XML

converter is defined.

« DMY (day-month-year)

« MDY (month-day-year)

e YMD (year-month-day)

e YJ(year-daynumber a.k.a. "Julian"

format)

YMD A hint to the parser asto the most likely | Yes Yes
Separator separator between the date components

that will be seen.

The default value comes from the local

system configuration, and also includes

the period ("."), comma (","), hyphen ("-

"), dlash ("/") and space.
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Table 34. Date Properties

Property Description Editable Affects XML
Window for | If theyear isonly given astwo digit, this | Yes Yes
Two-digit isthe cut-off date for determining the

Years century. The default is 1950.

Left Thesetwo propertiescontrol what sort of | Yes Yes

Padding, padding is to be found on either side of

Right the field and then removed. Any

Padding characters listed here will be removed.

Characters can be specified either by
their Unicode values, their Unicode
names, or single-quoted.

The default for both is spaces (0x20) and
tabs (0x09).

If there are field delimiters, these arethe
characters that are trimmed from the
contents within the delimiters. The
region-level Characters to Toss setting
determines which characters are
trimmed outside of the delimiters. If
there are no delimiters, then the
Charactersto Toss settingisapplied first,
and then L eft Padding and Right Padding
are applied.
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DateTime Datatype Properties
A date plus atime.

Thisis parsed as a date followed by the Date-Time Separator followed by atime. It
combines the properties of both, and includes that one additional property.

Table 35. DateTime Properties

Property Description Editable Affects XML

Date-Time Thisisthe character that separates the Yes Yes
Separator date string from the time string. The
default valuesare 'T' and ' .

Decimal Datatype Properties

Reads 16 bytes and interpretsit as a .net System.Decimal. Numbers as large as 1028
(positive or negative) and with as many as 28 significant digits can be stored as adecimal
type without loss of precision.
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Double Datatype Properties
The standard |EEE 8-byte floating point format.

Table 36. Double Properties

Property Description Editable Affects XML
Scaling Thisisavaue from -16 (shifts the Yes Yes

Factor decimal 16 places to the right, making

(10™n) the number smaller by n orders of

magnitude) to 0 (keeps the number
exactly asit appearsin the input) to 16
(shifts the decimal 16 placesto the left,
making the number larger by n orders of
magnitude). To enter a scaling factors
from 10716 to 10%6, just enter the
exponent value.

Example: Entering an exponent of 3 will
cause any numbers to be multiplied by
1000 (103) before being output to XML.

Endian When binary numbers are stored, they | Yes Yes
can be stored with the smallest
component first (little-endian) or last

(big-endian).

o Little—the standard for Intel x86-
based machines (default)

« Big
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Float Datatype Properties
The standard |EEE 4-byte floating point format.

Table 37. Float Properties

Property Description Editable Affects XML
Scaling Thisisavaue from -16 (shifts the Yes Yes

Factor decimal 16 places to the right, making

(10™n) the number smaller by n orders of

magnitude) to 0 (keeps the number
exactly asit appearsin the input) to 16
(shifts the decimal 16 places to the left,
making the number larger by n orders of
magnitude). To enter a scaling factors
from 10716 to 10%6, just enter the
exponent value.

Example: Entering an exponent of 3 will
cause any numbers to be multiplied by
1000 (103) before being output to XML.

Endian When binary numbers are stored, they | Yes Yes
can be stored with the smallest
component first (little-endian) or last

(big-endian).

o Little—the standard for Intel x86-
based machines (default)

« Big
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Integer Datatype Properties

A four-byte integer with arange of 0 to 4,294,967,295 for unsigned or -2,147,483,648 to
2,147,483,647 for signed.

Table 38. Integer Properties

Property Description Editable Affects XML
Signed o true(default) Yes Yes
o false—usethisto make the value
unsigned
Scaling Thisisavaue from -16 (shifts the Yes Yes
Factor decimal 16 places to the right, making
(10™n) the number smaller by n orders of

magnitude) to 0 (keeps the number
exactly asit appearsin the input) to 16
(shifts the decimal 16 places to the left,
making the number larger by n orders of
magnitude). To enter a scaling factors
from 10716 to 10%6, just enter the
exponent value.

Example: Entering an exponent of 3 will
cause any numbers to be multiplied by
1000 (103) before being output to XML.

Endian When binary numbers are stored, they | Yes Yes
can be stored with the smallest
component first (little-endian) or last

(big-endian).

o Little—the standard for Intel x86-
based machines (default)

« Big
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Long Datatype Properties

An eight-byte integer with arange of 0 to 18,446,744,073,709,551,615 for unsigned or -
9,223,372,036,854,775,808 to 9,223,372,036,854,775,807 for signed.

Table 39. Long Properties

Property Description Editable Affects XML
Signed o true (default) Yes Yes
o false—usethisto make the value
unsigned
Scaling A value from -16 (shiftsthe decimal 16 | Yes Yes
Factor places to the right, making the number
(10™n) smaller by n orders of magnitude) to 0

(keeps the number exactly as it appears
in the input) to 16 (shiftsthe decimal 16
places to the left, making the number
larger by n orders of magnitude). To
enter ascaling factorsfrom 10160 1016,
just enter the exponent value.

Example: Entering an exponent of 3 will

cause any numbers to be multiplied by
1000 (103) before being output to XML.

Endian When binary numbers are stored, they Yes Yes
can be stored with the smallest
component first (little-endian) or last

(big-endian).

o Little—the standard for Intel x86-
based machines (default)

« Big
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Number Datatype Properties
This corresponds to numbers stored in text form.

Notethat if the number isfollowed by apercent ("%") it isdivided by 100; if followed by
apermille ("%0") it isdivided by 1000.

A leading or trailing '+' isignored, as numbers are assumed positive. A leading or trailing
*-' will make the number negative.

Table 40. Number Properties

Property Description Editable Affects XML

Decimal The character that correspondsto the Yes Yes
decimal point. It istypically aperiod
(".") orcomma(","). Thedefault valueis
determined by the settings on the
machine creating the custom XML
converter.

Thousands | The character that correspondsto the Yes Yes
thousands separator. The default is
fetched from the system settings, and is
typically acomma (","), period (".") or
space, and is subsequently stored with
the custom XML converter. If seeninthe
input, it isthrown away and not
preserved in the output.

Base Thenumeric baseinwhichthenumberis | Yes Yes
storedintheinput file. It can be anything
from 2 (binary) to base 36. The default is
10 (decimal). Other common numbers
are 8 (octal) and 16 (hexadecimal).

304 Stylus Studio® 2010 User Guide



Custom XML Conversion Definitions Properties Reference

Table 40. Number Properties

Property Description Editable Affects XML
Scaling A value from -16 (shiftsthe decimal 16 | Yes Yes

Factor places to the right, making the number

(10™n) smaller by n orders of magnitude) to 0

(keeps the number exactly as it appears
in the input) to 16 (shiftsthe decimal 16
places to the left, making the number
larger by n orders of magnitude). To
enter ascaling factorsfrom 101610 1016,
just enter the exponent value.

Example: Entering an exponent of 3 will
cause any numbers to be multiplied by
1000 (103) before being output to XML.

"C' Rulesfor |« yes—if anumber beginswithOitis | Yes Yes
Octal and considered octal, or if it beginswith
Hex Ox it is considered hexadecimal;

otherwise it is considered decimal

(default)

e no-numbers are considered in the
given Base only
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Table 40. Number Properties

Property Description Editable Affects XML
Use o yes—if thenumberissurroundedby | Yes Yes

Currency '("and ") or has artrailing 'cr' (case-

Conventions insensitive) it is considered

negative, or if it hasatrailing 'db' or
'dr' (also case-insengitive) it is
considered positive (default)

° no
Left Thesetwo propertiescontrol what sort of | Yes Yes
Padding, padding is to be found on either side of
Right the field and then removed. Any
Padding characters listed here will be removed.

Characters can be specified either by
their Unicode values, their Unicode
names, or single-quoted.

Thedefault for both is spaces (0x20) and
tabs (0x09).

If there are field delimiters, these arethe
characters that are trimmed from the
contents within the delimiters. The
region-level Characters to Toss setting
determines which characters are
trimmed outside of the delimiters. If
there are no delimiters, then the
Charactersto Tosssettingisapplied first,
and then L eft Padding and Right Padding
are applied.
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Short Datatype Properties
A two-byte integer with arange of 0 to 65,535 for unsigned or -32,768 to 32,767 for

signed.

Table 41. Short Properties

Property

Description

Editable

Affects XML

Signed

o true (default)

o false—usethisto make the value
unsigned

Yes

Yes

Scaling
Factor
(10™n)

A value from -16 (shifts the decimal 16
places to the right, making the number
smaller by n orders of magnitude) to 0
(keeps the number exactly as it appears
in the input) to 16 (shiftsthe decimal 16
places to the left, making the number
larger by n orders of magnitude). To
enter ascaling factorsfrom 10160 1016,
just enter the exponent value.

Example: Entering an exponent of 3 will

cause any numbers to be multiplied by
1000 (103) before being output to XML.

Yes

Yes

Endian

When binary numbers are stored, they

can be stored with the smallest

component first (little-endian) or last

(big-endian).

o Little—the standard for Intel x86-
based machines (default)

« Big

Yes

Yes
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String Datatype Properties
A regular string of characters.

Table 42. String Properties

Property Description Editable Affects XML
Normalize o yes—changeall linefeeds, carriage | Yes Yes
White Space returns and tabs into spaces, then

removeall spacesfrom start and end
of text, then collapse any
consecutive spaces into asingle
space (default)

« no (leave al whitespace a one)

Left Thesetwo propertiescontrol what sort of | Yes Yes
Padding, padding is to be found on either side of

Right the field and then removed. Any

Padding characters listed here will be removed.

Characters can be specified either by
their Unicode values, their Unicode
names, or single-quoted.

The default for both is spaces (0x20) and
tabs (0x09).

If there are field delimiters, these arethe
characters that are trimmed from the
contents within the delimiters. The
region-level Characters to Toss setting
determines which characters are
trimmed outside of the delimiters. If
there are no delimiters, then the
Charactersto Toss settingisapplied first,
and then L eft Padding and Right Padding
are applied.
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Time Datatype Properties

A timevaue.

The parsing rules are as follows:

1.
2.
3.

10.
11.

12.

If the first character isan 'n' or 'N', it is assumed to be noon (12:00:00).
If the first character isan 'm' or 'M', it is assumed to be midnight (00:00:00).
If thereisa HM S separator, the next three steps are skipped.

If thelength issix or more, then the hours are thefirst two characters, the minutes are
the next two characters, and the seconds are the next two digits.

If thelengthisfour or five, then the hoursarethefirst two characters, and the minutes
are the next two characters.

No valid date can be determined.

If an HM S separator was seen, then the following rules are tried:

Up to two digits become the hour, terminated by the HM S separator.

Up to two more digits become the minute, also terminated by the HM S separator.
If there are any more digits, the next two become the seconds value.

If thereisadecima character and more digits, they become fractional parts of the
seconds.

If an'am’ or 'pm’ (case-insensitive) marker is found, the hours are adjusted
accordingly.

Stylus Studio® 2010 User Guide 309



Converting Non-XML Files to XML

13. Wrapping is performed for seconds >= 60 and minutes >= 60. Hours are modul oed
with 24.

Table 43. Time Properties

Property Description Editable Affects XML
HMS Thisisahint to the parser asto themost | Yes Yes
Separator likely separator between the hours,

minutes and seconds that will be seen.

The default value comes from the local
system configuration, and also includes
the colon (":"), period (".") and space.

Left Thesetwo propertiescontrol what sort of | Yes Yes
Padding, padding is to be found on either side of

Right the field and then removed. Any

Padding characters listed here will be removed.

Characters can be specified either by
their Unicode values, their Unicode
names, or single-quoted.

The default for both is spaces (0x20) and
tabs (0x09).

If there arefield delimiters, these are the
characters that are trimmed from the
contents within the delimiters. The
region-level Characters to Toss setting
determines which characters are
trimmed outside of the delimiters. If
there are no delimiters, then the
Charactersto Toss settingisapplied first,
and then L eft Padding and Right Padding
are applied.
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Zoned Datatype Properties
Also known asthe"IBM Signed" format. It is related to Comp3.

Table 44. Zoned Properties

Property Description Editable Affects XML
Scaling A value from -16 (shiftsthe decimal 16 | Yes Yes

Factor places to the right, making the number

(10™n) smaller by n orders of magnitude) to 0

(keeps the number exactly as it appears
in the input) to 16 (shiftsthe decimal 16
places to the left, making the number
larger by n orders of magnitude). To
enter ascaling factorsfrom 10160 1016,
just enter the exponent value.

Example: Entering an exponent of 3 will
cause any numbers to be multiplied by
1000 (103) before being output to XML.

Specifying Control Characters

Lists of symbols are used to designate characters for properties like Field Component
Separator, Line Terminator, and Field Separator.

Individual symbols can be expressed in several forms. Numbers and letters, for example,
can be entered using single quotes, such as‘A’, ‘B’, ‘C’. Control characters or other
Unicode values can be expressed using their decimal value, or their hex value by
preceding it with Ox — 128 or 0x80, for example. In addition, certain control characters
have alternate mnemonic representations, and Stylus Studio supports them, as well.

When entering multiple symbols for a given property, separate symbols using a comma.
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The following table summarizes commonly used control characters. For more
information, visit http://www.unicode.org.

Table 45. Commonly Used Control Characters

Decimal Hex Mnemonic Control Key
0 0x00 NUL @, \0O'
1 0x01 SOH A

2 0x02 STX "B

3 0x03 ETX ~C

4 0x04 EOT "D

5 0x05 ENQ "E

6 0x06 ACK "F

7 0x07 BEL or BELL |~G,"\a
8 0x08 BS ~H, \b'
9 0x09 TAB or HT AL A
10 0x0A LF g \n'
11 0x0B VT K, W
12 0x0C FF AL, AP
13 0x0D CR M, \r!
14 Ox0E SO N

15 OxOF Sl O

16 0x10 DLE P

17 0x11 DClor XON |"Q

18 0x12 DC2 "R

19 0x13 DC3or XOFF | 7S

20 0x14 DC4 AT

21 0x15 NAK U
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Table 45. Commonly Used Control Characters

Decimal Hex Mnemonic Control Key
22 0x16 SYN Y
23 0x17 ETB W
24 0x18 CAN X
25 0x19 EM Y
26 Ox1A SUB nZ
27 0x1B ESC Al
28 0x1C FS N
29 0x1D GS N
30 Ox1E RS AN
31 Ox1F usS N
127 Ox7F DEL

128 0x80

129 0x81

130 0x82 BPH

131 0x83 NBH

132 0x84 IND

133 0x85 NEL

134 0x86 SSA

135 0x87 ESA

136 0x88 HTS

137 0x89 HTJ

138 Ox8A VTS

139 0x8B PLD
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Table 45. Commonly Used Control Characters

Decimal Hex Mnemonic Control Key
140 0x8C PLU
141 0x8D RI
142 Ox8E SS2
143 Ox8F SS3
144 0x90 DCS
145 0x91 PU1
146 0x92 PU2
147 0x93 STS
148 0x94 CCH
149 0x95 MW
150 0x96 SPA
151 0x97 EPA
152 0x98 SOS
153 0x99

154 O0x9A SCl
155 0x9B CSl
156 0x9C ST
157 0x9D 0osC
158 Ox9E PM
159 Ox9F APC
160 O0xAO0 NBSP
173 OxAD SHY
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Chapter 4

Converting EDI to XML

@i‘? Support for the EDI to XML module is available only in Stylus Studio XML
Enterprise Suite.

@ Watch it! You can view a video demonstration of this feature by clicking the
television icon or by clicking this link: watch the Introduction to the EDI to XML
module video.

This chapter describes how to use the Stylus Studio EDI to XML module to convert
standard and proprietary EDI to XML.

This chapter covers the following topics:

“What isthe EDI to XML Module?’ on page 316

“Creating an EDI to XML Conversion” on page 320
“Previewing an EDI to XML Conversion” on page 322
“Example: Converting a Conforming EDI File” on page 323
“Example: Converting a Non-conforming EDI File” on page 326
“Resolving EDI Document Errors’ on page 332

“Specifying XML Converter Properties’” on page 339
“Customizing an EDI Standard” on page 340

“Generating XQuery and XML Schemafrom EDI” on page 360
“EDI Structure Definitions Properties Reference” on page 365
“EDI XML Converters Properties Reference” on page 375
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Converting EDI to XML

What is the EDI to XML Module?

The EDI to XML moduleisagraphical tool designed to help you translate EDI documents
to XML. In particular, it enables you to convert EDI documents that do not conform to
any of the EDI dialects supported by DataDirect XML Converter, whose conversion
engine forms the basis of the EDI to XML module. Documents might be nonconforming
for any number of reasons — perhaps the document contains an error in the standard EDI
structure, or perhapsyou have customized an EDI standard to suit your business purposes.
Regardiess, the EDI to XML module makesit possible to convert nonconforming EDI to
XML and to save that conversion definition for use with other EDI documents that share
the same specification.

Supported EDI Dialects

DataDirect XML Converter supports the following EDI diaects: ATIS, Cargo-IMP,
EANCOM, EDIFACT, Edig@s, HIPAA, HL7, NCPDP, PADIS, TRADACOMS, and
X12.

When to Use the EDI to XML Module

Consider using the EDI to XML module when you
« Want to visually inspect the data and structure of an EDI document
« Need to convert an EDI document that does not conform to an EDI standard

« Want to create a conversion definition that allows you to convert other non-
conforming EDI documents

« Want to experiment with different XML Converter settingsto see how they affect the
conversion process and the resulting XML

« Want to create scenarios that use different EDI documents, based on different EDI
standards, or that use different XML Converter settings
You can perform all of these operations and others using the EDI to XML editor.

This section covers the following topics:

o “TheEDI to XML Editor” on page 317

o “The SEF File” on page 318

« “Choosing an EDI Document” on page 319

o “EDI to XML Conversions and EDI Standards’ on page 319
« “EDI XML Conversions and EDI Definitions’ on page 342

316

Stylus Studio® 2010 User Guide



What is the EDI to XML Module?

The EDI to XML Editor

The EDI to XML editor isavisual editor that helps you create a conversion file that can
be used to convert EDI documentsto XML and to preview the XML that results from that
conversion. The conversion file you create can be saved and used to convert other EDI
documents with the same structure to XML.
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: EHEEA ™ 4] @ 0 i
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. . o Untitled!...
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Requirement M andatory " 2
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Position 20 £ @ 828: Debit Autharization FlGa: oT: 9988776655 : 11223
. . . 829 Payment Cancellation Request HeT:831:00128001
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P + @ 830: Planning Schedule with Releaze Capab... ] 00o00l:20041%
= @ 831 Application Control Totals N9:BT: 28200001
+-@1 5T: Transaction Set Header TREN:1: 28200001
=RF.S0 EGH: Beginning Eigrnent BAMT: 2 : 10000000
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-8t 337: Time 1:NNNN32 123 s
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AR 497 O ebeemine | Ambifin abime b
< e @ Mo errars found. !
3 < = X X -
[ 2 « . Preview window
Hoaw = o =00<
< = = =
4’_{| < 4 =00=
, 2 << ></I3A04> v
L L >
= '\ 831 [Untitled sef] |
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Figure 190. EDI to XML Editor with Preview Window Displayed

You can use the EDI to XML editor to:

« View an EDI file you want to convert to XML. The EDI document pane shows any
errorsin thefile—that is, how the file deviates from the EDI standard on whichit is
based — and provides Quick Fixes and other tools to help you correct the errors.

« Customize EDI standard definitions to accommodate proprietary or non-conforming
EDI. By default, the EDI structure pane displays the structure of the EDI standard
associated with the EDI document displayed in the EDI document pane, but you can
change both the diaect and version to display the structure for any of the numerous
dialects supported by DataDirect XML Converter.
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You can import alocal copy of EDI standard definitions and modify them in
numerousways—adding new valuesto acodelist, changing asegment’s Requirement
property from Mandatory to Optional, and so on. See*“ Customizing an EDI Standard”
on page 340 for more information on this topic.

« Specify propertiesfor the DataDirect XML Converter. The EDI to XML module uses
the DataDirect XML Converter engine to convert EDI to XML. See “ Specifying
XML Converter Properties’ on page 339 for more information on this topic.

o PreviewtheEDI to XML conversion. Whenyou click the Preview Result button (1),
Stylus Studio opens the Preview window and displays the XML that results from
converting the source EDI document using the parameters specified for the XML
Converter engine as well as changes made to the EDI standard, if any.

Using Undo

Tip

Undo (Edit > Undo, or Ctrl+2) is supported throughout the EDI to XML editor. For
example, you can undo changes made to

« TheURIfield

« TheDialect and Version drop-down lists

« Nodesinthe EDI structure pane

Use Undo to undo changesincrementally. If you want to undo all of the changesyou have

made to the EDI structure definition, use the Restore Definition feature. See “Undoing
Customizations’ on page 358 for more information.

The SEF File

Whileyou can usethe EDI to XML moduleto convert individual EDI documentsto XML,
the module’'smain purposeisto allow you to develop a set of conversion settings that can
be captured and then reused to convert to XML other EDI documents with the same
structure. These settings are saved in a Sandard Exchange Format (SEF) file (. sef) that
is created when you save your work in the EDI to XML editor.

The SEF file contains information about any EDI definitions that you might have
imported and changed, as well as changes to the XML Converter properties default
values. The structure information for supported EDI dialects and versions remains with
the XML Converter, ensuring that the SEF file remains very small.

Onceyou create a SEF file, you can useit to convert other EDI documentsin one of these
ways:

318
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« Referencing it in the converter:EDI URI scheme — the user= property allows you to
specify the URI of a SEFfile. (The easiest way to make changesto the converter: URI
scheme is through the XML Converter properties. See “ Specifying XML Converter
Properties’ on page 339 and “EDI XML Converters Properties Reference” on
page 375 for more information on these topics.)

o Invoking the setEDIExtension() method that is part of the XML Converter API. This
method isavailablein both Javaand .NET interfaces. See“How XML Convertersare
Used in Stylus Studio” on page 214 for more background information on the
DataDirect XML Converter in Stylus Studio, or refer to the DataDirect XML
Converter documentation that is part of your Stylus Studio installation —
\components\XML Converters for .NET and \components\XML Converters for Java
where you installed Stylus Studio.

o Openthe SEF file in Stylus Studio and create a new scenario using a new EDI
document as the source document you want to convert to XML.

Choosing an EDI Document

When choosing an EDI document from which you want to create an EDI to XML
conversion, consider using onethat is representative of other EDI documents you need to
convertto XML. You might need to create multiple EDI to XML conversionsfor thetypes
of EDI documentsyou typically convert to XML. But when the EDI documents you need
to convert to XML have the same dialect and version, for example, consider creating one
EDI to XML conversion to convert both documents.

EDI to XML Conversions and EDI Standards

An EDI to XML conversion can become associated with an EDI standard (dialect and
version) in one of two ways:

o StylusStudioinfersthe EDI standard based on the source EDI document that isbeing
used to create the EDI to XML conversion

« You can specify the EDI standard explicitly (whether or not you are using a source
EDI document)
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The EDI dialect and version associated with an EDI to XML conversion is aways
displayed in the EDI to XML editor.

o Untitled_.*|

P slapt v |[€] EDIFACT v |DI7A hd @ URI: converterEDI
EDI Stucture I ~ UNB+UNOC: 3+23456789)
Ea ages

UNH+1+3LERPT: D: 574:
=[5} Segments

BGM+RAC+ILIRETI+Y
H- & A4l Accommodation allocation information DTM+20:12971201: 102

Figure 191. EDI Dialect and Version Controls

You can change the EDI dialect and/or version any time you are working with the EDI to
XML editor using the Select Dialect and Select Version fields.

Creating an EDI to XML Conversion

This section describes how to create an EDI to XML conversion and how to save your
work as a SEF file.

You can base your EDI to XML conversion on

« Anexisting EDI document. Use this method when you have a sample EDI document
that is representative of other documentsin your enterprise that will need to be
converted to XML.

« AnEDI standard. Use this method when you do not have a sample EDI document but
know how your proprietary EDI differs from one of the EDI standards (dialect and
version) supported by Stylus Studio.

The following sections use sample files installed with Stylus Studio to illustrate the
conversion process and features of the EDI to XML module. See “Example: Converting
aConforming EDI File” on page 323 and “ Example: Converting a Non-conforming EDI
File’ on page 326 for more information.

Using an EDI Document

[0 To create an EDIto XML conversion using an EDI document:

1. Select File > New > EDI to XML Conversion from the Stylus Studio menu.
The New EDI to XML Conversion dialog box appears.

2. Inthe Select a sample EDI document field, type the URI for the EDI document you
want to use as the model for your EDI to XML conversion.

320
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Alternative: Use the more button ([-]) to locate the EDI document.

When you select the document, the EDI dialect and version on which it is based are
displayed in the Dialect and Version fieldsin the Select the dialect and version you
need to customize group box.

Click OK.

The EDI to XML editor appears. The EDI document is displayed in the EDI
document pane; the EDI structure for the EDI standard on which the document is
based is displayed in the EDI Structure pane.

To saveyour work inthe EDI to XML editor, select File > Save from the Stylus Studio
menu.

Stylus Studio displays the Save As dialog box, prompting you to save the filewith a
.sef extension.

Using an EDI Standard

0 To create an EDI to XML Conversion using an EDI standard:

1.

Select File > New > EDI to XML Conversion from the Stylus Studio menu.
The New EDI to XML Conversion dialog box appears.

Select the Select the dialect and version you need to customize radio button.

Use the Dialect and Version fieldsin the Select the dialect and version you need to
customize group box to select the dialect and version of the EDI standard you want
to customize.

Click OK.

The EDI to XML editor appears. The EDI structurefor the EDI standard you selected
isdisplayed in the EDI Structure pane. The EDI document pane is empty.

You can change the dialect and version using the drop-down lists at the top of the EDI
to XML editor.

To saveyour work inthe EDI to XML editor, select File > Save from the Stylus Studio
menul.

Stylus Studio displays the Save As dialog box, prompting you to save the filewith a
.sef extension.
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Previewing an EDI to XML Conversion

The EDI to XML module usesthe Stylus Studio scenariosfeature to help you preview the
results of your EDI to XML conversion. A scenarioisacollection of information—in the
case of an EDI to XML conversion, an EDI input document and output URI — that you
can save and reuse to test how different EDI customizations and XML Converter settings
affect the conversion of an EDI document to XML.

When you create an EDI to XML conversion using an EDI document, Stylus Studio
automatically creates a scenario that specifiesthat EDI document asthe EDI input for the
EDI to XML conversion. You can change the EDI input document, or create another
scenario using a different EDI document, on the Scenario Properties dialog box.

0 To display the Scenario Properties dialog box:
Click the Edit scenario properties button ([--]) on the EDI to XML editor tool bar.
Alternative: Select EDI > Scenario Properties from the Stylus Studio menu.

Alternative: Select Create Scenario from the scenario drop-down list on the EDI to
XML editor tool bar.

Scenario Properties E|
Eisting scenarios: Y
General |
a1
Inputs %
EDI input {optional): | Enterprise Suitefexamples/EDILoXMLIES1. 212w E]
| output URI {optional:
]
Use relative paths [ ereview result in an external application
{ 0K ] [ Cancel

Figure 192. Scenario Properties Dialog Box

Active Scenario Is Previewed

Asyou create new scenarios, they arelisted in the Existing Scenarios field. The scenario
selected in thislist isthe active scenario —when you preview the EDI to XML conversion,
the active scenario isthe one that is being run. You can specify adifferent active scenario
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by selecting it in thislist, but it can be more convenient to select it from the Create
Scenario from the scenario drop-down list on the EDI to XML editor tool bar:

o Untitled...* |

Scenariol (IMREE w | 004030 v

@B 143 Transaction Set |dentifier Code
@B 329 Transaction Set Control Mumber
¥ CF‘ 1705 Implementation Corventian

+-@& BGM: Beginning Seagment

+-@ C3 Curency

4@ DTP: Date or Time or Period

4% GROUP_1: M1

+-{¥ GROUP_2 N1

Figure 193. Setting the Active Scenario

When you choose anew active scenario, Stylus Studio usesthe EDI input and output URI
specified in the scenario when you preview the EDI to XML conversion.

How to Preview an EDI to XML Conversion

0 To preview an EDI to XML conversion:

1. Select the scenario you want to preview from the scenario drop-down list on the EDI
to XML editor tool bar.

2. Click the Preview Result (® ) button.
Alternative: Select EDI > Preview Result from the Stylus Studio menu.

Example: Converting a Conforming EDI File

This section describes how to convert an EDI fileto XML using the Stylus Studio EDI to
XML module. It usesthe 831.x12 EDI file, whichisinstalled in the \EDItoXML\EDI files
folder whereyou installed Stylus Studio. Thisfile conformsto the X12 EDI standard, and
contains no errors.

0 To convert 831.x12 to XML:

1. Select File > New > EDI to XML Conversion from the Stylus Studio menu.
The New EDI to XML Conversion dialog box appears.

2. Inthe Select a sample EDI document field, type the URI for the 831.x12 EDI file.
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Alternative: Use the more button ([--]) to locate 831.x12.

When you select the document, X12 is displayed in the Dialect field and 004030 is
displayed in the Version field in the Select the dialect and version you need to
customize group box.

3. Click OK.
The EDI to XML editor appears. The 831.x12 EDI file you selected in Step 2 is
displayed in the EDI document pane. The message in the status bar (No errors found)
indicates that the 831.x12 EDI file has no errors.

The EDI Structure pane displays information for X12 version 004030 from the
DataDirect XML Converter repository. Stylus Studio uses thisinformation to parse
and validate the source EDI document associated with this EDI to XML conversion.

Sincethe 831.x12 EDI file hasno errors and appears to conform to the X 12 standard,
it isready to be converted to XML. (For information on addressing errorsin EDI files,
see “Resolving EDI Document Errors’ on page 332.)

@ stylus Studio 2009 XML Enterprise Suite - [Untitled3.sef *] CEX
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Loop Seque... Fake L gkl ¥ | |[x12 4| 004030 |
Description URI: convererEDI E]
HIga:00: 00:
# Transaction Messages Cleg:CT: 3988776655 : 112E2334455: 20
v Segments HaT:831:001253001
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< ¥
C @ Mo errors found. ) i ¢

For Help, pres: Ln 12 Col 1 Char O {0x0000) UM

Figure 194. 831.x12 EDI Before Conversion

4. To convert the 831.x12 EDI fileto XML, click the Preview Result button ('®).

The Save As diaog box appears, requesting that you save your EDI to XML
conversion as a SEF file.
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5. Provide aname for thefile and click the Save button.
Stylus Studio opens the Preview window and displays the XML that results from
converting the 831.x12 EDI file.

Em\ File Edit ¥iew Project Debug EDI SourceControl Tools Window Help x
Bl i
: tuil * Ll 4] S g 6 :
i Properties P .
Fa Vil @ Unlllled1...|
SEF Yersion 1.61 Y @l o
Loop Seque... Fake b 831 ....................... | E] X12 ............. b 004030 .......... M|
Description URI: converterEDI E]
W HIsa:00: :00: -
Tranzaction Messages g oT: 39887 76655:1122334455: 20

[ Segments ClaT:831:00128001
£ Composites BGN:00:88200001: 20041201
5 Elements N9:EBT: 28200001
&™) Code Lists TRN:1:88200001
BaMT:Z: 100000.00
QOTv:46:1
SE:7:00128001
GE:1:128
IEA:1:000032123

<
@ Mo errors found.

i

< =<
=
= =

z L = =01=

2 :

e ', 831 [UniiedT s T

Processing... Ln 12 Cal 1 Char O {0x0000) UM

Figure 195. 831.x12 Converted to XML

Note that no changes were made to either the EDI structure for the X 12 standard or to the
default converter settings used by the XML Converter engine (as shown in the URI field).
Sometimes you will need or want to create local copies of EDI standards definitions or
change properties used by the XML Converter engine. These topics are discussed in the
following example, “Example: Converting a Non-conforming EDI File” on page 326, as
well asin greater detail in “ Specifying XML Converter Properties’ on page 339 and

“Customizing an EDI Standard” on page 340.
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Example: Converting a Non-conforming EDI File

This section describes how to convert the code99.x12 EDI fileto XML using the Stylus
Studio EDI to XML module. Thisfileisinstalled in the \EDItoxML\EDI files folder where
you installed Stylus Studio.

The code99.x12 EDI file uses a proprietary X12 format — one that is based on the X12
standard but uses enterprise-specific code lists and code list values. This example shows
how to maodify the XML Converter properties and local EDI definitions to accommodate
this proprietary X12 format.

0 To convert code99.x12 to XML:

1.

Select File > New > EDI to XML Conversion from the Stylus Studio menu.
The New EDI to XML Conversion dialog box appears.

In the Select a sample EDI document field, type the URI for the code99.x12 EDI file.
Alternative: Use the more button ([.-]) to locate code99.x12.
When you select the document, X12 is displayed in the Dialect field and 004030 is

displayed in the Version field in the Select the dialect and version you need to
customize group box.

Click OK.

The EDI to XML editor appears. The code99.x12 EDI file you selected in Step 2 is
displayed in the EDI document pane.

The message in the status bar (No errors found) indicatesthat the code99.x12 EDI file
has no errors. Or at least none that is apparent based on the default settings for the
properties used by the XML Converter engine.

By default, the XML Converter engine does not validate code list tables. However,
since our application development policy requiresthat we validate code lists, we need
to change the code list validation property.
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4. Todisplay the property settings for the XML Converter, click the more button ((.])
to the right of the converter URI field.

Stylus Studio displays the Select XML Converters Properties dialog box.

@ Select XML Converter Properties

Property Walug )

Line separatar [newline] cilf

Encoding [encoding) utf-8

Enable walidation [wal] yes

‘where ta place decoded data values [decode] comment A

‘where ta place coded data values [value) bext

Comment element types (field) yes

‘wWhether ta indent XML output [indent]

Strict validation on value lengthz [len) no

Strict segment-ordering checking [seg| yes

Force emor if value not in code list [tbl] no

Shiict datatype content checking [yp) yes

Tieat all zegments and elements as optional [opt] no

Enforce seament masimum counts (countl ves b
URI: |converterEDI?

Pook [ Cancel ]

Figure 196. Select XML Converter Properties Dialog Box

The property that controls code list validation is Force error if value not in code list
(tbl).

5. Changethevaluefor tbl to yes and click OK.

When you make a change to the SEF file, aswe have just done by changing the XML
Converter properties associated with it, Stylus Studio reloads the source EDI
document after amoment. This occurs automatically, but you can forceit by clicking
the Waiting to reload document text in the status bar. You can also change the delay
(by default, it is 5 seconds) in the Options dialog box (Tools > Options > Module
Settings > EDI to XML).

See “Working with Code Lists’ on page 337 for more information on code list
validation.
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With code list validation on, we see that our EDI source document contains an error
(indicated by ared squiggle at the error’s location in the EDI document pane. If you

hover the pointer over thered squiggle, atool tip provides more information about the
error:

HIsa:00: s00: :01:1515151513 :01:5151515151 (04120
Hed:orT: 9288776655 1122334455: 20041201 : 1217 : 128 : £: 004030
Har:231:00128001

y ERROR Walue 99 not in codelist 353.

BHamT: Z: Dialect: X1&

Qry:4¢ Version: syntax=00403/004030;nessage=00403/004030;agency=004030;table=004030
am: 70 Message: 831

Sequment: BGN (line 4)

Position: EBGNOL

Element: 353 (=) Transaction Set Purpose Code

Value; 99"

Native error: 7, in table: 723

The walue for an element in the data stream cannot be found in the codelist associated
with the element. Turning off codelist walidation with "tbl=no™ will eliminate the
Brror.

Figure 197. Tool Tips for Errors in EDI Documents

6. When we alert our provider to this error, he informs us that all EDI documents he
providesusfor processing will include this code value in the Transaction Set Purpose
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Code code list, asit doesin the code99.x12 EDI file we are using to build our EDI to
XML conversion:

E_m\_ Fil= Edit Yiew Project Debug EDI SourceControl Tools window Help x
=1 - R & 0
A :;Dmp:rt'es vae | = Uniitieds...|
Lj:ﬂj?ﬁe[ Segment Refer... [ ’codaﬂﬁ—v| E] |><1 P 3 E 004030 & |
Ezﬂ:‘:::;‘?ﬂ:e Tandatory URI: converterEDI E]
Ordinal 2 @ 824: Application Advice -~ HIga:00: 00
Position 20 @ 826: T ax Information Exchange Clag: CcT: 99887 76655: 112253544
@ 827 Financial Return Motice - - Qoizonn
(& 828 Debit Authorization
@ 929: Payment Cancelation Request al
8 830: Planning Schedule with Release Cap. TEN:1:887200001
= @ 831: Application Contral Tatals BIAMT: 7 : 100000, 00
& = b1 at pbosf Hes
EH' leginning § n QIY:£6:1
— e — rpose O FE:7:00128001
1id 00 = Driginal GE:1:128
id 01 = Cancellation IEA:1:000032123
id 02=Add
id 03=Delete
id 04 = Change
id 05=FReplace
id (6 = Confirmation
id 07 = Duplicate
id 08=Status
id 10=Nat Found
id 11 =FResponze
id 12 =Not Processed
id 13=Request
id 14 = Advance Naotification | [ S
234 Ao Fleioaien
< s ¥ @ | Mo errors found.
For Help, pres: Ln 4 Col 25 Char 13 {0x0000) MM

Figure 198. Clicking the EDI Document Back-maps to the EDI Structure

7. If weclick line BGN:99:88200001:20041201 in the EDI document panel, Stylus Studio
back-mapsto the corresponding nodein the EDI Structuretree. Thisallowsusto see
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that the Transaction Set Purpose Code code list value 99 is not defined in the X12

standard:
£ Unlitled#...|
P |codesd | w12 » | 0040320 v
URI: converterEDI E]
id 50 & Reaister A HIsa:00: 00:
id 51 § Historical Inquiry Clog: oT: 9928776655 : 112233244

id 52
id 53
id 54
id 55
id 56
id 77

Fesponse to Histarical Ir
Completion

Approval

Excavation

Expiration Motification
Simulation Exercise

Ty:46: 1
id 5C E Chaigeable Resubmiss. . o
. - - SE:7:001z28001
id CM|= Completion Matification GE:1:128
id COJ= Corected T
id Ex[ Final Loading Configurat IEA:1:000032123
A GO Goocted

Z00001:20041201
NS9:EBT: 38200001
TRN:1:38zZ00001
HaMT:Z:100000.00

Figure 199. EDI Value Not Present in EDI Standard

We know we can ignore the error by suppressing code list validation (as seen earlier
in this example). But to accommodate the new code value, we need to add it to the
Transaction Set Purpose Code code list. We do this by modifying alocal copy of the
Transaction Set Purpose Code code list to include code 99. This modification to the
standard will exist only in the SEF file that is used to convert other files of thistype;
we are not changing the definition of the EDI standard in the DataDirect XML
Converter repository.
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8. IntheEDI Structure pane, right-click 353:Transaction Set Purpose Code and choose
Add > Code from the shortcut menu.

Stylus Studio displays the Code Definition dialog box.

Code Definition X

(=) gingle code

Walue:

Descripkion:

O Range

Begin: End:

Ok, Cancel
Figure 200. Code Definition Dialog Box

9. Enter 99 inthe Value field; enter Status Under Review in the Description field, and
click OK.

The values in the Transaction Set Purpose Code code list tree are displayed in bold,
indicating that this definition (and any changesto it) islocal, stored in the SEF file
that represents our EDI to XML conversion. (For more information, see
“Customizing an EDI Standard” on page 340.)

After amoment, Stylus Studio reloads the source EDI document. The red squiggle
does not appear because we have added 99 to the codelist table; the statusbar displays
an OK symbol (&) and the message, No errors found. The EDI to XML conversion
can now be tested.

10. To convert the code99.x12 EDI fileto XML, click the Preview Result button ('®).
The Save As diaog box appears, requesting that you save your EDI to XML
conversion as a SEF file.

11. Provide aname for thefile and click the Save button.

Stylus Studio opens the Preview window and displays the XML that results from
converting the code99.x12 EDI file
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Resolving EDI Document Errors

This section describes the features of the EDI to XML editor that help you identify and
resolve errorsin the EDI document you are using asamodel for creating the EDI to XML
conversion. It coversthe following topics:

o “What Isan EDI Document Error?’ on page 332

« “How Errors Are Represented” on page 333

« ‘“Locating Data Errors’ on page 334

« “Displaying Information about Errors’ on page 334
« “Correcting Dialect and Version Errors’ on page 335
o “Quick Fixes’ on page 335

What Is an EDI Document Error?
An EDI document error is any value in the document that is inconsistent with the EDI
standard on which the document is based. Examples of errorsinclude
o Mis-matched EDI dialect or version
« Missing mandatory segments and €l ements
o Segmentsthat are out of order
« Code list valuesthat are not defined in the EDI standard
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How Errors Are Represented

EDI document errorsarerepresented using colorsand symbolsin the EDI document pane,

as summarized in the following table.
Table 46.

Error Type Example

Description

Incorrect EDI dialect

BGMtRACHILIARETI O

UNH+1+3L3RPT:D: 37A: ED: EDSLOS
DTM+50:13971201: 102

UNB+UNOC: 3+234567820: 1: E+1937 65432

A red background
indicates that the EDI
dialect specified in the

document does not agree
with the dialect specified
in the EDI to XML editor.

Incorrect EDI version |szsaaa: T

3T:831:00128001
BGN:00:28200001: 20041201
N2:BT:88200001

S 5Ll A yellow background
G CT: 298877 AA55: 1122334455 2004120 |nd|ca[es that the EDI

version specified in the

document does not agree
with the version specified
inthe EDI to XML editor.

Dataerror | DoCt3ED

A red squiggle indicates
that the EDI document
containsdatathat is
inconsistent with the EDI
standard on which the
document is based.

The number of data errors identified is summarized in the status bar. Prev and Next
buttons (and their keyboard equivalents) help you navigate from one error to the next.
Note that incorrect dialect and version are not included in this count.

BFF+40:DEL NOMEERA45:DEALTL

UNT+33+1
UNZE+1+66

rd

5

© 21 errors found. Press F4 to locate the next error; press Shift+F4 ta locate the previous errar.

& Prev |[ 8 Mest

Ln & Col 21 Char 13 {00000

MUM

Figure 201. Errors are Summarized in Status Bar
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Locating Data Errors

You can |locate data errors by searching the document visually. An alternative isto use
toolsin the EDI to XML editor to move the cursor from one error to the next to ensure
that you do not overlook any errors that might affect the conversion process or the
composition of your SEF file:

« F4 and Next button in the status bar — moves the cursor to the next error in the source
EDI document

« Shift+F4 and the Prev button in the status bar — movesthe cursor to the previous error
in the source EDI document

When the cursor stops on an error in the EDI document, Stylus Studio expands the
corresponding node in the EDI Structure tree to show the related EDI definition. The
Properties window also shows properties for that definition.

Displaying Information about Errors

Onceyou locate an error, hover the pointer over the error (thered squigglefor dataerrors;
the red or yellow background for EDI dialect or version errors) to display atool tip:

HIsa:00: s00: :01:1515151513 :01:5151515151 (04120
Hed:orT: 9288776655 1122334455: 20041201 : 1217 : 128 : £: 004030
Har:231:00128001
Z00001:zZ0041201
ooool
.-f‘[{DEEDDDS] ERROR Value 29 not in codelist 353,
BHamT: Z: Dialect: X1&
Qry:4¢ Version: syntax=00403/004030;nessage=00403/004030;agency=004030;table=004030
am: 70 Message: 831
Sequment: BGN (line 4)

Position: EBGNOL

Element: 353 (=) Transaction Set Purpose Code
Value; 99"

Native error: 7, in table: 723

The walue for an element in the data stream cannot be found in the codelist associated
with the element. Turning off codelist walidation with "tbl=no™ will eliminate the
Brror.

Figure 202. Tool Tips for Errors in EDI Documents

Thetool tip provides information about the error and suggestions for correcting it.
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Correcting Dialect and Version Errors

To correct adialect or version error, right-click the linewith the red or yellow background
in the EDI document pane and choose the appropriate fix from the shortcut menu:

UNH Cl:{ange the EDIFACT wersion ko 3.0
BGHM LocSte the definition far the jtern at the current position
DTM

%UNB¢"MHN-Q¢OQ&:£TQQH-1-V¢1DD7£:HQ°-1-V¢071201:

Locate the description For the walue at the current position

Figure 203. Fixing a Version Error

Stylus Studio changes the value in the Select Dialect or Select Version fieldsat the top of
the EDI to XML editor and the red or yellow background is cleared.

Note that you can change the dialect and version manually any time you need using the
drop-down lists:

-4 Unlilled...“
P |slsmpt b E] EDIFACT v | Dara @ URI: converterEDI
f—w--

A TRU: Technical ules A .
E TSR: Transport zervice
= TWL: Travel product inf
= UCD: Data element e
= UCF: Group responze

= UL Interchange respo
= UCH: Message/packar

¢ +234567890:1:X+198765432:1: XH
LSP.P'I‘ D: 97A4:ED: ED3LOE
+ELIRETI+3

(15971201 :102
:19921231:10%
DTM+137:12%30101: 102
NADHEY+DISTRIBEUTOR: : 92

Figure 204. Dialect and Version Fields

o e S SO e

Note When the SEF fileisbeing used to convert an EDI document to XML, whether in Stylus
Studio or programmatically, using DataDirect XML Converter, the EDI standard
declared in the EDI document — and not the values shown in the EDI to XML editor —
establishesthedialect and version used to parse the document for conversion. Any locally
defined definitionsin the SEF file are used during the conversion as well.

Quick Fixes

The Quick Fixes feature displays one or more ways to address a given error. Quick Fixes
isavailable for data errors only.
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To display Quick Fixes chaices, right-click on adocument error (the red squiggle) in the
EDI document pane and choose Quick Fixes from the shortcut menu. The menu displays
the fixes that are available for the current error:

QLILck Fixes Ignore error DDEEOOO? everywhere

LU@E the definition For the item at the current: position Uss opt=yes:seg=no

Locate the description Far the walue at the current position

Figure 205. Sample Quick Fixes Menu

Fixes (when there is more than one) are listed in increasing order of scope —when
possible, the scope of thefirst choiceislimited to the current error (or classof error) only;
other fixes listed are typically broader in scope (turning off atype of checking or
validation, for example).

How Quick Fixes Works

Quick Fixestypically providesthe following suggestions for addressing errorsin the EDI
document:

« Change the value of a property in the EDI structure. For example, error DDEE0004
indicates that a mandatory el ement was missing. One Quick Fix for thistype of error
isto change that element’s Requirement property from Mandatory to Optional. This
resultsin importing alocal copy of the segment’s definition to the SEF file and
changing the element’s Requirement property. This change affects the specific
definition only and might be appropriate if you want to do validation in general, but
in this specific context, you do not require avaue for the element.

You can import and change EDI standard definitions at any time. See “ Customizing
an EDI Standard” on page 340 for more information.

« Ignore a specific error number —in this example, ignore all DDEEQ004 errors. This
has the effect of treating all elements as optional. Thisis appropriate if you want to
convert the data without checking if all mandatory elements are present.

« Changean XML Converter property. In this example, the suggestion would be to use
opt=yes, which treatsall elementsand segmentsasoptional. Thisisappropriateif you
want to convert the data and do little or no validity checking.

You can change the XML Converter properties at any time. See “ Specifying XML
Converter Properties’ on page 339 for more information.
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Working with Code Lists

EDI dialects are typically associated with one or more code lists, tablesthat contain a set
of codes and their descriptions that can be used to validate EDI segments and messages.

Code list validation is controlled by the tbl XML Converter property in the Select XML
Converter Properties dialog box, shown here.

L/Z Select XML Converter Properties

Froperty URL Mame Walue
Line separator newline cilf
Encoding encoding utf-8
Enable validation wal yes
‘where to place decoded data values decode comment
‘Wwhere to place coded data values value Lext
Comment element ypes field yes
‘whether to indent kL output indent
Strict validation on value lengths len no
Strict segment-ordering checking f=le| =53
I Force emor if value not in code list thil ho I
Stnct datatype content checking typ yes
Treat all zegments and elements az optional opt no
Enforce seament masimum counts count ves b
URI: | converterEDI?
[ ok [ Cancel ]

Figure 206. tbl= Property Controls Code List Validation

Enabling Code List Validation

By default, Stylus Studio does not perform code list validation against the EDI you are
converting to XML (tbl=no). To enable code list validation, set thl=yes. For an example
of code list validation, see “ Example: Converting a Non-conforming EDI File’ on

page 326.

Handling Missing Values

When validation is on, the XML Converters engine raises an error for any missing or
unrecognized code list values. You can handle missing or unrecognized values in one of
two ways. You can:

o Addmissing valuesto alocal copy of the EDI standard code list.
o Addaspecia value, “..." that suppresses code list validation for that table only.
When you enter “...” for acodelist value, any elementswith values not in the codelist are

treated asvalid. Further, if you provide adescription for the“...” codelist value when you
create the code, that value is output in the XML comments. Here, for example, any
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Tip

missing values from the Piece Identification Indicator code list table are output to XML

with the comment “missing”:

= Untitled...*

Scenariol w E] CARGO

™ Code Lists
& 101: Standard Message |dentifier
& 102 End of Message Code

& 103 Line |dentifier

& 105 &wWB Column |dentifier

& 107: Dffice Function Designator
& 120: Master AW Indicator

& 122 Contact Identifier

& 125 Test Subject Qualifier

g 126 H'wB as agreed

Mew Definition

g id A =Assigned a
id | = Assigned ar]
id M =Mot azsigr

Import Definition

v

3

27

v URI: converterEDI

Code Definition for *138*

(®) single code

id R =Required Add

Code. ..

& 201: Month

& 2024 Cancellation

& 204 Day of the ‘week

a 205: Day Change Indicator

a 206: Type of Time Indicator

a 207: Type of Information Indicator
& 304150 Country Code

& 3 Airport/City Code

] B B B

O Range

X

Yalue:

Description:

missing

Beqin: End:

[ Ok ][ Cancel ]

Figure 207. Providing Descriptions for Missing Code List Table Values

Notethat the“...” code value affects codelist validation only for thetable for which it was
created. Code list validation for other tables is unaffected.

See “Example: Converting a Non-conforming EDI File” on page 326 for an example of
modifying a code list; see “Creating a Code” on page 354 to learn how to add avalueto

acodelist.

You can add the“...” codelist value on-the-fly using the Quick Fixesfeature. See“Quick

Fixes’ on page 335 for more information.
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Specifying XML Converter Properties

The EDI to XML module uses the DataDirect XML Converter engine to convert EDI
documentsto XML. You specify the properties you want the XML Converter engineto
use for your EDI to XML conversion in the Select XML Converter Properties dialog box:

f!4 Select XML Converter Properties

Property Walug 4
Line separator [newline) cilf

E ncaoding [encoding) ulf-8

Enable walidation [val] yes

‘where to place decoded data values [decode] comment A
‘Where to place coded data values [value] Lext

Comment element types (field) yes

‘whether to indent ML autput [indent]

Strict walidation on walue lengths [len) no

Strict zegment-ordering checking [seg) yes

Force erar if value nat in code list [thl) no

Strict datatype content checking [typ) yes
Tieat all segments and elements as optional [opt] no
Enforce seament magimurn counts (count] ves b

URI: |converterEDI?

| Ok | [ Cancel ]

Figure 208. Select XML Converter Properties Dialog Box

The settingsyou specify here are saved with the SEF filefor your EDI to XML conversion
and are displayed in the URI field (in converter:EDI URI scheme format) at the top of the
EDI to XML editor.

See “EDI XML Converters Properties Reference” on page 375 for detailed information
about XML Converter properties.

0 To display the Select XML Converters dialog box:
Click the Edit Converter Properties button ([--]) in the URI field.

About the Converter URI

Theconverter URI scheme (converter:EDI) providesthe property settingsthat are used by
the XML Converter engine. Note that it displays only properties whose settings you have
changed — default values used by the XML Converter are not displayed.

See “The Converter URI Scheme” on page 269 to learn more about the converter URI
scheme and how it is used in Stylus Studio and by DataDirect XML Converter.
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Customizing an EDI Standard

This section describes the DataDirect XML Converter EDI standards repository and how
to create customized EDI definitions for your EDI to XML conversions. It covers the
following topics.

« “The EDI Standards Repository” on page 340

o “Waysto Customize an EDI Standard” on page 341

« “EDI XML Conversions and EDI Definitions’ on page 342

o “Viewsof the EDI Structure’ on page 342

« “Creating New Structure Definitions’ on page 344

« “Modifying Existing Definitions’ on page 348

« “Modifying Definition Properties’” on page 355

« “Importing EDI Standard Definitions’ on page 356

« “Undoing Customizations’ on page 358

« “Removing a Definition” on page 359

The EDI Standards Repository

The DataDirect XML Converter installed with Stylus Studio includes a repository of all
the EDI standards it supports— ATIS, Cargo-IMP, EANCOM, EDIFACT, Edig@s,
HIPAA, HL7, NCPDP, PADIS, TRADACOMS, and X 12 dialects, and most recent and
current versions of these dialects. A filtered view of the repository is displayed in the EDI
Structure pane, which shows definitions for the EDI standard specified in the Select
Dialect and Select Version fields.

If you use an EDI document to create your EDI to XML conversion, the EDI dialect and
version areinferred from the source document. You can change the dialect and/or version
to view definitions for another EDI standard any time you choose.

The EDI Structure pane also shows any new definitions you have created or existing
definitions you have modified. For more information, see “Ways to Customize an EDI
Standard” on page 341 and “Views of the EDI Structure” on page 342.
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Ways to Customize an EDI Standard

There are several ways to customize an EDI standard to reflect proprietary EDI formats.
You can:

« Modify definitionsin alocal copy of the EDI standard —add a value to a code list,
remove a segment reference, and so on.

« Change definition properties — change a requirement from mandatory to optional,
choose to rename the definition when it is output to XML, and so on.

« Import definitions — you might want to import code list values from a current EDI
standard into an EDI to XML conversion based on a prior standard, for example.

What Happens When You Customize a Standard

When you customize an EDI standard by changing a definition, Stylus Studio imports a
copy of that definition into your EDI to XML conversion that reflects the changes you
made to the EDI standard definition. Thislocal copy of the EDI standard definition
remainswith your EDI to XML conversion in the SEF file unless you restore the standard
definition.

All imported definitions — whether imported implicitly (by changing a property, for
example) or explicitly — are displayed in bold text in the EDI Structure pane. In the
following illustration, for example, the segment reference DFI: Default Information has
been added to the transaction message 831: Application Control Totals.

= @ 831: Application Control Totals
®-@ 5T: Tranzaction Set Header
+-@ BGN: Beginning Segment
+-@3 DTM: Date/Time Feference
+-@ N9 Reference |dentification
+-@ TRM: Trace
H-@d ATV Quantity
#-{> GROUP_1: AMT
E3Re=l DF|: Default Infarmation

5 @ 832 Price/Sales Catalog [%

= @ 833 Mortgage Credit Report Order

Figure 209. Bold Text Shows Changes to Standard Definition

Here, both 831: Application Control Totalsand Group 1: AMT are shown in bold because
those definitions have changed based on the addition of the DFI: Default Information
segment reference.
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Creating New Definitions

In addition to making changes to definitions from an EDI standard, you can create new
definitions for messages, segments, elements, composites, and code lists. These
definitions are added to the local definitionsthat are part of your EDI to XML conversion,
along with any EDI standard definitions that you have customized. New definitions are
also shown using bold text in the EDI Structure pane.

See “Creating New Structure Definitions” on page 344 for more information.

EDI XML Conversions and EDI Definitions
When you use an EDI to XML conversion to convert an EDI document to XML, the
DataDirect XML Converter engine uses
o TheEDI dialect and version declared in the EDI document you are converting
« Any customized definitions you have created (shown in bold in the EDI Structure

pane)

« XML Converter properties specified in the converter:EDI URI
The SEF file associated with your EDI to XML conversion does not contain any
information about the EDI standard displayedinthe EDI to XML editor. Rather, the XML
Converter engine usesits knowledge about the EDI standard (from the repository) for the

document being converted, along with any changes to the standard for those definitions
that you have created or modified.

Views of the EDI Structure
The EDI Structure pane provides two views to help you build your EDI to XML

conversion:
« Thecomplete specification for the EDI standard you have selected, including local
definitions

« Only local definitions that you have imported to the SEF
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You use the Show Full Dialect Specification button (-2/) to toggle between these views.

e 6 Composites

® 5 Elements  £pj standard definitions
5 a Code Lists

= Untitled._= Dialect Version
] ~| ) [x12 | o0z030

+ E Tranzaction Meszages Show full/local
#-[—) Segments specification

Figure 210. EDI Structure Pane Shows Full or Local Specification

When you create an EDI to XML conversion (whether based on an EDI document or
starting directly from an EDI standard), the EDI Structure pane makes the complete
specification accessible—just expand anodeto view adefinition, and its properties appear

in the Properties window.

w  Untitled...*

EDI Structure
#-F9 Transaction Messages
#-[ Seaments
= 6 Composites
sibe Uit of Measure
&E 355: Unit or Basis for Measurement
&8 1018 Exporent
2B 543 Multiplier
2B 355: Unit or Basis for Measurement
28 1015 Exponent
2B 643: Multiplier
2B 355: Unit or Basis for Measurement
' 1018 Exponent
2B 543 Multiplier
B 355: Unit or Basis for Measurement
CP' 1018 Exponent
2B 549 Multiplier
2B 355: Unit or Basis for Measurement
28 1015 Exponent
+-@8 643 Multiplier
5 L-_E; Elements
Ex @ Code Lists

O O
7

[ LR v | =12 + | 003030 >

Figure 211. Full Specification

Asyou build your EDI to XML conversion and make changes to the EDI standard, you
might want to simplify the view in the EDI Structure pane to display only those local
definitions. In the following illustration, the segments A1, A2, and AC have all been
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imported from repository. These definitions, which are shown in bold, reside in the SEF
file that represents your EDI to XML conversion.

o Untitled...*|

] N EE ~ | oo3o30 v| @

EDI Stuicture
8 Transaction Meszages
SR ] Segments
+- 2 Al: Rejection
#- 2 A2 Acceptance Detail
+- 2 AC: Movement Rate Set Header
6 Composites
% Elements
@ Code Lists

Figure 212. Imported Definitions

Creating New Structure Definitions

A structure definition is atop-level definition in an EDI Structure:

o Message
o Segment
o Element
« Composite
o Codelist

Structure definitions can be created from anywherein the EDI Structure—that is, context
(as shown by cursor placement or focus) does not matter. New structure definitions are
placed in the appropriate EDI structure folder, sorted alphanumerically. Creating a new
structure definition does not affect existing definitions in the EDI Structure.

This section covers the following topics:

« “Adding aMessage” on page 345

« “Adding a Segment” on page 345

« “Adding an Element” on page 346

« “Adding aComposite” on page 347

« “Adding aCodeList” on page 347

For information on creating context-specific definitions (code list values, segment
references, and similar definitions, see “Modifying Existing Definitions” on page 348.
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Adding a Message

0 To add a message:

1. Right-click any nodeinthe EDI Structure and select New Definition > Message from
the shortcut menu.
Alternative: Select EDI > New Definition > Message from the Stylus Studio menu.

The Message Definition dialog box appears.

Message Definition E|
Message Marne:

Description:

QK Cancel
Figure 213. Message Definition Dialog Box

2. Enter amessage name and, optionally, a description.

3. Click OK.

The message definition is added to the existing transaction messages in the EDI
Structure; new messages are sorted in al phanumeric order.

Adding a Segment

0 To add a segment:

1. Right-click any node in the EDI Structure tree and select New Definition > Segment
from the shortcut menu.

Alternative: Select EDI > New Definition > Segment from the Stylus Studio menu.
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The Segment Definition dialog box appears.

Segment Definition E|
Seqment Marme: | |
Description:

OF. Cancel

Figure 214. Segment Definition Dialog Box

Enter a segment name and, optionally, a description.

Click OK.

The segment definition is added to the existing segments in the EDI Structure; new
segments are sorted in a phanumeric order.

Adding an Element

O To add an element:

1.

Right-click any node in the EDI Structure and select New Definition > Element from
the shortcut menu.

Alternative: Select EDI > New Definition > Element from the Stylus Studio menu.
The Element Definition dialog box appears.

Element Definition

Element Name: | ‘

Data Type: |.QN - Alphanumeric v ‘

Length

Description:

[ Ok ] [ Cancel ]

Figure 215. Element Definition Dialog Box
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2. Enter an element name and specify a data type (the default is AN — Alphanumeric).
3. Optionally specify minimum and maximum lengths and a description.

4. Click oK.

The element definition is added to the existing el ementsin the EDI Structure; new
elements are sorted in alphanumeric order.

Adding a Composite

0 To add a composite:

1. Right-click any node in the EDI Structure and select New Definition > Composite
from the shortcut menu.

Alternative: Select EDI > New Definition > Composite from the Stylus Studio menu.
The Composite Definition dialog box appears.

Composite Definition @

Composite Marme: |

Description:

QK Cancel
Figure 216. Composite Definition Dialog Box

2. Enter acomposite name and optionally specify adescription.

3. Click OK.

The composite definition is added to the existing compositesin the EDI Structure;
new composites are sorted in alphanumeric order.

Adding a Code List

0 To add a code list:

1. Right-click any nodeinthe EDI Structure and select New Definition > Code List from
the shortcut menu.

Alternative: Select EDI > New Definition > Code List from the Stylus Studio menu.
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The Code List Definition dialog box appears.

Code List Definition

Code List Name:

QK Cancel
Figure 217. Code List Definition Dialog Box

2. Enter acodelist name and click OK.
The code list definition is added to the existing code lists in the EDI Structure; new
code lists are sorted in alphanumeric order.

See “Creating a Code” on page 354 to learn how to add values to acode list.

Modifying Existing Definitions
In addition to creating new definitions, you can al so modify existing definitionsin an EDI
Structure. For example, you can add an element reference to an existing composite. When
you modify an existing definition, Stylus Studio imports alocal copy of this definition
from the EDI repository and placesit in your EDI to XML conversion. Imported
definitions are displayed in bold in the EDI Structure paneinthe EDI to XML editor. See
“Ways to Customize an EDI Standard” on page 341 for more information on this topic.
This section covers the following topics:
« “Adding versusInserting” on page 348
« “Creating a Segment Reference” on page 349
o “Creating a Group” on page 350
« “Creating an Element or Composite Reference” on page 351
« “Creating a Repetition” on page 353
o “Creating a Variation” on page 353
« “Creating a Code’ on page 354
You can also modify an existing definition by changing one of its properties. See
“Modifying Definition Properties’ on page 355 for more information.

Adding versus Inserting
You modify an existing definition by adding or inserting another definition to it.
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« When you add a definition, it is added to the end of the existing definition. For
example, if you add an element reference to a segment, the new element referenceis
added after the last element reference currently defined for that segment.

To add a definition, choose Add from the shortcut or Stylus Studio menu.

« Whenyouinsert adefinition, you get to choose whether to placeit before or after the
current definition. For example, if thefocusison asegment reference, you can choose
whether to place a new group before or after the segment reference.

To insert adefinition, choose Insert After or Insert Before from the shortcut or Stylus
Studio menu.

Creating a Segment Reference

You can create a segment reference for amessage or agroup. You can reference an
existing segment or create a new segment and reference that.

0 To create a segment reference:

1. Right-click the message or group definition to which you want to add the segment
reference and select Add > Segment Reference from the shortcut menu.
Alternative: Select EDI > Add > Segment Reference from the Stylus Studio menu.
The Add Segment Reference dialog box appears.

Add Segment Reference @

Lo tete N Y A AT Accommodation sllocatied

Mews Segment ...

Reference Properties

Modifier: v
Requirement: Conditional hd
Maxirnurm Use: 1
Ordinal: 4

Positian: 10z0

Figure 218. Add Segment Reference Dialog Box

2. Choose the segment you want to reference, or click New Segment to create a new
segment as your segment reference. See “Adding a Segment” on page 345 for
information on creating segments.
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Choose the setting for the Modifier property — you can leave thisfield blank, or you
can define the segment reference as Dependent, Must Be Used, Not Recommended,
Not Used, or Used.

Choose the setting for the Requirement property —you can choose Conditional,
Facultative, Mandatory, or Optional.

Choosethe setting for the Maximum Use, Ordinal, and Position property. You can use
the default valuesiif appropriate.

Click OK to add the segment reference to the EDI Structure.

Creating a Group

You can create a group for amessage or another group. You can use an existing segment
for the group’s loop trigger or create a new segment and use that.

[0 To create agroup:

1.

Right-click the message or group definition to which you want to add the group and
select Add > Group from the shortcut menu.

Alternative: Select EDI > Add > Group from the Stylus Studio menu.
The Group Definition dialog box appears.

Group Definition @

aal: Accommodation allofid

Mew Segment .,

Choose a loop trigger:

Group label (optional):

Modifier: v
Requiremnent: Conditional v
Maximum Use; 1

Ordinal:

Position:

Figure 219. Group Definition Dialog Box

Choose the segment you want to use as the loop trigger, or click New Segment to
create anew segment as your loop trigger. See “Adding a Segment” on page 345 for
information on creating segments.
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3. Optionaly, specify agroup label.

4. Choose the setting for the Modifier property — you can leave thisfield blank, or you
can define the segment reference as Dependent, Must Be Used, Not Recommended,
Not Used, or Used.

5. Choosethe setting for the Requirement property —the default is Conditional, but you
can choose Facultative, Mandatory, or Optional.

6. Choose the setting for the Maximum Use property. You can use the default value if
appropriate. You can specify Ordinal or Position propertiesfor agroup definition only
if the Loop Sequence property for the EDI Structure is set to Enable.

7. Click OK to add the group to the EDI Structure.

Creating an Element or Composite Reference

You can create an element or composite reference for a segment, composite, repetition,
variation, or another element or composite reference. You can use an existing element or
composite for the element or composite reference, or create a new element or composite
and use that.

0 To create an element or composite reference:
1. Right-click the definition to which you want to add the element or composite
reference and select Add > Element or Composite Reference from the shortcut menu.

Alternative: Select EDI > Add > Element or Composite Reference from the Stylus
Studio menu.
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The Add Element or Composite Reference dialog box appears.

Add Element or Composite Reference E]

Choose an element or composite:
{0001 : Synkayx identifier w
Mew Element ... ] [ Mew Composite ...
Reference Properties

Modifier: v

Requirement: Conditional i

Repeat Counk: 1

Mlinirurn:

flaximum;

Ordinal: 3

Figure 220. Add Element or Composite Reference Dialog Box

2. Choosethe element or composite you want to reference, or click New Element or New
Composite to create a new element or composite to reference. See “Adding an
Element” on page 346 or “Adding an Element” on page 346 for information on
creating these definitions.

3. Choose the setting for the Modifier property — you can leave thisfield blank, or you
can define the reference as Delete, Dependent, Must Be Used, Not Recommended,
Not Used, or Used.

4. Choose the setting for the Requirement property — the default is Conditional, but you
can choose Facultatif (composite reference) or Dependent (element reference),
Mandatory, or Optional.

5. Enter the value for the Repeat Count, Minimum, Maximum, and Ordinal properties.
You can use the default value, if available and appropriate.

6. Click OK to add the reference to the EDI Structure.
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Creating a Repetition

You can create arepetition for a segment, composite, segment or composite reference, or
another repetition. A repetition is created as a child of the definition. It is given the label
REPEAT in the EDI Structure.

0 To create arepetition:
1. Right-click the definition for which you want to create a repetition and select Add >
Repetition from the shortcut menu.
Alternative: Select EDI > Add > Repetition from the Stylus Studio menu.
The repetition is added to the definition.

Creating a Variation

You can create a variation for a segment or acomposite. A variation resultsin the cloning
of the segment or composite on which it isbased. The original definition isgiven thelabel
inthe EDI Structure of # Base; thefirst variationislabeled #1. Subsequent variations are
labeled #2, #3, and so on. Thefirst # is the symbol for the tree node, and not part of the
name.

0 To create a variation:
1. Right-click the definition for which you want to create a variation and select Add >
Variation from the shortcut menu.
Alternative: Select EDI > Add > Variation from the Stylus Studio menu.
The variation is added to the definition.
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Creating a Code

You can add a code to an element, an element reference, acode list, or another code. You
can create a single code (99, for example) or arange of codes (AA to AZ, for example).

00 To create a code definition:

1. Right-click the definition to which you want to add the code definition and select Add
> Code from the shortcut menu.

Alternative: Select EDI > Add > Code from the Stylus Studio menu.
The Code Definition dialog box appears.

Code Definition X

(=) gingle code

Yalue: |

Description:

O pange

Begin: End:

Ok Cancel
Figure 221. Code Definition Dialog Box

2. If you want to create

= A singlecode, enter avaluein the value field and, optionally, adescriptionin the
Description field.

= A range of codes, select the Range radio button, and enter range values in the
Begin and End fields.

3. Click OK to add the reference to the EDI Structure.
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Modifying Definition Properties

TheProperties window, likethe one showninthefollowingillustration, allowsyou to edit

properties associated with the definiti

on in the EDI Structure that currently has focus.

Untitled. ..~

3

831 w | 004020

+-[A 823 Lockbox

+-fA 824 Application Advice

+ @ H2E: Tax Information Exchange
£ @ H27: Financial Retumn Notice
EY @ 828 Debit Authorization

V| [x12

m

3 786 Security Level Code
+-@ DTM: Date/Time Reference
+-@ N9 Reference |dentification
+ @& TRM: Trace

H-@3 OTY: Quantity

NS :ETACSZ00001
£ @ H29; Payment Cancellation Request TR BE200001
+ g 830 Planning Schedule with Releaze Capability o .2.100000.00
= 931: Application Control Totals p .
+-@3 ST: Transaction Set Header E'Y%?SDiZEDDI
=-@3 BGM: Beqinning Seament A o
+ CP' 353 Tranzaction Set Purpose Code SE:1:12d
el 127 Reference |dentification Properties
w88 373 Date
#-gB 337 Time Mame Walue
T C.P' E2% Time Code T_vpt?_ Element Reference
+-#8 127 Reference ldentification Mod".'e'
5 C.P' B4 Transaction Type Code Fequirement Mandatary
g . Repeat Count 1
+- @5 306 Action Code AN - Alphanumesic

v EI URI: converterEDI

CTaa:00: $00:
Hleg: oT: 89887 76655:1122334455: 20
HeT:231:00128001

BeN:00 :%8200001: Z00412Z01

D atatype

Minimum Length Default (1]
M aximum Length Default (50
Ordinal 2

4% GROUP_1: AMT

Figure 222. Properties Window

A definition gains focus when you

Click alinein the EDI document pane
Click a definition in the EDI Structure pane

TheProperties isadocking window. By default, it is docked to the Stylus Studio window,
but you can drag it anywhere you like.

When you modify adefinition’s properties, Stylus Studio imports alocal copy of this
definition from the EDI repository and places it in your EDI to XML conversion.

Imported definitions are displayed in

bold in the EDI Structure pane. See “Waysto

Customize an EDI Standard” on page 341 for more information on thistopic.

You can also modify an existing definition by adding new definitionsto it. See

“Moadifying Existing Definitions’ on

page 348 for more information.
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Importing EDI Standard Definitions

This section describes how to import EDI standard definitions. You might want to do this,
for example, to import code list values from a more recent version of a dialect while
leaving the rest of the EDI standards on which your EDI to XML conversion is based
intact.

In the following example, we are importing the Late Reason Code code list from X12
version 005050 into our EDI to XML conversion, which isbased on X12 version 004030,
to acquire a new code value — LB = Awaiting Wage Amount Verification.

0 To import an EDI standard definition:

1. Openthe EDI to XML conversion whose EDI structure you want to update by
importing an EDI Standard.

2. Inthe EDI Structure pane, select the definition you want to import.
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Here, we have selected 9: L ate Reason Code. Note that the last code defined for this
code list (in version 004030) is LA = Intermittent Lost Time Prior to First Payment.

o Untitled.._* |

EE v [«z v| el

EDI Stucture

#-F9 Transaction Messages
+-[= Segments

3 E Composites

3 kﬁ Elements

= Eb Code Lists

id C1 = Caoverage Lack of Infarmation

id D1 = Dispute Concerning Coverage

id D2 = Digpute Conceming Compenzability in ‘wWhole
id D3 = Dizpute Concerning Compensability in Part
id D4 = Dispute Concerning Disability in wWhale

id DB = Dispute Concerning Disability in Part

id DE = Dispute Concerning Impaimnent

id E1 ="Wrongful Detemination of Mo Coverage

id EZ = Ermor(z] from Emplayer

id E3 = Emar(s] from Employes

id E4 = Emor(s] from State

id E5 = Emor(s] from Health Care Provider

id EF = Errar(z] from Other Claim Adrministrator, Independent Adjuster or Thi
id L1 = Late Mo Excuse

id L2 = Late Motification, Employer

id L3 = Late Motification, Employes

id L4 = Late Motification. State

id L5 = Late Motification, Health Care Provider

id LE = Late Motification, &ssigned Fisk

id L7 = Late Investigation

id L8 = Technical Processing Delay or Computer Failure
id L9 = Manual Processing Delay

id LA = Intemittent Last Time Priar ta First Payrent
+ ¥ 11 Biling Code

Figure 223. EDI Structure

3. Changethevauein the Select Version field to 005050.
This displays the EDI structure for X12 version 005050 in the EDI Structure pane.
Note that the Late Reason Code code list includes LB = Awaiting Wage Amount
Verification.

4. Right-click the codelist 9: Late Reason Code, and choose Import Definition from the
shortcut menu.
This directs Stylus Studio to import the codes for this code list from X12 version
005050 into the local EDI Structure.

5. Change the version back to 004030 (since thisisthe version on which the EDI to
XML conversion is based).
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6. Click the Show Full Dialect Specification button (=2]). Note that the 9: Late Reason
Code code list appearsin bold to indicate that alocal copy of this definition has been
created.

o Unitled...*|

P (231

EDI Structure

3 8 Transaction Meszages
[} Segments
6 Composites
% Elements

= Eb Code Lists

= & 9: Late Reason Code

V| =2 | ooanz0 v

id C1 =C ge Lack of Inf

id D1 = Dispute Concerning Coverage

id D2 = Dispute Concerning Compensability in Whole
id D3 = Dispute Concerning Compensability in Part
id D4 = Dispute Concerning Disability in Whole

id D5 = Dispute Concerning Disability in Part

id D6 = Dispute Concerning Impairment

id E1 = Wrongful Determination of No C. h

id E2 = Emor(s) from Employer

id E3 = Emor(z] from Employee

id E4 = Error(z]) from State

id E5 = Error(s) from Health Care Provider

id EG6 = Error(s) from Other Claim Administrator. Independent
id L1 = Late Mo Excuse

id L2 = Late Motification. Employer

id L3 = Late Motification, Employee

id L4 = Late Notification, State

id L5 = Late Motification, Health Care Provider

id L6 = Late Motification, Assigned Risk

id L7 = Late Investigation

id L8 = Technical P ing Delay or Comp Failure
id L9 = Manual Processing Delay

id LA = Intermittent Lost Time Prior to First Payment
id LB = Awaiting Wage Amount Verification

Figure 224. Local Definitions in EDI Structure

Undoing Customizations

You can undo any customi zations you make using the Restore feature in the EDI to XML
editor. When you undo a customization, the modified definition reverts to its EDI
standard, effectively removing it from the SEF file for your EDI to XML conversion.

Tip You can use Undo to undo changesincrementally, backing out changesone at atime. See
Using Undo on page 318 for more information.
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0 To undo achange to an EDI standard definition:

1.

Tip

In the EDI Structure tree, select the modified EDI standard definition whose change
you want to undo.

Modified definitions are displayed in bold text. Use the Show Full Dialect
Specification button (&) to toggle the display of modified standardsin the EDI
Structure tree.

Right-click the modified definition and select Restore Definition from the short cut
menu.

Alternative: Select EDI > Restore Definition from the Stylus Studio menu.

The modified definition revertsto its EDI standard; it is removed from the SEF file
for your EDI to XML conversion and no longer appearsin bold text in the EDI
Structure tree.

Removing a Definition

In addition to adding and changing definitions, you can modify your local copy of an EDI
standard by removing a definition. You can remove the following definitions:

Composite references
Element references
Segment references
Groups

Repetitions
Variations

Use care when removing references and groups, as this can have unintended
consequences regarding the expected structure of an EDI document and numbering.

Tip If you want to remove a definition because that structure is never used by the EDI
documentsin your organization, consider changing the definition’s Modifier property to
Not used. This retains the definition in the EDI Structure, but instructs the XML
Converter engine to ignore it when converting EDI to XML.
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0 To remove a definition:

1.

In the EDI Structure tree, select the definition you want to remove from the EDI
Structure.

Right-click the definition and select Remove from the short cut menu.
Alternative: Select Remove from the Stylus Studio menu.

The definition is removed from the EDI Structure tree.

Generating XQuery and XML Schema from EDI

Stylus Studio provides tools to help you generate XQuery and XML Schema from EDI
messages.

Generate X Query/XML Schema — use this tool when you are working in the EDI to
XML editor. The current context of the EDI dialect, version, and message type
provide much of the information used to generate the XQuery and/or XML Schema.
The SEF file associated with your EDI to XML Conversion also providesinformation
that has an impact on the generated X Query/and or XML Schema.

EDI to XQuery document wizard — use the EDI to X Query document wizard when
you want to generate X Query and/or XML Schemafrom an EDI message but are not
currently working in the EDI to XML editor.

Generate XQuery/XML Schema

The Generate XQuery/XML Schematool letsyou generate X Query and/or XML Schema
based on the currently selected EDI message in the EDI to XML editor.

0 To use the Generate XQuery/XML Schema tool:

1.

Inthe EDI to XML editor, select the EDI message for which you want to generate
XQuery and/or XML Schemafrom the EDI structure pane.
Select EDI > Generate XQuery/XML Schema from the menu.

Alternative: Right-click the EDI message and choose Generate XQuery/XML Schema
from the short-cut menu.
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The Generate XQuery/XML Schema dialog box appears.

Generate XQuery/XMLSchema g|

Message: BANSTA Banking Status Mode: (3)Batch () Interactive

Create ¥Query For this EDI Message
®CiFile: | file:ffjc: ftempfUntitled1_BANSTA.xq E]

(%) Mandatory segments and elements only
(O all segments but only mandatory elements

(O all segments and glements

Create ¥ML Schema for this EDI Message

¥SD File: | File:fffc: frempfUntitled ] _BANSTA, xsd E]
‘Write annotations describing each element

Enumerations for elements that have codelists

Use "unbounded” for maxOccurs when loop value is 99 or higher {accommodates limitations in many validators)

[ Ok ] [ Cancel ]

Figure 225. Generate XQuery/XML Schema Dialog Box

3. Specify the generation options as described in the following section, “ Generate
XQuery/XML SchemaDialog Box” on page 361.

4. Click OK.

Generate XQuery/XML Schema Dialog Box
This section describes the fields of the Generate XQuery/XML Schema dialog box.

Message
Displays the name of the message; based on the message that was active in the EDI
Structure pane of the EDI to XML editor when you selected EDI > Generate
XQuery/XML Schema from the menu.

Mode

Whether the EDI is processed in batch or interactive mode. Valid for EANCOM,
EDIFACT, and IATA (Cargo-IMP and PADIS) only.

Create XQuery for this EDI Message — A check box you use to indicate that you want to
generate XQuery for the EDI message.

« XQ File—The URI for thefile to which the generated XQuery iswritten. By
default, thisisuntitledn_name.xquery file, where nisaunique number and name
isthe EDI message name abbreviation.
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Mandatory segments and elements only —Generates only those segmentswhose
Requirement property is“mandatory” and, for them, only the mandatory element
and composite references.

All segments but only mandatory elements — Generates all segments, but, for
each of them, only the mandatory element and composite references.

All segments and elements — Generates all segments, and all element and
composite references specified for them.

Create XML Schema for this EDI Message — A check box you use to indicate that you
want to generate XML Schema for the EDI message.

XSD File — The URI for the file to which the generated XML Schemais written.
By default, thisisuntitledn_name.xsd file, where nisaunique number and name
isthe EDI message name abbreviation.

Write annotations describing each element — Whether or not you want the
generated XML Schemato include annotations that are part of the EDI message.

Enumerations for elements that have codelists — Whether or not you want the
generated XML Schemato include enumerations for fields that have lists of
values.

Use “unbounded” for maxOccurs when loop value is 99 or higher) — Replaces
maxOccurs values of 100 or greater with “unbounded”. This option ensures that
the generated XML Schema can be successfully validated by most processors.

EDI to XQuery Document Wizard

The EDI to XQuery document wizard lets you generate X Query and/or XML Schema.
Thedocument wizard givesyou theflexibility to specify values such asthe XML structure
and SEF file to use when generating output.

0 To use the EDI to XQuery document wizard:

1. Inthe Stylus Studio, select File > Document Wizards from the menu.
The Document Wizard dialog box appears.
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2. Click the XQuery tab and double-click the EDI to XQuery icon.
The Generate XQuery from EDI Standards dialog box appears.

Generate XQuery from EDI Standards g|
Message
Dialect: w Wersion: | 1997 w Mode: (%)Batch () Interactive
A~

Message = Description

BANSTA  Banking Status

COACSU Commercial Account Surmary
COMDIS  Commercial Dispute

COMTRL Syntax and Service Report
CREMUL  Multiple Credit Advice
DEBMUL  Multiple Debit Advice

DELFOR.  Delivery Schedule

DESADY  Despatch Advice

FIMCAMN  Financial Cancellation

FINSTA Financial Statement v
AML Skruckure AQuery Generation Options
Use long names far: Elements  [v| Segments (#) Mandatory segments and elements only
[[wrap with "GROUP" and "INTERCHANGE" elements (O all segments but only mandatory elements
[ Prefix GROUP_N tags with the message name (O all segments and elements

[eut the data value in value= attributes
[Put decoded data valuss in decode= attributes

Create ¥ML Schema For this EDI Message

%50 File: E]
‘Write annotations describing each element

Enumerations for elements that have codelists

Use "unbounded” for maxOccurs when loop value is 99 ar higher
{accommodates limitations in many validators)

SEF File

(]

[ Ok ] [ Cancel ]

Figure 226. Generate XQuery from EDI Standards Dialog Box

3. Specify the generation options as described in the following section, “ Generate
XQuery from EDI Standards’ on page 363.

4. Click OK.

Generate XQuery from EDI Standards
This section describes the fields of the Generate XQuery from EDI Standards dialog box.

Message

You use the fieldsin the Message group box to specify information about the EDI
standard for which you want to generate XQuery.
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Dialect — Drop-down list that lets you specify the EDI dialect for which you want
to generate XQuery.

Version — Drop-down list that lets you specify the version for the EDI dialect you
sel ected.

Mode — Whether the EDI is processed in batch or interactive mode. Valid for
EANCOM, EDIFACT, and IATA only.

Message/Description — The specific EDI message for which you want to generate
the XQuery.

XML Structure
You usethefieldsof the XML Structure group box to specify the structure of the XML

Use long names for — Whether or not you want to use the long element and/or
segment names as part of the XML tag — UNBO1-SyntaxIdentifier VErsus UNBO1,
for example.

Wrap “GROUP” element around message groups — Whether you want to wrap
a <GRoupP> element around transaction messages. This can make message
groupings easier to handle with XPath for EDI document with multiple message
groups.

Prefix GROUP_N tags with the message name — Adds the message name to the
GROUP_n prefix in the XML element tag. For example, <TS_831_GROUP_1>.

Put the data value in value= attributes — Places code list datavaluesin an value=
string in the element tag. For example, <BGNO1 value="00"><!--353: Transaction
Set Purpose Code--></BGNO1>. By default, the data value is output to XML as text
(<BGNO1><!--353: Transaction Set Purpose Code-->00</BGNO1>).

Put decoded data values in decode= attributes — Places decoded code list data
valuesin adecode= string in the element tag. For example, <1SA15
decode="Production Data”>. By default, the decoded value is not output to XML.

XQuery Generate Options

You use the XQuery Generation Options group box to specify what EDI structures
you want represented in the generated X Query. X Query resulting from the document
wizard isoutput as an Untitledn.xquery file, where nisaunique number, directly to
the Stylus Studio desktop.

Mandatory segments and elements only —Generates only those segmentswhose
Requirement property is“mandatory” and, for them, only the mandatory element
and composite references.

All segments but only mandatory elements — Generates all segments, but, for
each of them, only the mandatory element and composite references.
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« All segments and elements — Generates all segments, and all element and
composite references specified for them.

Create XML Schema for this EDI Message

In addition to generating X Query for an EDI message, you can choose to generate an
XML Schema for the same message at the same time. The fields in this group box
allow you to specify the settings that are used to generate the XML Schemafor the
selected EDI message.

o XSD File — The URI for the XML Schema (.xsd) file that is output by the
document wizard.

« Write annotations describing each element — Whether or not you want the
generated XML Schemato include annotations that are part of the EDI message.

o Enumerations for elements that have codelists — Whether or not you want the
generated XML Schemato include enumerations for fields that have lists of
values.

e Use “unbounded” for maxOccurs when loop value is 99 or higher) — Replaces
maxOccurs values of 100 or greater with “unbounded”. This option ensures that
the generated XML Schema can be successfully validated by most processors.

SEF File — The URI of the Standard Exchange Format (SEF) file, if any, you want to use
when generating XML in XQuery and XML Schema files. The SEF file can augment
information that Stylus Studio uses to generate XQuery and XML Schema — customized
EDI definitions are stored in the SEF file, for example. If the same setting is specified by
both the document wizard and the SEF file, the SEF file value is used.

EDI Structure Definitions Properties Reference

This section provides reference information for the EDI Structure definition properties
displayed in the Properties window in the EDI to XML editor.

This section covers the following topics:

Code List Properties on page 366

Composite Properties on page 366
Composite Reference Properties on page 367
EDI Structure Properties on page 368
Element Properties on page 368

Element Reference Properties on page 369
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« Group Properties on page 370

« Message Properties on page 371

« Repetition Properties on page 372

o  Segment Properties on page 372

« Segment Reference Properties on page 373

« Transaction Message Properties on page 374

Code List Properties

Table 47. Code List Properties

property is set to Conditional .

Rules entered in thisfield are preserved, but the ruleis not
enforced at runtime.

Property Description Editable
Type A label that identifies the type of definition. No
Name The name of the code list. Names are always uppercase. Yes
Composite Properties
Table 48. Code List Properties
Property Description Editable
Type A label that identifies the type of definition. No
Name The name of the composite. Names are always uppercase. Yes
Description | The definition description. Can be mixed case. Yes
Syntax Rules | The logic used when a composite reference’s Requirement Yes
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Composite Reference Properties

Table 49. Composite Reference Properties

Property

Description

Editable

Type

A label that identifies the type of definition.

No

Modifier

Indicates whether the composite reference is used in your
customized EDI structure. For new composite references, you
can leave thisfield empty. If you are modifying an existing
compositereference because you want toindicatethat itisnot
used in your customized EDI structure, set Modifier to Not
Used instead of removing it from the EDI structure.

Valid values for this property are Deleted, Dependent, Must
be used, Not recommended, Not used, Recommended.

Yes

Requirement

Whether the composite reference is Conditional, Dependent,
Mandatory, or Optional.

Note: If aModifier is specified, it overrides the Requirement
at runtime.

Yes

Repeat
Count

The number of times the reference can occur within the
segment, composite, or other definition.

Yes

Ordinal

Thereference’s place within the segment, composite, or other
definition. Thisfield isgrayed out unlessyou have set the EDI
Structure Loop Sequence Enabled property to Enable.

Not availableif the composite referenceyou are editing is part
of acomposite (and not a segment).

Yes

Rename
XML Node

If present, thisvalueis used instead of the composite
reference name to form the XML node name. The original
name is retained as an attribute in the XML tag.

Not availableif the composite referenceyou are editingispart
of acomposite (and not a segment).

Yes
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EDI Structure Properties

Table 50. EDI Structure Properties

Property Description Editable
SEF Version | The SEF syntax version Yes
Loop Determines whether groups have their own ordinal and Yes
Sequence position number.

Enabled

Description | The definition description. Can be mixed case. Yes

Element Properties

Table 51. Element Properties

Property Description Editable
Type A label that identifies the type of definition. No
Name The name of the element. Names are always uppercase. Yes
Datatype The element’s datatype. Yes
Code List The code list associated with this element. HL7 only. Yes
Minimum The element’s minimum length. Yes
Length

Maximum The element’s maximum length. Yes
Length

Description | The definition description. Can be mixed case. Yes
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Element Reference Properties

Table 52. Element Reference Properties

definition. Default value if present, has been cal culated not to
interfere with other definitions.

Property Description Editable
Type A label that identifies the type of definition. No
Modifier Indicates whether the element referenceis used in your Yes
customized EDI structure. For new element references, you
can leave thisfield empty. If you are modifying an existing
element reference because you want to indicate that it is not
used in your customized EDI structure, set Modifier to Not
Used instead of removing it from the EDI structure.
Valid values for this property are Dependent, Must be used,
Not recommended, Not used, Recommended.
Requirement | Whether the element reference is Conditional, Dependent, Yes
Mandatory, or Optional.
Note: If aModifier is specified, it overrides the Requirement
at runtime.
Repeat The number of times the reference can occur within the Yes
Count segment, composite, or other definition.
Minimum The element’s minimum length. Yes
Length
Maximum The element’s maximum length. Yes
Length
Ordina Thereference’s place within the segment, composite, or other | Yes
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Table 52. Element Reference Properties

Property Description Editable

Rename If present, thisvalue is used instead of the element reference | Yes
XML Node | name to form the XML node name. The origina nameis
retained as an attribute in the element tag.

Not applicable to element references defined in segment

references.
Append Allowsyou to append acodelist valueto theelement tag of a | Yes
Valueto related node — <ISA01_P tag="ISA01">, for example. This

XML Node | alowsyou to create an XML Schemathat can aid XML
mapping —when the source XML document presents
name/value pairs as separate el ements, you can effectively
collapsetwo nodesinto one. The tag to which you append the
code list value is also given an attribute that identifies the
source of the code value to assist XML Converter when
converting XML to EDI.

Not available for element references defined in segment
references.

Group Properties
Table 53. Group Properties

Property Description Editable
Type A label that identifies the type of definition. No
Modifier Indicates whether the group is used in your customized EDI | Yes

structure. For new groups, you can leave this field empty. If
you are modifying an existing group because you want to
indicate that it is not used in your customized EDI structure,
set Modifier to Not Used instead of removing it from the EDI
structure.

Valid values for this property are Dependent, Must be used,
Not recommended, Not used, Recommended.
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Table 53. Group Properties

Property Description Editable
Requirement | Whether the group is Conditional, Dependent, Mandatory, or | Yes
Optional.
Note: If aMaodifier is specified, it overrides the Requirement
at runtime.

Maximum The number of times the group can appear in the associated | Yes
Use message or group.

Append Whether or not you want to append anumber (starting with1 | Yes
Counter to for thefirst group, 2 for the second, and so on) to the GROUP
XML Node | tagin the generated XML — <GROUP_1>, for example.

Ordinal The group’s place within the message or other group. This Yes
fieldisgrayed out unlessyou have set the EDI Structure Loop
Sequence Enabled property to Enable.

Position The position within the associated message or group at which | Yes
the group starts. Default value if present, has been calculated
not to interfere with other segments or groupsin the message.

Thisfield isgrayed out unless you have set the EDI Structure
Loop Sequence Enabled property to Enable.

Rename If present, thisvalueisusedinstead of the group nametoform | Yes
XML Node | the XML node name. The original nameisretained as an
attribute in the element tag.

Message Properties

Table 54. Message Properties

Property Description Editable
Type A label that identifies the type of definition. No
Name The name of the message. Names are always uppercase. Yes
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Table 54. Message Properties

property is set to Conditional .

Rules entered in thisfield are preserved, but the ruleis not
enforced at runtime.

Property Description Editable
Description | The definition description. Can be mixed case. Yes
Rename If present, this value is used instead of the message nameto | Yes
XML Node | formthe XML node name. The original name isretained as
an attribute in the XML tag.
Repetition Properties
Table 55. Repetition Properties
Property Description Editable
Type A label that identifies the type of definition. No
Repetition The number of times the definition (segment, segment Yes
reference, composite, composite reference, other repetition,
or variation) can be repeated.
Segment Properties
Table 56. Segment Properties
Property Description Editable
Type A label that identifies the type of definition. No
Name The name of the segment. Names are always uppercase. Yes
Description | The definition description. Can be mixed case. Yes
Syntax Rules | The logic used when a segment reference’s Requirement Yes
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Table 56. Segment Properties

Property Description Editable
Allow For the HL7 dialect, this property allows the last element Yes
multipletail | (whether composite or atomic) of that segment to repeat an
components | unlimited number of times (aslong asthe overall limit of 254
elements in a segment is not exceeded).
Valid values are True and False (the default).
Rename If present, thisvalueis used instead of the segment nameto | Yes
XML Node | formthe XML node name. The original name isretained as
an attribute in the XML tag.
Segment Reference Properties
Table 57. Segment Reference Properties
Property Description Editable
Type A label that identifies the type of definition. No
Modifier Indicates whether the segment referenceis used in your Yes
customized EDI structure. For new segment references, you
can leave thisfield empty. If you are modifying an existing
segment reference because you want to indicate that it is not
used in your customized EDI structure, set Modifier to Not
Used instead of removing it from the EDI structure.
Valid values for this property are Dependent, Must be used,
Not recommended, Not used, Recommended.
Requirement | Whether the composite referenceis Conditional, Facultatif, | Yes
Mandatory, or Optional.
Note: If aMaodifier is specified, it overrides the Requirement
at runtime.
Maximum The number of times the segment reference can appear inthe | Yes
Use associated message or group.
Ordinal The segment reference’s place within the message or group. | Yes
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Table 57. Segment Reference Properties

Property Description Editable

Position The position within the associated message or group at which | Yes
the segment reference starts. Default valueif present, has
been cal culated not to interfere with other segments or groups
in the message.

Rename If present, this valueis used instead of the segment reference | Yes
XML Node | name to form the XML node name. The origina nameis
retained as an attribute in the XML tag.

Transaction Message Properties
See Message Properties on page 371.
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EDI XML Converters Properties Reference

See Chapter 4, XML Converters™ Properties, in the DataDirect XML Converters™

User's Guide and Reference for complete properties reference information for all

DataDirect XML Converters. information. Documentation for DataDirect XML

Converters™ isavailable:

o Inthe\doc folder for DataDirect XML Converters where you installed Stylus Studio
—\components\XML Converters for .NET\doc, for example

« Onthe DataDirect Technologies web site:
http://www.datadirect.com/techres/xmlconvertersproddoc/index.ssp
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Chapter 5 \working with XSLT

Stylus Studio provides many features for creating, updating, and applying stylesheets.

This section of the documentation covers the following topics:

o “Getting Started with XSLT” on page 377

o “Tutorial: Understanding How Templates Work” on page 401
o “Working with Stylesheets’ on page 413

« “Specifying Extension Functionsin Stylesheets’ on page 430
o “Working with Templates’ on page 435

o “Using Third-Party XSLT Processors’ on page 440

o “Validating Result Documents” on page 445

« “Post-processing Result Documents’ on page 446

« “Generating Formatting Objects’ on page 447

. “Generating Scalable Vector Graphics’ on page 453

« “Generating Java Code for XSLT” on page 454

o “Generating C# Code for XSLT” on page 460

o “XSLT Instructions Quick Reference” on page 465

Getting Started with XSLT

This section provides an introduction to using Extensible Stylesheet Language
Transformations (XSLT). It discusses the following topics:

“What Is XSLT?" on page 378
o “What Isa Stylesheet?’ on page 379
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« “What IsaTemplate?’ on page 382

o “How the XSLT Processor Applies a Stylesheet” on page 385

« “Controlling the Contents of the Result Document” on page 391
« “Specifying XSLT Patterns and Expressions’ on page 393

o “Frequently Asked Questions About XSLT” on page 395

« “Sourcesfor Additional XSLT Information” on page 396

« “Benefits of Using Stylus Studio” on page 397

What Is XSLT?

The Extensible Stylesheet Language (XSL) isthe World Wide Web Consortium's (W3C)
language for manipulating XML data. XSLT isthe component of XSL that allowsyou to
write a stylesheet that you can apply to XML documents. The result of applying a
stylesheet isthat the XSLT processor createsanew XML, HTML, or text document based
on the source document. The XSLT processor follows the instructionsin the styleshest.
The instructions can copy, omit, and reorganize data in the source document, as well as
add new data.

XSL isan XML-based language. It was devel oped by the W3C X SL working group
within the W3C Stylesheets Activity. The W3C activity group has organized its
specification of XSL into three parts:

« XPath specifiesthe syntax for patterns and expressionsused in stylesheets. The XSLT
processor uses an X Path expression to execute a query on the source document to
determine which nodes to operate on. See Writing X Path Expressions on page 691.

o XSLT specifies the syntax for a stylesheet that you apply to one XML document to
createanew XML, HTML, or text document.

« XSL formatting object language is an XML vocabulary for specifying formatting
instructions.

What XSLT Versions Does Stylus Studio Support?

Stylus Studio 2010 supports XSLT 1.0 and XSLT 2.0. XSLT 2.0 was designed to work
with XPath 2.0.

For more information on

e XSLT 1.0,goto http://www.w3.0org/TR/xs1t

e XSLT 2.0,g0to http://www.w3.0org/TR/xs1t/20
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To learn more about the changes from XSLT 1.0to XSLT 2.0, go to
http://www.w3.0rg/TR/xs1t20/#changes.

What Is a Stylesheet?

A stylesheet isan XML document that contains instructions for generating a new
document based on information in the source document. This can involve adding,
removing, or rearranging nodes, as well as presenting the nodes in a new way.

Thisfollowing topics provide more information:
« “Example of a Stylesheet” on page 379
o “About Stylesheet Contents’ on page 382

Example of a Stylesheet

When you work with a stylesheet, three documents are involved:
« XML source document

o Result document, which can be HTML, XML, or text

o XSL stylesheet, which isalso an XML document

For example, suppose you have the following XML document:
<?xml version="1.0"7>
<bookstore>
<book>
<author>W. Shakespeare</author>
<title>Hamlet</title>
<published>1997</published>
<price>2.95</price>
</book>
<book>
<author>W. Shakespeare</author>
<title>Macbeth</title>
<published>1989</published>
<price>9.95</price>
</book>
<book>
<author>D. Alighieri</author>
<title>The Divine Comedy</title>
<published>1321</published>
<price>5.95</price>

</book>
</bookstore>
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You can use a stylesheet to transform this XML document into an HTML document that
appears as follows in a Web browser:

3 Stylesheet Example - Microsoft Intemnet Explorer ==l E3
J File Edt Miew Favorites Toolz Help |
<. 9 AN T
Back Fanxand Stop  Refresh  Home Search Favorites
JAgdress I@ H:\wmisback groundbtestFilestbaalks. html j @Go H Links
Title Author Price
The Divine Comedy D. Alighien 5.95
Hamlet W. Shakespeare  2.95
Macbeth W. Shakespeare  9.95
|&] Dore [ | %% Localinranet A

Figure 227. Example of Transformed XML

The Web page in Figure 227 is defined by the following HTML document:

<html> <head> <title>Stylesheet Example</title> </head>
<body> <table align="center" cellpadding="5">
<tr><th>Title</th><th>Author</th><th>Price</th></tr>
<tr><td>The Divine Comedy</td><td>D. Alighieri</td>

<td align="right">5.95</td></tr>
<tr><td>Hamlet</td><td>W. Shakespeare</td>

<td align="right">2.95</td></tr>
<tr><td>Macbeth</td><td>W. Shakespeare</td>

<td align="right">9.95</td></tr>
</table> </body> </html>

The HTML document contains HTML markup that is not in the source document. In the
HTML document, the data from the source document is not in the same order asitisin
the XML source document. Also, this HTML document does not include some data that
isin the XML source document. Specifically, the HTML document does not include
information about the date of publication (the published elements).

To create thisHTML file, the stylesheet contains two templates that provide instructions
for

« Adding atable with a heading row

« Wrapping the contents of the title, author, and price elementsin table cells
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Following is a stylesheet that does this.

<?xml version = "1.0"> )
1:stv] <xs1:stylesheet xmlns:xsl= Namespace declaration for W3C
xslistyle ==—u. "http://www.w3.0org/19 [/Transform"

XSLT namespace.

sheet is an version="1.0">
XSLT <xs1:output method="html"/>

<xs| :r‘]cem_|p1 atﬁ mgtch:" "> xsT:output is an XSLT
instruction. <html> <head> . . . .

<title>Stylesheet Example</title></head> instruction. In this stylesheet, it

It must be <body> ) N specifies that the result
the root :E?l:'le align="center" cellpadding="5"> document will be in HTML
elementina <th>Title</th>
Sty|esheet <tE>Auth0r</ﬁh>
i Stylus SSTiapey oot xelioly-temlates s on
Studio. select="/bookstore/book"> XSLT instruction. For each node

xs1:template
is an XSLT
instruction. It
contains literal
data to be
copied to the
resultdocument
and XSLT
instructions to
be followed by
the XSLT
processor. The
processor
performs these
steps for the
source nodes
identified by the
match attribute
value. In this
template, the
match attribute
identifies the
root node of the
source
document.

<xs1:sort select="author"/>
</xs1:apply-templates>

</table>

</body>

</html>
</xsT:template>

<xs1:template match="book">

<tr>

</td>

</tr>
</xs1:template>
4/xs1:stylesheet>

This template matches
book elements in the
source document. That
is, the template’s match
attribute identifies book
elements. In this
stylesheet, the XSLT
processor performs the
actions in this template
three times, once for
each book element in
the source document.

<td><xsl:value-of select="title"/></td>

<td><xs1:value-of select="authar"/></td>

<td align="right">
<xsT:value-of select="price"

identified by this instruction’s
select attribute, the XSLT
processor goes to another
template in this stylesheet, and
performs the actions defined in
that template. When done, the
processor returns here, and
moves to the next line in this
template. In this template, the
select attribute identifies all
book elements in the source
document.

xs1:value-ofis an xs1:sortis an XSLT

XSLT instruction. The instruction. The XSLT processor
XSLT processor processes the book nodes in
extracts the contents  alphabetical order by author.

of the source node

specified in the select

attribute and copies it

into the result

document.
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About Stylesheet Contents

Note

Stylesheets are XML documents. They contain a combination of
o XSLT elements and attributes. In the previous stylesheet, the XSLT elements are
o “xsl:stylesheet” on page 499
o “xd:output” on page 490
o “xdl:template’” on page 499
o “xsl:apply-templates’ on page 467
o “xdl:sort” on page 496
o “xd:value-of” on page 502

Each XSLT element is an instruction to the XSLT processor. For information about
al XSLT ingtructions, see “XSLT Instructions Quick Reference”’ on page 465.

o Non-XSLT elements and attributes. In the previous stylesheet, these include the
HTML elements that create the table.

The root element of a stylesheet must declare a namespace that associates a prefix with
the URI for an XSLT processor. The URI in the namespace declaration in the previous
example identifies the W3C standard XSLT processor. This declaration, shown again
below, instructs the X SLT processor to recognize the XSLT elements and attributes by
their xs1 prefix:

xmlns:xs1="http://www.w3.0rg/1999/XSL/Transform"

In this stylesheet, you must use the xs1 prefix for all XSLT instructions.

The Stylus Studio XSLT processor requires the namespace URI to be
http://www.w3.org/1999/XSL/Transform. Theprefix can be anything you want. Typically,
itisxsl.

When you write a stylesheet, you specify the actions you want the XSLT processor to
perform when it processes a particular source node. To do this, you define XSLT
templates, which are described in the next section.

What Is a Template?

A template defines what the XSLT processor should do when it processes a particular
node in the XML source document. The XSLT processor popul ates the result document
by instantiating a sequence of templates. Instantiation of atemplate meansthat the XSLT
processor

382
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« Copiesany literal datafrom the template to the result document
« Executesthe XSLT instructionsin the template

The following topics further describe what atemplateiis:

« Contents of a Template on page 383

« Determining Which Template to Instantiate on page 384

o How the select and match Attributes Are Different on page 385

Contents of a Template

The stylesheet example in “Example of a Stylesheet” on page 379 defines the following
templates using the xs1:template instruction:

<xs1:template match="/">
<html><head><title>Stylesheet Example</title></head>
<body>
<table align="center" cellpadding="5">
<tr><th>Title</th><th>Author</th><th>Price</th></tr>
<xsl:apply-templates select="/bookstore/book">

<xs1:sort select="author">

</xs1:apply-templates>

</table></body></html>
</xsT1:template>
<xs1:template match="book">

<tr><td><xsl:value-of select="title"/></td>
<td><xs1:value-of select="author"/></td>

<td align="right"><xs1:value-of select="price"/></td></tr>
</xs1:template>

Inthe xs1:template tag, the value of the match attribute is an XPath pattern. This pattern
matches (identifies) a node or a set of nodes in the source XML document. The value of
the match attribute is the template rule.

The template body defines actions you want the XSLT processor to perform each time it
instantiates this template. It contains

o XSLT instructions you want the XSLT processor to follow; for example, xs1:apply-
templates in the first template, and xs1:value-of in the second template.

« Elementsthat specify literal output you want the XSLT processor to insertintheresult
document. For example:

<table align="center" cellpadding="5">
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Determining Which Template to Instantiate

Note

When the X SLT processor applies astylesheet to an XML document, it begins processing
with the root node of the XML source document. To process the root node, the XSLT
processor searches the stylesheet for atemplate rule that matches the root node. A
template rule matches the root node when the value of the template’ smatch attributeis"/".

If you explicitly defined atemplate rule that matches the root node, the XSLT processor
finds it and instantiates its template. If the XSLT processor does not find an explicitly
defined template rule that matches the root node, the processor instantiates the default
template that matches the root node. Every stylesheet includes this default template.

Whether or not you explicitly define atemplate rule that matchesthe root node, the XSLT
processor always instantiates a template that matches the root node.

In the sample stylesheet on “Example of a Stylesheet” on page 379, the template rulein
the first template matches the root node:

<xs1:template match="/">

The XSLT processor instantiates this template to start generating the result document. It
copies the first few lines from the template to the result document. Then the XSLT
processor reaches the following XSLT instruction:

<xsl:apply-templates select="/bookstore/book"/>

When the XSLT processor reachesthe select attribute, it createsalist of all source nodes
that match the specified pattern. In this example, the list contains book elements. The
processor then processes each node in thelist in turn by instantiating its matching
template. First, the XSLT processor searches for a template that matches the first book
element. The template rule in the second template matches the book element:

<xs1:template match="book">

After instantiating this template for the first book element, the XSLT processor searches
for atemplate that matches the second book €lement. The XSLT processor instantiates the
book template again, and then repeats the process for the third book element. That is, the
XSLT processor searches for a matching template, and instantiates that template when it
is found.

After three instantiations of the book template, the XSLT processor returns to the first
template (the template that matches the root node) and continues with the line after the
xs1:apply-templates instruction.
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How the select and match Attributes Are Different
Consider the following instructions:

<xsl:apply-templates select=expression/>
<xs1:template match=pattern/>

The xs1:apply-templates instruction usesthe select attribute to specify an XPath
expression. The xs1:template instruction usesthe match attribute to specify an XPath
pattern.

When the XSLT processor reaches an expression that is the value of aselect attribute, it
evaluates the expression relative to the current node. The result of the evaluation is that
the XSLT processor selects a set of nodes to be processed.

When the X SLT processor reaches a pattern that is the value of amatch attribute, it
evaluates the pattern alone. The result of the evaluation is that the XSLT processor
determines whether or not the pattern matches the node already selected for processing.

For example, suppose you have the following instruction:

<xsl:apply-templates select="/bookstore/book"/>

Thisinstruction selects the book elements for processing. For each book element, the
XSLT processor searches for atemplate that matches the book element. The following
template matches the book €l ement because the pattern identifies all elementsthat contain
author elements. Because book €lements contain author e ements, thistemplateisa
match:

<xs1:template match="*[author]">

<td><xs1:value-of select="author"/></td>
</xs1:template>

This example shows that the expression that the X SLT processor uses to select nodes and
the pattern it uses to match nodes are independent of each other.

How the XSLT Processor Applies a Stylesheet

Whenthe X SLT processor appliesastyleshest, it starts by automatically selecting theroot
node for processing and then searching for atemplate that matches the root node. The
XSLT processor then iterates through the process of instantiating templates, selecting
nodesin the source document for processing, and matching patterns, until no more
templates need to be instantiated.
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This section uses the sample stylesheet on “Example of a Stylesheet” on page 379 to
present this process in more detail in the following topics:

« Instantiating the First Template on page 386

« Selecting Source Nodes to Operate On on page 387

« Controlling the Order of Operation on page 388

« Omitting Source Data from the Result Document on page 389
« When More Than One Template Is aMatch on page 390

« When No Templates Match on page 390

Instantiating the First Template

To apply astylesheet, the XSLT processor searchesfor atemplate that matchesthe source
document root. The XSLT processor then instantiates the matching template and begins
to processit line by line.

The specific processing depends on the contents of the template that matches the root
node. The parts of the template include

e XSLT instructions
o Litera result elements
o Literal result text

Itisimportant to understand that the contents of the XML source document do not dictate
the order of XSLT processing. The XSLT processor performs only those actionsthat you
specify, and operates on only the source nodes that you select. For example:

<xs1:template match="/">
<html><head><title>Stylesheet Example</title></head>
<body>
<table align="center" cellpadding="5">
<tr><th>Title</th><th>Author</th><th>Price</th></tr>
<xsl:apply-templates select="/bookstore/book"/>

</table></body></html>
</xs1:template>

This template matches the root node. Consequently, the XSLT processor begins
processing by instantiating this template. This means it processes each part of the
template in the order in which it appears.

In the preceding example, the XSLT processor first copiesthefirst four linesin the
template body directly into the result document. Then it executesthe xs1:apply-
templates instruction. When execution of that instruction is complete, the XSLT
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processor continues processing thistemplate with the last line in the template body. After
that, processing of this template is complete, and processing of the stylesheet is also
compl ete.

Selecting Source Nodes to Operate On

Aside from the root node, the XSLT processor operates on only those nodesin the source
document that are selected asthe result of executing an XSLT instruction. In a stylesheset,
there are two XSLT instructions that select nodes in the source document for processing:

<xs]:apply-templates select = "expression"/>
<xs1:for-each select ="expression">

template_body
</xs1:for-each>

The value of the select attribute is an X Path expression. To evaluate this expression, the
XSLT processor uses the current source node astheinitial context node. Thisisthe node
for which theinstruction that containsthe select attributeis being executed. For example,
if thisinstruction isin the template that matchesthe root node, the root nodeisthe current
source node.

Inan xsl:apply-templates Or xs1:for-each instruction, the XSLT processor uses the
select expression you specify plus the current source node to select a set of nodes. By
default, the new list of source nodesis processed in document order. However, you can
use the xs1:sort instruction to specify that the selected nodes are to be processed in a
different order. See “xsl:sort” on page 496.

When the X SLT processor reaches an xs1:apply-templates instruction, the XSLT
processor processes each nodein the list of selected nodes by searching for its matching
template and, if amatching template is found, instantiating it. In other words, the XSLT
processor instantiates atemplate for each node if a matching template is found. The
matching template might not be the same template for all selected nodes. If the XSLT
processor does not find a matching template, it continues to the next selected node.

Inan xs1:for-each instruction, the XSLT processor instantiates the embedded template
body once for each node in the list of selected nodes.
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Controlling the Order of Operation

Typically, the template that matches the root node includes an xs1:apply-templates
instruction. When the XSLT processor executes the xs1:apply-templates instruction, it
performs the following steps:

1. Theprocessor evaluates the expression specified for the xs1:apply-templates select
attribute to create alist of the source nodes identified by the expression.

2. Foreachnodeinthelist, the XSLT processor instantiates the best matching template.
(Template properties such as priority and mode allow multiple templates to match the
same node.)

3. The processor returns to the template that containsthe xs1:apply-templates
instruction and continues processing that template at the next line.

It isimportant to note that in step 2, the matching template might itself contain one or
more xs1:apply-templates instructions. As part of the instantiation of the matching
template, the XSLT processor searchesfor atemplate that matchesthe nodesidentified by
the new xs1:apply-templates instruction. In thisway, the XSLT processor can descend
many levels to complete processing of the first selected node in the initial xs1:apply-
templates instruction. The xs1:apply-templates instruction allows you to access any
elements in the source document in any order.

Example

The sample template on “Instantiating the First Template” on page 386 contains the
following xs1:apply-templates instruction:

<xs1:apply-templates select="/bookstore/book" />

The select attribute specifies " /bookstore/book" asthe expression. This selects the set of
book elementsin the source document as the nodes you want to process. For each selected
node, the XSLT processor performs the following steps.

1. The XSLT processor searches the stylesheet for atemplate that matches "book™.
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2. When the XSLT processor finds the template that matches the book €lement, it
instantiates it. The following template matches the book €lements selected by the
xs1:apply-templates instruction:

<xs1:template match="book">
<tr><td><xsl:value-of select="title"/></td>
<td><xs1:value-of select="author"/></td>
<td align="right"><xsl:value-of select="price"/></td></tr>
</xs1:template>

3. The XSLT processor creates an HTML table row and executesthe xs1:value-of
instructions. These instructions insert the values for the matching book’s title,
author, and price elements into the table.

The XSLT processor repeatsthis processfor each book node. In other words, it instantiates
this template three times, once for each book € ement in the source document.

It isimportant to note that the XSLT processor does not search for a matching template
once and then instantiate that matching template for each selected element. Rather, the
XSLT processor performs the search for a matching template for each node selected for
processing. For each node selected for processing, the XSLT processor

« Searchesfor and chooses the best matching template
« Instantiates the chosen template

Another way to control the order of operation isto specify the xs1:1f, xs1: choose, and
xs1:when instructions. See “XSLT Instructions Quick Reference” on page 465.

Omitting Source Data from the Result Document

The XSLT processor operateson only those nodesthat you specify. If anodein your XML
source document is never referenced in a stylesheet, the XSLT processor never does
anything with it.

For example, the sample source XML document on “Example of a Stylesheet” on
page 379 includes more than the title, author, and price for each book. It also includesthe
year of publication:

<book>
<author>W. Shakespeare</author>
<title>Hamlet</title>
<published>1997</published>

<price>2.95</price>
</book>
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However, the template that matches the book element does not specify any processing for
the pub1ished element. Consequently, the pub1ished elements do not appear in the result
document.

When More Than One Template Is a Match

Sometimes, more than one template matches the node selected by an xs1:apply-
templates instruction. In this situation, the X SLT processor chooses the best match.
Which match is the best match depends on the template's priority, mode, and order in the
stylesheet. Priority, mode, and order are template properties that you can set.

Priority — Priority is anumeric value, such as 1, 10, or 99. The higher the numeric
value, the higher the template's priority. Priority is a useful way to distinguish the
relative importance of two templates.

Mode—A template’'smode all ows you to define the context in which agiven template
should be performed. To use the mode attribute, you specify it (mode="xyz", for
example) in both the xs1:template and xs1:apply-template instructions. Once you
have specified a mode, the processor applies atemplate only if the modes match.

Order — If the XSLT processor cannot distinguish the best match among two or more
templates, it usesthe last matching template that appears in the stylesheet. Thus, you
can enforce priority indirectly by the order in which you define the templates within
a stylesheet.

For information on specifying these attributes, see “xdl:template” on page 499 and
“xdl:apply-templates’ on page 467.

When No Templates Match

When the XSLT processor cannot find atemplate that matches a selected node, it uses
built-in templates. Every stylesheet includes built-in templates whether or not you
explicitly define them.

The XSLT processor supports these built-in templates:

The following template matches the root node and element nodes and selects all
attributes and child nodes for further processing:

<xs1:template match="*|/">
<xsl:apply-templates />
</xs1:template>
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« Thefollowing template matches text and attribute nodes. Thistemplate copiesthe
value of the text or attribute node to the result document:

<xs1:template match="@*|text()">
<xs1:value-of select="." />
</xs1:template>

Although Stylus Studio does not explicitly insert these templatesin stylesheetsyou create
with Stylus Studio, they are always present. That is, as specified by the W3C XSLT
Recommendation, these templates are always defined, whether or not they are explicitly
defined. See “Using Stylus Studio Default Templates’ on page 437.

Controlling the Contents of the Result Document

This section highlights some of the XSLT instructions you can specify in a stylesheet to
control the contents of the result document. This section discusses the following topics:
«  Specifying Result Formatting on page 391

« Creating New Nodes in the Result Document on page 392

« Controlling White Space in the Result on page 392

Specifying Result Formatting

In astylesheet, you can specify that the X SLT processor should format the result as XML,
HTML, or text. Table 58 describes the XSLT processor output for each aternative:

Table 58. Output Based on Result Format

Result Format XSLT Processor Output
XML Well-formed XML.
HTML Recognized HTML tags and attributes that are formatted

according to the HTML 4.0 specification. Most browsers
should be able to correctly interpret the result. It is your
responsibility to ensure that the result is well-formed
HTML. For example, <BR> elements should not have child
nodes.

Text All text nodes in the result in document order.

See “xdl:output” on page 490 for information about specifying formatting in astylesheet.
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Creating New Nodes in the Result Document

The simplest way to create new nodesin aresult document is to specify them aslitera
result elements or literal result text in a stylesheet template. For example:

<xs1:template match="/">
<html><head></head><body><table>
<tr><th>Title</th><th>Author</th><th>Price</th></tr>

</table></body></html>
</xs1-template>

This template creates many nodes in the result document that were not in the source
document.

You can also use XSLT instructions to create new nodes. Typically, you use XSLT
instructions when you need to compute the name or value of the node. You can find
information about using the following instructionsin the “XSLT Instructions Quick
Reference” on page 465:

o “xd:element” on page 478

o “xdl:attribute” on page 468

o “Xsl:comment” on page 475

o “xdl:processing-instruction” on page 495

o “xdlitext” on page 501

You can use the xgl:value-of on page 502 instruction to provide the contents for a new
node. You can also create a new node by copying the current node from the source

document to the result document. The current node is the node for which the XSLT
processor instantiates a template. See “xdl:copy” on page 475.

Controlling White Space in the Result

For readability, XML documents (both source documents and stylesheets) often include
extrawhite space. White spacein XML documents includes spaces, tabs, and new-line
characters. Because this white space is for readability, it receives special treatment.

Text nodes that contain only white space are

« Preserved asnormal text nodesin a source document

« Ignored in a stylesheet, unless the parent node is xs1: text
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Significant white space

Stylus Studio recommends that you specify xs1: text in astylesheet whenever you want
to create significant white space in the result. Sgnificant white space is white space that
you want to appear in the result in exactly the way that you specify.

To obtain white space for readability during output formatting, specify the xs1:output
instruction with the indent attribute. Default values are yes for HTML, and no for XML.
With Stylus Studio, you can select the Indent check box on the Params/Other tab to
display indented output instead of one long string. Note that the value of the indent
attribute, if specified in the stylesheet, has precedence over the Indent option.

Specifying XSLT Patterns and Expressions

In astylesheet’s xs1:template, xs1:apply-templates, xs1:for-each, and xs1:value-of
instructions, you specify patterns or expressions as the values for the match or select
attributes. These patterns are X Path expressions. You specify patterns or expressions to

« Define which nodes atemplate rule matches.
o Select lists of source nodesto process.
« Extract source node contents to generate result nodes.

Depending on the context, an X SLT pattern or expression can mean one of the following:
« Doesthistemplate match the current node?

« Given the current node, select all matching source nodes.

« Given the current node, select the first matching source node.

« Given the current node, do any source nodes match?

Patterns or expressions can match or select any type of node. The XSLT processor can
match a pattern to anode based on the existence of the node, the name of the node, or the
value of the node. You can combine patterns and expressions with Bool ean operators. For

detailed information about patterns and expressions, see “Writing X Path Expressions’ on
page 691.

Examples of Patterns and Expressions

Following are examples of patterns and expressions you can specify in stylesheet
instructions:

xs1:template match = "book/price"
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Matches any price element that isa child of a book €lement.
xs1:template match = "book//award"

Matches any award element that is a descendant of abook €lement.
xs1:template match = "book [price]"

Matches any book €lement that has achild that isa price element